Quantum140PLC

概述 硬件连接 创建设备 创建标签 标签的地址规则 标签举例 在线升级驱动

概述

硬件连接

Quantum140PLC与开物2000的通讯方式是采用的以太网通讯的，它支持的MODBUS RTU的通讯协议，将Quantum140PLC的EtherNet端口通过网线连接到HUB,

同时将计算机连接到HUB.使用Conept软件配置PLC的IP地址.

创建设备

在开发环境的‘硬件系统’中按照‘新节点和设备向导’的指示配置所连接的模块。以便于开物2000识别和使用。

步骤1：选择设备类型。双击‘’，或单击选中‘’，更改设备名称，最后单击‘选择’按钮。

步骤2：选择操作方式-新建设备(一个设备中可以包含多个)。选中‘新建设备’后单击‘下一步’按钮(或双击‘新建设备’)。

步骤3：选择创建方式-单个创建或者多个创建。 选择创建方式后单击‘下一步’按钮(或双击‘标准创建’)。

步骤4：设置PLC设备类型及TCP参数选项，单击‘下一步’按钮。

步骤5：显示设备及参数汇总窗口，单击‘完成’按钮，结束设备配置向导。

创建标签

使用设备向导创建完成PLC设备的配置后，可以进行标签设计。

1、在开发环境的‘标签’中添加标签，显示下图，选择主设备为上面的‘’，选择并填写‘主设备地址’，修改标签名。

2、根据PLC的工作模式和标签所监控的参数物理意义，修改测量值零点、测量值量程、工程值零点、工程值量程、扫描周期、转换方式、记录属性等。单击‘添加’或‘完成’按钮。

标签的地址规则

标签的主地址可以按照下面的规则配置填写：

标签类型[ID:]Ch

说明：

项目符号

ID指PLC的地址，用于识别设备中的 PLC， PLC的站号地址以十进制表示，地址设定范围为1～ 255 。标签地址中省略ID时，开物2000系统默认为是所连接设备的最小的站号地址。

项目符号

Ch指的是 线圈或者寄存器地址。十进制表示。

项目符号 标签地址配置成不存在类型或模块地址错误或通道号超出有效范围时，标签将不被承认，读不上数据。

标签地址

含义

数据类型

读写类型

标签值范围

10ID:Ch

开关量输入

开关量

只读

true/false

00ID:Ch

开关量输出

开关量

可读可写

true/false

H30ID:Ch

模拟量输入

模拟量

只读

0～FFFF

H40ID:Ch

模拟量输出

模拟量

可读可写

0～FFFF

D30ID:Ch

模拟量输入

模拟量

只读

0～65535

D40ID:Ch

模拟量输出

模拟量

可读可写

0～65535

标签举例

标签 ：101:5
数据值类型：开关量
描述 ：表示设备配置示例中站号地址为1的PLC的 通道地址为5的输入点的状态（只读）

标签 ：002:10
数据值类型：开关量
描述 ：表示设备配置示例中站号地址为2的PLC的 通道地址为10的输出点的状态（可读可写）

标签 ：H304:5
数据值类型：模拟量
描述 ：表示设备配置示例中站号地址为4的PLC的 通道地址为5的保持寄存器的值（十六进制表示）（只读）

标签 ：H405:4
数据值类型：模拟量
描述 ：表示设备配置示例中站号地址为5的PLC的 通道地址为4的保持寄存器的值（十六进制表示）（可读可写）

标签 ：D304:5
数据值类型：模拟量
描述 ：表示设备配置示例中站号地址为4的PLC的 通道地址为5的保持寄存器的值（十进制表示）（只读）

标签 ：D405:4
数据值类型：模拟量
描述 ：表示设备配置示例中站号地址为5的PLC的 通道地址为4的保持寄存器的值（十进制表示）（可读可写）