LG-K系列PLC(Loader)

概述 硬件连接 创建设备 创建标签 标签的地址规则 标签举例 常见问题 在线升级驱动

概述

硬件连接

该版本驱动使用Master_K系列的LOADER协议与开物2000进行通讯，通讯介质采用RS232。

RS232接线方式：

PLC 端口 | PC或其他设备
RX2 | 3TX
TX3 | 2RX
GND5 | 5GND

通讯参数设置如下：(必须使用38400bps的波特率)

波特率 | 38400bps
数据位 | 8
停止位 | 1
校验方式 | 无校验

创建设备

在开发环境的‘硬件系统’中按照‘新节点和设备向导’的指示配置所连接的PLC。以便于开物2000识别和使用。

步骤1：选择设备类型。双击‘LG K系列PLC(Loader)’，或单击选中‘LG K系列PLC(Loader)’，更改设备名称，最后单击‘选择’按钮。

步骤2：选择操作方式-新建设备。选中‘新建设备’后单击‘下一步’按钮(或双击‘新建设备’)。

步骤3：选择创建方式(Loader协议仅支持单设备)。选中创建方式后单击‘下一步’按钮(或双击‘标准创建’)。

步骤4：设置PLC类型其中设备号不用设定（因为Loader协议仅支持单设备），单击‘下一步’按钮。

步骤5：设备串口通讯参数，单击‘下一步’。

步骤6：显示设备及参数配置图，点击‘完成’按钮，完成设备配置向导.

创建标签

使用设备向导创建完成PLC设备的配置后，可以进行标签设计。

1、在开发环境的‘标签’中添加标签，显示下图，选择主设备为上面的‘LG_PLC’，选择并填写‘主设备地址’，修改标签名。

2、根据PLC的工作模式和标签所监控的参数物理意义，修改测量值零点、测量值量程、工程值零点、工程值量程、扫描周期、转换方式、记录属性等。单击‘添加’或‘完成’按钮。

标签的地址规则

标签的主地址可以按照下面的规则配置填写：

标签类型CH

说明：

项目符号 | 在建立位标签时要注意，若地址为P，M，L，K，F 则通道地址的最后一位为16进制数（表示某位），前面的数据为字类型（表示最后一位数据位于的字地址）；
项目符号 | 例如：P004D表示P区的004字的13位的状态。若地址为T，C，则通道地址为T，C区某一位的状态，例如：T255表示 T 区第255位的状态。
项目符号

Ch指的是PLC的参数地址。地址范围和表示形式见参数对照表。

项目符号 标签地址配置成不存在类型或模块地址错误或通道号超出有效范围时，标签将不被承认，读不上数据。

标签地址

含义

数据类型

读写类型

通道地址范围

标签值范围

P CH

输入/输出继电器

开关量

可读可写

0～15F(K200S/K80S)

0～31F(K300S)

0～63F(K1000S)

0/1

MCH

辅助继电器（位）

开关量

可读可写

0～191F

0/1

LCH

连接继电器（位）

开关量

可读可写

0～63F

0/1

KCH

保持继电器（位）

开关量

可读可写

0～31F

0/1

F CH

特殊继电器（位）

开关量

只读

0～63F

0/1

CCH

计数器状态（位）

开关量

可读可写

0～255

0/1

TCH

定时器状态（位）

开关量

可读可写

0～255

0/1

PWCH

输入/输出继电器(字)

模拟量

可读可写

0～15(K200S/K80S)

0～31(K300S)

0～63(K1000S)

0～65535

MW CH

辅助继电器(字)

模拟量

可读可写

0～191

0～65535

LWCH

连接继电器(字)

模拟量

可读可写

0～63

0～65535

KWCH

保持继电器(字)

模拟量

可读可写

0～31

0～65535

CWCH

计数器当前值(字)

模拟量

可读可写

0～255

0～65535

TWCH

定时器当前值(字)

模拟量

可读可写

0～255

0～65535

FW CH

特殊继电器(字)

模拟量

只读

0～63

0～65535

DWCH

数据寄存器

模拟量

可读可写

0～9999(K1000S)

0～4999(其它)

0～65535

SWCH

步进继电器(字)

模拟量

可读可写

0～4999

0～65535

标签举例

标签 ：P004B
数据值类型：开关量
描述 ：表示设备配置示例中PLC的通道地址为004B的输入/输出继电器的状态（1位开关量通道的值）

标签 ：M0042
数据值类型：开关量
描述 ：表示设备配置示例中PLC的通道地址为0042的辅助继电器的状态（1位开关量通道的值）

标签 ：L0042
数据值类型：开关量
描述 ：表示设备配置示例中PLC的通道地址为0042的连接继电器的状态（1位开关量通道的值）

标签 ：K0042
数据值类型：开关量
描述 ：表示设备配置示例中PLC的通道地址为0042的保持继电器的状态（1位开关量通道的值）

标签 ：F0042
数据值类型：开关量
描述 ：表示设备配置示例中PLC的通道地址为0042的特殊继电器的状态（1位开关量通道的值）

标签 ：C20
数据值类型：开关量（通道地址为十进制）
描述 ：表示设备配置示例中PLC的通道地址为20的计数器的状态（1位开关量通道的值）

标签 ：T12
数据值类型：开关量（通道地址为十进制）
描述 ：表示设备配置示例中PLC的通道地址为12的定时器的状态（1位开关量通道的值）

标签 ：PW002
数据值类型：模拟量（通道地址为十进制）
描述 ：表示设备配置示例中PLC的通道地址为2的输入/输出寄存器的值（16位开关量通道的值）

标签 ：MW20
数据值类型：模拟量（通道地址为十进制）
描述 ：表示设备配置示例中PLC的通道地址为20的辅助寄存器的值（16位开关量通道的值）

标签 ：LW 20
数据值类型：模拟量（通道地址为十进制）
描述 ：表示设备配置示例中PLC的通道地址为20的连接寄存器的值（16位开关量通道的值）

标签 ：KW 20
数据值类型：模拟量（通道地址为十进制）
描述 ：表示设备配置示例中PLC的通道地址为20的保持寄存器的值（16位开关量通道的值）

标签 ：CW20
数据值类型：模拟量（通道地址为十进制）
描述 ：表示设备配置示例中PLC的通道地址为20的计数器的当前值（16位开关量通道的值）

标签 ：TW 12
数据值类型：模拟量（通道地址为十进制）
描述 ：表示设备配置示例中PLC的通道地址为12的定时器的当前值（16位开关量通道的值）

标签 ：FW 20
数据值类型：模拟量 （通道地址为十进制）
描述 ：表示设备配置示例中PLC的通道地址为20的特殊寄存器的值（16位开关量通道的值）

标签 ：DW20
数据值类型：模拟量（通道地址为十进制）
描述 ：表示设备配置示例中LC的通道地址为20的数据寄存器的值 （16位开关量通道的值）

标签 ：SW 12
数据值类型：模拟量（通道地址为十进制）
描述 ：表示设备配置示例中PLC的通道地址为12的步进寄存器的值 （16位开关量通道的值）

注：对于PLC的设置需通过LG PLC提供的编程软件(KGL_WE应用程序)来进行设置。

常见问题：

1、用户使用该驱动时，与设备通讯连接不上？

答：用户需要将开物2000软件中的波特率设定为38400，同时需要PLC的编程软件设定通讯波特率为38400，这样就可以通讯成功！