LG-K系列PLC(Cnet)

概述 硬件连接 创建设备 创建标签 标签的地址规则 标签举例 在线升级驱动

概述

硬件连接

该版本驱动支持的协议是LINK协议，与设备的连接主要是通过Master_K系列的Cnet模块（G4L-CUEA/G6L-CUEB/G6L-CUEC模块 ），除此之外，

K80S,K120S,K200S的CPU口也支持这类协议，但是接线不相同，请用户注意以下几种接线方式。对于Cnet模块分三种接线方式:(RS232/RS485/RS422)，

对于CPU口的接线方式。

上位机与PLC的连接如下图所示：

Cnet模块的RS422接线方式：

Cnet模块的RS485接线方式：

Cnet模块的RS232接线方式：

K80S、K120S、K 200S的CPU口的接线方式：

1

2

3

4

5

6

7

8

9

1

2

3

4

5

6

7

8

9

PC

PLC(K200S)

通讯参数设置如下：(建议使用大于19200bps的波特率)

波特率 | 19200bps
数据位 | 8
停止位 | 1
校验方式 | 无校验

创建设备

在开发环境的‘硬件系统’中按照‘新节点和设备向导’的指示配置所连接的PLC。以便于开物2000识别和使用。

步骤1：选择设备类型。双击‘’，或单击选中‘’，更改设备名称，最后单击‘选择’按钮。

步骤2：选择操作方式-新建设备(一个设备中可以包含多个)。选中‘新建设备’后单击‘下一步’按钮(或双击‘新建设备’)。

步骤3：选择创建方式(一个设备中可以包含多个)。选中 创建方式后单击‘下一步’按钮(或双击‘标准创建’)。

步骤4：设置PLC类型和设备号，单击‘下一步’按钮。

步骤5：设备串口通讯参数，单击‘下一步’。

步骤6：显示设备及参数配置图，点击‘完成’按钮，完成设备配置向导.

创建标签

使用设备向导创建完成PLC设备的配置后，可以进行标签设计。

1、在开发环境的‘标签’中添加标签，显示下图，选择主设备为上面的‘’，选择并填写‘主设备地址’，修改标签名。

2、根据PLC的工作模式和标签所监控的参数物理意义，修改测量值零点、测量值量程、工程值零点、工程值量程、扫描周期、转换方式、记录属性等。单击‘添加’或‘完成’按钮。

标签的地址规则

标签的主地址可以按照下面的规则配置填写：

标签类型[ID:][CH]

说明：

项目符号

ID指PLC的站号地址，用于识别设备中的PLC， PLC的站号地址以十进制表示，地址设定范围为0～ 255 。标签地址中省略ID时，开物2000系统默认为是所连接设备的最小的站号地址。

项目符号

Ch指的是PLC的参数地址。地址范围 和表示形式见参数对照表。

项目符号 标签地址配置成不存在类型或模块地址错误或通道号超出有效范围时，标签将不被承认，读不上数据。

标签地址

含义

数据类型

读写类型

通道地址范围

标签值范围

PID:CH

输入/输出继电器

开关量

可读可写

0～15F(K200S/K80S)

0～31F(K300S)

0～63F(K1000S)

0/1

MID:CH

辅助继电器

开关量

可读可写

0～191F

0/1

LID:CH

连接继电器

开关量

可读可写

0～63F

0/1

K ID:CH

保持继电器

开关量

可读可写

0～31F

0/1

C ID:CH

计数器状态

开关量

可读可写

0～255

0/1

T ID:CH

定时器状态

开关量

可读可写

0～255

0/1

FID:CH

特殊继电器

开关量

只读

0～63F

0/1

PWID:CH

输入/输出继电器(字)

模拟量

可读可写

0～15(K200S/K80S)

0～31(K300S)

0～63(K1000S)

0～65535

MW ID:CH

辅助继电器(字)

模拟量

可读可写

0～191

0～65535

LWID:CH

连接继电器(字)

模拟量

可读可写

0～63

0～65535

KW ID:CH

保持继电器(字)

模拟量

可读可写

0～31

0～65535

CW ID:CH

计数器设定值(字)

模拟量

可读可写

0～255

0～65535

TW ID:CH

定时器设定值(字)

模拟量

可读可写

0～255

0～65535

FW ID:CH

特殊继电器(字)

模拟量

只读

0～63

0～65535

DW ID:CH

数据寄存器

模拟量

可读可写

0～10000

0～65535

SW ID:CH

步进继电器(字)

模拟量

可读可写

0～4999

0～65535

标签举例

标签 ：P1:2
数据值类型：开关量
描述 ：表示设备配置示例中站号地址为1的PLC的 通道地址为2的输入/输出继电器的状态

标签 ：M1:2A
数据值类型：开关量
描述 ：表示设备配置示例中站号地址为1的PLC的 通道地址为2A的辅助继电器的状态

标签 ：L1:2F
数据值类型：开关量
描述 ：表示设备配置示例中站号地址为1的PLC的 通道地址为2F的连接继电器的状态

标签 ：K1:2A
数据值类型：开关量
描述 ：表示设备配置示例中站号地址为1的PLC的 通道地址为2A的保持继电器的状态

标签 ：C1:20
数据值类型：开关量（通道地址为十进制）
描述 ：表示设备配置示例中站号地址为1的PLC的 通道地址为20的计数器的状态

标签 ：T1:12
数据值类型：开关量（通道地址为十进制）
描述 ：表示设备配置示例中站号地址为1的PLC的 通道地址为12的定时器的状态

标签 ：F1:2A
数据值类型：开关量
描述 ：表示设备配置示例中站号地址为1的PLC的 通道地址为2A的特殊继电器的状态

标签 ：PW1:2
数据值类型：模拟量（通道地址为十进制）
描述 ：表示设备配置示例中站号地址为1的PLC的 通道地址为2的输入/输出寄存器的值（16位开关量通道的值）

标签 ：MW1:2A
数据值类型：模拟量（通道地址为十进制）
描述 ：表示设备配置示例中站号地址为1的PLC的 通道地址为2A的辅助寄存器的值（16位开关量通道的值）

标签 ：LW1:2F
数据值类型：模拟量（通道地址为十进制）
描述 ：表示设备配置示例中站号地址为1的PLC的 通道地址为2F的连接寄存器的值（16位开关量通道的值）

标签 ：KW1:2A
数据值类型：模拟量（通道地址为十进制）
描述 ：表示设备配置示例中站号地址为1的PLC的 通道地址为2A的保持寄存器的值（16位开关量通道的值）

标签 ：CW1:20
数据值类型：模拟量（通道地址为十进制）
描述 ：表示设备配置示例中站号地址为1的PLC的 通道地址为20的计数器的当前值

标签 ：TW1:12
数据值类型：模拟量（通道地址为十进制）
描述 ：表示设备配置示例中站号地址为1的PLC的 通道地址为12的定时器的当前值

标签 ：FW1:2A
数据值类型：模拟量 （通道地址为十进制）
描述 ：表示设备配置示例中站号地址为1的PLC的 通道地址为2A的特殊寄存器的值（16位开关量通道的值）

标签 ：DW1:20
数据值类型：模拟量（通道地址为十进制）
描述 ：表示设备配置示例中站号地址为1的PLC的 通道地址为20的数据寄存器的值

标签 ：SW1:12
数据值类型：模拟量（通道地址为十进制）
描述 ：表示设备配置示例中站号地址为1的PLC的 通道地址为12的步进寄存器的值

注：对于通讯模块的设置需通过CNET.EDITOR应用程序来进行设置。