GE PLC

GE 90系列PLC综述

概述 硬件接线图 创建设备 创建标签 标签的地址规则 标签举例 在线升级驱动

GE 90系列PLC概述

GE 90系列PLC包括90-30系列PLC、90-70系列PLC、VersaMax系列、VersaMax Nano/Micro 系列、Series 90 Micro 系列。

开物2000使用您计算机中的串行口与一台或多台GE 90系列PLC的通讯口连接，实现数据通讯功能。GE 90系列PLC通讯口包括90-70系列CPU 通讯口、90-30系列CPU通讯口、CCM模块通讯口 。

双方共同采用SNPX协议，开物2000作为SNP主站，GE PLC作为从站。在使用CCM模块通讯前，需要修改CCM参数，使通讯口采用SNPX协议。

在1200米的系统中可连接8个从站。如果电缆长度被限制在600米，则可以配置16个从站。对于300米电缆长度的系统，可以配置32个从站。

当开物2000与多台GE 90系列PLC连接时，通过PLC 的SNP ID来识别不同的PLC，不同CPU/CCM的SNP ID必须互不相同。

CPU或CCM模块的SNP ID通过Logicmaster 90或VersaPro或其他编程软件进行设置。缺省情况下，SNP ID输入为空。SNP IP由7个以内的ASCII字符组成，对于90-30系列PLC，SNP IP限定由6个以内的ASCII字符组成，并且限制ASCII字符为字符‘0’-‘9’、大写字母‘A’-‘F’。

开物2000还支持其它多种设备，详情请与 华富惠通公司联系。

GE 90系列PLC与系统的接线图

计算机采用RS-485通讯方式时，一个串口最多能101台GE 90系列PLC，其地址号范围是0-101。

下面是点对点的系统连接图：

下面是多点的系统连接图：

在开物2000开发环境中创建设备

在开发环境的‘硬件系统’中按照‘新节点和设备向导’的指示配置所连接的PLC。以便于开物2000识别和使用。

步骤1：选择设备类型。双击‘GE PLC’，或单击选中‘GE PLC’，更改设备名称，最后单击‘选择’按钮。

步骤2：选择操作方式-新建设备(一个设备中可以包含多个PLC)。选中‘新建设备’后单击‘下一步’按钮(或双击‘新建设备’)。

步骤3：选择创建设备的方式：选中‘多个PLC创建’后，单击‘下一步’按钮。

步骤4：显示多设备创建界面，选择好PLC类型，输入站号和SNP ID后，点击‘添加PLC’按钮。添加完所有的PLC后，单击‘下一步’按钮。

缺省情况下，SNP ID输入为空。SNP IP由7个以内的ASCII字符组成，对于90-30系列PLC，SNP IP限定由6个以内的ASCII字符组成，并且限制ASCII字符为字符‘0’-‘9’、大写字母‘A’-‘F’。

下图示范的是开物2000系统通过两台PLC(一台为CGR772，SNP ID为“”；另一台为CPU352，SNP ID为“352001”)。

步骤5：显示计算机串行口通讯参数窗口，修改完串行口、波特率等参数后，单击‘下一步’按钮。

步骤6：显示设备及参数汇总窗口，单击‘完成’按钮，结束设备配置向导。

标签的创建

使用设备向导创建完成PLC的配置后，可以进行标签设计。

1、在开发环境的‘标签’中添加标签，显示下图，选择主设备为上面的‘GEPLC’，选择并填写‘主设备地址’，修改标签名。

2、根据PLC的工作模式和标签所监控的参数物理意义，修改测量值零点、测量值量程、工程值零点、工程值量程、扫描周期、转换方式等。单击‘添加’或‘完成’按钮。

标签的地址配置规则

标签的主地址可以按照下面的规则配置填写：

标签类型[ID:]Ch

说明：

项目符号

ID指PLC的站号，用于识别设备中的PLC，请参见设备向导中步骤4。

项目符号

Ch指寄存器地址。

项目符号 | 红色字表示格式中可变部分，十进制数表示，变化范围参见各种PLC的帮助文件。
项目符号 | 蓝色括号不出现在标签地址中，蓝色括号内的内容通常可省略。
项目符号 | 标签地址配置成不存在类型或设备表号错误或通道号超出有效范围时，标签将不被承认，读不上数据。
项目符号

开关量寄存器的数据类型配置成模拟量时，表示对应的位寄存器所在8位开关量组成的字节的字节值。

即：如果两个模拟量型开关量寄存器的Ch-寄存器地质不同，但是在相同的字节内时，那么表示的是相同的字节。

标签地址 | 含义 | 数据类型 | 读写类型 | 标签值范围
AI ID:Ch | 模拟输入AI（字） | 模拟量 | 可读可写 | 0~65535
AQ ID:Ch | 模拟输出AQ（字） | 模拟量 | 可读可写 | 0~65535
R ID:Ch | 寄存器R（字） | 模拟量 | 可读可写 | 0~65535
S ID:Ch | 系统状态S（位/字节） | 开关量/模拟量 | 只读 | 0~255
SA ID:Ch | 系统状态SA（位/字节） | 开关量/模拟量 | 可读可写 | 0~255
SB ID:Ch | 系统状态SB（位/字节） | 开关量/模拟量 | 可读可写 | 0~255
SC ID:Ch | 系统状态SC（位/字节） | 开关量/模拟量 | 可读可写 | 0~255
G ID:Ch | 全局变量G（位/字节） | 开关量/模拟量 | 可读可写 | 0~255
I ID:Ch | 离散输入I（位/字节） | 开关量/模拟量 | 可读可写 | 0~255
Q ID:Ch | 离散输出Q（位/字节） | 开关量/模拟量 | 可读可写 | 0~255
T ID:Ch | 暂存状态T（位/字节） | 开关量/模拟量 | 可读可写 | 0~255
M ID:Ch | 内部状态M（位/字节） | 开关量/模拟量 | 可读可写 | 0~255

标签举例：

标签 ：Q1:1
数据值类型：开关量
描述 ：表示开物设备中站号为1的PLC的开关量输出寄存器%Q0001，取值true~false(对应硬件的1~0)。

标签 ：I2:33
数据值类型：开关量
描述 ：表示开物设备中站号为2的PLC的开关量输入寄存器%I0033，取值true~false(对应硬件的1~0)。

标签 ：I2:33
数据值类型：模拟量
描述 ：表示开物设备中站号为2的PLC的开关量输入寄存器%I0033~%I0040组成的字节值。

标签 ：I2:40
数据值类型：模拟量
描述 ：表示开物设备中站号为2的PLC的开关量输入寄存器%I0033~%I0040组成的字节值。

标签 ：AI1:3
数据值类型：模拟量
描述 ：表示开物设备中站号为1的PLC的模拟量寄存器%AI0003,以16位无符号整型数表示。

标签 ：R1:3
数据值类型：模拟量
描述 ：表示开物设备中站号为1的PLC内部寄存器%R0003，以16位无符号整型数表示。


90-30系列PLC

标签地址及范围 标签举例 在线升级驱动

90-30系列PLC 支持的标签列表

CPU311

CPU313

CPU323

CPU331

CPU350

CPU352

CPU360

CPU363

CPU364

AI1~AI64

AI1~AI64

AI1~AI64

AI1~AI128

AI1~AI2048

AI1~AI2048

AI1~AI2048

AI1~AI2048

AI1~AI2048

AQ1~AQ32

AQ1~AQ32

AQ1~AQ32

AQ1~AQ64

AQ1~AQ512

AQ1~AQ512

AQ1~AQ512

AQ1~AQ512

AQ1~AQ512

R1~R512

R1~R1024

R1~R1024

R1~2048

R1~R9999

R1~R9999

R1~R9999

R1~R9999

R1~R9999

S1~S32

S1~S32

S1~S32

S1~S32

S1~S32

S1~S32

S1~S32

S1~S32

S1~S32

SA1~SA32

SA1~SA32

SA1~SA32

SA1~SA32

SA1~SA32

SA1~SA32

SA1~SA32

SA1~SA32

SA1~SA32

SB1~SB32

SB1~SB32

SB1~SB32

SB1~SB32

SB1~SB32

SB1~SB32

SB1~SB32

SB1~SB32

SB1~SB32

SC1~SC32

SC1~SC32

SC1~SC32

SC1~SC32

SC1~SC32

SC1~SC32

SC1~SC32

SC1~SC32

SC1~SC32

G1~G1280

G1~G1280

G1~G1280

G1~G1280

G1~G1280

G1~G1280

G1~G1280

G1~G1280

G1~G1280

I1~I512

I1~I512

I1~I512

I1~I1024

I1~I4096

I1~I4096

I1~I4096

I1~I4096

I1~I4096

Q1~Q512

Q1~Q512

Q1~Q512

Q1~Q1024

Q1~Q4096

Q1~Q4096

Q1~Q4096

Q1~Q4096

Q1~Q4096

T1~T256

T1~T256

T1~T256

T1~T256

T1~T256

T1~T256

T1~T256

T1~T256

T1~T256

M1~M1024

M1~M1024

M1~M1024

M1~M1024

M1~M4096

M1~M4096

M1~M4096

M1~M4096

M1~M4096

90-30系列PLC 设备标签举例：

标签 ：I2:1
数据值类型：开关量
描述 ：表示开物设备中站号为2的PLC的开关量输入寄存器%I0001，取值true~false(对应硬件的1~0)。


90-70系列PLC

90-70系列PLC支持的标签列表

CGR772 | CGR935 | CPM790 | CPU788 | CPU789
AI1~AI8192 | AI1~AI8192 | AI1~AI8192 | AI1~AI8192 | AI1~AI8192
AQ1~AQ8192 | AQ1~AQ8192 | AQ1~AQ8192 | AQ1~AQ8192 | AQ1~AQ8192
R1~R16384 | R1~R16384 | R1~R16384 | R1~R16384 | R1~R16384
S1~S32 | S1~S32 | S1~S32 | S1~S32 | S1~S32
SA1~SA32 | SA1~SA32 | SA1~SA32 | SA1~SA32 | SA1~SA32
SB1~SB32 | SB1~SB32 | SB1~SB32 | SB1~SB32 | SB1~SB32
SC1~SC32 | SC1~SC32 | SC1~SC32 | SC1~SC32 | SC1~SC32
G1~G1280 | G1~G1280 | G1~G1280 | G1~G1280 | G1~G1280
I1~I2048 | I1~I12288 | I1~I12288 | I1~I12288 | I1~I12288
Q1~Q2048 | Q1~Q12288 | Q1~Q12288 | Q1~Q12288 | Q1~Q12288
T1~T256 | T1~T256 | T1~T256 | T1~T256 | T1~T256
M1~M2048 | M1~M12288 | M1~M12288 | M1~M12288 | M1~M12288

CPU790 | CPX772 | CPX782 | CPX928 | CPX938
AI1~AI8192 | AI1~AI8192 | AI1~AI8192 | AI1~AI8192 | AI1~AI8192
AQ1~AQ8192 | AQ1~AQ8192 | AQ1~AQ8192 | AQ1~AQ8192 | AQ1~AQ8192
R1~R16384 | R1~R16384 | R1~R16384 | R1~R16384 | R1~R16384
S1~S32 | S1~S32 | S1~S32 | S1~S32 | S1~S32
SA1~SA32 | SA1~SA32 | SA1~SA32 | SA1~SA32 | SA1~SA32
SB1~SB32 | SB1~SB32 | SB1~SB32 | SB1~SB32 | SB1~SB32
SC1~SC32 | SC1~SC32 | SC1~SC32 | SC1~SC32 | SC1~SC32
G1~G1280 | G1~G1280 | G1~G1280 | G1~G1280 | G1~G1280
I1~I12288 | I1~I12288 | I1~I12288 | I1~I12288 | I1~I12288
Q1~Q12288 | Q1~Q12288 | Q1~Q12288 | Q1~Q12288 | Q1~Q12288
T1~T256 | T1~T256 | T1~T256 | T1~T256 | T1~T256
M1~M12288 | M1~M12288 | M1~M12288 | M1~M12288 | M1~M12288

90-70系列PLC 设备标签举例：

标签 ：I2:1
数据值类型：开关量
描述 ：表示开物设备中站号为2的PLC的开关量输入寄存器%I0001，取值true~false(对应硬件的1~0)。


Series 90 Micro系列

Series 90 Micro支持的标签列表

Series 90 Micro

AI1~AI128

AQ1~AQ128

R1~R1024

S1~S32

SA1~SA32

SB1~SB32

SC1~SC32

G1~G1280

I1~I512

Q1~Q512

T1~T256

M1~M1024

Series 90 Micro 设备标签举例：

标签 ：I2:1
数据值类型：开关量
描述 ：表示开物设备中站号为2的PLC的开关量输入寄存器%I0001，取值true~false(对应硬件的1~0)。


VersaMax Nano/Micro系列

VersaMax Nano/Micro系列支持的标签列表

VersaMax Nano/Micro

AI1~AI128

AQ1~AQ128

R1~R1024

AI1~AI64

AQ1~AQ32

R1~R512

S1~S32

SA1~SA32

SB1~SB32

SC1~SC32

G1~G1280

I1~I512

Q1~Q512

T1~T256

M1~M1024

VersaMax Nano/Micro系列标签举例：

标签 ：I2:1
数据值类型：开关量
描述 ：表示开物设备中站号为2的PLC的开关量输入寄存器%I0001，取值true~false(对应硬件的1~0)。


VersaMax系列

VersaMax系列支持的标签列表

VersaMax

AI1~AI128

AQ1~AQ128

R1~R1024

AI1~AI64

AQ1~AQ32

R1~R512

S1~S32

SA1~SA32

SB1~SB32

SC1~SC32

G1~G1280

I1~I2048

Q1~Q2048

T1~T256

M1~M1024

VersaMax系列标签举例：

标签 ：I2:1
数据值类型：开关量
描述 ：表示开物设备中站号为2的PLC的开关量输入寄存器%I0001，取值true~false(对应硬件的1~0)。