DeviceName

金钟默勒PLC PS4-201-MM1

设备概述 设备设置 设备连接 标签设置 标签举例 注意事项 在线升级

1.设备概述

(图 1)

PS4-201-MM1 PLC的标准配置如下：

Inputs/Outputs（出入输出）:
8 digital inputs
6 digital outputs
2 analog inputs
1 analog output

Program memory:（存储容量）
24 kByte (+32 kByte optional)
Recipe memory (optional): 32 kByte

Expansion options:（扩展选项）
Local expansion using LE4 modules
Decentralised expansion using EM4 modules

Networking capability:（通讯能力）
Suconet K
PROFIBUS-DP
Ethernet

开物2000目前支持的类型如下：
目前开物只支持与PS4-201-MM1的M的寄存器的通讯

关于金钟默勒PLC 更详细信息，请访问 金钟默勒 网站。

开物2000还支持其它多种设备，详情请与 华富惠通公司 联系。

2.设备设置

硬件设置值推荐如下：

设定项 设定值

波特率 9600 bps

数据位 8

停止位 1

校验位 无校验

3.设备连接

金钟_默勒PLC 协议支持与金钟_默勒PS4系列及与其兼容的PS3系列PLC之间的通讯，本协议可以采用RS232串行通讯，使用您计算机中的串行口及金钟_默勒公司提供的专用通讯电缆线。

图 4.3.3 设备连接示意图

4.标签设置

设备名称 | 标签格式 | 通道 ddd 的范围 (注此处指的是最大范围，具体范围见说明) | 标签值范围 | 功能说明
MW | MW0:ddd.bbb | 0~819 1 | [0,65535] | 读/写无符号字 (注：位只读)
SMW | SMW0:ddd | 0~819 1 | [-32768,32767] | 读/写有符号字
MB | MB0:ddd.bbb | 0~1638 3 | [0,255] | 读/写无符号字节 (注：位只读)
SMB | SMB0:ddd | 0~1638 3 | [-128，127] | 读/写有符号字节
MDW | MSW0:ddd | 0~409 5 | 0..4294967295 | 读/写无符号双字
SMDW | SMDW0:ddd | 0~409 5 | -2147483648..2147483647 | 读/写有符号双字
MF | MF0：ddd | 0~4095 | 1.5 x 10^-45 .. 3.4 x 10^38 | 读/写浮点数

说明：ddd 代表通道号，bbb 代表位号,所有 bbb 范围是0-7。通道范围取决于用户在 Sucosoft S40 PLC编程软件中定义

的Mark Range的范围。当Mark Range的范围定义为 16384时为最大范围。

5.标签举例

您可以参照如下规则建立标签。

标签 ：MW0:0
数据值类型：模拟量
描述 ：M寄存器的第1个字的值。

标签 ： SMDW 0:2
数据值类型 ：模拟量
描述 ：M寄存器的第3个双字的值。

标签 ： MW0:5.3
数据值类型 ：开关量
描述 ：M寄存器的第6个字的 第4位的值。

标签 ：MB0:3.5
数据值类型 ：开关量
描述 ：M寄存器的第4个字节的 第6位的值。

6.注意事项