新建网页 1

西门子S7-300系列(MPI)

概述 硬件连接 创建标签 标签的地址规则 标签举例

概述

MPI 协议支持与德国西门子公司SIMATIC S7-300系列PLC之间的通讯。在计算机中安装好MPI卡（或使用PC-Adapter适配器）后，用MPI电缆将PLC与计算机连接好。再开始安装西门子公司提供的PRODAVE-S7软件，通过PRODAVE-S7的配置程序PG-PC Interf ace正确配置MPI卡（或使用PC-Adapter适配器）和PLC参数。目前本驱动支持的设备有：S7_312C, S7_313C, S7_313C2PtP, S7_313C2DP,S7_314C2PtP,S7_314C2DP,S7_312IFM,S7_313, S7_314, S7_314IFM, S7_315, S7_3152DP,S7_3162DP,S7_3182DP 412-1,412-2 ,414-2, 414-3 ,416-2,416-3, 417-4。

硬件连接

1． 用MPI卡与PLC连接
您可以按下图将监控软件与一个或多个PLC相连。

2． 使用MPI适配器与PLC连接

3． SIMATIC S7-300系列PLC与系统的接线图

请详见相关硬件设备手册

创建标签

使用设备向导创建完成模块的配置后，可以进行标签设计。

1、在开发环境的‘标签’中添加标签，显示下图，选择主设备为上面的‘西门子S7_300PLC’，选择并填写‘主设备地址’，修改标签名。

2、根据模块的工作模式和标签所监控的参数物理意义，修改测量值零点、测量值量程、工程值零点、工程值量程、扫描周期、转换方式、记录属性等。单击‘添加’或‘完成’按钮。

标签的地址规则

标签的主地址可以按照下面的规则配置填写：

标签类型[ID:]ChID[.BitID[.ThirdSegID[.FourSegID[.FiveSegID]]]]

说明：

  • ID指网络中的硬件子设备地址，用于识别设备中的某个硬件子设备。 一般情况下，ID可以是十进制或十六进制表示形式,位数不限。通常从0开始编址。

  • ChID一般指通道号。可以是十进制或八进制或十六进制表示形式,位数不限。通常从0开始编址。

  • BitID指开关量标签的位序号。可以是八进制或十六进制表示形式,位数不限。通常从0开始编址。

  • ID,ChID,BitID,ThirdSegID,FourSegID,FiveSegID的含义可以自由定义。可以是十进制或八进制或十六进制表示形式,位数不限。通常从0开始编址。

  • 红色字表示格式中可变部分，变化范围参见各种 驱动的帮助文件。

  • 蓝色括号不出现在标签地址中，蓝色括号内的内容在设备中只包含一个 子设备时可省略。

  • 标签地址配置成不存在类型或模块地址错误或通道号超出有效范围时，标签将不被承认，读不上数据。

标签地址 | 含义 | 数据类型 | 读写类型 | CH(通道)范围 | Bit(通道)范围 | 标签值范围
A ID：CH.Bit | 按位读写数字量输出寄存器（Q） | 开关量 | 读写 | 0--8192 | 0--7 | true 或 false
AB ID：CH | 按字节读写输出寄存器（Q） | 模拟量 | 读写 | 0--8192 | ———— | 0--255
AW ID：CH | 按字读写输出寄存器（Q） | 模拟量 | 读写 | 0--8192 | ———— | 0--65535
DBB ID：CH.Bit | 按安节读写数据块寄存器 | 模拟量 | 读写 | 0--64 | 0--1024 | 0--255
DBW ID：CH.Bit | 按字读写数据块寄存器 | 模拟量 | 读写 | 0--64 | 0--1024 | 0--65535
DBI ID：CH.Bit | 按16们整型读写数据块寄存器 | 模拟量 | 读写 | 0--64 | 0--1024 | -32768--+32767
DBDW ID：CH.Bit | 按双字读写数据块寄存器 | 模拟量 | 读写 | 0--64 | 0--1024 | 0--4294967295
DBDI ID：CH.Bit | 按32位整型读写数据块寄存器 | 模拟量 | 读写 | 0--64 | 0--1024 | -147483648--+147483647
DBF ID：CH.Bit | 按4节字浮点型读写数据块寄存器 | 模拟量 | 读写 | 0--64 | 0--1024 | 浮点数范围
E ID：CH.Bit | 按位读取数字量输入寄存器（I） | 开关量 | 只读 | 0--8192 | 0--7 | true 或 false
EB ID：CH | 按字节读取数字量输入寄存器（I） | 模拟量 | 只读 | 0--8192 | ———— | 0--255
EW ID：CH | 按字读取数字量输入寄存器（I） | 模拟量 | 只读 | 0--8192 | ———— | 0--65535
M ID：CH.Bit | 按位读写位寄存器（M） | 开关量 | 读写 | 0--8192 | 0--7 | true 或 false
MB ID：CH | 按字节读写位寄存器（M） | 模拟量 | 读写 | 0--8192 | ———— | 0--255
MW ID：CH | 按字读写位寄存器（M） | 模拟量 | 读写 | 0--8192 | ———— | 0--65535
T ID：CH | 读取定时器（T） | 模拟量 | 只读 | 0--8192 | ———— | 0--255
Z ID：CH | 读写计数器（C） | 模拟量 | 读写 | 0--8192 | ———— | 0--65535
S ID：CH | 读取状态寄存器 | 模拟量 | 读写 | 0 | ———— | 0（运行）或1（停止）

标签举例:

    标签：A 2:0.0
    数据    值类型：开关量
    描述：表示    读写ID号为2的PLC中输出寄存器第1字节中的第1位

    标签：AB2:30
    数据    值类型：模拟量
    描述：表示    读写ID号为2的PLC中输出寄存器中第30字节的值

    标签：AW2:30
    数据    值类型：模拟量
    描述：表示    读写ID号为2的PLC中输出寄存器中30，31字节的值

    标签：DBB2:1.0
    数据    值类型：模拟量
    描述：表示    读写ID号为2的PLC中1号DB块第1字节寄存器的值

    标签：DBW2:2.4
    数据    值类型：模拟量
    描述：表示    读写ID号为2的PLC中2号DB块第5字节、第6字节寄存器组合成的无符号16位整型值

    标签：DBI2:3.4
    数据    值类型：模拟量
    描述：表示    读写ID号为2的PLC中3号DB块第5字节、第6字节寄存器组合成的有符号16位整型值

    标签：DBDW2:4.0
    数据    值类型：模拟量
    描述：表示    读写ID号为2的PLC中4号DB块第0字节、第1字节、第2字节、第3字节寄存器组合成的无符号32位整型值

    标签：DBDI2:5.4
    数据    值类型：模拟量
    描述：表示    读写ID号为2的PLC中5号DB块第4字节、第5字节、第6字节、第7字节寄存器组合成的有符号32位整型值

    标签：DBF2:6.8
    数据    值类型：模拟量
    描述：表示    读写ID号为2的PLC中6号DB块第8字节、第9字节、第10字节、第11字节寄存器组合成的浮点数

    标签：    E2:0.0
    数据    值类型：开关量
    描述：表示    读取ID号为2的PLC中输入寄存器第1字节中的第1位

    标签：EB2:30
    数据    值类型：模拟量
    描述：表示    读取ID号为2的PLC中输入寄存器中第30字节的值

    标签：EW2:30
    数据    值类型：模拟量
    描述：表示    读取ID号为2的PLC中输入寄存器中30，31字节的值

    标签：M2:0.0
    数据    值类型：开关量
    描述：表示    读写ID号为2的PLC中位寄存器第1字节中的第1位

    标签：MB2:30
    数据    值类型：模拟量
    描述：表示    读写ID号为2的PLC中位寄存器中第30字节的值

    标签：MW2:30
    数据    值类型：模拟量
    描述：表示    读写ID号为2的PLC中位寄存器中30，31字节的值组合成的无符号整型值

    标签：T2:0
    数据    值类型：模拟量
    描述：表示    读取ID号为2的PLC中第1个定时器值

    标签：Z2:0
    数据    值类型：模拟量
    描述：表示    读写ID号为2的PLC中第1个计数器值

    标签：S2
    数据    值类型：开关量
    描述：表示ID号为2的PLC的运行状态，0表示运行，1表示停止

常见问题

问题1：
PRODAVE S7软件到哪里可以获得，这个软件是通讯必需的吗？
答：PRODAVE S7软件是西门子公司单独提供的MPI/PPI管理软件，由西门子公司付费提供，用于设定各种通讯设备的通讯设置，并提供简单的数据通讯调试功能。采用MPI方式与西门子的PLC进行数据通讯时，该软件是必须的。

问题2：
在监控软件中为什么标签DBW0≠DBB0+DBB1？
答：数据块寄存器DBB、DBW、DBDW标签比较特殊，在配置标签时需要指定PLC地址、区号和地址号。因此标签地址结构如下：
DBWPLC地址:区号.区内地址
问题中的标签地址没有配置完整，DBB0和DBB1是两个不同区的数据块寄存器，相当于下面表达式：
DBW0.0≠DBB0.0+DBB1.0
DBW和DBB之间实际存在的关系式如下：
DBW0=DBB0.0+DBB0.1

另外，S7-300/400PLC中数据块标签地址的定义为自数据块开始的第几个字节，如DBW2:4.30同DBB2:4.30所读取的数据起始地址是一样的，但是DBB读取一个字节，DBW则读取2个字节，DBF2:4.30同DBDW2:4.30读到的数据是一致的，但是DBF将 数据类型做了转换变成了浮点数。


西门子S7-300系列(MPI)

概述 硬件连接 创建标签 标签的地址规则 标签举例

概述

MPI 协议支持与德国西门子公司SIMATIC S7-300系列PLC之间的通讯。在计算机中安装好MPI卡（或使用PC-Adapter适配器）后，用MPI电缆将PLC与计算机连接好。再开始安装西门子公司提供的PRODAVE-S7软件，通过PRODAVE-S7的配置程序PG-PC Interf ace正确配置MPI卡（或使用PC-Adapter适配器）和PLC参数。目前本驱动支持的设备有：S7_312C, S7_313C, S7_313C2PtP, S7_313C2DP,S7_314C2PtP,S7_314C2DP,S7_312IFM,S7_313, S7_314, S7_314IFM, S7_315, S7_3152DP,S7_3162DP,S7_3182DP 412-1,412-2 ,414-2, 414-3 ,416-2,416-3, 417-4。

硬件连接

1． 用MPI卡与PLC连接
您可以按下图将监控软件与一个或多个PLC相连。

2． 使用MPI适配器与PLC连接

3． SIMATIC S7-300系列PLC与系统的接线图

    请详见相关硬件设备手册

创建标签

使用设备向导创建完成模块的配置后，可以进行标签设计。

  • 1、在开发环境的‘标签’中添加标签，显示下图，选择主设备为上面的‘西门子S7_300PLC’，选择并填写‘主设备地址’，修改标签名。

  • 2、根据模块的工作模式和标签所监控的参数物理意义，修改测量值零点、测量值量程、工程值零点、工程值量程、扫描周期、转换方式、记录属性等。单击‘添加’或‘完成’按钮。

标签的地址规则

    标签的主地址可以按照下面的规则配置填写：

    标签类型[ID:]ChID[.BitID[.ThirdSegID[.FourSegID[.FiveSegID]]]]

    说明：

    • ID指网络中的硬件子设备地址，用于识别设备中的某个硬件子设备。 一般情况下，ID可以是十进制或十六进制表示形式,位数不限。通常从0开始编址。

    • ChID一般指通道号。可以是十进制或八进制或十六进制表示形式,位数不限。通常从0开始编址。

    • BitID指开关量标签的位序号。可以是八进制或十六进制表示形式,位数不限。通常从0开始编址。

    • ID,ChID,BitID,ThirdSegID,FourSegID,FiveSegID的含义可以自由定义。可以是十进制或八进制或十六进制表示形式,位数不限。通常从0开始编址。

    • 红色字表示格式中可变部分，变化范围参见各种 驱动的帮助文件。

    • 蓝色括号不出现在标签地址中，蓝色括号内的内容在设备中只包含一个 子设备时可省略。

    • 标签地址配置成不存在类型或模块地址错误或通道号超出有效范围时，标签将不被承认，读不上数据。

    标签地址

    含义

    数据类型

    读写类型

    CH(通道)范围

    Bit(通道)范围

    标签值范围

    A ID：CH.Bit | 按位读写数字量输出寄存器（Q） | 开关量 | 读写 | 0--8192 | 0--7 | true 或 false
    AB ID：CH 按字节读写输出寄存器（Q） 模拟量 读写 0--8192 ———— 0--255
    AW ID：CH 按字读写输出寄存器（Q） 模拟量 读写 0--8192 ———— 0--65535
    DBB ID：CH.Bit | 按安节读写数据块寄存器 | 模拟量 | 读写 | 0--64 | 0--1024 | 0--255
    DBW ID：CH.Bit | 按字读写数据块寄存器 | 模拟量 | 读写 | 0--64 | 0--1024 | 0--65535
    DBI ID：CH.Bit | 按16们整型读写数据块寄存器 | 模拟量 | 读写 | 0--64 | 0--1024 | -32768--+32767
    DBDW ID：CH.Bit | 按双字读写数据块寄存器 | 模拟量 | 读写 | 0--64 | 0--1024 | 0--4294967295
    DBDI ID：CH.Bit | 按32位整型读写数据块寄存器 | 模拟量 | 读写 | 0--64 | 0--1024 | -147483648--+147483647
    DBF ID：CH.Bit | 按4节字浮点型读写数据块寄存器 | 模拟量 | 读写 | 0--64 | 0--1024 | 浮点数范围
    E ID：CH.Bit | 按位读取数字量输入寄存器（I） | 开关量 | 只读 | 0--8192 | 0--7 | true 或 false
    EB ID：CH 按字节读取数字量输入寄存器（I） 模拟量 只读 0--8192 ———— 0--255
    EW ID：CH 按字读取数字量输入寄存器（I） 模拟量 只读 0--8192 ———— 0--65535
    M ID：CH.Bit | 按位读写位寄存器（M） | 开关量 | 读写 | 0--8192 | 0--7 | true 或 false
    MB ID：CH 按字节读写位寄存器（M） 模拟量 读写 0--8192 ———— 0--255
    MW ID：CH 按字读写位寄存器（M） 模拟量 读写 0--8192 ———— 0--65535
    T ID：CH 读取定时器（T） 模拟量 只读 0--8192 ———— 0--255
    Z ID：CH 读写计数器（C） 模拟量 读写 0--8192 ———— 0--65535
    S ID：CH 读取状态寄存器 模拟量 读写 0 ———— 0（运行）或1（停止）

标签举例:

    标签：A 2:0.0
    数据    值类型：开关量
    描述：表示    读写ID号为2的PLC中输出寄存器第1字节中的第1位

    标签：AB2:30
    数据    值类型：模拟量
    描述：表示    读写ID号为2的PLC中输出寄存器中第30字节的值

    标签：AW2:30
    数据    值类型：模拟量
    描述：表示    读写ID号为2的PLC中输出寄存器中30，31字节的值

    标签：DBB2:1.0
    数据    值类型：模拟量
    描述：表示    读写ID号为2的PLC中1号DB块第1字节寄存器的值

    标签：DBW2:2.4
    数据    值类型：模拟量
    描述：表示    读写ID号为2的PLC中2号DB块第5字节、第6字节寄存器组合成的无符号16位整型值

    标签：DBI2:3.4
    数据    值类型：模拟量
    描述：表示    读写ID号为2的PLC中3号DB块第5字节、第6字节寄存器组合成的有符号16位整型值

    标签：DBDW2:4.0
    数据    值类型：模拟量
    描述：表示    读写ID号为2的PLC中4号DB块第0字节、第1字节、第2字节、第3字节寄存器组合成的无符号32位整型值

    标签：DBDI2:5.4
    数据    值类型：模拟量
    描述：表示    读写ID号为2的PLC中5号DB块第4字节、第5字节、第6字节、第7字节寄存器组合成的有符号32位整型值

    标签：DBF2:6.8
    数据    值类型：模拟量
    描述：表示    读写ID号为2的PLC中6号DB块第8字节、第9字节、第10字节、第11字节寄存器组合成的浮点数

    标签：    E2:0.0
    数据    值类型：开关量
    描述：表示    读取ID号为2的PLC中输入寄存器第1字节中的第1位

    标签：EB2:30
    数据    值类型：模拟量
    描述：表示    读取ID号为2的PLC中输入寄存器中第30字节的值

    标签：EW2:30
    数据    值类型：模拟量
    描述：表示    读取ID号为2的PLC中输入寄存器中30，31字节的值

    标签：M2:0.0
    数据    值类型：开关量
    描述：表示    读写ID号为2的PLC中位寄存器第1字节中的第1位

    标签：MB2:30
    数据    值类型：模拟量
    描述：表示    读写ID号为2的PLC中位寄存器中第30字节的值

    标签：MW2:30
    数据    值类型：模拟量
    描述：表示    读写ID号为2的PLC中位寄存器中30，31字节的值组合成的无符号整型值

    标签：T2:0
    数据    值类型：模拟量
    描述：表示    读取ID号为2的PLC中第1个定时器值

    标签：Z2:0
    数据    值类型：模拟量
    描述：表示    读写ID号为2的PLC中第1个计数器值

    标签：S2
    数据    值类型：开关量
    描述：表示ID号为2的PLC的运行状态，0表示运行，1表示停止

常见问题

问题1：

PRODAVE S7软件到哪里可以获得，这个软件是通讯必需的吗？

答：PRODAVE S7软件是西门子公司单独提供的MPI/PPI管理软件，由西门子公司付费提供，用于设定各种通讯设备的通讯设置，并提供简单的数据通讯调试功能。采用MPI方式与西门子的PLC进行数据通讯时，该软件是必须的。

问题2：

在监控软件中为什么标签DBW0≠DBB0+DBB1？

答：数据块寄存器DBB、DBW、DBDW标签比较特殊，在配置标签时需要指定PLC地址、区号和地址号。因此标签地址结构如下：

DBWPLC地址:区号.区内地址

问题中的标签地址没有配置完整，DBB0和DBB1是两个不同区的数据块寄存器，相当于下面表达式：

DBW0.0≠DBB0.0+DBB1.0

DBW和DBB之间实际存在的关系式如下：

DBW0=DBB0.0+DBB0.1

另外，S7-300/400PLC中数据块标签地址的定义为自数据块开始的第几个字节，如DBW2:4.30同DBB2:4.30所读取的数据起始地址是一样的，但是DBB读取一个字节，DBW则读取2个字节，DBF2:4.30同DBDW2:4.30读到的数据是一致的，但是DBF将数据类型做了转换变成了浮点数。