西门子S7-200系列PLC

概述 硬件连接 硬件设置 标签地址列表 标签地址规则 标签地址举例 在线升级驱动

PPI通信协议概述

PPI协议支持与德国西门子公司西门子S7-200系列PLC之间的通讯。支持 CPU221,CPU222,CPU224,CPU226以及其扩展。本协议采用串行通讯，使用你计算机中的串口。

S7-200系列PLC与开物2000系统的连接

您可以按下图将开物2000与一个或多个PLC相连。

硬件设置

在PC/PPI电缆上有DIP开关，可设置通讯的波特率，具体的设置方法如下：

38.4K 0000
19.2K 0010
9.6K 0100
2.4K 1000
1.2K 1010

通讯参数的缺省设置：

设置项 设置值
波特率： 9600bps
数据位： 8位
校验 ： 无校验
停止位： 1位

创建设备

在开发环境的‘硬件系统’中按照‘新节点和设备向导’的指示配置所连接的模块。以便于开物2000识别和使用。

步骤1：选择设备类型。双击‘西门子S7-200系列PLC’，或单击选中‘西门子S7-200系列PLC’，更改设备名称，最后单击‘选择’按钮。

步骤2：选择操作方式-新建设备(一个设备中可以包含多个)。选中‘新建设备’后单击‘下一步’按钮(或双击‘新建设备’)。

步骤3： 显示单个、多个仪表或者自动创建，单击‘下一步’按钮。

步骤4：单击“下一步”。

步骤5：显示串口的设定参数，单击“下一步”。

注：通讯超时时间可以修改，现在的超时时间设定为300毫秒，最大值设定不能超过1000毫秒

步骤6：显示设备的设定参数，单击“完成”。

西门子S7-200系列PLC的标签地址表

我们的驱动程序支持本系列PLC CPU221,CPU222,CPU224,CPU226以及其扩展。
所支持的寄存器为 I, Q, AIW, AQW, V, SM。
由于S7-200系列PLC的型号不同，设备地址的范围不同和格式如下表：
寄存器名称 寄存器范围

标签地址格式

CPU221 | CPU222 | CPU224 | CPU226 | 位 | 字节 | 字 | 双字
I 寄存器 | I0.0~I15.7 | I0.0~I15.7 | I0.0~I15.7 | I0.0~I15.7 | Ix.y | IBx | IWx | IDx
寄存器 | Q0.0~Q15.7 | Q0.0~Q15.7 | Q0.0~Q15.7 | Q0.0~Q15.7 | Qx.y | QBx | QWx | QDx
模拟输入 | AIW0~AIW30 | AIW0~AIW30 | AIW0~AIW30 | AIWx
模拟输出 | AQW0~AQW30 | AQW0~AQW30 | AQW0~AQW30 | AQWx
变量寄存器 | VB0.0~VB2047.7 | VB0.0~VB2047.7 | VB0.0~VB5119.7 | VB0.0~VB5119.7 | Vx.y | VBx | VWx | VDx
特殊寄存器 | SM0.0~SM179.7 | SM0.0~SM179.7 | SM0.0~SM179.7 | SM0.0~SM179.7 | SMx.y | SMBx | SMWx | SMDx
位存储器 | M0.0~M31.7 | M0.0~M31.7 | M0.0~M31.7 | M0.0~M31.7 | Mx.y | MBx | MWx | MDx

注意：站号从2开始。

西门子S7-200系列PLC标签地址格式

对于不同的型号的设备地址格式在开物2000的标签中的地址格式与S7-200的编程软件是一致的，以CPU224为例说明：

标签地址格式如下:

开关量输入I寄存器:
I 0.0~I0.7…I15.0~I15.7, IB0~B15, IW0~IW14, ID0~ID12 ;

开关量输出Q寄存器：
Q0.0~Q0.7…Q15.0~Q15.7, QB0~QB15,QW0~QW14,QD0~QD12 ;

模拟量输入AIW寄存器：
AIW0~AIW30;

模拟量输出AQW寄存器：
AQW0~AQW30;

变量寄存器V寄存器：
V0.0~V0.7…V5119.0~V5119.7,VB0~VB5119,VW0~5118, VD0~5116;

特殊寄存器SM寄存器：
S0.0~SM0.7…SM179.0~SM179.7,SMB0~SMB179,SMW0 ~SMW178,
SMD0~SMD176;

最常用的定义方法：
V X XXXX

标签地址举例

标签地址：I0.0
数据类型：开关量
数据长度：BIT
描述：变量寄存器I0.0(为一个位)

标签地址：VW200
数据类型：模拟量
数据长度：WORD
描述：变量寄存器VW200(两个字节200和201)

标签地址：VD200
数据类型：模拟量
数据长度：DOUBLE WORD
描述：变量寄存器VD200(四个字节200、201、202和203)