西门子S7-200系列PLC (Modem)

西门子S7-200系列PLC [image] (Modem)

概述 硬件连接 硬件设置 标签地址列表 标签地址规则 标签地址举例 在线升级驱动 常见问题

概述

S7_200通过Modem与开物2000进行通讯，和开物2000通过PPI电缆通信没有区别，只不过中间通过Modem连接而已，关键在于设备与Modem的连接。必须首先通过S7_200软

件与Modem进行连接，按照如下的设置进行配置。

硬件设置

设置步骤：本例使用全向 极光III(蓝谭星跃+) V.92 Modem STEP 7-Micro/Win32软件

一、连接方式：计算机--〉Modem----PSTN----Modem---->S7-200 PLC

二、远端Modem和S7200连线方法：配置如下电缆，连接与MODEM和PPI电缆之间。

2--3

3--2

5--5

三、设置方法

1、PC/PPI cable的特性配置：选中使用Modem Connect项。

2、配置Local Modem

新建quanxiang Modem

初始化：AT&f&D0E0&k0\N0X3S37=9&W0\N

Prefix :ATDT

HangUp String:ATH0

配置完成后： 测试‘Program/Test’的Status一定要成功。

3、配置Remote Mode

新建quanxiang Modem

初始化：AT&f&D0E0&k0\N0X3S0=1S37=9&W0\N

配置完成后： 测试‘Program/Test’的Status一定要成功。

注：要在本地将远程猫进行以上操作设置。（即将参数写入远程猫中）

4、双击Connect Modem输入电话号码后，自动连接。

5、连接成功后，Refresh PLC 会自动搜索在线的PLC,使用和没有Modem

注：常用AT指令。

&V:察看Modem配置

&W:保存配置

S0=0:自动应答，响铃一次后自动应答

&D0:忽略DTR

E0:关闭本地回应

&K0:禁用流控制

\N0:缓冲模式，无错误控制

四 在PC/PPI电缆上有DIP开关，可设置通讯的波特率，具体的设置方法如下：

38.4K 0000
19.2K 0010
9.6K 0100
2.4K 1000
1.2K 1010

通讯参数的缺省设置：

设置项 设置值
波特率： 9600bps
数据位： 8位
校验 ： 无校验
停止位： 1位

在开物2000开发环境中创建设备

在开发环境的‘硬件系统’中按照‘新节点和设备向导’的指示配置所连接的仪表。以便于开物2000识别和使用。

步骤1：选择设备类型。双击‘西门子S7-200系列PLC (Modem)’，或单击选中‘西门子S7-200系列PLC (Modem)’，更改设备名称，最后单击‘选择’按钮。

步骤2：选择操作方式-新建设备(一个设备中可以包含多个PLC)。选中‘新建设备’后单击‘下一步’按钮(或双击‘新建设备’)。

步骤3：选择创建设备的方式：选中‘单个PLC创建’后，单击‘下一步’按钮。

步骤4：显示创建单个PLC界面。终端号码为远程Modem所连接的电话的号码。单击‘下一步’按钮。

步骤5：显示串口通讯参数配置窗口，按照实际连接情况，更改完串口后，单击‘下一步’按钮。

步骤6：显示设备及参数汇总窗口，单击‘完成’按钮，结束设备配置向导。

标签的创建

使用设备向导创建完成仪表的配置后，可以进行标签设计。

1、在开发环境的‘标签’中添加标签，显示下图，选择主设备为上面的‘TM205’，选择并填写‘主设备地址’，修改标签名。

2、根据仪表的工作模式和标签所监控的参数物理意义，修改测量值零点、测量值量程、工程值零点、工程值量程、扫描周期、转换方式、记录属性等。单击‘添加’或‘完成’按钮。

西门子S7-200系列PLC的标签地址表

我们的驱动程序支持本系列PLC CPU221,CPU222,CPU224,CPU226以及其扩展。
所支持的寄存器为 I, Q, AIW, AQW, V, SM。
由于S7-200系列PLC的型号不同，设备地址的范围不同和格式如下表：
寄存器名称 寄存器范围

标签地址格式

CPU221 | CPU222 | CPU224 | CPU226 | 位 | 字节 | 字 | 双字
I 寄存器 | I0.0~I15.7 | I0.0~I15.7 | I0.0~I15.7 | I0.0~I15.7 | Ix.y | IBx | IWx | IDx
寄存器 | Q0.0~Q15.7 | Q0.0~Q15.7 | Q0.0~Q15.7 | Q0.0~Q15.7 | Qx.y | QBx | QWx | QDx
模拟输入 | AIW0~AIW30 | AIW0~AIW30 | AIW0~AIW30 | AIWx
模拟输出 | AQW0~AQW30 | AQW0~AQW30 | AQW0~AQW30 | AQWx
变量寄存器 | VB0.0~VB2047.7 | VB0.0~VB2047.7 | VB0.0~VB5119.7 | VB0.0~VB5119.7 | Vx.y | VBx | VWx | VDx
特殊寄存器 | SM0.0~SM179.7 | SM0.0~SM179.7 | SM0.0~SM179.7 | SM0.0~SM179.7 | SMx.y | SMBx | SMWx | SMDx
位存储器 | M0.0~M31.7 | M0.0~M31.7 | M0.0~M31.7 | M0.0~M31.7 | Mx.y | MBx | MWx | MDx

注意：站号从2开始。

西门子S7-200系列PLC标签地址格式

对于不同的型号的设备地址格式在开物2000的标签中的地址格式与S7-200的编程软件是一致的，以CPU224为例说明：

标签地址格式如下:

开关量输入I寄存器:
I 0.0~I0.7…I15.0~I15.7, IB0~B15, IW0~IW14, ID0~ID12 ;

开关量输出Q寄存器：
Q0.0~Q0.7…Q15.0~Q15.7, QB0~QB15,QW0~QW14,QD0~QD12 ;

模拟量输入AIW寄存器：
AIW0~AIW30;

模拟量输出AQW寄存器：
AQW0~AQW30;

变量寄存器V寄存器：
V0.0~V0.7…V5119.0~V5119.7,VB0~VB5119,VW0~5118, VD0~5116;

特殊寄存器SM寄存器：
S0.0~SM0.7…SM179.0~SM179.7,SMB0~SMB179,SMW0 ~SMW178,
SMD0~SMD176;

最常用的定义方法：
V X XXXX

标签地址举例

标签地址：I0.0
数据类型：开关量
数据长度：BIT
描述：变量寄存器I0.0(为一个位)

标签地址：VW200
数据类型：模拟量
数据长度：WORD
描述：变量寄存器VW200(两个字节200和201)

标签地址：VD200
数据类型：模拟量
数据长度：DOUBLE WORD
描述：变量寄存器VD200(四个字节200、201、202和203)

常见问题

1、开物2000的通过Modem与S7-200硬件的设置连接中需要注意的问题？

答：添加硬件，在设备参数中填写远端设备对应的电话号码；在标签中配置为每个设备配置一标签ENMODEM，为模拟量标签，当置ENMODEM=0时关闭该设备对应的MODEM连接；当置ENMODEM=1时打开该设备对应的MODEM连接；同一时间只能有一只远端MODEM处于工作状态；其他标签的用法同串口驱动。

标签名称： 标签类型+设备单元号

例访问：单元号为6设备的 ，建标签 ENMODEM6；当置ENMODEM6=0 时，关闭MODEM通讯；当置ENMODEM6=1 时，打开MODEM通讯

注意*MODEM 的连接超时时间为30秒，当一次连接失败后会重新启动第二次连接，两次连接失败就取消连接操作。

*因使用的MODEM不同一些参数的设置值可能需做调整