艾默生PLC

概述 标签说明 标签举例 在线升级驱动

概述

本驱动程序提供艾默生PLC的支持。

仪表通讯参数

通讯格式默认为：1 位启始位，8位数据位，1 位停止位， 偶校验。

波特率：4800、9600、19200、38400bps可选。

地址：可选范围为1～31，十进制。

标签说明

项目符号

下表中ID指仪表的设备表号(开物2000设备向导中的设备号)。

项目符号

红色字表示格式中设备号，十进制数表示 ，蓝色部分表示地址号，十进制表示。

项目符号

注:此处仪表中的通信地址以10进制表示。

项目符号

标签命名规则位，'＿'前面为艾默生PLC的寄存器类型，后面为数据格式，其中'S'代表有符号；'W'代表字格式；'DW'代表双字格式；'F'代表浮点数；

项目符号

对于四个字节的标签，其规则一般为读取CH对应的寄存器号开始的连续两个寄存器 ，如读取D寄存器D0000，D0001，D0002，D0003对应的两个DWORD对应的数据，则标签配置为D_DW1:0和D_DW1:2，其中D_DW1:0对应D0000和D0001，D_DW1:2对应D0002和D0003。 例外情况为C_DW和C_SDW，其一个标签本身就对应两个寄存器，如读取C200和C201，则分别建立标签C_DW200和C_DW201，其中C_DW200对应9700和9701，C_DW201对应9702和9703。

标签地址

含义

数据类型

读写类型

通道地址范围

标签值范围

X ID:CH

读取外部输入继电器

开关量

只读

10进制:0-255[8进制:0-377]，标签中使用8进制

0/1[true/false]

Y ID:CH

读取输出频率

开关量

读写

10进制:0-255[8进制:0-377]标签中使用8进制

0/1[true/false]

M ID:CH

读取|设置辅助继电器

开关量

读写

10进制:0-1999

0/1[true/false]

SM ID:CH

读取|设置特殊辅助继电器

开关量

读写

10进制:0-255

0/1[true/false]

S ID:CH

读取|设置步进状态继电器

开关量

读写

10进制:0-991

0/1[true/false]

T ID:CH

读取|设置定时器状态

开关量

读写

10进制:0-255

0/1[true/false]

C ID:CH

读取|设置计数器状态

开关量

读写

10进制:0-255

0/1[true/false]

D_SW ID:CH

读取|设置数据寄存器[有符号|字格式]

模拟量

读写

10进制:0-7999

-32768--32767

SD_SW ID:CH

读取|设置特殊数据寄存器[有符号|字格式]

模拟量

读写

10进制:0-255

-32768--32767

C_SW ID:CH

读取|设置计数器寄存器当前值[有符号|字格式]

模拟量

读写

10进制:0-199

-32768--32767

T_SW ID:CH

读取|设置定时器寄存器当前值[有符号|字格式]

模拟量

读写

10进制:0-255

-32768--32767

Z_SW ID:CH

读取|设置数据寄存器[有符号|字格式]

模拟量

读写

10进制:0-15

-32768--32767

D_W ID:CH

读取|设置数据寄存器[无符号|字格式]

模拟量

读写

10进制:0-7999

0--65535

SD_W ID:CH

读取|设置特殊数据寄存器[无符号|字格式]

模拟量

读写

10进制:0-255

0--65535

C_W ID:CH

读取|设置计数器寄存器当前值[无符号|字格式]

模拟量

读写

10进制:0-199

0--65535

T_W ID:CH

读取|设置定时器寄存器当前值[无符号|字格式]

模拟量

读写

10进制:0-255

0--65535

Z_W ID:CH

读取|设置变址寄存器[无符号|字格式]

模拟量

读写

10进制:0-15

0--65535

D_SDW ID:CH

读取|设置数据寄存器[有符号|双字格式]

模拟量

读写

10进制:0-7998

-2147483648--2147483647

SD_SDW ID:CH

读取|设置特殊数据寄存器[有符号|双字格式]

模拟量

读写

10进制:0-254

-2147483648--2147483647

C_SDW ID:CH

读取|设置计数器寄存器当前值[有符号|双字格式]

模拟量

读写

10进制:200-255

-2147483648--2147483647

D_DW ID:CH

读取|设置数据寄存器[无符号|双字格式]

模拟量

读写

10进制:0-7998

0--4294967295

SD_DW ID:CH

读取|设置特殊数据寄存器[无符号|双字格式]

模拟量

读写

10进制:0-254

0--4294967295

C_DW ID:CH

读取|设置计数器寄存器当前值[无符号|双字格式]

模拟量

读写

10进制:200-255

0--4294967295

D_F ID:CH

读取|设置特殊数据寄存器[四字节浮点数]

模拟量

读写

10进制:0-7998

-99999999--99999999

标签举例：(以多个仪表创建为例，标签中包括仪表号)

标签 ：X1:377
数据值类型：模拟量
描述 ：表示读取1号PLC的377号[8进制]外部输入继电器。

标签 ：Y1:377
数据值类型：模拟量
描述 ：表示读取1号PLC的377号[8进制]外部输出继电器。

标签 ：T1:10
数据值类型：模拟量
描述 ：读取|设置1号PLC的10号定时器状态。

标签 ：D_W1:10
数据值类型：模拟量
描述 ：读取|设置1号PLC的10号数据寄存器[无符号|字格式]。

标签 ：D_SW1:10
数据值类型：模拟量
描述 ：读取|设置1号PLC的10号数据寄存器[有符号|字格式]。

标签 ：D_SDW1:10
数据值类型：模拟量
描述 ：读取|设置1号PLC的10号数据寄存器[有符号|双字格式]。

标签 ：D_DW1:10
数据值类型：模拟量
描述 ：读取|设置1号PLC的10号数据寄存器[无有符号|双字格式]。

标签 ：D_F1:10
数据值类型：模拟量
描述 ：读取|设置1号PLC的10号数据寄存器[浮点数格式]。