研华ADAM7000系列PLC

概述 硬件连接 创建设备 创建标签 标签的地址规则 标签举例 在线升级驱动

概述

ADAM7000以232，485方式与开物2000进行通讯，使用计算机的串行口。在 使用的该协议中系统会根据连接设备自动识别。

硬件连接

提供RS233（PORT0，PORT1）和RS485（PORT3）三个通讯口，通讯标准为：

Port0：波特率 9.6K-38.4K LRC校验

Port1: 波特率 600-38.4k LRC校验

Port2: 4800-614.4k LRC校验或CRC-16校验

ADAM7000连接站号为1-255

ADAM-7000接线方式：

l 计算机经过RS485转换器连接到ADAM7000模块的PORT2，PORT2的端口参数由

模块R1458寄存器设定，默认值为5521H；高位不为55H时通讯参数被内定为9600BPS，7DATA，1STOP。设定方式参考：高位为55H，低位如下；

B7：奇偶校验， 0-EVEN；1-ODD；

B6：数据位长度 0-7BIT；1-8BIT；

B5 是否校验 0-无校验；1-有校验；

B4 停止位 0-1BIT；1-2BIT；

B3B2B1B0 ：0000-4800BPS；0001-9600BPS；0010-19200BPS；0011-38400BPS

使用7095转换模块将ADAM7000模块CPU板的PORT0端口转换为两个普通RS232和一个以太网端口，计算机通过转换后的端口与模块相连。PORT0参数为9600BPS，7DATA，1STOP。

默认通讯参数如下：

波特率 | 9600bps
数据位 | 8
停止位 | 1
校验方式 | 无校验

创建设备

在开发环境的‘硬件系统’中按照‘新节点和设备向导’的指示配置所连接的PLC。以便于开物2000识别和使用。

步骤1：选择设备类型。双击‘’，或单击选中‘’，更改设备名称，最后单击‘选择’按钮。

步骤2：选择操作方式-新建设备(一个设备中可以包含多个)。选中‘新建设备’后单击‘下一步’按钮(或双击‘新建设备’)。

步骤3：选择创建方式(一个设备中可以包含多个)。选中 创建方式后单击‘下一步’按钮(或双击‘标准创建’)。

步骤4：设置PLC类型和设备号，单击‘下一步’按钮。

步骤5：设备串口通讯参数，单击‘下一步’。

步骤6：显示设备及参数配置图，点击‘完成’按钮，完成设备配置向导.

创建标签

使用设备向导创建完成PLC设备的配置后，可以进行标签设计。

1、在开发环境的‘标签’中添加标签，显示下图，选择主设备为上面的‘’，选择并填写‘主设备地址’，修改标签名。

2、根据PLC的工作模式和标签所监控的参数物理意义，修改测量值零点、测量值量程、工程值零点、工程值量程、扫描周期、转换方式、记录属性等。单击‘添加’或‘完成’按钮。

标签的地址规则

标签的主地址可以按照下面的规则配置填写：

标签类型[ID:][CH]

说明：

项目符号

ID指PLC的站号地址，用于识别设备中的PLC， PLC的站号地址以十进制表示，地址设定范围为0～ 255 。标签地址中省略ID时，开物2000系统默认为是所连接设备的最小的站号地址。

项目符号

Ch指的是PLC的寄存器地址。地址采用十进制.

项目符号 标签地址配置成不存在类型或模块地址错误或通道号超出有效范围时，标签将不被承认，读不上数据。

标签地址

含义

数据类型

读写类型

通道地址范围

标签值范围

XID:CH

输入寄存器（位）

开关量

只读

0～255

0/1

XWID:CH

输入 寄存器（字）

模拟量

只读

0～240 0～65535

YID:CH

输出寄存器（位）

开关量

只读

0～255

0/1

YW ID:CH

输出寄存器（字）

模拟量

只读

0～240 0～65535

M ID:CH

保持寄存器（位）

开关量

可读可写

0～799 (非保持)

800～1399（保持）

1400～1911（非保持）

1912～2001（特殊）

0/1

MW ID:CH

保持寄存器（字）

模拟量

可读可写

0～1986 0～65535

SID:CH

步进寄存器

开关量

只读

0～499 （非保持）

500~999（保 持）

0/1

SWID:CH

步进寄存器

开关量

只读

0～984 0～65535

TBD:CH

定时器状态

开关量

只读

0～255

0/1

CBID:CH

计数器状态

开关量

只读

0～255

0/1

TWID:CH

定时器当前值

模拟量

可读可写

0～255 0～65535

CWID:CH

计数器当前值

模拟量

可读可写

0～255 0～65535

RID:CH

资料暂存器

模拟量

可读可写

0～8071

0～65535

标签举例

标签 ：X0:2
数据值类型：开关量
描述 ：表示设备配置示例中站号地址为0的PLC的通道地址为2的输入 寄存器的状态

标签 ：XW1:2
数据值类型：模拟量
描述 ：表示设备配置示例中站号地址为1的PLC的通道地址为2的 输入寄存器的状态

标签 ：Y1:2
数据值类型：开关量
描述 ：表示设备配置示例中站号地址为1的PLC的通道地址为2的输出寄存器的状态

标签 ：YW1:2
数据值类型：模拟量
描述 ：表示设备配置示例中站号地址为1的PLC的通道地址为2的保持继电器的状态

标签 ：M1:2
数据值类型：开关量
描述 ：表示设备配置示例中站号地址为1的PLC的通道地址为2的 内部非保持寄存器的状态

标签 ：MW1:2
数据值类型：模拟量
描述 ：表示设备配置示例中站号地址为1的PLC的通道地址为2的辅助寄存器的值

标签 ：S1:2
数据值类型：开关量
描述 ：表示设备配置示例中站号地址为1的PLC的通道地址为2的 步进非保持寄存器的状态

标签 ：SW1:2
数据值类型：模拟量
描述 ：表示设备配置示例中站号地址为1的PLC的通道地址为2的连接寄存器的值

标签 ：CB1:20
数据值类型：开关量
描述 ：表示设备配置示例中站号地址为1的PLC的道地址为20的计数器的状态

标签 ：TB1:12
数据值类型：开关量
描述 ：表示设备配置示例中站号地址为1的PLC的 通道地址为12的定时器的状态

标签 ：CW1:20
数据值类型：模拟量
描述 ：表示设备配置示例中站号地址为1的PLC的 通道地址为20的计数器的当前值

标签 ：TW1:12
数据值类型：模拟量
描述 ：表示设备配置示例中站号地址为1的PLC的 通道地址为12的定时器的当前值

标签 ：R1:20
数据值类型：模拟量
描述 ：表示设备配置示例中站号地址为1的PLC的 通道地址为20的资料暂存器的当前值

注：关于字状态的寄存器的地址表示方法