盟立OMC1系列PLC

概述 硬件连接 创建设备 创建标签 标签的地址规则 标签举例 在线升级驱动 常见问题

概述

盟立OMC1系列PLC与开物2000进行串口通讯的时候采用Modbus RTU协议进行通讯。它只支持00、40参数的读写操作，00、40四种参数的实际含义需要查阅 兼容设备的技术手册和通讯手册 。该设备与开物2000进行通讯前，设备的通讯端口要与计算机的空闲串口连接。

硬件连接

通过查阅此硬件设备的技术手册和通讯手册，可以找到设备与计算机串口的连接线定义。RS485/RS422和串口之间需要增加485/232转换器。

RS232通讯方式的硬件连接入下图所示：

创建设备

在开发环境的‘硬件系统’中按照‘新节点和设备向导’的指示配置所连接的设备。以便于开物2000识别和使用。

步骤1： 单击［PLC］组前的‘+’号，展开［PLC］组。双击［ 盟立OMC1系列PLC］，单击‘选择’按钮。

步骤2：选择操作方式-新建设备。选中［新建设备］后单击［下一步］按钮 （或双击［新建设备］）。

步骤3：选择创建设备方式。根据网络连接方式进行选择，对于RS232方式，选中 ［单个设备创建］后单击［下一步］按钮（或双击［单个设备创建］）。

步骤4：显示创建单个设备界面。在界面上选择完设备类型，修改完设备号后（设备号的含义和取值范围请参考硬件设备的产品手册），单击［下一步］按钮。

步骤5：显示串口参数配置窗口， 根据设备和实际通讯连接情况，选择串口，修改其它参数。单击［下一步］按钮。

步骤6：显示设备及参数汇总窗口，单击［完成 ］按钮，结束设备配置向导。

创建标签

使用设备向导创建完成模块的配置后，可以进行标签设计。

1、选择并填写［主设备地址］，修改标签名称。

2、根据模块的工作模式和标签所监控的参数物理意义，修改测量值零点、测量值量程、工程值零点、工程值量程、扫描周期、转换方式、记录属性等。单击‘添加’或‘完成’按钮。

标签的地址规则

标签的主地址可以按照下面的规则配置填写：

标签类型[ID:]Ch

说明：

项目符号

标签类型指的是00、40两种类型。

项目符号

ID指设备地址，用于识别开物工程设备中的某个PLC。ID是十进制表示形式，位数不限。从1开始编址。标签地址中省略ID时，开物2000系统默认为是所连接的设备地址是开物工程设备中的最小的设备地址。

项目符号

Ch指参数地址号。是十进制表示。地址范围：40XXX寄存器的从400001开始，00XXX寄存器的地址从00002开始。

项目符号 | 红色字表示格式中可变部分，变化范围参见各种PLC的技术手册。
项目符号 | 蓝色括号不出现在标签地址中，蓝色括号内的内容在 工程设备中只包含一个子设备时可省略。
项目符号 | 标签地址配置成不存在类型或设备地址错误或 参数地址超出有效范围时，标签将不被承认，读不上数据。

标签地址

含义

数据类型

读写类型

标签值范围

00 ID:Ch

开关量输入/输出

开关量

读写

true= 线圈闭合

false=线圈断开

40 ID:Ch

模拟量输入/输出

模拟量

读写

0～65535

标签举例

标签 ：401:007
数据值类型：模拟量
描述 ：表示设备配置示例中1号设备的Modbus映射地址为40007寄存器的值

标签 ：001:002
数据值类型：开关量
描述 ：表示01号设备的Modbus映射地址为00002的开关量输入/输出的状态

常见问题

1、在Fama_P31编程软件中进行Modbus地址映射需要注意的问题？

答：在Fama_P31编程软件中进行Modbus地址映射时，4XXXX寄存器和0XXXX寄存器的映射，必须分别从40001和00001开始。

但是由于本身的硬件关系，地址为（00001）的标签状态不能被开物2000以标签的形式显示出来。所以用户在开物2000软件中定义0XXXX寄存器

的标签的时候，需要从00002开始定义标签地址。由于硬件的原因，不得不把00001地址给舍弃掉。但是该地址必须被映射一个变量。

（注：开物2000软件中标签地址与Fama_P31编程软件中的Modbus映射地址是一一对应的）。