欧姆龙PLC版本及状态信息

欧姆龙PLC

概述 硬件连接 硬件设置 通讯线连接图 标签地址列表 标签地址规则 标签地址举例 在线升级驱动 华富惠通公司

HostLink通信协议概述

欧姆龙HostLink 协议支持与欧姆龙PLC的通讯。本协议采用串行通讯，使用您的计算机中的串行口。您可以按下图将开物2000与一个或多个PLC相连。开物2000与PLC之间的连接可以采用连接适配器，如3G2A6-LK201-EV1、C200H-LK201等，也可以直接与带有RS232接口的PLC连接。

欧姆龙PLC与开物2000系统的连接

您可以按下图将开物2000与一个或多个PLC相连。

硬件设置

当使用RS232与上位机相连时，PLC的推荐设置如下：
设置项 | 推荐值
波特率： 9600
数据位长度 | 7
停止位长度 | 2
奇偶校验位 | 偶校验

当使用RS232与上位机相连时，PLC的通讯参数配置请参照相应型号的使用手册。这里对连接适配器3G2A6-LK201-EV1的设置略作说明。连接的传输速度（波特率）由连接适配器3G2A6-LK201-EV1背板上的SW2上的1-4决定对应关系如下：

波特率

SW2.1

SW2.2

SW2.3

SW2.4

19200

OFF

OFF

ON

OFF

9600

ON

OFF

ON

OFF

4800

OFF

ON

ON

OFF

2400

ON

ON

ON

OFF

1200

OFF

OFF

OFF

ON

600

ON

OFF

OFF

ON

300

OFF

ON

OFF

ON

推荐值

ON

OFF

ON

OFF

连接的数据位长度、停止位长度、奇偶校验位由连接适配器3G2A6-LK201-EV1背板上的SW1上的6-7决定。对应关系如下：

对应列表

SW1.6

SW1.7

奇偶校验

传输代码

OFF

OFF

偶校验

7位ASCII,二位停止位

OFF

ON

奇校验

ON

OFF

偶校验

8位JIS,一位停止位

ON

ON

奇校验

推荐值

OFF

OFF

偶校验

7位ASCII,二位停止位

除以上推荐设置外，SW2.6应设为OFF，SW1.8设为ON。

当使用RS232与上位机相连时，PLC的地址在开物2000中的设置范围从1到31。以3G2A6-LK201-EV1为例该地址由背板上的SW1上的1-5决定。对应关系如下：

地址号

SW1.1

SW1.2

SW1.3

SW1.4

SW1.5

0

OFF

OFF

OFF

OFF

OFF

1

OFF

OFF

OFF

OFF

0N

2

OFF

OFF

OFF

0N

OFF

3

OFF

OFF

OFF

0N

0N

--

--

--

--

--

--

30

0N

0N

0N

0N

OFF

31

0N

0N

0N

0N

0N

通讯线连接图

标签的地址配置规则

标签的主地址可以按照下面的规则配置填写：

标签类型[StaID:]Chn

说明：
1、StaID指PLC的设备地址，PLC的地址在开物2000中的设置范围从1-31。

2、Chn指寄存器的地址号。

3、红色字表示格式中可变部分，十进制数表示，变化范围列于取值范围中。蓝色括号不出现在标签地址中，蓝色括号内的内容可省略。标签地址配置成不存在类型或PLC设备地址错误或寄存器的地址号超出有效范围时，标签将不被承认。如定义的标签在所用的下位机具体型号中不存在，将读不上数据。

欧姆龙PLC标签地址列表

标签地址格式代表开物2000标签定义中的主地址。标签类型代表开物2000标签定义中的标签数据类型。

PLC寄存器名称 地址格式

寄存器地址Chn取值范围

位寄存器bit的取值范围
CQM1 | C200H, C200HS, C200HX,C200HE C200HG,CPM1A,SRM1 | CPM2A | CQM1,C200H, C200HS, C200HX,C200HE C200HG,CPM1A,SRM1,CPM2A
状态寄存器 | STATUS[StaID:]Chn | 0 | 0 | 0 | 0
数据寄存器 | DM[StaID:]Chn[.bit] | 0-6655 | 0-6655 | 0-6655 | 0-15
数据寄存器 | DM_BCD[StaID:]Chn | 0-6655 | 0-6655 | 0-6655 | 0
工作寄存器 | WRStaID:]Chn[.bit] | 0-511 | 0-511 | 0-511 | 0-15
工作寄存器 | WR[StaID:]Chn | 0-511 | 0-511 | 0-511 | 0
数据区双寄存器 | DMLength_BCD[StaID:]Chn | 0-6655 | 0-6655 | 0-6655 | 0
特殊寄存器 | SR[StaID:]Chn[.bit] | 244-255 | 244-244 | 228-255 | 0-15(位表示强制置位(true)，强制复位(false);)
辅助寄存器 | AR[StaID:]Chn[.bit] | 0-27 | 0-27 | 0-23 | 0-15(位表示强制置位(true)，强制复位(false);)
输入/输出寄存器 | IR[StaID:]Chn[.bit] | 0-243 | 0-511 | 0-227 | 0-15(位表示强制置位(true)，强制复位(false);)
保持寄存器 | HR[StaID:]Chn[.bit] | 0-99 | 0-99 | 0-19 | 0-15(位表示强制置位(true)，强制复位(false);)
连接寄存器 | LR[StaID:]Chn[.bit] | 0-63 | 0-63 | 0-15 | 0-15(位表示强制置位(true)，强制复位(false);)
定时器/计数器状态 | TC[StaID:]Chn | 0-511 | 0-511 | 0-255 | 0
定时器/计数器当前值 | CNT[StaID:]Chn | 0-511 | 0-511 | 0-255 | 0
取消强制置位\复位 KC[StaID:]Chn 0 0 0 －－
错误寄存器 ERROR[StaID:]Chn[.bit] 0-3 0-3 0-3 0-7

接上：
PLC寄存器名称 | 标签地址格式 | 标签数据类型 | 标签取值范围 | 读写 | 注释
状态寄存器 STATUS[StaID:]Chn 模拟量 0-2 可读写

STATUS的值与PLC操作模式的关系为：
STATUS=0 Programme(编程状态)。
STATUS=1 Monitor(监控状态)。
STATUS=2 Run(运行状态)。

数据寄存器 | DM[StaID:]Chn | 模拟量 | -32768-32767 | 可读写
数据寄存器 | DM_BCD[StaID:]Chn | 模拟量 | 0-9999 | 可读写 | BCD格式数据，如果DM寄存器中的数为十六进制，则会发生错误
数据区双寄存器 | DMLength_BCD[StaID:]Chn | 模拟量 | 0-99999999 | 可读写 | BCD格式数据，如果DM寄存器中的数为十六进制，则会发生错误
特殊寄存器 | SR[StaID:]Chn | 模拟量 | 0-65535 | 可读写
辅助寄存器 | AR[StaID:]Chn | 模拟量 | 0-65535 | 可读写
输入/输出寄存器 | IR[StaID:]Chn | 模拟量 | 0-65535 | 可读写
保持寄存器 | HR[StaID:]Chn | 模拟量 | 0-65535 | 可读写
连接寄存器 | LR[StaID:]Chn | 模拟量 | 0-65535 | 可读写
定时器/计数器状态 | TC[StaID:]Chn | 开关量 | 0-1 | 可读写
定时器/计数器当前值 | CNT[StaID:]Chn | 模拟量 | 0-9999 | 可读写
取消强制置位\复位 | KC[StdID:]Chn | 开关量 | 0 | 只写 | 为true时取消所有强制置位\复位；false不作任何处理
错误寄存器 | ERROR[StaID:]Chn | 模拟量 | 0-255 | 可读写 | 写入任何数据，只表示清除错误。

关于通讯状态标签的说明：

标签地址

含义

数据类型

读写类型

标签值范围

CommLink 通信线路状态(-系统标签-) 模拟量/字符串量

只读

0=通讯始终不成功
1=通讯正常
2=通讯出现干扰
3=通讯出现故障
4=通讯线路断路
5=暂停通讯

DeviceLink ID:

设备通讯连接状态(-系统标签-)

模拟量/字符串量

只读

0=通讯始终不成功
1=通讯正常
2=通讯出现干扰
3=通讯出现故障
4=通讯线路断路
5=暂停通讯

注：
1：ERROR0的含义：

7 6 5 4 3 2 1 0

ERROR0.0=1: 内存错
ERROR0.1=1: JMP指令错
ERROR0.2=1: I/O总线错
ERROR0.3=1: PC连接错
ERROR0.4=1: RTI指令错误
ERROR0.5=1: HostLink单元传送错
ERROR0.6=1: 程序错，丢失END指令（F0）
ERROR0.7=1: FAUS(CPU停止运行)

2: ERROR1的含义

7 6 5 4 3 2 1 0

0，1位的含义如下：
0 0:Group 1(控制信号错)
0 1:Group 2(数据总线故障)
0 0:Group 3( 地址总线故障)
2，3，4位的含义如下：
0 0 0: CPU机架
0 0 0: I/O扩展机架1
0 1 0: I/O扩展机架2
0 1 1: I/O扩展机架7
ERROR1.5=1: 双总线错
ERROR1.6=1：电池故障（F7）
ERROR1.7=1: FAL错

3：ERROR2的含义如下：

7 6 5 4 3 2 1 0

ERROR2.1=1: DM通道错(F8)
ERROR2.3=1: I/O校验错(F7)
ERROR2.4=1: 扫描时间超出（F8）,I/O单元超出
ERROR2.5=1: 间接跳转指令错（F9）
ERROR2.6=1: I/O设置错(E0)
ERROR2.7=1: 远程I/O错(B0~3)

4: ERROR3的含义如下：

FAL, FALS, NO

7 6 5 4 3 2 1 0

5：往ERROR寄存器写入任何数据，只表示清除错误。

标签地址举例

标签地址：DM3:100
数据类型：模拟量
描述 ：3号PLC的数据寄存器DM0100

标签地址：Status8:0
数据类型：模拟量
描述 ：8号PLC所处的状态

STATUS=0 Programme(编程状态)。
STATUS=1 Monitor(监控状态)。
STATUS=2 Run(运行状态)。

标签地址：DMLength_BCD5:1200
数据类型：模拟量
描述 ：5号PLC的数据寄存器DM1200和数据寄存器DM1201组合成的8位十进制数据。DM1200的数据值组成高四位，DM1201的数据值组成低四位。