欧姆龙PLC

概述 硬件设置 设备创建 标签地址列表 标签地址规则 标签地址举例 在线升级驱动

HostLink通信协议概述

欧姆龙HostLink协议支持与欧姆龙PLC的通讯。本协议采用串行通讯，使用您的计算机中的串行口。您可以按下图将开物2000与一个或多个PLC相连。开物2000与PLC之间的连接可以采用连接适配器，如3G2A6-LK201-EV1、C200H-LK201、CJ1等，也可以直接与带有RS232接口的PLC连接。而拨号通讯则是在上位机跟PLC之间用MODEM进行数据传送，这样就大大的扩展了上位监控和现场设备的距离。设备连接只要用两个MODEM分别连接上位机和PLC, 并且分别插上一电话线 (电话号码不同)就可。

硬件设置
MODEM初始化：请按如下步骤进行初始化

AT&F&W0&W1 //恢复出厂设置 ATS0=1 //设置自动应答方式

AT&D0 //MODEM忽略DTR信号 ATS37=9 //设置波特率为9600

AT&K0 //不使用流控 AT&Y1 //设置文件1为活动状态 AT&W1 //保存当前设置到文件1中

当使用RS232与上位机相连时，PLC的推荐设置如下：

设置项 | 推荐值
波特率： 9600
数据位长度 | 7
停止位长度 | 2
奇偶校验位 | 偶校验

当使用RS232与上位机相连时，PLC的通讯参数配置请参照相应型号的使用手册。这里对连接适配器3G2A6-LK201-EV1的设置略作说明。连接的传输速度（波特率）由连接适配器3G2A6-LK201-EV1背板上的SW2上的1-4决定对应关系如下：

波特率

SW2.1

SW2.2

SW2.3

SW2.4

19200

OFF

OFF

ON

OFF

9600

ON

OFF

ON

OFF

4800

OFF

ON

ON

OFF

2400

ON

ON

ON

OFF

1200

OFF

OFF

OFF

ON

600

ON

OFF

OFF

ON

300

OFF

ON

OFF

ON

推荐值

ON

OFF

ON

OFF

连接的数据位长度、停止位长度、奇偶校验位由连接适配器3G2A6-LK201-EV1背板上的SW1上的6-7决定。对应关系如下：

对应列表

SW1.6

SW1.7

奇偶校验

传输代码

OFF

OFF

偶校验

7位ASCII,二位停止位

OFF

ON

奇校验

ON

OFF

偶校验

8位JIS,一位停止位

ON

ON

奇校验

推荐值

OFF

OFF

偶校验

7位ASCII,二位停止位

除以上推荐设置外，SW2.6应设为OFF，SW1.8设为ON。

当使用RS232与上位机相连时，PLC的地址在开物2000中的设置范围从1到31。以3G2A6-LK201-EV1为例该地址由背板上的SW1上的1-5决定。对应关系如下：

地址号

SW1.1

SW1.2

SW1.3

SW1.4

SW1.5

0

OFF

OFF

OFF

OFF

OFF

1

OFF

OFF

OFF

OFF

0N

2

OFF

OFF

OFF

0N

OFF

3

OFF

OFF

OFF

0N

0N

--

--

--

--

--

--

30

0N

0N

0N

0N

OFF

31

0N

0N

0N

0N

0N

设备创建

步骤1：新建设备

步骤2：选择创建方式

步骤3：选择类型和设置电话号码

步骤4：配置串口通讯参数

步骤5：设备创建结束

标签的地址配置规则

标签的主地址可以按照下面的规则配置填写：

标签类型[StaID:]Chn

说明：
1、StaID指PLC的设备地址，PLC的地址在开物2000中的设置范围从1-31。

2、Chn指寄存器的地址号。

3、红色字表示格式中可变部分，十进制数表示，变化范围列于取值范围中。蓝色括号不出现在标签地址中，蓝色括号内的内容可省略。标签地址配置成不存在类型或PLC设备地址错误或寄存器的地址号超出有效范围时，标签将不被承认。如定义的标签在所用的下位机具体型号中不存在，将读不上数据。

欧姆龙PLC标签地址列表

标签地址格式代表开物2000标签定义中的主地址。标签类型代表开物2000标签定义中的标签数据类型。

PLC寄存器名称 标签地址格式

寄存器地址Chn取值范围

标签数据类型 标签取值范围 注释
拨号控制 IPC 　 开关量 0-1 1表示拨号

0表示挂断

状态寄存器 STATUS[StaID:]Chn 0 模拟量 0-2

STATUS的值与PLC操作模式的关系为：
STATUS=0 Programme(编程状态)。
STATUS=1 Monitor(监控状态)。
STATUS=2 Run(运行壮态)。

数据寄存器 | DM[StaID:]Chn | 0-6655 | 模拟量 | 0-65535
数据寄存器 | DM_BCD[StaID:]Chn | 0-6655 | 模拟量 | 0-9999 | BCD格式数据
数据区双寄存器 | DMLength_BCD[StaID:]Chn | 0-6655 | 模拟量 | 0-99999999 | BCD格式数据
特殊寄存器 | SR[StaID:]Chn | 0-6654 | 模拟量 | 0-65535
辅助寄存器 | AR[StaID:]Chn | 0-27 | 模拟量 | 0-65535
输入/输出寄存器 | IR[StaID:]Chn | 0-511 | 模拟量 | 0-65535
保持寄存器 | HR[StaID:]Chn | 0-99 | 模拟量 | 0-65535
连接寄存器 | LR[StaID:]Chn | 0-63 | 模拟量 | 0-65535
定时器/计数器状态 | TC[StaID:]Chn | 0-511 | 开关量 | 0-511
定时器/计数器当前值 | CNT[StaID:]Chn | 0-511 | 模拟量 | true-false
错误寄存器 | ERROR[StaID:]Chn | 0-3 | 模拟量 | 0-255

注：
1：ERROR0的含义：

7 6 5 4 3 2 1 0

ERROR0.0=1: 内存错
ERROR0.1=1: JMP指令错
ERROR0.2=1: I/O总线错
ERROR0.3=1: PC连接错
ERROR0.4=1: RTI指令错误
ERROR0.5=1: HostLink单元传送错
ERROR0.6=1: 程序错，丢失END指令（F0）
ERROR0.7=1: FAUS(CPU停止运行)

2: ERROR1的含义

7 6 5 4 3 2 1 0

0，1位的含义如下：
0 0:Group 1(控制信号错)
0 1:Group 2(数据总线故障)
0 0:Group 3( 地址总线故障)
2，3，4位的含义如下：
0 0 0: CPU机架
0 0 0: I/O扩展机架1
0 1 0: I/O扩展机架2
0 1 1: I/O扩展机架7
ERROR1.5=1: 双总线错
ERROR1.6=1：电池故障（F7）
ERROR1.7=1: FAL错

3：ERROR2的含义如下：

7 6 5 4 3 2 1 0

ERROR2.1=1: DM通道错(F8)
ERROR2.3=1: I/O校验错(F7)
ERROR2.4=1: 扫描时间超出（F8）,I/O单元超出
ERROR2.5=1: 间接跳转指令错（F9）
ERROR2.6=1: I/O设置错(E0)
ERROR2.7=1: 远程I/O错(B0~3)

4: ERROR3的含义如下：

FAL, FALS, NO

7 6 5 4 3 2 1 0

5：往ERROR寄存器写入任何数据，只表示清除错误。

标签地址举例

标签地址：DM3:100
数据类型：模拟量
描述 ：3号PLC的数据寄存器DM0100

标签地址：Status
数据类型：模拟量
描述 ：开物2000工程设备中站号最小的PLC的状态寄存器

标签地址：DMLength_BCD5:1200
数据类型：模拟量
描述 ：5号PLC的数据寄存器DM1200和数据寄存器DM1201组合成的8位十进制数据。DM1200的数据值组成高四位，DM1201的数据值组成低四位。


用户常见问题

设备向导首页的“调试设置”按钮有什么用处 设备向导首页的“版本信息”按钮有什么用处
RS485网络应用提示

3.10.0.0版及更高版本中，设备向导首页的“调试设置”按钮有什么用处?

请注意“调试设置”按钮功能只有在开发和调试阶段才能使用，在现场运行时一定要关闭所有调试选项，否则可能会产生不可预见的错误。

点击“调试设置”按钮，打开调试窗口。根据需要打开调试选项，退出保存工程后运行一段时间。开物会记录这段时间发生的一些重要信息。通过这些信息可以达到下面目的：

项目符号

检查标签设计是否有错误
项目符号

查看设备通讯效率，提供设计优化参考
项目符号

检查线路连接情况，是否有强干扰源
项目符号

检查运行计算机的硬件配置，操作系统，运行的开物版本，运行的驱动程序版本。
项目符号

检查系统资源，尤其是内存是否够用。
项目符号

将工程文件夹压缩成一个文件Email给开物2000的技术人员，为技术人员远程离线诊断错误提供原始资料。
项目符号

查找诊断其他与通讯相关的未明错误的原因。

3.10.0.0版及更高版本中，设备向导首页的“版本信息”按钮有什么用处?

通过点击“版本信息”按钮，可以达到下面目的：

项目符号

提示当前所用驱动程序的版本号，方便开物2000的技术服务人员提供更细致的服务。
项目符号

提示驱动程序提供的功能，支持的硬件型号等重要信息。
项目符号

显示最新的驱动程序帮助文件。

我编写了一个M寄存器控制Q寄存器的移位程序，从程序上来讲，应该是Q寄存器的状态变化比M寄存器滞后，（注：两者的扫描周期相同），为什么出现M寄存器的状态变化比Q寄存器滞后？

RS485 网络应用提示

项目符号 | 在RS485 网络中， 当通讯距离增长（<1200m），或波特率提高时，应在网络的 两端最后一个节点处的 com+，com-间并接一只 120 Ω左右的线路匹配电阻，以保障网络的可靠运行。
项目符号 | 当 RS485 网络节点数量增加，（>32）或通讯距离超过 1200m 时，应在网络中适当地加入 RS485 中继器。（最好是隔离型的），以保证网络的通讯顺畅。
项目符号 | RS485网络结构应尽量保证为一条干线，各节点引入的支线段应越短越好，以免引起杂波干扰，影响通讯。
项目符号 | RS485 网络的通讯线最好使用屏蔽双绞线。com+与 com-为一个线对，并且屏蔽层应在网络的源端单点接地，可有效地防止外界干扰。
项目符号 | RS485网络干线在布线时， 应避免与动力线系统电源线靠近或平行布置，尽量与其距离远一些。