松下FP系列PLC

连接及设置 连接图 标签变量地址配置 在线升级驱动

注意事项:

在使用各类型标签时，请正确选项择相应的数据类型，否则数据将采集不对。

如:

R1:2.0 是开关量标签，而不应为模拟量标签；

R1:2 是模拟量标签，而不应为开关量标签。

松下MEWTOCOL协议支持与松下FP3系列及与其兼容的FP系列PLC之间的通讯，本协议可以采用串行通讯，使用您计算机中的串行口。也可以通过以太网（ETHERNET）进行通讯。

松下FP3和FP系列PLC与系统的连接及设置
您可以按下图将开物2000与一个或多个PLC相连。
利用串行口进行连接时，可直接与PLC的RS232端口相连，也可以通过RS232/422适配器（AFP8550）PLC的RS422端口相连。

图一：计算机通过串行口与PLC通讯
利用以太网进行连接时，可以选用ET-LAN单元通过以太网与上位机相连，该单元使用TCP/IP协议。

图二：计算机通过以太网与PLC通讯

设置松下FP 系列PLC：
当使用RS232与上位机相连时，PLC的缺省与推荐设置如下:
设置项 | 缺省值 | 推荐值
波特率： 9600 9600
数据位长度 | 8 | 8
停止位长度 | 1 | 1
奇偶校验位 | 奇校验 | 奇校验

当使用RS232与上位机相连时，PLC的通讯参数配置请参照相应型号的使用手册。例如FP1,利用S232与上位机相连时，PLC的系统寄存器#412设置为K1(即十进制常数1,以下相同)，否则使用缺省值K0。当使用推荐设置时，PLC的系统寄存器#413。设置为H3(即十六进制常数9,以下相同)，PLC的系统寄存器#414设置为K1。在有些PLC 中要将PLC中的RS232通讯使能。
当使用RS422与上位机相连时，PLC的缺省与推荐设置如下 :

设置项 | 缺省值 | 推荐值
波特率 | 9600 | 9600
数据位长度 | 8 | 8

当使用RS422与上位机相连时，PLC的通讯参数配置请参照相应型号的使用手册。
当使用RS422与上位机相连时，上位机的RS232推荐设置如下:
设置项 | 推荐值
波特率： 9600
数据位长度 | 8
停止位长度 | 1
奇偶校验位 | 奇校验

当使用以太网通讯时PLC设置：
如图3所示，以太网的运行模式如下表所示ET-LAN单元的模式开关1----4 确定：

开关号

         内容 ON OFF 缺省

1

         通常模式时 --------------------- 必须设为OFF OFF
测试模式时 测试模式2 测试模式1

2

         握手模式选择 存储器握手模式 I/O握手模式 OFF

3

         在线/离线选择 在线 离线 ON

4

         测试/通常模式选择 测试模式 通常模式 OFF

注意：当开关4为OFF时必须将开关1设为OFF。
图3 ET-LAN单元模式开关设置

松下FP3和FP系列PLC与系统的接线图
当使用RS232接口与计算机相连时,由计算机RS232到PLC的具体连线如下图示:

当使用RS422接口与计算机相连时,由计算机RS232到RS232/422适配器（AFP8550）的具体连线如下图示

由适配器到PLC编程口（RS422）之间的连线选用AFP5520或AFP5523。
关于网络接线请参照有关网络方面的书籍。

标签地址及范围

标签的主地址可以按照下面的规则配置填写：

标签类型[ID:][CH][.BIT]

说明：

项目符号 | ID指仪表的设备号地址， 该版本驱动只适用于RS232，所以ID值只能为0。 标签地址中省略ID时，开物2000系统默认为是所连接设备的最小的站号地址。
项目符号 | Ch指通道号，范围因标签类型而异，十进制表示。
项目符号 | BIT指位号，范围因标签类型而异，十进制表示。
项目符号 | 标签地址配置成不存在类型或仪表地址错误或通道号超出有效范围时，标签将不被承认，读不上数据。
标签地址格式 | 说明 | 类型 | 读写属性 | CH地址范围 | BIT地址范围 | 标签值范围 | 注意
XID:CH.BIT 外部输入寄存器（位格式） 开关量
           只读 视具体型号而定，请参看附录 0--15 true 或 false 创建标签时，请将标签类型设为"开关量"
XID:CH | 外部输入寄存器（字格式） | 模拟量 | 只读 | 视具体型号而定，请参看附录 | 无此位 | 0--65535 | 创建标签时，请将标签类型设为"模拟量"
YID:CH.BIT | 外部输出寄存器 （位格式） | 开关量 | 读写 | 视具体型号而定，请参看附录 | 0--15 | true 或 false | 创建标签时，请将标签类型设为"开关量"
YID:CH | 外部输出寄存器 （字格式） | 模拟量 | 读写 | 视具体型号而定，请参看附录 | 无此位 | 0--65535 | 创建标签时，请将标签类型设为"模拟量"
RID:CH.BIT
           内部寄存器（位格式） 开关量 读写 　 视具体型号而定，请参看附录 0--15 true 或 false 创建标签时，请将标签类型设为"开关量"
RID:CH | 内部寄存器 （字格式） | 模拟量 | 读写 | 视具体型号而定，请参看附录 | 无此位 | 0--65535 | 创建标签时，请将标签类型设为"模拟量"
LID:CH.BIT | 链接寄存器（位格式） | 开关量 | 只读 | 视具体型号而定，请参看附录 | 0--15 | true 或 false | 创建标签时，请将标签类型设为"开关量"
LID:CH | 链接寄存器（字格式） | 模拟量 | 只读 | 视具体型号而定，请参看附录 | 无此位 | 0--65535
TsID:CH | 定时接点 | 开关量 | 只读 | 　 视具体型号而定，请参看附录 | 无此位 | 0--65535
CsID:CH | 计数器接点 | 开关量 | 只读 | 视具体型号而定，请参看附录 | 无此位 | 0--65535
DTID:CH | 数据寄存器 | 模拟量 | 读写 | 视具体型号而定，请参看附录 | 无此位 | 0--65535
FID:CH | 文件寄存器 | 模拟量 | 读写 | 视具体型号而定，请参看附录 | 无此位 | 0--65535
LDID:CH | 链接数据寄存器 | 模拟量 | 读写 | 视具体型号而定，请参看附录 | 无此位 | 0--65535
IX ID:CH | 索引寄存器 | 模拟量 | 读写 | 0 | 无此位 | 0--65535
IY ID:CH | 索引寄存器 | 模拟量 | 读写 | 0 | 无此位 | 0--65535
SVID:CH | 定时/计数器设置值 | 模拟量 | 读写 | 视具体型号而定，请参看附录 | 无此位 | 0--65535
EVID:CH | 定时/计数器经过值 | 模拟量 | 读写 | 视具体型号而定，请参看附录 | 无此位 | 0--65535
MODE ID:CH | 控制器操作方式 | 模拟量 | 读写 | 0 | 无此位 | true 或 false

附录:

松下PLC各型号标签地址范围：

FP2:
标签地址格式 | 说明 | CH地址范围 | BIT地址范围
XID:CH.BIT | 外部输入寄存器（位格式） | 0--127 | 0--15
XID:CH | 外部输入寄存器（ 字格式） | 0--127 | 无此位
YID:CH.BIT | 外部输出寄存器 （位格式） | 0--127 | 0--15
YID:CH | 外部输出寄存器 （字格式） | 0--127 | 无此位
RID:CH.BIT
           内部寄存器（位格式） 0--252 0--15
RID:CH | 内部寄存器 （字格式） | 0--252 | 无此位
LID:CH.BIT | 链接寄存器（位格式） | 0--127 | 0--15
LID:CH | 链接寄存器（ 字格式） | 0--127 | 无此位
TsID:CH | 定时接点 | 0--999 | 无此位
CsID:CH | 计数器接点 | 1000-1023 | 无此位
DTID:CH | 数据寄存器 | 0-5999 | 无此位
FID:CH | 文件寄存器 | 0-30716 | 无此位
LDID:CH | 链接数据寄存器 | 0-255 | 无此位
IX ID:CH | 索引寄存器 | 0 | 无此位
IY ID:CH | 索引寄存器 | 0 | 无此位
SVID:CH | 定时/计数器设置值 | 0--1023 | 无此位
EVID:CH | 定时/计数器经过值 | 0--1023 | 无此位
MODE ID:CH 控制器操作方式

0

无此位

FP2SH：
标签地址格式 | 说明 | CH地址范围 | BIT地址范围
XID:CH.BIT | 外部输入寄存器（位格式） | 0--511 | 0--15
XID:CH | 外部输入寄存器（ 字格式） | 0--511 | 无此位
YID:CH.BIT | 外部输出寄存器 （位格式） | 0--511 | 0--15
YID:CH | 外部输出寄存器 （字格式） | 0--511 | 无此位
RID:CH.BIT
           内部寄存器（位格式） 0--886 0--15
RID:CH | 内部寄存器 （字格式） | 0--886 | 无此位
LID:CH.BIT | 链接寄存器（位格式） | 0--639 | 0--15
LID:CH | 链接寄存器（ 字格式） | 0--639 | 无此位
TsID:CH | 定时接点 | 0--2999 | 无此位
CsID:CH | 计数器接点 | 1000--3071 | 无此位
DTID:CH | 数据寄存器 | 0-10239 | 无此位
FID:CH | 文件寄存器 | 0-32764 | 无此位
LDID:CH | 链接数据寄存器 | 0-8447 | 无此位
IX ID:CH | 索引寄存器 | 0 | 无此位
IY ID:CH | 索引寄存器 | 0 | 无此位
SVID:CH | 定时/计数器设置值 | 0-3071 | 无此位
EVID:CH 定时/计数器经过值

0-3071

无此位
MODE ID:CH 控制器操作方式

0

无此位

FP3：
标签地址格式 | 说明 | CH地址范围 | BIT地址范围
XID:CH.BIT | 外部输入寄存器（位格式） | 0--127 | 0--15
XID:CH | 外部输入寄存器（ 字格式） | 0--127 | 无此位
YID:CH.BIT | 外部输出寄存器 （位格式） | 0--127 | 0--15
YID:CH | 外部输出寄存器 （字格式） | 0--127 | 无此位
RID:CH.BIT
           内部寄存器（位格式） 0--97 0--15
RID:CH | 内部寄存器 （字格式） | 0--97 | 无此位
LID:CH.BIT | 链接寄存器（位格式） | 0--127 | 0--15
LID:CH | 链接寄存器（ 字格式） | 0--127 | 无此位
TsID:CH | 定时接点 | 0-199 | 无此位
CsID:CH | 计数器接点 | 200-255 | 无此位
DTID:CH | 数据寄存器 | 0-2047 | 无此位
FID:CH | 文件寄存器 | 0-22524 | 无此位
LDID:CH | 链接数据寄存器 | 0-255 | 无此位
IX ID:CH | 索引寄存器 | 0 | 无此位
IY ID:CH | 索引寄存器 | 0 | 无此位
SVID:CH | 定时/计数器设置值 | 0-255 | 无此位
EVID:CH | 定时/计数器经过值 | 0-255 | 无此位
MODE ID:CH | 控制器操作方式 | 0 | 无此位

FP10SH:
标签地址格式 | 说明 | CH地址范围 | BIT地址范围
XID:CH.BIT | 外部输入寄存器（位格式） | 0--511 | 0--15
XID:CH | 外部输入寄存器（ 字格式） | 0--511 | 无此位
YID:CH.BIT | 外部输出寄存器 （位格式） | 0--511 | 0--15
YID:CH | 外部输出寄存器 （字格式） | 0--511 | 无此位
RID:CH.BIT
           内部寄存器（位格式） 0-886 0--15
RID:CH | 内部寄存器 （字格式） | 0--886 | 无此位
LID:CH.BIT | 链接寄存器（位格式） | 0--639 | 0--15
LID:CH | 链接寄存器（ 字格式） | 0--639 | 无此位
TsID:CH | 定时接点 | 0-2999 | 无此位
CsID:CH | 计数器接点 | 1000-3071 | 无此位
DTID:CH | 数据寄存器 | 0-10239 | 无此位
FID:CH | 文件寄存器 | 0-32764 | 无此位
LDID:CH | 链接数据寄存器 | 0-8447 | 无此位
IX ID:CH | 索引寄存器 | 0 | 无此位
IY ID:CH | 索引寄存器 | 0 | 无此位
SVID:CH | 定时/计数器设置值 | 0-3071 | 无此位
EVID:CH | 定时/计数器经过值 | 0-3071 | 无此位
MODE ID:CH | 控制器操作方式 | 0 | 无此位

FPC:
标签地址格式 | 说明 | CH地址范围 | BIT地址范围
XID:CH.BIT | 外部输入寄存器（位格式） | 0--127 | 0--15
XID:CH | 外部输入寄存器（ 字格式） | 0--127 | 无此位
YID:CH.BIT | 外部输出寄存器 （位格式） | 0--127 | 0--15
YID:CH | 外部输出寄存器 （字格式） | 0--127 | 无此位
RID:CH.BIT
           内部寄存器（位格式） 0--97 0--15
RID:CH | 内部寄存器 （字格式） | 0--97 | 无此位
LID:CH.BIT | 链接寄存器（位格式） | 0--127 | 0--15
LID:CH | 链接寄存器（ 字格式） | 0--127 | 无此位
TsID:CH | 定时接点 | 0-199 | 无此位
CsID:CH | 计数器接点 | 200-255 | 无此位
DTID:CH | 数据寄存器 | 0-2047 | 无此位
FID:CH | 文件寄存器 | 0-22524 | 无此位
LDID:CH | 链接数据寄存器 | 0-255 | 无此位
IX ID:CH | 索引寄存器 | 0 | 无此位
IY ID:CH | 索引寄存器 | 0 | 无此位
SVID:CH | 定时/计数器设置值 | 0-255 | 无此位
EVID:CH | 定时/计数器经过值 | 0-255 | 无此位
MODE ID:CH | 控制器操作方式 | 0 | 无此位

FPM_C16T:
标签地址格式 | 说明 | CH地址范围 | BIT地址范围
XID:CH.BIT | 外部输入寄存器（位格式） | 0--12 | 0--15
XID:CH | 外部输入寄存器（ 字格式） | 0--12 | 无此位
YID:CH.BIT | 外部输出寄存器 （位格式） | 0--12 | 0--15
YID:CH | 外部输出寄存器 （字格式） | 0--12 | 无此位
RID:CH.BIT
           内部寄存器（位格式） 0--15 0--15
RID:CH | 内部寄存器 （字格式） | 0--15 | 无此位
TsID:CH | 定时接点 | 0-99 | 无此位
CsID:CH | 计数器接点 | 100-127 | 无此位
DTID:CH | 数据寄存器 | 0-255 | 无此位
IX ID:CH | 索引寄存器 | 0 | 无此位
IY ID:CH | 索引寄存器 | 0 | 无此位
SVID:CH 定时/计数器设置值 0-127

无此位
EVID:CH | 定时/计数器经过值 | 0-127 | 无此位
MODE ID:CH | 控制器操作方式 | 0 | 无此位

FPM_C20R:
标签地址格式 | 说明 | CH地址范围 | BIT地址范围
XID:CH.BIT | 外部输入寄存器（位格式） | 0--12 | 0--15
XID:CH | 外部输入寄存器（ 字格式） | 0--12 | 无此位
YID:CH.BIT | 外部输出寄存器 （位格式） | 0--12 | 0--15
YID:CH | 外部输出寄存器 （字格式） | 0--12 | 无此位
RID:CH.BIT | 内部寄存器（位格式） | 0--62 | 0--15
RID:CH | 内部寄存器 （字格式） | 0--62 | 无此位
TsID:CH | 定时接点 | 0-99 | 无此位
CsID:CH | 计数器接点 | 100-143 | 无此位
DTID:CH | 数据寄存器 | 0-1659 | 无此位
IX ID:CH | 索引寄存器 | 0 | 无此位
IY ID:CH | 索引寄存器 | 0 | 无此位
SVID:CH | 定时/计数器设置值 | 0-143 | 无此位
EVID:CH | 定时/计数器经过值 | 0-143 | 无此位
MODE ID:CH | 控制器操作方式 | 0 | 无此位

FPM_C20T:
标签地址格式 | 说明 | CH地址范围 | BIT地址范围
XID:CH.BIT | 外部输入寄存器（位格式） | 0--12 | 0--15
XID:CH | 外部输入寄存器（ 字格式） | 0--12 | 无此位
YID:CH.BIT | 外部输出寄存器 （位格式） | 0--12 | 0--15
YID:CH | 外部输出寄存器 （字格式） | 0--12 | 无此位
RID:CH.BIT | 内部寄存器（位格式） | 0--62 | 0--15
RID:CH | 内部寄存器 （字格式） | 0--62 | 无此位
TsID:CH | 定时接点 | 0-99 | 无此位
CsID:CH | 计数器接点 | 100-143 | 无此位
DTID:CH | 数据寄存器 | 0-1659 | 无此位
IX ID:CH | 索引寄存器 | 0 | 无此位
IY ID:CH | 索引寄存器 | 0 | 无此位
SVID:CH | 定时/计数器设置值 | 0-143 | 无此位
EVID:CH | 定时/计数器经过值 | 0-143 | 无此位
MODE ID:CH | 控制器操作方式 | 0 | 无此位

FPM_C32T:
标签地址格式 | 说明 | CH地址范围 | BIT地址范围
XID:CH.BIT | 外部输入寄存器（位格式） | 0--12 | 0--15
XID:CH | 外部输入寄存器（ 字格式） | 0--12 | 无此位
YID:CH.BIT | 外部输出寄存器 （位格式） | 0--12 | 0--15
YID:CH | 外部输出寄存器 （字格式） | 0--12 | 无此位
RID:CH.BIT | 内部寄存器（位格式） | 0--62 | 0--15
RID:CH | 内部寄存器 （字格式） | 0--62 | 无此位
TsID:CH | 定时接点 | 0-99 | 无此位
CsID:CH | 计数器接点 | 100-143 | 无此位
DTID:CH | 数据寄存器 | 0-1659 | 无此位
IX ID:CH | 索引寄存器 | 0 | 无此位
IY ID:CH | 索引寄存器 | 0 | 无此位
SVID:CH | 定时/计数器设置值 | 0-143 | 无此位
EVID:CH | 定时/计数器经过值 | 0-143 | 无此位
MODE ID:CH | 控制器操作方式 | 0 | 无此位

FPM_C20RC:
标签地址格式 | 说明 | CH地址范围 | BIT地址范围
XID:CH.BIT | 外部输入寄存器（位格式） | 0--12 | 0--15
XID:CH | 外部输入寄存器（ 字格式） | 0--12 | 无此位
YID:CH.BIT | 外部输出寄存器 （位格式） | 0--12 | 0--15
YID:CH | 外部输出寄存器 （字格式） | 0--12 | 无此位
RID:CH.BIT | 内部寄存器（位格式） | 0--62 | 0--15
RID:CH | 内部寄存器 （字格式） | 0--62 | 无此位
TsID:CH | 定时接点 | 0-99 | 无此位
CsID:CH | 计数器接点 | 100-143 | 无此位
DTID:CH | 数据寄存器 | 0-6143 | 无此位
IX ID:CH | 索引寄存器 | 0 | 无此位
IY ID:CH | 索引寄存器 | 0 | 无此位
SVID:CH | 定时/计数器设置值 | 0-143 | 无此位
EVID:CH | 定时/计数器经过值 | 0-143 | 无此位
MODE ID:CH | 控制器操作方式 | 0 | 无此位

FPM_C20TC:
标签地址格式 | 说明 | CH地址范围 | BIT地址范围
XID:CH.BIT | 外部输入寄存器（位格式） | 0--12 | 0--15
XID:CH | 外部输入寄存器（ 字格式） | 0--12 | 无此位
YID:CH.BIT | 外部输出寄存器 （位格式） | 0--12 | 0--15
YID:CH | 外部输出寄存器 （字格式） | 0--12 | 无此位
RID:CH.BIT | 内部寄存器（位格式） | 0--62 | 0--15
RID:CH | 内部寄存器 （字格式） | 0--62 | 无此位
TsID:CH | 定时接点 | 0-99 | 无此位
CsID:CH | 计数器接点 | 100-143 | 无此位
DTID:CH | 数据寄存器 | 0-6143 | 无此位
IX ID:CH | 索引寄存器 | 0 | 无此位
IY ID:CH | 索引寄存器 | 0 | 无此位
SVID:CH | 定时/计数器设置值 | 0-143 | 无此位
EVID:CH | 定时/计数器经过值 | 0-143 | 无此位
MODE ID:CH | 控制器操作方式 | 0 | 无此位

FPM_C32TC:
标签地址格式 | 说明 | CH地址范围 | BIT地址范围
XID:CH.BIT | 外部输入寄存器（位格式） | 0--12 | 0--15
XID:CH | 外部输入寄存器（ 字格式） | 0--12 | 无此位
YID:CH.BIT | 外部输出寄存器 （位格式） | 0--12 | 0--15
YID:CH | 外部输出寄存器 （字格式） | 0--12 | 无此位
RID:CH.BIT | 内部寄存器（位格式） | 0--62 | 0--15
RID:CH | 内部寄存器 （字格式） | 0--62 | 无此位
TsID:CH | 定时接点 | 0-99 | 无此位
CsID:CH | 计数器接点 | 100-143 | 无此位
DTID:CH | 数据寄存器 | 0-6143 | 无此位
IX ID:CH | 索引寄存器 | 0 | 无此位
IY ID:CH | 索引寄存器 | 0 | 无此位
SVID:CH | 定时/计数器设置值 | 0-143 | 无此位
EVID:CH | 定时/计数器经过值 | 0-143 | 无此位
MODE ID:CH | 控制器操作方式 | 0 | 无此位

FPO_C10:
标签地址格式 | 说明 | CH地址范围 | BIT地址范围
XID:CH.BIT | 外部输入寄存器（位格式） | 0--12 | 0--15
XID:CH | 外部输入寄存器（ 字格式） | 0--12 | 无此位
YID:CH.BIT | 外部输出寄存器 （位格式） | 0--12 | 0--15
YID:CH | 外部输出寄存器 （字格式） | 0--12 | 无此位
RID:CH.BIT | 内部寄存器（位格式） | 0--62 | 0--15
RID:CH | 内部寄存器 （字格式） | 0--62 | 无此位
TsID:CH | 定时接点 | 0-99 | 无此位
CsID:CH | 计数器接点 | 100-143 | 无此位
DTID:CH | 数据寄存器 | 0-1659 | 无此位
IX ID:CH | 索引寄存器 | 0 | 无此位
IY ID:CH | 索引寄存器 | 0 | 无此位
SVID:CH | 定时/计数器设置值 | 0-143 | 无此位
EVID:CH | 定时/计数器经过值 | 0-143 | 无此位
MODE ID:CH | 控制器操作方式 | 0 | 无此位

FPO_C14:
标签地址格式 | 说明 | CH地址范围 | BIT地址范围
XID:CH.BIT | 外部输入寄存器（位格式） | 0--12 | 0--15
XID:CH | 外部输入寄存器（ 字格式） | 0--12 | 无此位
YID:CH.BIT | 外部输出寄存器 （位格式） | 0--12 | 0--15
YID:CH | 外部输出寄存器 （字格式） | 0--12 | 无此位
RID:CH.BIT | 内部寄存器（位格式） | 0--62 | 0--15
RID:CH | 内部寄存器 （字格式） | 0--62 | 无此位
TsID:CH | 定时接点 | 0-99 | 无此位
CsID:CH | 计数器接点 | 100-143 | 无此位
DTID:CH | 数据寄存器 | 0-1659 | 无此位
IX ID:CH | 索引寄存器 | 0 | 无此位
IY ID:CH | 索引寄存器 | 0 | 无此位
SVID:CH | 定时/计数器设置值 | 0-143 | 无此位
EVID:CH | 定时/计数器经过值 | 0-143 | 无此位
MODE ID:CH | 控制器操作方式 | 0 | 无此位

FPO_C16:
标签地址格式 | 说明 | CH地址范围 | BIT地址范围
XID:CH.BIT | 外部输入寄存器（位格式） | 0--12 | 0--15
XID:CH | 外部输入寄存器（ 字格式） | 0--12 | 无此位
YID:CH.BIT | 外部输出寄存器 （位格式） | 0--12 | 0--15
YID:CH | 外部输出寄存器 （字格式） | 0--12 | 无此位
RID:CH.BIT | 内部寄存器（位格式） | 0--62 | 0--15
RID:CH | 内部寄存器 （字格式） | 0--62 | 无此位
TsID:CH | 定时接点 | 0-99 | 无此位
CsID:CH | 计数器接点 | 100-143 | 无此位
DTID:CH | 数据寄存器 | 0-1659 | 无此位
IX ID:CH | 索引寄存器 | 0 | 无此位
IY ID:CH | 索引寄存器 | 0 | 无此位
SVID:CH | 定时/计数器设置值 | 0-143 | 无此位
EVID:CH | 定时/计数器经过值 | 0-143 | 无此位
MODE ID:CH | 控制器操作方式 | 0 | 无此位

FPO_C32:
标签地址格式 | 说明 | CH地址范围 | BIT地址范围
XID:CH.BIT | 外部输入寄存器（位格式） | 0--12 | 0--15
XID:CH | 外部输入寄存器（ 字格式） | 0--12 | 无此位
YID:CH.BIT | 外部输出寄存器 （位格式） | 0--12 | 0--15
YID:CH | 外部输出寄存器 （字格式） | 0--12 | 无此位
RID:CH.BIT | 内部寄存器（位格式） | 0--62 | 0--15
RID:CH | 内部寄存器 （字格式） | 0--62 | 无此位
TsID:CH | 定时接点 | 0-99 | 无此位
CsID:CH | 计数器接点 | 100-143 | 无此位
DTID:CH | 数据寄存器 | 0-6143 | 无此位
IX ID:CH | 索引寄存器 | 0 | 无此位
IY ID:CH | 索引寄存器 | 0 | 无此位
SVID:CH | 定时/计数器设置值 | 0-143 | 无此位
EVID:CH | 定时/计数器经过值 | 0-143 | 无此位
MODE ID:CH | 控制器操作方式 | 0 | 无此位

FPO_T32C:
标签地址格式 | 说明 | CH地址范围 | BIT地址范围
XID:CH.BIT | 外部输入寄存器（位格式） | 0--12 | 0--15
XID:CH | 外部输入寄存器（ 字格式） | 0--12 | 无此位
YID:CH.BIT | 外部输出寄存器 （位格式） | 0--12 | 0--15
YID:CH | 外部输出寄存器 （字格式） | 0--12 | 无此位
RID:CH.BIT | 内部寄存器（位格式） | 0--62 | 0--15
RID:CH | 内部寄存器 （字格式） | 0--62 | 无此位
TsID:CH | 定时接点 | 0-99 | 无此位
CsID:CH | 计数器接点 | 100-143 | 无此位
DTID:CH | 数据寄存器 | 0-16383 | 无此位
IX ID:CH | 索引寄存器 | 0 | 无此位
IY ID:CH | 索引寄存器 | 0 | 无此位
SVID:CH | 定时/计数器设置值 | 0-143 | 无此位
EVID:CH | 定时/计数器经过值 | 0-143 | 无此位
MODE ID:CH | 控制器操作方式 | 0 | 无此位

FP1_C14:
标签地址格式 | 说明 | CH地址范围 | BIT地址范围
XID:CH.BIT | 外部输入寄存器（位格式） | 0--12 | 0--15
XID:CH | 外部输入寄存器（ 字格式） | 0--12 | 无此位
YID:CH.BIT | 外部输出寄存器 （位格式） | 0--12 | 0--15
YID:CH | 外部输出寄存器 （字格式） | 0--12 | 无此位
RID:CH.BIT | 内部寄存器（位格式） | 0--15 | 0--15
RID:CH | 内部寄存器 （字格式） | 0--15 | 无此位
TsID:CH | 定时接点 | 0-99 | 无此位
CsID:CH | 计数器接点 | 100-127 | 无此位
DTID:CH | 数据寄存器 | 0-255 | 无此位
IX ID:CH | 索引寄存器 | 0 | 无此位
IY ID:CH | 索引寄存器 | 0 | 无此位
SVID:CH | 定时/计数器设置值 | 0-143 | 无此位
EVID:CH | 定时/计数器经过值 | 0-143 | 无此位
MODE ID:CH | 控制器操作方式 | 0 | 无此位

FP1_C16:
标签地址格式 | 说明 | CH地址范围 | BIT地址范围
XID:CH.BIT | 外部输入寄存器（位格式） | 0--12 | 0--15
XID:CH | 外部输入寄存器（ 字格式） | 0--12 | 无此位
YID:CH.BIT | 外部输出寄存器 （位格式） | 0--12 | 0--15
YID:CH | 外部输出寄存器 （字格式） | 0--12 | 无此位
RID:CH.BIT | 内部寄存器（位格式） | 0--15 | 0--15
RID:CH | 内部寄存器 （字格式） | 0--15 | 无此位
TsID:CH | 定时接点 | 0-99 | 无此位
CsID:CH | 计数器接点 | 100-127 | 无此位
DTID:CH | 数据寄存器 | 0-255 | 无此位
IX ID:CH | 索引寄存器 | 0 | 无此位
IY ID:CH | 索引寄存器 | 0 | 无此位
SVID:CH | 定时/计数器设置值 | 0-143 | 无此位
EVID:CH | 定时/计数器经过值 | 0-143 | 无此位
MODE ID:CH | 控制器操作方式 | 0 | 无此位

FP1_C24:
标签地址格式 | 说明 | CH地址范围 | BIT地址范围
XID:CH.BIT | 外部输入寄存器（位格式） | 0--12 | 0--15
XID:CH | 外部输入寄存器（ 字格式） | 0--12 | 无此位
YID:CH.BIT | 外部输出寄存器 （位格式） | 0--12 | 0--15
YID:CH | 外部输出寄存器 （字格式） | 0--12 | 无此位
RID:CH.BIT | 内部寄存器（位格式） | 0--62 | 0--15
RID:CH | 内部寄存器 （字格式） | 0--62 | 无此位
TsID:CH | 定时接点 | 0-99 | 无此位
CsID:CH | 计数器接点 | 100-143 | 无此位
DTID:CH | 数据寄存器 | 0-1659 | 无此位
IX ID:CH | 索引寄存器 | 0 | 无此位
IY ID:CH | 索引寄存器 | 0 | 无此位
SVID:CH | 定时/计数器设置值 | 0-143 | 无此位
EVID:CH | 定时/计数器经过值 | 0-143 | 无此位
MODE ID:CH | 控制器操作方式 | 0 | 无此位

FP1_C56:
标签地址格式 | 说明 | CH地址范围 | BIT地址范围
XID:CH.BIT | 外部输入寄存器（位格式） | 0--12 | 0--15
XID:CH | 外部输入寄存器（ 字格式） | 0--12 | 无此位
YID:CH.BIT | 外部输出寄存器 （位格式） | 0--12 | 0--15
YID:CH | 外部输出寄存器 （字格式） | 0--12 | 无此位
RID:CH.BIT | 内部寄存器（位格式） | 0--62 | 0--15
RID:CH | 内部寄存器 （字格式） | 0--62 | 无此位
TsID:CH | 定时接点 | 0-99 | 无此位
CsID:CH | 计数器接点 | 100-143 | 无此位
DTID:CH | 数据寄存器 | 0-1659 | 无此位
IX ID:CH | 索引寄存器 | 0 | 无此位
IY ID:CH | 索引寄存器 | 0 | 无此位
SVID:CH | 定时/计数器设置值 | 0-143 | 无此位
EVID:CH | 定时/计数器经过值 | 0-143 | 无此位
MODE ID:CH | 控制器操作方式 | 0 | 无此位

FP1_C72:
标签地址格式 | 说明 | CH地址范围 | BIT地址范围
XID:CH.BIT | 外部输入寄存器（位格式） | 0--12 | 0--15
XID:CH | 外部输入寄存器（ 字格式） | 0--12 | 无此位
YID:CH.BIT | 外部输出寄存器 （位格式） | 0--12 | 0--15
YID:CH | 外部输出寄存器 （字格式） | 0--12 | 无此位
RID:CH.BIT | 内部寄存器（位格式） | 0--62 | 0--15
RID:CH | 内部寄存器 （字格式） | 0--62 | 无此位
TsID:CH | 定时接点 | 0-99 | 无此位
CsID:CH | 计数器接点 | 100-143 | 无此位
DTID:CH | 数据寄存器 | 0-6143 | 无此位
IX ID:CH | 索引寄存器 | 0 | 无此位
IY ID:CH | 索引寄存器 | 0 | 无此位
SVID:CH | 定时/计数器设置值 | 0-143 | 无此位
EVID:CH | 定时/计数器经过值 | 0-143 | 无此位
MODE ID:CH | 控制器操作方式 | 0 | 无此位

斜体字dddh、dddd、ddd等表示格式中可变部分，d表示十进制数，h表示十六进制数，变化范围列于取值范围中。开物2000按照寄存器数据类型和寄存器名称来读取下位机相应的数据。如定义非法寄存器，将不被承认。如定义的寄存器在所用的下位机具体型号中不存在，将读不上数据。