德力西DLP200系列智能仪表

施耐德Twido系列PLC

概述 硬件连接 创建设备 创建标签 标签地址及范围 标签举例 在线升级驱动

概述

开物2000支持以下型号的仪表：

施耐德TWido系列的PLC

开物2000还支持其它多种设备，详情请与 华富惠通公司联系。

硬件连接

通讯端口硬件的推荐设置：

施耐德Twido系列PLC采用通过232/485连接,需要使用施耐德公司的专用电缆连接 。

电缆的使用：使用TwidoSoft软件和PLC通讯时，将专用电缆的拨码开关置于2 的位置，当用开物与PLC通讯时将电缆的拨码开关置于3的位置。

需要使用施耐德公司TwidoSoft软件设置PLC的通讯参数，选择通讯设置为ModBus,设置设备地址，波特率等。在TwidoSoft软件中选择通讯设置为ModBus,在ModBus Driver中设置串口的参数。

波特率 | 19200bps
起始位 | 1
数据位 | 8
停止位 | 1
校验位 | 偶校验

创建设备

在开发环境的‘硬件系统’中按照‘新节点和设备向导’的指示配置所连接的仪表。以便于开物2000识别和使用。

步骤1：选择设备类型，更改设备名称，最后单击‘选择’按钮。

步骤2：选择操作方式-新建设备(一个设备中可以包含多个)。选中‘新建设备’后单击‘下一步’按钮(或双击‘新建设备’)。

步骤3：选择创建方式(一个设备中可以包含多个)。选中 创建方式后单击‘下一步’按钮(或双击‘标准创建’)。

步骤4：设置仪表类型和设备号，单击‘下一步’按钮。

步骤5：设备串口通讯参数， 如下图所设，单击‘下一步’。

步骤6：显示设备及参数配置图，点击‘完成’按钮，完成设备配置向导.

创建标签

使用“天辰仪表向导“完成设备的创建后，可以进行标签设计。

1、在开发环境的‘标签’中添加标签，显示下图，选择上述主设备‘delixi’，选择并填写‘主地址’，修改标签名。

2、根据仪表的工作模式和标签所监控的参数物理意义，修改工程值零点、工程值量程、扫描周期、转换方式、记录属性等。
单击‘添加’或‘完成’按钮。

标签地址及范围

标签的主地址可以按照下面的规则配置填写：

标签类型[ID:][CH]

说明：

项目符号 | 标签地址中省略ID时，开物2000系统默认为是所连接设备的最小的站号地址,施耐德Twido系列PLC的站号为0～255。
项目符号 | Ch指通道号，范围因标签类型而异， 即是施耐德Twido系列PLC 的 位地址或者字地址。
项目符号 | bbb指位号，为开关量， 指的是来自字的抽取位。
项目符号 | 标签地址配置成不存在类型或仪表地址错误或通道号超出有效范围时，标签将不被承认，读不上数据。

标签地址(基地址) | 含义 | 数据类型 | 读写类型 | 通道地址范围 | 标签值范围
M ID:CH | 位对象 | 开关量 | 可读可写 | 0～127 | 0/1
MW ID:CH.bbb | 字对象 | 模拟量 | 可读可写 | 0～2999 | 0～65535
MD ID:CH | 双字对象 | 模拟量 | 可读可写 | 0～2998 | 0～4294967295
MF ID:CH | 浮点数对象 | 模拟量 | 可读可写 | 0～2998 | -3.402824e+38 ～+3.402824e+38
SMW ID:CH | 有符号字对象 | 模拟量 | 可读可写 | 0～2999 | -32767~32768
SMD ID:CH | 有符号双字对象 | 模拟量 | 可读可写 | 0～2998 | -2147483647～2147483648

注：通道的地址范围和用户在TwidoSoft软件中为PLC的配置的寄存器的范围有关，表中的范围是PLC控制器中最大的地址范围。

标签举例

标签 ：M1:1
数据值类型：开关量
描述 ：表示设备号地址为1的施耐德PLC的第一存储位对象的值

标签 ：MW1:1
数据值类型：模拟量
描述 ：示设备号地址为1的施耐德PLC的第一个存储字对象的数值

标签 ：MW1:1.1
数据值类型：开关量
描述 ：示设备号地址为1的施耐德PLC的第一个存储字对象抽取的位对象

标签 ：MD1:1
数据值类型：模拟量
描述 ：示设备号地址为1的施耐德PLC的第一个存储双字对象的数值

标签 ：MF1:1
数据值类型：模拟量
描述 ：示设备号地址为1的施耐德PLC的第一个浮点数对象的数值

标签 ：SMW1:1
数据值类型：开关量
描述 ：示设备号地址为1的施耐德PLC的第一个有符号字对象的数值

标签 ：SMD1:1
数据值类型：模拟量
描述 ：示设备号地址为1的施耐德PLC的第一个有符号双字对象的数值