巨腾Open-PLC(以太网)

概述 硬件连接 创建设备 创建标签 标签的地址规则 标签举例 在线升级驱动 常见问题

概述

硬件连接

巨腾OPEN-PLC与开物2000的通讯方式是采用的以太网通讯的，它支持的MODBUS RTU的通讯协议，如果PC机与巨腾OPEN-PLC直连，

则网线使用图一中的568A Male 和 568B Male 两个水晶接线头，如果通过ET_switch相连，则网线的两头使用图二中的568A Male的接线模式即可。

（图一）

（图二）

创建设备

在开发环境的‘硬件系统’中按照‘新节点和设备向导’的指示配置所连接的模块。以便于开物2000识别和使用。

步骤1：选择设备类型。双击‘’，或单击选中‘’，更改设备名称，最后单击‘选择’按钮。

步骤2：选择操作方式-新建设备(一个设备中可以包含多个)。选中‘新建设备’后单击‘下一步’按钮(或双击‘新建设备’)。

步骤3：选择创建方式-标准创建(一个设备中可以包含多个)。选中 创建方式后单击‘下一步’按钮(或双击‘标准创建’)。

步骤4：设置PLC设备类型及TCP参数选项，单击‘下一步’按钮。

步骤5：显示设备及参数汇总窗口，单击‘完成’按钮，结束设备配置向导。

创建标签

使用设备向导创建完成PLC设备的配置后，可以进行标签设计。

1、在开发环境的‘标签’中添加标签，显示下图，选择主设备为上面的‘’，选择并填写‘主设备地址’，修改标签名。

2、根据PLC的工作模式和标签所监控的参数物理意义，修改测量值零点、测量值量程、工程值零点、工程值量程、扫描周期、转换方式、记录属性等。单击‘添加’或‘完成’按钮。

标签的地址规则

标签的主地址可以按照下面的规则配置填写：

标签类型[ID:]Ch

说明：

  • ID指PLC的地址，用于识别设备中的 PLC， PLC的站号地址以十进制表示，地址设定范围为1～ 255 。标签地址中省略ID时，开物2000系统默认为是所连接设备的最小的站号地址。

  • Ch指的是在Open-PLC的编程软件ISAGRAF中的 配置的连接点的网络地址。 地址范围通常为 0001～0FFF。十六进制表示。

  • 标签地址配置成不存在类型或模块地址错误或通道号超出有效范围时，标签将不被承认，读不上数据。

标签地址

含义

数据类型

读写类型

标签值范围

10ID:Ch

开关量输入

开关量

只读

true/false

00ID:Ch

开关量输出

开关量

可读可写

true/false

30ID:Ch

模拟量输入

模拟量

只读

0～65535

40ID:Ch

模拟量输出

模拟量

可读可写

0～65535

DeviceLink ID:

设备通讯连接状态(-系统标签-)

模拟量/字符串量

只读

0=通讯始终不成功

1=通讯正常
2=通讯出现干扰
3=通讯出现故障
4=通讯线路断路
5=暂停通讯

标签举例

标签 ：101:EDF
数据值类型：开关量
描述 ：表示设备配置示例中站号地址为1的PLC的modbus地址为0EDF的开关量输入的值（只读）

标签 ：002:FDC
数据值类型：开关量
描述 ：表示设备配置示例中站号地址为2的PLC的modbus地址为0FDC的开关量输出的值

标签 ：304:EEF
数据值类型：模拟量
描述 ：表示设备配置示例中站号地址为4的PLC的modbus地址为0EEF的寄存器的值（只读）

标签 ：405:0EF
数据值类型：模拟量
描述 ：表示设备配置示例中站号地址为5的PLC的modbus地址为00EF的寄存器的值（可读可写）

标签 ：DeviceLink3:
数据值类型：模拟量
描述 ：表示设备配置示例中站号地址为4的PLC的最新通讯状态

常见问题

1、为什么开物2000与该设备建立通讯的初始化时间比较长？

答：主要原因是开物2000与该设备通过以态网（TCP/IP协议）通讯， 开物2000通过插口（Socket）进行数据传输，该组件进行初始化的时候需要一定的延迟时间，所以通讯的初始化时间比较长。