研华ADAM5000系列模块

和利时PLC CPU21XNET设备

概述 设备创建 标签创建 标签的地址配置规则 在线驱动升级

概述

和利时CPU21X NET PLC支持以太网通讯功能的plc,可以通过简单网络设置实现数据采集通讯。

设备创建向导及参数设置

． 运行创建向导创建设备

步骤1：选择设备类型，双击选择‘和 利时PLC CPU21XNET TCP设备’。

步骤2：选择操作方式-新建设备，单击下一步。

步骤 3 ，选择创建设备方式，单击下一步。

步骤4：选择设备及配置设备地址，进入下一步。

步骤5：显示所有配置参数，结束设备创建。

标签创建

使用设备创建向导创建完设备模块后就可以进行标签创建。

在开发环境中选‘标签’添加标签，见下图。选择主设备为创建的相应模块，选择并填写‘主设备地址’，修改标签名。

标签类型及地址配置规则

标签类型：DB,MB,EB,AB,PB,ZB,TB,DI，DD，FLOAT

标签(除DD外)主地址可以安下面规则创建：

标签类型[ID]:B.S.L

对DD开关量类型标签其地址配置规则为：

标签类型[ID]:B.S.P

说明：

1． 标签类型主要指监测和控制的数据类型。

2． 标示ID是指设备的地址号；

3． 标示B是指块号(适用于DB，DI，DD，FLOAT，其他类型标签与块号无关，设为0)

4． 标示S是指起始地址号(字节单位)。不同类型的范围不同；

5. 标示L指地址长度(字节数)，浮点FLOAT类型标签长度须为4。

6. 标识P表示开关量位号，范围0-15。

7． 标签地址配置成不存在标签类型或错误地址、超出范围，标签将被不承认，数据都将无法读数，为此请详细参考设备使用手册。

标签举例

标签：DB0:11.0.2

数据类型：模拟量

描 述：表示站号设备 0块号为10起始地址为0长度2个字节的模拟数据

标签：MB0:0.0.2

数据类型：模拟量

描 述：表示 0 站号设备起始地址为0长度2个字节的模拟数据

标签：DD0:11.602.2

数据类型：开关量

描 述：表示站号设备 0块号为11起始地址为602位号为2的开关量