台达DVP系列PLC

台达DVP系列PLC综述

概述 硬件连接及设置 硬件接线图 地址设置 标签类型 在线升级驱动

台达DVP系列PLC

台达DVP系列PLC通讯协议概述

台达DVP系列PLC通讯协议支持与台达DVP系列PLC之间的通讯，本协议采用串行通讯，使用您计算机中的串行口。

开物2000还支持其他多种PLC，详情请与 华富惠通公司 联系。

台达PLC与系统的连接及设置

您可以按下图将开物2000与一个或多个台达PLC相连。

利用串行口进行连接时，可以通过RS232/485适配器与台达PLC的RS485端子相连。

计算机通过串行口与台达PLC通讯示意图

设置台达PLC：

当使用RS485与上位机相连时，台达PLC的缺省与推荐设置如下

设置项

缺省值

推荐值

波特率：

无

9600

当使用RS485与上位机相连时，上位机的RS232推荐设置如下

设置项

推荐值

波特率：

9600

数据位长度

7

停止位长度

1

奇偶校验位

偶校验

台达PLC硬件接线图

当使用台达PLC的控制端子排的RS485接口与计算机相连时,由RS232/RS485适配器到台达变频器的具体连线

如下图示

台达PLC的设备地址

当使用RS485与上位机相连时，台达PLC的地址在开物2000中的设置范围从0到254。台达PLC的地址由台达PLC

的寄存器D1121设置。

台达PLC标签类型

标签的地址配置规则

标签的主地址可以按照下面的规则配置填写：

标签类型[ID:]Ch

说明：

项目符号 | ID指台达PLC的设备地址 ，Ch指寄存器的地址号
项目符号 | 红色字表示格式中可变部分，十进制数表示，变化范围参见各种模块的帮助文件。
项目符号 | 蓝色括号不出现在标签地址中，蓝色括号内的内容在设备中只包含一个模块时可省略。
项目符号 | 标签地址配置成不存在类型或模块表号错误或通道号超出有效范围时，标签将不被承认，读不上数据。

标签使用说明

标签地址

含义

数据类型

读写类型

标签值范围

C ID:Ch

计数器线圈

开关量

可读可写

true～false

D ID:Ch

数据寄存器

模拟量

可读可写

0～65535

M ID:Ch

辅助继电器

开关量

可读可写

true～false

S ID:Ch

步进寄存器

开关量

可读可写

true～false

T ID:Ch

定时器线圈

开关量

可读可写

true～false

X ID:Ch

输入线圈

开关量

可读可写

true～false

Y ID:Ch

输出节点

开关量

可读可写

true～false

CommLink

通信线路状态

模拟量

只读

0～5

DeviceLink ID:

设备通讯连接状态(-系统标签-)

模拟量

只读

0～5

标签/仪表型号

DVP20EX的Ch范围

DVPSeries的Ch范围

C ID:Ch

0～127,232～255

0～255

D ID:Ch

0～599,1000-1143

0～1279

M ID:Ch

0～1279

0～1279

S ID:Ch

0～127

0～1023

T ID:Ch

0～127

0～255

X ID:Ch

0～177(八进制表示，相当于十进制127)

0～377(八进制表示，相当于十进制255)

Y ID:Ch

0～177(八进制表示，相当于十进制127)

0～377(八进制表示，相当于十进制255)

用户如有疑问，请参照台达PLC的使用手册中的串行通讯部分。

标签使用举例:

假设台达PLC的设备地址为6，上位机欲访问C寄存器的第2个单元，则在设备标签的定义中该标签的

主地址应定义为C6:002，其中‘C’指明访问的寄存器类型，‘6’对应开物2000中的槽号，即设备

地址，002对应相应寄存器的单元号。当向C6：002中写入值时（比如1），PLC的参数项C2也被改写

成相应的值（1）。

注：此通讯驱动程序采用MODBUS ASCII协议，上位机与PLC通讯前，请将PLC的通讯协议设定为

MODBUS ASCII方式。