华光PLC

概述 硬件连接与设置 华光PLC的寄存器及其范围 标签举例 在线升级驱动

概述

本协议采用串行通讯，支持华光电子有限公司CCM网络协议。支持

(1) SG-8/8B 系列PLC。

(2) SU-5/5E、SU-6系列PLC。

(3) SU-B 系列PLC。

(4) DL305系列PLC。

注意：考虑到通讯的效率，本驱动只支持 Hex通讯方式。

硬件连接与设置

SG-8/8B系列PLC使用G-01DM数据通讯模块

SU-5,SU-6系列PLC使用U-01DM数据通讯模块

PLC采用RS-232口连接示意图

PLC采用RS-422口连接示意图

SU-5/6系列PLC使用U-01DM数据通讯模块的硬件设置：

SU-6 系列的数据通讯模块U-01DM上有两个DIP开关﹙SW4﹑SW5﹚和两个回转开关（X10﹑X1）;

⑴子局号码﹙即 PLC的地址号﹚的设定

用表面面板上的回转开关，以16进制数进行本局局号设定。CCM NET最多能带90台KOYO 系列 PLC，故作数据通讯单元使用时，局号设定范围为01（H）～5A(H) 。

⑵波特率的设定﹕采用 SW4的1～3设定。(空栏为OFF)

波特率传送速度﹙BPS﹚

SW4-1

SW4-2

SW4-3

300

ON

600

ON

1200

ON

ON

2400

ON

4800

ON

ON

9600

ON

ON

19200

ON

ON

ON

38400

⑶奇偶校验的设定﹕采用 SW4-4设定。

置成ON时为有校验﹙奇数﹚﹐置成OFF时为无校验。

⑷自我诊断﹕采用 SW4-5设定。

置成ON时为自我诊断方式﹙U-01DM硬件检查﹚，平时务必置于OFF位置。

⑸应答延迟时间的设定﹕采用 SW2的6～8设定。

应答延迟时间(ms)

SW4-6

SW4-7

SW4-8

0

2

ON

5

ON

10

ON

ON

20

ON

50

ON

ON

100

ON

ON

500

ON

ON

ON

⑹ ASCII/HEX的设定 ：用SW5-4置于ON时为ASCII方式﹐置于OFF时为HEX方式。

注：考虑到通讯的效率，本驱动只支持Hex通讯方式

  华光SU-6系列PLC连线图

SG-8/8B系列PLC使用G-01DM数据通讯模块的硬件设置说明：

  DIP开关的设定：

SG-8 系列的数据通讯模块G-01DM上有两个DIP开关﹙9单元﹚﹐即SW1，SW2；

1 子局号码﹙即PLC的地址号﹚的设定﹕采用SW1的1～7设定。

例﹕将SW1-6置成ON（逻辑 "1"）﹐其余1～5及7置成OFF（逻辑 "0"）﹐则局号设定为32（即 20H）; 显然﹐子局号范围是01～5AH。

2 一对一设定：采用SW1-8进行设定置于ON时为一对一方式，置于OFF时为一对N方式

3 主局/子局的设定：采用SW1-8进行设定置于ON时为主局，置于OFF时为子局

4 波特率的设定﹕采用SW2的1～3设定。(空栏为OFF)

波特率传送速度﹙BPS﹚ | SW2-1 | SW2-2 | SW2-3
300 | ON
600 　 | ON
1200 | ON | ON
2400 　 　 | ON
4800 | ON 　 | ON
9600 　 | ON | ON
19200 | ON | ON | ON

5 奇偶校验的设定﹕采用SW2-4设定。

置成ON时为有校验﹙奇数﹚﹐置成OFF时为无校验。

6 自我诊断﹕采用SW2-5设定。

置成ON时为自我诊断方式﹙CPU←→G-01DM之间的通讯检查﹚，平时务必置于OFF位置。

7 换帧延迟﹕SW2-6置于ON时，有10ms的换帧延迟时间。

8 应答延迟时间的设定﹕采用SW2的7和8设定。

应答延迟时间(ms) | SW2-7 | SW2-8 | 无线发讯机控制
0 　 　 | 无
20 | ON | 无
100 　 | ON | 无
500 | ON | ON | 有

有设定为500ms时，无线发讯机控制继电器才同时ON。

9 ASCII/HEX 的设定 ：SW2-9置于ON时为ASCII方式﹐置于OFF时为HEX方式。

注：考虑到通讯的效率，本驱动只支持 Hex通讯方式

华光SG--8系列PLC硬件连接图

上位计算机与多个SG-8组成CCM NET时，通常存在两种连接方式。SG-8通过CPU基架上的G-01DM同作为主局的上位计算机或同为子局的其它PLC通讯。

每个G-01DM上有两个25针D型插头，其中：CN2为RS-232C/RS-422串行接口，CN1为RS-422接口。

G-0DM 上有两个短路插片，其连线及意义如下：

应用上位计算机RS-232C串口时的硬件连线图如下：

华光PLC的寄存器及其范围

1 SG-8/8B 系列 PLC

SG-8/8B

功能寄存器

Bit 使用

寄存器使用

寄存器名称

寄存器标志

范围

点数

范围

点数

定时器当前值

R

R0000-R0377

256

计数器当前值

R1000-R1377

256

数据寄存器

R400-R777

4096

R1400-R7377

特殊寄存器

R7400-R7777

128

扩展寄存器

R10000-R37777

12288

输入

I

I0000-I1777

1024

R40400-R40477

64

输出

Q

Q000-Q1777

1024

R40500-R40577

64

全局传送输入寄存器

GI

GI0000-GI3777

2048

R40000-R40177

128

特定局传送输出寄存器

GQ

GQ0000-GQ3777

2048

R40200-R40377

128

内部寄存器

M

M0000-M3777

2048

R40600-R40777

128

特殊寄存器

SP

SP000-SP777

512

R41200-R41237

32

定时器

T

T000-T377

256

R41100-R41117

16

计数器

C

C000-C377

256

R41140-R41157

16

级

S

S0000-S1777

1024

R41000-R41077

64

2 SU-5/5E,SU-6 系列 PLC

SU-5/5E,SU-6

功能寄存器

Bit 使用

寄存器使用

寄存器名称

寄存器标志

SU-5/5E,SU-6

点数

范围

点数

定时器当前值

R

R0000-R0177

128

计数器当前值

R1000-R1177

128

数据寄存器

R1400-R7377

3072

特殊寄存器

R7400-R7777

256

扩展寄存器

输入

I

I000-I477

320

R40400-R40423

20

输出

Q

Q000-Q477

320

R40500-R40523

20

全局传送输入寄存器

GI

GI000-GI777

512

R40000-R40037

32

特定局传送输出寄存器

GQ

-

内部寄存器

M

M000-M737

480

R40600-R40635

30

特殊寄存器

SP

SP000-SP137

288

R41200-R41205

18

SP320-SP617

R41215-R41230

定时器

T

T000-T177

128

R41100-R41107

8

计数器

C

C000-C177

128

R41140-R41147

8

级

S

S0000-S577

384

R41000-R41027

24

3 SU-6B 系列 PLC

SU-6B

功能寄存器

Bit 使用

寄存器使用

寄存器名称

寄存器标志

范围

点数

范围

点数

定时器当前值

R

R0000-R0377

256

计数器当前值

R1000-R1177

128

数据寄存器

R1400-R7377

3072

R10000-R17777

4096

特殊寄存器

R700-R737

32

R7400-R7777

256

扩展寄存器

输入

I

I000-I477

320

R40400-R40423

20

输出

Q

Q000-Q477

320

R40500-R40523

20

全局传送输入寄存器

GI

GI000-GI1777

1024

R40000-R40077

64

特定局传送输出寄存器

GQ

-

内部寄存器

M

M0000-M1777

1024

R40600-R40677

64

特殊寄存器

SP

SP000-SP137

352

R41200-R41205

22

SP320-SP717

R41215-R41234

定时器

T

T000-T377

256

R41100-R41117

16

计数器

C

C000-C177

128

R41140-R41147

8

级

S

S0000-S1777

1024

R41000-R41077

64

4 DL_305系列PLC

D3-350CPU:

D3-350CPU

功能寄存器

Bit 使用

寄存器使用

点数

寄存器名称

寄存器标志

范围 (八进制)

范围

定时器经过值

R

无

V0-V377

256

计数器经过值

V1000-R1177

128

数据寄存器

V1400-V7377

3072

PLC程序使用

V10000-V17777

4096

输入

I

X0-X777

V40400-V404 37

512

输出

Q

Y0-Y777

V40500-V40527

512

内部寄存器

M

C0-C1777

V40600-V40677

1024

特殊寄存器

SP

SP0-SP777

V41200-V412 37

512

定时器 状态

T

T0-T377

V41100-V41117

256

计数器 状态

C

CT0-CT177

V41140-V41147

128

级

S

S0-S1777

V41000-V41077

1024

标签举例

1. 标签名称：I0

标签地址： I0

标签类型：I/O开关量

说明：第0通道的输入寄存器。

2. 标签名称：Q17

标签地址： Q17

标签类型：I/O开关量

说明：第17通道的输出寄存器。

3. 标签名称：R112

标签地址： R112

标签类型：I/O模拟量

说明：第112通道的定时器当前值。

4. 标签名称：T19

标签地址： T19

标签类型：I/O开关量

说明：第19定时器的输出值。

5. 标签名称：C78

标签地址： C78

标签类型：I/O开关量

说明：第78计数器的输出触点。

注意事项：

寄存器的取值范围表示为八进制。


华光PLC

华光DL_305系列PLC

概述 设备创建 标签创建 寄存器及其范围 标签类型 标签举例 常见问题

概述

华光 DL305系列PLC有多种CPU,DL350可支持368点I/O，另外还可以通过远程I/O来扩展。本帮助文档主要说明D3-350CPU的使用。

注意：考虑到通讯的效率，本驱动只支持Hex通讯方式。

设备创建

硬件连接：

D3-305CPU有两个连接口PORT1、PORT2。PORT1是RS223C,波特率固定在9600的连接；PORT2是RS232C/RS442,最高为38.4Kbps

的连接。当PORT2位RS232C连接时，最大距离为15m;RS442为1000m,地址选择在1-90。

串口通讯参数：

plc通讯参数的设置需要通过华光电子电子工业有限公司提供的编程软件（DirectSoft）来设定(参考后面的部分说明)，

具体使用请参考软件说明。

本驱动默认的参数为： 波特率：9600；数据位：8；停止位：1；校验：奇。

设备创建：

1：选择‘华光plc’

2:新建设备：

3：选择创建方式：

4：选择设备设置单元号

5：设置通讯参数

6：创建结束

标签创建

1：选择设备、标签类型

2：配置主地址

标签类型：

DL_305支持的标签类型有：R, I,Q,M,SP,T,C,S

地址配置：TAGS:C

说明：TAG为标签类型，如R等；S为单元号；C为寄存器通道号。如果为单设备S模认为1，地址的具体映射说明参看下表和设备技术资料 。

寄存器及其范围

D3-350CPU:

D3-350CPU

功能寄存器

Bit 使用

寄存器使用

点数

寄存器名称

寄存器标志

范围 (八进制)

范围

定时器经过值

R

无

V0-V377

256

计数器经过值

V1000-R1177

128

数据寄存器

V1400-V7377

3072

PLC程序使用

V10000-V17777

4096

输入

I

X0-X777

V40400-V404 37

512

输出

Q

Y0-Y777

V40500-V40527

512

内部寄存器

M

C0-C1777

V40600-V40677

1024

特殊寄存器

SP

SP0-SP777

V41200-V412 37

512

定时器 状态

T

T0-T377

V41100-V41117

256

计数器 状态

C

CT0-CT177

V41140-V41147

128

级

S

S0-S1777

V41000-V41077

1024

标签举例

1. 标签名称：I0

标签地址： I1:0

标签类型：I/O开关量

说明：单元1第0通道的输入寄存器,即X0。

2. 标签名称：Q17

标签地址： Q1:17

标签类型：I/O开关量

说明：单元1第17通道的输出寄存器，即Y17。

3. 标签名称：R112

标签地址： R1:112

标签类型：I/O模拟量

说明：单元1第112通道的定时器当前值。

4. 标签名称：T19

标签地址： T1:19

标签类型：I/O开关量

说明：单元1第19定时器的输出值。

5. 标签名称：C78

标签地址： C1:78

标签类型：I/O开关量

说明：单元1第78计数器的输出触点，即CT78。

注意事项：

寄存器的取值范围表示为八进制。

常见问题

1.如果出现连接不上，可能是串口通讯参数设置不正确，驱动串口通讯参数是用DirectSoft软件在DirectNet通讯

协议连接成功的参数，请仔细检查。

2.由于协议原因可能通讯效率不是很高，在启动后可能稍等一会数据才能全部上来。

3.考虑到跟以前华光plc设备兼容,对输入X和输出Y采用的是I和Q类标签类型分别来定义，使用时须注意。

4.使用时请按照上面‘寄存器及其范围’表格说明来定义地址。

D3-350CPU通讯参数设置说明：

1：执行DirectSoft软件

PORT1：

2：新建一工程并选择设备类型

3：点击‘Add’添加Link

4：选择COM口

5：选择DirectNET(CCM协议)

6：创建一Link Name,如:DL305

7：正连接

8：点击 Use PLC按钮结束

9：刚才第6步连接成功的参数就是驱动中串口需要配置的参数

PORT2:

1:选择配置port2

2:配置参数，这些参数就是驱动重要配置的通讯参数