丰炜PLC

标签的使用举例 标签的地址规则 标签举例

标签地址配置规则

标签地址可以按照下面的规则配置填写：

标签类型[ID:]Ch
说明：

项目符号

ID指PLC的设备地址号，用于识别同一设备中的不同子PLC，PLC地址为十进制表示。

项目符号

Ch指通道号，范围根据PLC类型不同，十进制表示。

项目符号 | 红色字表示格式中的可变部分，变化范围参见PLC厂商提供的的帮助说明文件。
项目符号 | 蓝色括号不出现在标签地址中，蓝色括号内的内容在“单个 PLC创建”时可省略。
项目符号 | 标签地址配置成不存在类型或PLC地址错误或通道号超出有效范围时，标签将不被承认，不能读/写数据。

标签地址

含义

数据类型

读写类型

标签通道范围

X[ID:]Ch

输入继电器

开关量

读/写

0～1000

Y[ID:]Ch

输入继电器

开关量

读/写

0～1000

M[ID:]Ch

辅助继电器

开关量

读/写

0～6000

S[ID:]Ch

步进继电器

开关量

读/写

0～1000
SM[ID:]Ch

特殊继电器

开关量

只读 9000～9255
TimeContact[ID:]Ch

定时器触点

开关量 只读 0～255
TimeLoop[ID:]Ch

定时器线圈

开关量 只读 0～255
CountContact[ID:]Ch | 计数器触点 | 开关量 | 只读 | 0～255
CountLoop[ID:]Ch | 计数器线圈 | 开关量 | 只读 | 0～255
D[ID:]Ch | 数据寄存器 | 模拟量 | 读/写 | 0～9255
Timer[ID:]Ch | 定时器当前值 | 模拟量 | 读/写 | 0～255
Counter[ID:]Ch | 记数器当前值 | 模拟量 | 读/写 | 0～255

注 ：标签通道地址范围视PLC本身的通道范围而定。

注意X,Y的通道地址为八进制。

标签举例：(以多个PLC创建为例，标签中包括PLC号，若选择单个PLC创建则不用配置PLC号，只须配置通道号，如M0。)

标签 ：X0:0
数据值类型：开关量
描述 ：表示0号PLC的第0位输入值

标签 ：Y0:0
数据值类型：开关量
描述 ：表示0号PLC的第0位输出值

标签 ：M0:0
数据值类型：开关量
描述 ：表示0号PLC的辅助继电器第0位

标签 ：S0:0
数据值类型：开关量
描述 ：表示0号PLC的步进继电器第0位

标签 ：S M0:9000
数据值类型：开关量
描述 ：表示0号PLC的特殊功能寄存器M9000的状态值

标签 ：TimeContact0:0
数据值类型 ：开关量
描述 ：表示0号PLC的定时器第0位接点状态

标签 ：TimeLoop0:0
数据值类型 ：开关量
描述 ：表示0号PLC的定时器第0位线圈状态

标签 ：CountContact0:0
数据值类型 ：开关量
描述 ：表示0号PLC的计数器第0位接点状态

标签 ：CountLoop0:0
数据值类型 ：开关量
描述 ：表示0号PLC的计数器第0位线圈状态

标签 ：D0:0
数据值类型 ：模拟量
描述 ：表示0号PLC的寄存器D0的值

标签 ：Timer0:0
数据值类型 ：模拟量
描述 ：表示0号PLC的定时器T0的经过值

标签 ：Counter0:0
数据值类型 ：模拟量
描述 ：表示0号PLC的计数器C0的经过值