三菱FX系列PLC通讯口

概述 硬件连接 创建设备 标签的地址规则 标签举例 在线升级驱动

概述

开物2000采用ComputerLink协议，支持与三菱FX2_485及其兼容的FX系列PLC之间以485或422方式进行通讯。开物2000支持下面的PLC类型：

项目符号 | FX1S
项目符号 | FX0N
项目符号 | FX
项目符号 | FX2C
项目符号 | FX1N
项目符号 | FX2N
项目符号 | FX2NC

硬件连接

硬件设置值推荐如下：

设定项 设定值

波特率 9600 bps

数据位 7

停止位 1

校验位 无校验

1．RS422全双工方式

说明：R为连接电阻，阻值为330Ω；

SG为信号的地线；

FG为屏蔽的地线。

2．RS485半双工方式

创建设备

在使用开物2000之前，需要设定PLC通讯方式及设备地址：

设置可以通过编程器或编程软件FX_GP WIN-C设置，将D8120设置为：

6080H (通讯方式设置：ComputerLink方式，7位数据位，1位停止位，无校验，波特率9600，命令格式Format1，带和检查)

在D8121中设置PLC站号，如00。

标签的地址规则

标签的主地址可以按照下面的规则配置填写：

标签类型[ID:]ChID

说明：

项目符号

ID指开物2000设备中的 三菱PLC的站号，用于识别设备中的PLC。 一般情况下，ID可以是十进制或十六进制表示形式,位数不限。通常从0开始编址。标签地址中省略ID时，开物2000系统默认为是所连接的最小模块地址。
项目符号

ChID一般指通道号。可以是十进制或八进制表示形式,位数不限。通常从0开始编址。
项目符号 | 红色字表示格式中可变部分，变化范围参见下面设备标签地址表。
项目符号 | 蓝色括号不出现在标签地址中，蓝色括号内的内容在开物设备中只包含一个PLC时可省略。
项目符号 | 标签地址配置成不存在类型或地址错误或超出有效范围时，标签将不被承认，读不上数据。

注意事项：

X,Y寄存器的取值范围表示为八进制。

范围举例：X000-X007,X010-X017….X070-X077,X100-X107,X170-X177.

Y000-Y007,Y010-Y017….Y070-Y077,Y100-Y107,Y170-Y177.

标签地址

含义

数据类型

读写类型

标签值范围

XID:Ch

输入寄存 器 八进制地址

开关量

只读

true～false

YID:Ch

输出寄存器 八进制地址

开关量

读写

true～false

M ID:Ch

辅助寄存器 十进制地址

开关量

读写

true～false

SID:Ch

状态寄存器 十进制地址

开关量

读写

true～false

D ID:Ch

数据寄存器 十进制地址

模拟量

读写

0～65535

TNID:Ch

定时器当前值 十进制地址

模拟量

读写

0～65535

TS ID:Ch

定时器触点 十进制地址

开关量

只读

true～false

CN ID:Ch

计数器当前值 十进制地址

模拟量

读写

0～65535

CS ID:Ch

计数器触点 十进制 地址

开关量

只读

true～false

标签名称

标签类型

三菱FX系列PLC

FXon FX1s FX,FX2c FX1N FX2N,FX2NC

输入寄存（X）八进制

开关量

X0000-X0177

X0000-X0017

X0000-X0337

X0000-X0177

X0000-X0267

（Y）八进制

开关量

Y0000-Y0177

Y0000-Y0015

YOOOO-Y0337

Y0000-Y0177

Y0000-Y0267

辅助寄存器 （M）

开关量

M0000-M0511

M8000-M8254

M0000-M1535

M8000-M8255

M0000-M3071

M8000-M8255

状态寄存器 （S）

开关量

S000-S0127

S000-S0999

数据寄存器 （D）

模拟量

D0000-D0255

D1000-D2499

D8000-8255

D0000-D0999

D1000-D2999

D6000-8255

D0000-D7999

D8000-D8255

定时器触点 （TS）

开关量

TS000-TS063

TS000-TS255

定时器当前值 （TN）

模拟量

TN000-TN063

TN000-TN255

计数器触点 （CS）

开关量

CS000-CS031

CS235-CS254

CS000-CS255

计数器当前值 （CN）

模拟量

CN000—CN031

CN235-CN254

CN000-CN255

标签举例

标签 ：X0
数据值类型：开关量
描述 ：表示第0通道的输入寄存器

标签 ：Y17
数据值类型：开关量
描述 ：表示第17通道的输出寄存器

标签 ：D112
数据值类型：模拟量
描述 ：表示第112通道的数据寄存器

标签 ：TN19
数据值类型：模拟量
描述 ：表示第19定时器的当前值

标签 ：CS078
数据值类型：开关量
描述 ：表示第78计数器的输出触点


用户常见问题

可以用开物设置定时器设定值吗?

项目符号

不能，在三菱Fx系列PLC中定时器设定值是一个常量，在梯形图中已经设定完成，在运行状态下是不能用上位机改变的。

RS485 网络应用提示

项目符号 | 在RS485 网络中， 当通讯距离增长（<1200m），或波特率提高时，应在网络的 两端最后一个节点处的 com+，com-间并接一只 120 Ω左右的线路匹配电阻，以保障网络的可靠运行。
项目符号 | 当 RS485 网络节点数量增加，（>32）或通讯距离超过 1200m 时，应在网络中适当地加入 RS485 中继器。（最好是隔离型的），以保证网络的通讯顺畅。
项目符号 | RS485网络结构应尽量保证为一条干线，各节点引入的支线段应越短越好，以免引起杂波干扰，影响通讯。
项目符号 | RS485 网络的通讯线最好使用屏蔽双绞线。com+与 com-为一个线对，并且屏蔽层应在网络的源端单点接地，可有效地防止外界干扰。
项目符号 | RS485网络干线在布线时， 应避免与动力线系统电源线靠近或平行布置，尽量与其距离远一些。