FX2_485概述

FX2_232概述

本协议支持与三菱FX及其兼容的FX系列PLC之间以232方式通过编程口进行通讯，本协议采用串行通讯，使用计算机的串行口。

支持的PLC类型：

FX1s,FX0N,FX,FX2c,FX1N,FX2N,FX2NC

系统连接与设置

本协议采用编程电缆与PLC进行一对一通讯，不需设置设备地址。

仅需将上位机与plc的通讯硬件参数设置如下：

波特率: 9600 bps

数据位: 7

停止位: 1

校验位: 偶校验

  硬件连线图

PLC通讯方式及设备地址的设定：

标签类型及范围

标签名称 | 标签类型 | 三菱FX系列 PLC
 |  | FXon | FX1s | FX,FX2c | FX1N | FX2N,FX2NC
输入寄存（X） 八进制 | 开关量 | X0000-X0177 | X0000-X0017 | X0000-X0337 | X0000-X0177 | X0000-X0267
输出寄存器（Y） 八进制 | 开关量 | Y0000-Y0177 | Y0000-Y0017 | YOOOO-Y0337 | Y0000-Y0177 | Y0000-Y0267
辅助寄存器 （M） | 开关量 | M0000-M0511 |  | M0000-M1535 |  | M0000-M3071
状态寄存器 （S） | 开关量 | S000-S0127 |  | S000-S0999
数据寄存器 （D） | 模拟量 | D0000-D0255 D1000-D2499 D8000-8255 |  | D0000-D0999 D1000-D2999 D6000-8255 |  | D0000-D7999 D8000-D8255
定时器触点（TS） | 开关量 | TS000-TS063 |  | TS000-TS255
定时器当前值 （TN） | 模拟量 | TN000-TN063 |  | TN000-TN255
计数器触点 （CS） | 开关量 | CS000-CS031 CS235-CS254 |  | CS000-CS255
计数器当前值 （CN） | 模拟量 | CN000—CN031 CN235-CN254 |  | CN000-CN255

举例：

1. 标签名称：X0

标签地址： X0

数据长度：bit

标签类型：I/O开关量

说明：第0通道的输入寄存器。

2. 标签名称：Y17

标签地址： Y17

数据长度：bit

标签类型：I/O开关量

说明：第17通道的输出寄存器。

3. 标签名称：D112

标签地址： D112

数据长度：WORD

标签类型：I/O模拟量

说明：第112通道的数据寄存器。

4. 标签名称：TN19

标签地址： TN19

数据长度：WORD

标签类型：I/O模拟量

说明：第19定时器的当前值。

5. 标签名称：CS078

标签地址： CS078

数据长度：bit

标签类型：I/O开关量

说明：第78计数器的输出触点。

注意事项：

X,Y寄存器的取值范围表示为八进制。

范围举例：X000-X007,X010-X017….X070-X077,X100-X107,X170-X177.

Y000-Y007,Y010-Y017….Y070-Y077,Y100-Y107,Y170-Y177.