三菱A系列PLC

概述 硬件连接 标签的地址规则 标签举例 在线升级驱动

概述

本驱动程序基于ComputerLink协议，包含A系列及AnA系列的两个子协议，支持开物2000系统与三菱A及AnA系列PLC之间以串口方式进行通讯，可实现开物2000系统对PLC各寄存器数据的读取和控制。

其中ACPU包括A1S(S1),A1SJ,A0J2H,A1,A1N,A2(S1),A2N(S1),A2S(S1),A2C,A52G,A3,A3N,A1SH,A1SJH,A2SH(S1),A3H,A3M,A73

AnA/AnU包括A2A(S1),A3A,A2ACPUP21/R21(S1),A3ACPUP21/R21,A2U(S1),A2AS(S1),A3U,A4U,QnA

硬件连接

按下图将安装开物2000系统的计算机与一个或多个PLC相连，将计算机串行口RS232/RS485/RS422通过计算机通信组件A1SJ71UC24-R2(RS232接口)或A1SJ71UC24-R4(RS422/485接口)与PLC相连。

使用RS422/485接口与PLC相连接。

使用RS232接口与PLC相连接。

通讯端口硬件的缺省与推荐设置：

波特率 9600 bps

数据位 8

停止位 1

校验位 偶校验

带和检查

计算机通信组件A1SJ71UC24-R2上的通讯参数配置如下所示

1、MODE1-MODE4用于通讯消息格式设置，将MODE拨盘指向1的位置,本协议只支持通信协议的模式1。

2. SW3-SW12用于串口通讯设置，按上面的缺省设置：SW03:OFF,SW04:ON, SW05:ON,SW06: OFF,SW07:ON,SW08:ON,SW09:ON,SW10:ON,SW11:OFF ,SW12:ON

开关号 | 使用意义 | 推荐值 | 备注
3 | 未使用 | ---- |
4 | Run模式写允许 | ON | (允许)
5 | 传输速率 | ON | （9600bps）
6 |  | OFF
7 |  | ON
8 | 数据位设定 | ON | (8位)
9 | 校验 | ON | 允许
10 | 奇偶校验设定 | ON | 偶校验
11 | 停止位 | OFF | 1位
12 | 和校验 | ON | 允许

计算机通信组件A1SJ71UC24-R4上的通讯参数配置如下所示

1. 站号设定（Station number setting）:将拨盘指向正确的位置。

2．模式设定（Mode Setting）: 将MODE拨盘指向5的位置(Type 1 dedicated protocol mode), 本协议只支持专有通信协议的模式1。

3．串口通讯设置：

开关号 | 使用意义 | 推荐值 | 备注
1 | 未使用 | ---- |
2 | Computer link/Multidrop link协议选择 | ON | (Computer Link)
3 | 未使用 | ---- |
4 | Run模式写允许 | ON | (允许)
5 | 传输速率 | ON | （9600bps）
6 |  | OFF
7 |  | ON
8 | 数据位设定 | ON | (8位)
9 | 校验 | ON | 允许
10 | 奇偶校验设定 | ON | 偶校验
11 | 停止位 | OFF | 1位
12 | 和校验 | ON | 允许

PLC驱动程序各功能标签变量的设定

开物2000按照寄存器标签名称来读取下位机相应的数据。开物2000定义的寄存器标签与下位机所有的寄存器相对应，定义非法寄存器标签将不被承认。如定义的寄存器标签在所用的下位机具体型号中不存在，将读不上数据。开物2000支持的标签类型有：X,Y, M,L,S,B,F,D,W,TS,TC,CS,CC,TN,CN；开物2000使用用户设定的标签变量生成PLC寄存器读写控制命令，读写命令的控制码由系统内部确定。

标签地址编码格式：寄存器标签名称+地址号;

寄存器名称

标签类型

寄存器标签地址取值范围

A

AnA

输入寄存器（X）

 开关量 X0000 –X2047 X0000-X8191
输出寄存器（Y）

 开关量 Y0000 -Y2047 Y0000-Y8191
辅助寄存器 （M） 开关量 M0000 -M2047

M9000 -M9255

M0000-M8191

M9000-M9255

锁存寄存器(L) | 开关量 | L0000 -L2047 | L0000 –L8191
步进寄存器(S)

 开关量 S0000 -S2047 S0000-S8191
通讯寄存器（B）

 开关量 B0000 –B1023 B0000-B8191
信号寄存器(F) | 开关量 | F0000 -F0255 | F000-F2047
数据寄存器 （D） 模拟量 D0000 -D1023

D9000 -D9255

D0000-D8191（D6143）

D0000- D9255

定时器接点 （TS） | 开关量 | TS0000-TS0255 | TS0000-TS2047
定时器线圈（TC） | 开关量 | TC0000-TC0255 | TC0000-TC2047
计数器接点 （CS） 开关量 CS0000-CS0255

 CS0000-CS1023
计数器线圈（CC） 开关量 CC0000—CC0255

 CC0000-CC1023
定时器当前值(TN) | 模拟量 | TN0000-TN0255 | TN0000-TN2047
计数器当前值(CN) | 模拟量 | CN0000-CN0255 | CN0000-CN1023
链接寄存器(W)

 模拟量 W0000-W1023 W0000-W8191
文件寄存器（R） | 模拟量 | R0000-R8191 | R0000-R8191

标签变量使用举例:

标签变量名称

标签类型

标签变量值举例

标签变量值说明
X0001 开关量

ON

0通道的0点输入
X15 开关量

ON

0通道的F点输入
X16 开关量

ON

1通道的0点输入

X17

开关量

ON

1通道的1点输入

X30

开关量

ON

1通道的E点输入

Y16 开关量

ON

1通道的0点输出

M25

开关量

ON

第25点

M125

开关量

ON

第125点

L12

开关量

ON

第12点

TN5

模拟量

789

第5定时器当前值

D45

模拟量

-1234

45通道数据寄存器

W0

模拟量

1234

0通道

W15

模拟量

1234

F通道

W16

模拟量

35537

11通道

W31

模拟量

35537

1F通道

CS078

开关量

ON

第78计数器输出触点


The following I:\开发文档\三菱A系列PLC\三菱A系列PLC.HHP file(s) could not be found:
    I:\开发文档\三菱A系列PLC\三菱A系列PLC.files\image002.jpg
    I:\开发文档\三菱A系列PLC\三菱A系列PLC.files\image004.jpg