通用帮助文件

通用帮助文件对使用驱动过程中的通用内容进行了详细的描述，主要内容包括建立设备、建立标签以及一些常见问题等。关于您使用的特定硬件设备的帮助文件请参见我们提供的特定硬件设备的使用帮助文件。

1. 北京华富惠通技术有限公司简介

2. 如何在开物2000中建立串口类设备

3. 如何在开物2000中建立以太网类设备

4. 如何在开物2000中建立板卡类设备

5. 如何在开物2000中建立标签

6. 使用开物2000需要注意的问题


公司简介

北京华富惠通技术有限公司简介

公司简介 联系我们 在线升级驱动 技术论坛

1.公司简介

项目符号 | 北京华富惠通技术有限公司座落在素有中国硅谷之称的中关村高新技术产业园区。
项目符号 | 北京华富惠通技术有限公司是一家以信息技术、自动化技术为主的高新技术企业，是北京市软件协会认证的软件企业。公司现有员工90名，平均年龄26周岁，绝大多数员工具有大学本科以上学历，是一只年轻化知识化的队伍。
项目符号 | 北京华富惠通技术有限公司在计算机软件开发、计算机网络集成、工业自动化系统开发等领域有很强 的实力和丰富的经验。在利用中关村得天独厚的技术、信息、人才和政策优势的同时，公司还在哈尔滨设有分公司和研发基地，充分利用当地的人力资源和成本优势，承接软件外包工程，并与日本、美国、印度等国家的软件企业有广泛的业务合作。目前为止，公司的多项软件产品已经取得高新技术产品认证和软件产品认证。公司在自动化软件领域有丰富的开发和实施经验 。
项目符号 | 北京华富惠通技术有限公司主要的自动化软件产品《controx 2000 通用监控系统支持软件包》在人机接口工具软件领域有很高的知名度，并在电力、化工、制造、电信、交通、楼宇等行业取得广泛应用，客户遍布全国各地，并积极开拓台湾、日本等海外市场。
项目符号 | 北京华富惠通技术有限公司是继西门子(中国)、费舍尔罗斯蒙特(中国)等4家外资公司后的第5个国际OPC工业标准基金会会员，成为中国唯一的在该国际标准组织有投票权的自动化软件公司。目前，公司已经成为中国自动化应用协会、北京高新技术企业协会、北京软件行业协会会员。
项目符号 | 北京华富惠通技术有限公司的目标是发展成为国内一流的软件开发企业、一流的软件外包企业，培养出自己的稳定高效的研究开发队伍和市场营销队伍以及项目管理队伍，同时加大产品市场占有率，利用公司积累的人员和管理优势，大力发展软件外包工作，提高公司品牌知名度，争取在有形和无形资产积累方面都取得成功。
项目符号 | 北京华富惠通技术有限公司将在2～3年的时间，通过技术创新和资本运营，发展成为国内一流的软件企业和一流的高新技术企业。

2.北京华富惠通技术有限公司真诚欢迎您通过以下方式联系我们

电话：010-82825388

传真：010-82825388-106

地址：中国北京市海淀区中关村软件园孵化器1号楼1201-1212

邮编：100094

公司网站： www.huafugroup.com

产品网站： www.controx2000.com

email： controx2000@huafugroup.com


建立 串口类设备

概述 硬件连接 创建设备 在线升级驱动 技术论坛

1.概述

在开物2000中和各种自动化设备进行通讯需要安装相应设备的驱动程序，请确保您在使用开物前已经安装了设备的驱动程序。

2.硬件连接

在您的自动化设备和开物2000之间进行正常通讯之前，请确保您已经正确进行了硬件连接。

项目符号 | 对于串口类设备，选用RS232方式通讯时请直接将设备和计算机的COM口进行连接；
项目符号 | 对于串口类设备，选用RS485方式通讯时请在硬件设备和计算机COM口之间使用RS232-RS485转换器进行信号转换，并且需要设定唯一的设备地址；
项目符号 | 对于其它接口设备，请按照厂商提供的方式进行硬件连接。

3.创建设备

在开物2000开发环境中创建设备包括以下主要步骤。

3.1 步骤1：在开发环境中右击建立的“网络节点”名称，选择“新建”，弹出如下对话框，根据您的需要选择需要建立的设备类型，根据需要更改”设备名“，同时可以查看”驱动版本号“，选择完毕后点击“选择”按钮。

3.2 步骤2：在”配置向导“中选择执行的操作方式——“新建设备”。选中“新建设备”后单击”下一步”按钮(或双击“新建设备”)，您也可以选择“修改设备”，对硬件设备的配置进行修改或者选择“察看设备”浏览已经配置好的设备信息。

其中下面的按钮的含义分别为：

版本信息：可以查看驱动的版本等信息；

调试设置：通常情况下“调试开关”打开，这时可以记录驱动程序运行过程中的基本信息，主要包括启动和退出的时间，标签配置情况，通讯情况等信息；如果把“输出错误信息”和“输出跟踪信息”也选中的话，这时将记录驱动运行过程中的全部通讯信息，对于记录通讯过程中的错误信息很有帮助，如果您在使用开物过程中，硬件连接有问题时，请打开所有调试开关，将通讯信息记录下来，待正常后，请您把“输出错误信息”和“输出跟踪信息”关闭。

注意：整个调试信息将存成LOG文件，并存储在相应工程目录下的“DEBUG”子目录下，文件名对于串口类设备以驱动DLL文件+COM口+日期时间的方式命名，如JLS_XMT.dll_com12004-07-31-13-33-54.LOG。

3.3 步骤3：在"设备建立方式向导"中选择创建设备的方式——包括“标准创建”和“多设备创建”。其中：

标准创建：指在一个开物主设备中创建一个设备；

多设备创建：指在一个开物主设备中创建多个子设备，您可以根据你的需求进行选择 。

注意：对于同一厂商相同系列设备选用RS485方式进行通讯的话需要选择“多设备创建”，否则会引起COM口的争用。

3.4 步骤4：在”设备建立向导“中选择“设备类型”，设置“设备地址”，同时您可以根据您的需要修改”虚拟地址“，然后可以点击“添加设备”将设置好的设备添加到设备配置图中。若需要修改设备的参数，应先选中“设备配置图”中的设备，然后更改设备类型、设备号和虚拟地址 等信息，最后点击“修改设备”；若需要删除多余的或错误的设备，可以先选中要删除的设备，然后选择“删除设备”。 其中：

设备类型：指用户使用的设备型号，通过下拉菜单选择；

设备地址：在RS485网络中设备的站地址，不允许重复；

虚拟地址：对于版本号5.0以上的驱动程序提供了虚拟地址的概念，对应标签建立时的 设备地址(虚拟地址可能等于设备地址也可能不等于设备地址，但是它们之间存在一个对应关系)。

对于版本号5.0以上驱动来说标签的建立规则为： 标签名+ID号(即虚拟地址)+“:”+通道号+“.”+"位号"，如标签ALARM5:3.4中“ALARM”为标签名，5为虚拟地址号，3为通道号，4为位号。假如虚拟地址和设备地址相同的话，则新旧版本的建立规则基本相同。

对于以前的驱动程序(版本号低于5.0)来说标签的建立规则为 ： 标签名+设备地址+“:”+通道号+“.”+"位号"，如标签ALARM5:3.4中“ALARM”为标签名，5为设备地址，3为通道号，4为位号。

虚拟地址的方便之处：

对于以前的驱动程序(版本号低于5.0)来说，当您在设备向导中添加设备并设置好了设备地址后，设定”设备地址”为2，在建立标签过程中由于包含了设备地址信息，标签为：ALARM2:0、ALARM2:1、ALARM2:2、ALARM2:3、ALARM2:4(这里ID号为设备地址)；假如由于某种原因您对设备地址进行修改之后，假如设备地址修改为3，则对于所有的标签都将更改为ALARM3:0、ALARM3:1、ALARM3:2、ALARM3:3、ALARM3:4对于所有的标签都需要修改(因为设备地址修改了，标签和设备的对应关系改变了)，当标签量很大时是非常麻烦的，而且修改不正确则可能导致严重的后果。

对于版本号5.0以上的驱动程序中提出的”虚拟地址“可以解决这个问题，当您在设备向导中添加设备并设置好了设备地址后，设定”设备地址”为2，”虚拟地址”为1，在建立标签过程中由于包含了虚拟地址信息，标签为：ALARM1:0、ALARM1:1、ALARM1:2、ALARM1:3、ALARM1:4(这里ID号为虚拟地址)；假如由于某种原因您对设备地址进行修改之后，假如”设备地址”修改为3，假如”虚拟地址”仍然为1的话，则对于所有的标签都不需要进行修改。

3.5 步骤5：在”修改计算机串行口通讯参数“向导中设置计算机的串口参数，主要包括串口号、波特率、数据位、停止位、校验方式等。其中波特率、数据位、停止位、校验方式等配置信息需要保证与下位机完全相同，关于下位机的波特率、数据位、停止位、校验方式在我们的针对某款硬件设备的帮助文件中一般会有说明，但是假如与硬件厂商提供的参数有区别的话，则以硬件厂商硬件使用说明书处为准。

注意：对于“MODEM参数设置”一般不需要配置。

3.6 步骤6：在”确认“向导中您需要仔细检查设备的建立情况是否正确，假如不正确请点击”上一步“进行修改，假如正确的话，点击”完成“结束建立设备过程。

注意：若需要对通讯过程中的高级参数进行设备，请点击”高级参数“进入高级参数设置向导。

3.7 步骤7：在”高级参数设置“向导中您可以设置超时时间、通讯间隔时间、读失败重试次数和写失败重试次数以及对于特定驱动程序提供的高级参数。

通过以上的步骤您已经完成了建立设备的过程，接下来可以进行标签的设计。


建立板卡类设备

概述 硬件连接 创建设备 在线升级驱动 技术论坛

1.概述

在开物2000中和各种自动化设备进行通讯需要安装相应设备的驱动程序，请确保您在使用开物前已经安装了设备的驱动程序。

2.硬件连接

在您的自动化设备和开物2000之间进行正常通讯之前，请确保您已经正确进行了硬件连接。

项目符号 | 对于板卡类设备请确保正确安装在计算机的ISA或PCI插槽上，并且正确设定了各种配置信息；
项目符号 | 对于其它接口设备，请按照厂商提供的方式进行硬件连接。

3.创建设备

在开物2000开发环境中创建设备包括以下主要步骤。

3.1 步骤1：在开发环境中右击建立的“网络节点”名称，选择“新建”，弹出如下对话框，根据您的需要选择需要建立的设备类型，根据需要更改”设备名“，同时可以查看”驱动版本号“，选择完毕后点击“选择”按钮。

3.2 步骤2：在”配置向导“中选择执行的操作方式——“新建设备”。选中“新建设备”后单击”下一步”按钮(或双击“新建设备”)，您也可以选择“修改设备”，对硬件设备的配置进行修改或者选择“察看设备”浏览已经配置好的设备信息。

其中下面的按钮的含义分别为：

版本信息：可以查看驱动的版本等信息；

调试设置：通常情况下“调试开关”打开，这时可以记录驱动程序运行过程中的基本信息，主要包括启动和退出的时间，标签配置情况，通讯情况等信息；如果把“输出错误信息”和“输出跟踪信息”也选中的话，这时将记录驱动运行过程中的全部通讯信息，对于记录通讯过程中的错误信息很有帮助，如果您在使用开物过程中，硬件连接有问题时，请打开所有调试开关，将通讯信息记录下来，待正常后，请您把“输出错误信息”和“输出跟踪信息”关闭。

注意：整个调试信息将存成LOG文件，并存储在相应工程目录下的“DEBUG”子目录下，文件名对于板卡类设备以驱动DLL文件+基地址+日期时间的方式命名，如Pcl812pg.dll_2002004-7-19 17-12-15.log。

3.3 步骤3：在"设备建立方式向导"中选择创建设备的方式——包括“标准创建”和“多设备创建”。其中：

标准创建：指在一个开物主设备中创建一个设备；

多设备创建：指在一个开物主设备中创建多个子设备，您可以根据你的需求进行选择 。

3.4 步骤4：在”设备建立向导“中选择“设备类型”，设置设备地址、基地址、AD输入方式、AD最大范围(或AD输入极性)、AD滤波次数、量程选择等选项，同时您可以根据您的需要修改”虚拟地址“，然后可以点击“添加设备”将设置好的设备添加到设备配置图中。若需要修改设备的参数，应先选中“设备配置图”中的设备，然后更改设备类型、设备号和虚拟地址 等信息，最后点击“修改设备”；若需要删除多余的或错误的设备，可以先选中要删除的设备，然后选择“删除设备”。 其中：

设备类型：指用户使用的板卡型号，通过下拉菜单选择；

板卡号：如果为多个板卡创建，则须填写板卡号，以便于开物2000对板卡设备的识别；如果为单个板卡创建则没有这个选项。

板卡类型：指用户使用的板卡型号，通过下拉菜单选择；

基址(16进制)：指16进制板卡基地址，如300，基地址不允许重复；

AD输入方式：指AD信号是单端还是差动；

AD最大范围(或AD输入极性)：选择AD信号的输入极性为单极性还是双极性(或者AD的输入极性为单极性或双极性)；

AD滤波次数：主要为滤除干扰而设计，算法为：若设定为10，则将采集到的10个数据按照大小顺序排列，取中间1/3数据的平均值，这个过程在驱动中完成，您可以根据板卡使用情况调节AD滤波次数。这个滤波次数为设备级的滤波次数，对于这块板卡的所有AD标签都起作用，但是在版本号5.0以上驱动程序中的标签中提供了针对标签的滤波次数，对这个标签起作用，并且覆盖原来的设备级滤波次数。实现方案为建立标签AD0:1.8，其中8为这个标签的滤波次数，其中滤波次数范围为1-32。

虚拟地址：对于版本号5.0以上的驱动程序提供了虚拟地址的概念，对应标签建立时的 设备地址(虚拟地址可能等于设备地址也可能不等于设备地址，但是它们之间存在一个对应关系)。

对于版本号5.0以上驱动来说标签的建立规则为： 标签名+ID号(即虚拟地址)+“:”+通道号+“.”+"位号"，如标签AD5:3.4中“ALARM”为标签名，5为虚拟地址号，3为通道号，4为位号。假如虚拟地址和设备地址相同的话，则新旧版本的建立规则基本相同。

对于以前的驱动程序(版本号低于5.0)来说标签的建立规则为 ： 标签名+设备地址+“:”+通道号+“.”+"位号"，如标签AD5:3.4中“AD”为标签名，5为设备地址，3为通道号，4为位号。

虚拟地址的方便之处：

对于以前的驱动程序(版本号低于5.0)来说，当您在设备向导中添加设备并设置好了设备地址后，设定”设备地址”为2，在建立标签过程中由于包含了设备地址信息，标签为：AD2:0、AD2:1、AD2:2、AD2:3、AD2:4(这里ID号为设备地址)；假如由于某种原因您对设备地址进行修改之后，假如设备地址修改为3，则对于所有的标签都将更改为AD3:0、AD3:1、AD3:2、AD3:3、AD3:4对于所有的标签都需要修改(因为设备地址修改了，标签和设备的对应关系改变了)，当标签量很大时是非常麻烦的，而且修改不正确则可能导致严重的后果。

对于版本号5.0以上的驱动程序中提出的”虚拟地址“可以解决这个问题，当您在设备向导中添加设备并设置好了设备地址后，设定”设备地址”为2，”虚拟地址”为1，在建立标签过程中由于包含了虚拟地址信息，标签为：AD1:0、AD1:1、AD1:2、AD1:3、AD1:4(这里ID号为虚拟地址)；假如由于某种原因您对设备地址进行修改之后，假如”设备地址”修改为3，假如”虚拟地址”仍然为1的话，则对于所有的标签都不需要进行修改。

关于定时/记数器功能的设置，您可以根据自己的需要选择定时/记数器的工作方式，下面给出了各种工作方式的特点

项目符号 | 方式0：计数结束时中断。编程后自动启动，计数器减1计数，计数到终点后输出高电平，可用于中断请求信号，GATE为低电平时停止计数，回到高电平后继续往下计数。再次启动要重新装入计数值或重新编程。
项目符号 | 方式1：可编程单稳脉冲输出，GATE上升沿进行初始化并开始计数。输出低电平的宽度等于计数时间。单脉冲输出可用GATE上升沿多次触发。
项目符号 | 方式2：比率发生器。编程后重复循环计数。计数到终点时输出一个时钟周期宽度的低电平脉冲，自动初始化后继续计数。用GATE的上升沿初始化，并开始计数。GATE为低电平时停止计数。
项目符号 | 方式3：方波发生器。这种方式是在编程后重复地循环计数，输出波形为方波。到达计数终点时输出电平改变，计数器自动初始化后继续计数。用GATE 的上升沿初始化并开始计数，GATE为低电平时停止计数。
项目符号 | 方式4：软件启动选通脉冲输出。编程后自动启动，计数到终点后输出一个时钟周期的低电平脉冲。用GATE的上升沿初始化并开始计数，GATE为低电平时停止计数。
项目符号 | 方式5：硬件启动选通脉冲输出。编程后，等待 GATE 上升沿进行初始化并开始计数，计数到终点后输出一个时钟周期的低电平脉冲，计数器开始计数后不受GATE信号电平的影响，这种选通脉冲的输出可用GATE的上升沿多次触发。

需要注意的是，为了使用方便，在驱动程序中已经对记数进行了处理，您看到的情况是记数是从小到大变化的。

关于“内部时钟源“是选择是使用板卡本身提供的时钟还是外部的时钟，一般是外部时钟，只有少数板卡提供了内部时钟。

关于可编程IO的设置

“芯片号”对应板卡设备的8255或其兼容芯片号，一片8255或其兼容芯片提供24路数字量通道，分位端口A、端口B和端口C低4位和端口C高4位，可以任意配置为输入或输出功能；端口A对应前8路；端口B对应中间8路；端口C低4位对应低4位；端口C高4位对应于高4位。

对于第0片8255或其兼容芯片通道号范围从0～23；第1片通道号范围从24～47；第3片通道号范围从48～71；第4片通道号范围从72～95，其它依此类推；

其中芯片号0的端口A对应数字量通道0～7，端口B对应通道8～15。

如果端口A设定为输出，则在配置标签时应为DO0、DO1、DO2、DO3、DO4、DO5、DO6、DO7。

如果端口A设定为输入，则在配置标签时应为DI0、DI1、DI2、DI3、DI4、DI5、DI6、DI7；

如果端口B设定为输出，则在配置标签时应为DO8、DO9、DO10、DO11、DO12、DO13、DO14、DO15。

如果端口B设定为输入，则在配置标签时应为DI8、DI9、DI10、DI11、DI12、DI13、DI14、DI15。

使用过程中请注意数字量标签的配置方法。

注意：对于板卡的配置信息都是针对”板卡配置图”中某一块板卡而言的，所以在设定关于板卡的任何信息前，都要选择您关心的板卡，同时设定完毕后要点击”修改”按钮完成设置。

通过以上的步骤您已经完成了建立板卡设备的过程，接下来可以进行标签的设计。


建立 以太网类设备

概述 硬件连接 创建设备 在线升级驱动 技术论坛

1.概述

在开物2000中和各种自动化设备进行通讯需要安装相应设备的驱动程序，请确保您在使用开物前已经安装了设备的驱动程序。

2.硬件连接

在您的自动化设备和开物2000之间进行正常通讯之前，请确保您已经正确进行了硬件连接。

项目符号 | 对于以太网类设备，通讯时请直接通过网线将设备和计算机进行连接，并且保证为硬件设备设定了唯一的IP地址；
项目符号 | 对于其它接口设备，请按照厂商提供的方式进行硬件连接。

3.创建设备

在开物2000开发环境中创建设备包括以下主要步骤。

3.1 步骤1：在开发环境中右击建立的“网络节点”名称，选择“新建”，弹出如下对话框，根据您的需要选择需要建立的设备类型，根据需要更改”设备名“，同时可以查看”驱动版本号“，选择完毕后点击“选择”按钮。

3.2 步骤2：在”配置向导“中选择执行的操作方式——“新建设备”。选中“新建设备”后单击”下一步”按钮(或双击“新建设备”)，您也可以选择“修改设备”，对硬件设备的配置进行修改或者选择“察看设备”浏览已经配置好的设备信息。

其中下面的按钮的含义分别为：

版本信息：可以查看驱动的版本等信息；

调试设置：通常情况下“调试开关”打开，这时可以记录驱动程序运行过程中的基本信息，主要包括启动和退出的时间，标签配置情况，通讯情况等信息；如果把“输出错误信息”和“输出跟踪信息”也选中的话，这时将记录驱动运行过程中的全部通讯信息，对于记录通讯过程中的错误信息很有帮助，如果您在使用开物过程中，硬件连接有问题时，请打开所有调试开关，将通讯信息记录下来，待正常后，请您把“输出错误信息”和“输出跟踪信息”关闭。

注意：整个调试信息将存成LOG文件，并存储在相应工程目录下的“DEBUG”子目录下，文件名对于以太网类设备以驱动DLL文件+TCP或UDP+端口号+日期时间的方式命名，如ETHERNET.dll_TCP_4096_2004-07-31-13-33-54.LOG。

3.3 步骤3：在"设备建立方式向导"中选择创建设备的方式——包括“标准创建”和“多设备创建”。其中：

标准创建：指在一个开物主设备中创建一个设备；

多设备创建：指在一个开物主设备中创建多个子设备，您可以根据你的需求进行选择 。

3.4 步骤4：在”设备建立向导“中选择“设备类型”，设置“设备地址”，同时您可以根据您的需要修改”虚拟地址“，然后可以点击“添加设备”将设置好的设备添加到设备配置图中。若需要修改设备的参数，应先选中“设备配置图”中的设备，然后更改设备类型、设备号和虚拟地址 等信息，最后点击“修改设备”；若需要删除多余的或错误的设备，可以先选中要删除的设备，然后选择“删除设备”。 其中：

设备类型：指用户使用的设备型号，通过下拉菜单选择；

设备地址：网络中设备的站地址，不允许重复；

虚拟地址：对于版本号5.0以上的驱动程序提供了虚拟地址的概念，对应标签建立时的 设备地址(虚拟地址可能等于设备地址也可能不等于设备地址，但是它们之间存在一个对应关系)。

对于版本号5.0以上驱动来说标签的建立规则为： 标签名+ID号(即虚拟地址)+“:”+通道号+“.”+"位号"，如标签ALARM5:3.4中“ALARM”为标签名，5为虚拟地址号，3为通道号，4为位号。假如虚拟地址和设备地址相同的话，则新旧版本的建立规则基本相同。

对于以前的驱动程序(版本号低于5.0)来说标签的建立规则为 ： 标签名+设备地址+“:”+通道号+“.”+"位号"，如标签ALARM5:3.4中“ALARM”为标签名，5为设备地址，3为通道号，4为位号。

虚拟地址的方便之处：

对于以前的驱动程序(版本号低于5.0)来说，当您在设备向导中添加设备并设置好了设备地址后，设定”设备地址”为2，在建立标签过程中由于包含了设备地址信息，标签为：ALARM2:0、ALARM2:1、ALARM2:2、ALARM2:3、ALARM2:4(这里ID号为设备地址)；假如由于某种原因您对设备地址进行修改之后，假如设备地址修改为3，则对于所有的标签都将更改为ALARM3:0、ALARM3:1、ALARM3:2、ALARM3:3、ALARM3:4对于所有的标签都需要修改(因为设备地址修改了，标签和设备的对应关系改变了)，当标签量很大时是非常麻烦的，而且修改不正确则可能导致严重的后果。

对于版本号5.0以上的驱动程序中提出的”虚拟地址“可以解决这个问题，当您在设备向导中添加设备并设置好了设备地址后，设定”设备地址”为2，”虚拟地址”为1，在建立标签过程中由于包含了虚拟地址信息，标签为：ALARM1:0、ALARM1:1、ALARM1:2、ALARM1:3、ALARM1:4(这里ID号为虚拟地址)；假如由于某种原因您对设备地址进行修改之后，假如”设备地址”修改为3，假如”虚拟地址”仍然为1的话，则对于所有的标签都不需要进行修改。

3.5 步骤5：在”修改计算机以太网通讯参数“向导中设置计算机的 以太网参数，主要包括设备IP地址、设备端口号、本地端口号等。其中设备IP号和设备端口号需要和下位机或通讯模块本身的IP号和端口号对应。在我们的针对某款硬件设备的帮助文件中一般会有说明，但是假如与硬件厂商提供的参数有区别的话，则以硬件厂商硬件使用说明书处为准。

3.6 步骤6：在”确认“向导中您需要仔细检查设备的建立情况是否正确，假如不正确请点击”上一步“进行修改，假如正确的话，点击”完成“结束建立设备过程。

注意：若需要对通讯过程中的高级参数进行设备，请点击”高级参数“进入高级参数设置向导。

3.7 步骤7：在”高级参数设置“向导中您可以设置超时时间、通讯间隔时间、读失败重试次数和写失败重试次数以及对于特定驱动程序提供的高级参数。

通过以上的步骤您已经完成了建立设备的过程，接下来可以进行标签的设计。


建立标签

概述 配置规则 建立标签 注意事项在线升级驱动 技术论坛

1.概述

在开物2000中完成”建立设备“的过程以后，可以进行标签设计。开物2000中标签分为两种类型，内存变量(内存点)和IO变量(IO点)。IO点是开物2000和下位机或其它应用软件相互交换的监控点和数据。内存变量是开物2000组态时用到的中间变量。

2.配置规则

在建立标签时需要按照如下规则进行：

标签组成：标签名+ID号+“:”+通道号+“.”+"位号"，其中”:“前面的称为”设备地址“，”:“后面的称为”数据地址“。如标签ALARM5:3.4中“ALARM”为标签名，5为ID号，3为通道号，4为位号。其中对于5.0以上版本的驱动来说，ID号为虚拟地址，对于以前的驱动版本(低于5.0版本)来说，ID号指设备地址。这里只是提供了标签的配置规则，对于具体的硬件设备来说，其标签的配置规则请参见驱动开发组提供的特定硬件的帮助文件。

说明：

项目符号 | 对于设备地址均采用10进制数据，对于数据地址可能采用10进制也可能采用16进制，需参照驱动开发组提供的特定硬件的帮助文件；
项目符号 | 对于虚拟地址其范围一般为0-255，设备地址和硬件设备相关，一般的在驱动开发组提供的特定硬件的帮助文件中会有说明，请保证在配置时不要超出这个范围；
项目符号 | 指通道号范围根据 硬件设备不同会有区别，详情请参见驱动开发组提供的特定硬件的帮助文件；
项目符号 | 对于位号的范围需要参见驱动开发组提供的特定硬件的帮助文件，也可能不存在这个地址。
项目符号 | 标签地址配置成不存在的类型或数据地址超出范围时，在开物运行环境下的详细信息中会看到”标签配置错误“的信息。

3.建立标签

在开发环境的“标签”击鼠标右键，选择“添加标签“，显示见下图，选择 您已经建立好的主设备，选择标签类型并填写标签地址，根据您的需要修改标签名 ，根据您的特定使用需求，修改测量值和工程值的最大值、最小值、扫描周期等属性。单击‘添加’或‘完成’按钮。。

其中：

测量值最大值：设定为该标签当前量程的上限值；

测量值最小值：设定为该标签当前量程的下限值；

工程值最大值：设定为实际物理参数的上限值；

工程值最小值：设定为实际物理参数的下限值；

如：硬件设备的量程为：0 ～ 99999，对应现场的重量信号为0 ～ 999.99N，则测量值最大值设为 99999；最小值设为 0；工程值最大值设为 999.99；最小值设为 0。

4.注意事项

4.1 通常驱动程序提供的数据是测量值数据，开物真正显示的为工程值数据，通过工程值和测量值的最大、最小的修改实际上是一种线性的量纲转换。假如只测量外界的现场信号则不需要更改测量值和工程值的最大值、最小值，保持默认值就可以。

4.2 关于标签的扫描周期：对于任何一个标签都提供扫描周期的设置，关于这个参数的设置对于系统的运行状况存在一定的影响，驱动程序理论上按照设定的扫描周期进行数据采集，但是当标签比较多的时候或者设定的扫描周期太小，比一次正常的通讯时间都要短的话，那么驱动程序将最大限度的进行数据采集，此时的扫描周期是达不到的。举例来说，假如一个标签的通讯时间需要50mS，一共3个标签，扫描周期均为500mS，那么这个扫描周期是可以满足的，这时驱动程序会按照您设定的扫描周期进行数据采集；假如一个标签的通讯时间需要50mS，一共20个标签，扫描周期均为500mS，那么这个扫描周期是不能够满足的，这时驱动程序即使全力运行也无法保证按照您设定的扫描周期进行数据采集，此时驱动程序只能保持高速运行，但满足不了您设定的扫描周期的要求，所以建议您在使用过程中对于标签扫描周期的设定一定要考虑您需要的数据刷新周期，同时要尽可能的设置大一些。


常见问题

问题1：驱动程序采用什么响应机制？

问题2：硬件设备采集到的数据为什么与实际数据不相同？

问题3：标签设置缺少ID号（设备地址或虚拟地址）时 代表什么含义？

问题4：开物网页上驱动无法下载的问题？

问题5：工程中要大量用到非标准的串口设备，并且连接到一台计算机上，如何方便的驱动？

问题6： 三菱ASJ71UC24_R4通讯模块将波特率设置为19200后为什么不能通讯？

问题7：驱动程序升级后，为什么运行原来运行正常的工程出现错误？

问题8： 开物中使用RS485通讯时，支持并联的设备的最大数量是多少，何种情况下必须加RS485通讯反射电阻？

问题9：板卡设备中标签中的位号代表什么含义？

问题10：板卡设备中是如何实现频率采集的？

问题1：驱动程序采用什么响应机制？

答：开物2000的驱动程序采用消息触发机制，面向对象编程，消息间通过同步对象保证资源共享及传输效率。

问题2：硬件设备采集到的数据为什么与实际数据不相同？ 返回

答：可能由于硬件设备在通讯时是将采集到的数据放大或缩小若干倍后传递给上位机的，一般的您需要在标签的测量值和工程值的最大、最小值进行相应的设置就可以解决。如： 硬件设备的量程为：0 ～ 99999，对应现场的重量信号为0 ～ 999.99N，则测量值最大值设为 99999；最小值设为 0；工程值最大值设为 999.99；最小值设为 0。

问题3：标签设置缺少ID号（设备地址或虚拟地址）时代表什么含义？ 返回

答：在开物中建立标签时,如果没有指定ID号（设备地址或虚拟地址）如标签设定为Parm0,则Parm标签指向在设备建立时指定的最小地址对应的设备.比如在建立设备时,建立了 设备地址为1和设备地址为2的硬件,则Parm0则指向了地址为1的设备,标签含义与Parm1:0完全相同。

问题4：开物网页上驱动无法下载的问题？ 返回

答：请您使用网际快车或者网络蚂蚁进行下载。

问题5：工程中要大量用到非标准的串口设备，并且连接到一台计算机上，如何方便的驱动？ 返回

答：方法有两个：1、通过ADAM4520或波士转换器等将RS232接口转换为RS485接口，从而把非标设备和计算机串口挂接到485总线上，在开物2000系统中针对非标设备开发出复杂的支持各种设备的驱动程序。实现一个串口连接多个设备。此种方案的通讯效率低，驱动程序是否能支持各种设备，与非标设备的协议结构有密切的关系；2、在计算机端安装MOXA的多串口卡，每个串口挂接一个非标设备，在开物2000系统中为每个设备设计驱动程序。此种方法实现简单、通讯效率高、驱动程序开发容易、成本低。开物2000软件在一台计算机上最多可支持10个串口。

问题6：三菱ASJ71UC24_R4通讯模块将波特率设置为19200后为什么不能通讯？ 返回

答：三菱ASJ71UC24_R4不支持19200BPS。

问题7：驱动程序升级后，为什么运行原来运行正常的工程出现错误？ 返回

答：我们在升级驱动程序时会最大程度考虑版本之间的兼容性，但是由于驱动程序模板在升级过程中对一些关键信息进行了修改，从而使得新旧版本的数据不能很好的对应，这时候就会出现问题。您需要删除原来的设备重新建立设备就可以解决问题。

问题8：开物中使用RS485通讯时，支持并联的设备的最大数量是多少，何种情况下必须加RS485通讯反射电阻？ 返回

答：RS485网络连接的设备数量与设备采用的通讯协议有关，通讯协议会做出限制。此外物理上一个RS485网络的每个网段最多只能连接32个设备，网段间要增加中继器。整个网络最多可连接255个设备。原则上网络的两端都需要跨接终端电阻（约为120欧姆），在十几米的距离内可省。

问题9：板卡设备中标签中的位号代表什么含义？ 返回

答：对于版本号5.0以下的板卡类驱动程序，标签中不支持位号，标签建立规则为AD1：2、DA1：0、DO1：1、DI1：3等；对于版本号5.0以上的板卡类驱动程序，对于AD和FREQ标签中提供了位号支持，其中AD标签中的位号代表特定通道的AD滤波次数，如AD1：2.10表示1号板卡第2通道的模拟量数据采集时的滤波次数是10；FREQ标签中的位号代表特定通道的采集频率信号时的采集时间，单位为10mS，如FREQ1：0.20，则表示通过计算20×10mS中的记数差值来得到频率值。

问题10：板卡设备中是如何实现频率采集的？ 返回

答：板卡设备中的频率标签的采集是通过TC功能（即定时/记数）芯片8253/8254来实现的。其原来为：频率信号的大小可以通过特定时间间隔内的记数值的变化得到，一般的，假如信号频率为500Hz，那么在1秒中这个信号会使TC记数500次，所以可以通过测量特定时间间隔内的记数值的变化来计算出频率信号的大小。如在0.2S中记数变化200次，则可以计算出频率信号大小为1000Hz。需要注意的是，时间间隔的设定和频率信号的范围是有关系的，一般的可以设定为6000000/FRE；如频率信号在5000左右，则时间间隔为12S左右，在开物中标签中的位号可以设定时间间隔，单位为10mS，范围在1-100之间，在设定时不要超过这个范围，否则标签会出现错误。