艾讯Ax系列板卡

艾讯Ax系列板卡综述

概述 板卡参数设置 在线升级驱动

概述

艾讯Ax系列板卡是台湾艾讯公司出品的PC-AT总线数据系列采集板卡。提供12位或16位的A/D、D/A、DI、DO、 温度测量、计数器/定时器功能。

开物2000支持的Ax系列板卡有：

AX5008 | 8 通道电磁激励隔离DI板
AX5032A | 16 通道电磁激励光电隔离DI板
AX5032IO | 32 通道光电隔离DI/DO板
AX5064I | 64 通道DI光电隔离板
AX5064O | 64 通道光电隔离DO板
AX5210H | 16 通道AD板
AX5210H+ | 16 通道AD & 2通道DA板
AX5213 | 2 通道隔离DA板
AX5214H | 48 位 DI/O 板
AX5215H | 96 位 DI/O 板
AX5220HA/B | 32 位 DI/O & 3 通道定时器/计数器板
AX5224H | 24 位 DI/O & 3 通道定时器/计数器板
AX5232 | 32 通道隔离温度/电压测量板
AX5244H | 144
AX5411H | 多功能板
AX5412H | 高速多功能板
AX5621H+ | 16位 多功能板

板卡参数设置

1、板卡硬件地址设置方法：（SW1）

板基地址选择范围200H ~ 3FFH。当开关置ON位时，该位无效；开关置OFF位时，该位有效。
板基地址计算公式如下:板基地址 = 所有有效位之和
例：如上图所示:板基地址 = 200H + 100H = 300H

2、在Windows 9X下安装as59020\v4_3提供的Driver for Windows 9x。在Windows NT/2000下安装as59040\v4_3提供的Driver for Windows NT。

3、执行完上面的安装后，运行devmgr32.exe，并根据应用需要，在devmgr32.exe添加板卡和配置板卡的使用参数。此信息写入到配置文件中(诸如 axdrv.ini)。

4、用户使用开物2000的配置向导，输入艾讯板卡配置文件名。

5、在板卡配置图中点击选中某块板卡，转到其他参数页，配置板卡的特殊功能参数（例如：测温板的热电偶类型和温度测量单位）

注：一台计算机上最多可使用29块艾讯板卡。


艾讯Ax5232卡

概述 参数设置 数据类型 在线升级驱动

Ax5232概述

Ax5232是32通道隔离型温度/电压测量板。具有32路温度/电压测量功能，12位转换率。温度测量支持J, K, S, T, E, R, B, N型热电偶。电压输入范围-5伏至+5伏。放大增益可选：1, 100, 200, 250, 500, 831, 1000,或自定义。Ax5232同时提供8路数字量IO功能

Ax5232参数设置

1、板卡地址设置方法：（SW1）

板基地址选择范围200H ~ 3FFH。当开关置ON位时，该位无效；开关置OFF位时，该位有效。
板基地址计算公式如下:板基地址 = 所有有效位之和
例：如上图所示:板基地址 = 200H + 100H = 300H

2、在Windows 9X下安装as59020\v4_3提供的Driver for Windows 9x。在Windows NT/2000下安装as59040\v4_3提供的Driver for Windows NT。

3、执行完上面的安装后，运行devmgr32.exe，并根据应用需要，在devmgr32.exe添加板卡和配置板卡的使用参数。对于Ax5232卡可选择第8项。此信息写入到配置文件中(诸如 axdrv.ini)。

4、用户使用开物2000的配置向导，输入艾讯板卡配置文件名。

5、配置板卡的型号的热电偶类型和温度测量单位。

Ax5232标签类型

功能描述

标签地址

标签通道（chl）范围

标签值类型

 标签值范围

模拟量输入

ADst:chl

0至31

模拟量

 -5至+5
热电偶测量 | TEMPst:chl | 0至31 | 模拟量 | -100至+2000
数字量输入 | DIst:chl | 0至7 | 数字量 | true或false
数字量输出 | DOst:chl | 0至7 | 数字量 | true或false

其中：st为站号（即板卡号），范围0至28；

chl为通道号，范围见上表。

举例：

标签值类型： 模拟量
标签值：Temp1：10
说明：表示板卡号为1，通道号为10(第11路)的模拟量输入，。