科日新PCI板卡

板卡概述 硬件 设置 标签的地址规则 标签举例 在线升级驱动

科日新K系列板卡概述

科日新控电子技术有限公司是一个由测控领域高尖技术人员组成的工控产品专业公司，属于北京市高新技术企业。公司集新产品开发、生产、工程实施、销售于一体，软硬件兼备。公司业务涉及测控行业的各个领域。

开物2000系统支持以下类型的科日新PCI板卡：

项目符号

KPCI847 ：8路TTL数字量输入 ；8路继电器数字量输出，LED继电器状态指示灯；

关于科日新K系列板卡的更详细信息请访问 科日新公司网站。

开物2000还支持其它多种设备，详情请与 华富惠通公司联系。

科日新K系列板卡的硬件设置

科日新K系列板卡采用PCI总线形式，占用计算机的PCI插槽。在您使用科日新PCI板卡时，请确认已经安装科日新公司提供的板卡驱动程序，安装完成后会在计算机的设备管理器中查看到板卡信息，详细设置情况清参阅板卡说明书。

标签地址配置规则

标签地址可以按照下面的规则配置填写：

标签类型[ID:]Ch

说明：

项目符号

ID指板卡号，用于识别 同一设备中的不同子板卡， 板卡号设定范围为0 ～ 31，十进制表示。

项目符号

Ch指通道号，范围根据板卡类型不同，十进制表示。

项目符号 | 红色字表示格式中 的可变部分，变化范围参见各种板卡的帮助文件。
项目符号 | 蓝色括号不出现在标签地址中，蓝色括号内的内容在“单个板卡创建”时可省略。
项目符号 | 标签地址配置成不存在类型或板卡地址错误或通道号超出有效范围时，标签将不被承认， 不能读/写数据。

标签地址

含义

数据类型

读写类型

标签值范围

AD ID:Ch

模拟量输入

模拟量

只读

取决于板卡类型，请参阅相关帮助文件。

DA ID:Ch

模拟量输出

模拟量

只写

DI ID:Ch

数字量输入

开关量

只读

DO ID:Ch

数字量输出

开关量

只写

Count ID:Ch

计数器

模拟量

只读

INI_Count ID:Ch

计数器初值 模拟量 只写

标签举例：(以多个板卡创建为例，标签中包括板卡号 ，若选择单个板卡创建则不用配置板卡号，只须配置通道号，如AD0。)

标签 ：AD0:0
数据值类型：模拟量
描述 ：表示0号板卡的第0通道模拟量输入值

标签 ：DA0:0
数据值类型：模拟量
描述 ：表示0号板卡的第0通道模拟量输出值

标签 ：DI0:0
数据值类型：开关量
描述 ：表示0号板卡的第0通道开关输入值

标签 ：DO0:0
数据值类型：开关量
描述 ：表示0号板卡的第0通道开关输出值

标签 ：Count0:0
数据值类型：模拟量
描述 ：表示0号板卡的第0个记数器通道当前值

标签 ：INI_Count0:0
数据值类型：模拟量
描述 ：表示0号板卡的第0个记数器通道初值


K847

科日新控K847

硬件功能与特性 标签地址及范围 标签举例 在线升级驱动

K847 的功能与特性

项目符号 | 8路TTL数字量输入
项目符号 | 8路继电器数字量输出，LED继电器状态指示灯

K847支持的标签地址及范围

各种标签的详细解释请参见科日新PCI板卡：

说明：

项目符号

ID指板卡号，用于识别设备中的不同板卡， 板卡号设定范围为0 ～ 31，十进制表示。

项目符号

Ch指通道号，范围根据板卡类型不同，十进制表示。

项目符号 | 红色字表示格式中可变部分，变化范围参见各种 板卡的帮助文件。
项目符号 | 蓝色括号不出现在标签地址中，蓝色括号内的内容在设备中只包含一块板卡时可省略。
项目符号 | 标签地址配置成不存在类型或板卡地址错误或通道号超出有效范围时，标签将不被承认， 不能读/写数据。

标签地址

含义

数据类型

读写类型

标签值范围

DI ID:Ch

数字量输入

开关量

只读

0～7

DO ID:Ch

数字量输出

开关量

只写

0～7

标签举例：(以多个板卡创建为例，标签中包括板卡号 ，若选择单个板卡创建则不用配置板卡号，只须配置通道号，如AD0。)

标签 ：DI0:0
数据值类型：开关量
描述 ：表示0号板卡的第0通道开关输入值

标签 ：DO0:0
数据值类型：开关量
描述 ：表示0号板卡的第0通道开关输出值