科日新K系列板卡综述

板卡概述 硬件 设置 创建设备 创建标签 标签的地址规则 标签举例 在线升级驱动

科日新K系列板卡概述

科日新控电子技术有限公司是一个由测控领域高尖技术人员组成的工控产品专业公司，属于北京市高新技术企业。公司集新产品开发、生产、工程实施、销售于一体，软硬件兼备。公司业务涉及测控行业的各个领域。

开物2000系统支持以下类型的科日新K系列板卡：

项目符号

K810 ：32路单端/16路双端差动12位模拟量输入

项目符号

K810A ：32路单端/16路双端差动12位模拟量输入

项目符号

K811 ：16路单端12位模拟量输入；2路12位模拟量输出；24路TTL数字量输出/输入；3路供用户使用的16位定时/计数器

项目符号

K811A ：16路单端12位模拟量输入；2路12位模拟量输出；24路TTL数字量输出/输入；3路供用户使用的16位定时/计数器

项目符号

K816 ：32路单端/16路双端12位模拟量输入 ；8路TTL数字量输入；16路继电器数字量输出；3路16位定时/计数器

项目符号

K821 ：6路8位模拟量输出

项目符号

K824 ：8路12位模拟量输出

项目符号

K830 ：8路16位定时/计数器

项目符号

K831 ：8路TTL数字量输入 ；8路TTL数字量输出；15路16位定时/计数器

项目符号

K833 ：8路16位定时/计数器

项目符号

K840 ：16路TTL数字量输入 ；16路继电器数字量输出，LED继电器状态指示灯

项目符号

K841 ：48路TTL数字量输出/输入；6路16位定时/计数器

项目符号

K842 ：32路TTL数字量输入

项目符号

K843 ：32路继电器数字量输出

项目符号

K846 ：64路继电器数字量输出

项目符号

K847 ：8路TTL数字量输入 ；8路继电器数字量输出，LED继电器状态指示灯

项目符号

K848 ：24路TTL数字量输出/输入 ；40路继电器数字量输出

项目符号

K849 ：64路TTL数字量输入

关于科日新K系列板卡的更详细信息请访问 科日新公司网站。

开物2000还支持其它多种设备，详情请与 华富惠通公司联系。

科日新K系列板卡的硬件设置

科日新K系列板卡采用ISA总线形式，占用计算机的ISA插槽。在您使用科日新K系列板卡时，请确认已经准确设定了一些板卡基本信息，主要包括板卡基地址、 量程选择、DA参考电压选择、时钟选择、触发方式选择、中断选择，电压方式选择等。其中型号不同，板卡的硬件设置可能会不同，详细设置情况清参阅板卡说明书。

在开物2000开发环境中创建设备

在开发环境的“硬件系统”中按照“新节点和设备向导”的指示配置所连接的 板卡。以便于开物2000识别和使用。

步骤1：选择”板卡“设备类型。双击“科日新IO板卡”，或单击选中“科日新IO板卡”，这里可以查看“驱动版本号”，更改设备名称， 如“Kxrix” ，然后单击“选择”按钮。

步骤2：在”科日新IO板卡向导“中选择执行的操作方式——“新建设备”。选中“新建设备”后单击”下一步”按钮(或双击“新建设备”)，您也可以选择“修改设备”，对板卡的配置进行修改或者选择“察看设备”浏览已经设置好的板卡配置情况。

其中下面的按钮的含义分别为：

下载最新驱动：可以帮助您进入开物技术支持网站的下载专区中；

帮助信息：可以查看驱动的版本等信息；

调试设置：通常情况下“调试开关”打开，这时可以记录开物的基本信息，主要包括启动和退出的时间，标签情况，通讯情况等信息；如果把“输出错误信息”和“输出跟踪信息”也选中的话，这时将记录开物运行过程中的全部通讯信息，对于记录通讯过程中的错误信息很有帮助，如果您在使用开物过程中，硬件连接有问题时，请打开所有调试开关，将通讯信息记录下来，待整个通讯工程正常后，请您把“输出错误信息”和“输出跟踪信息”关闭。

注意：整个信息将存成LOG文件，在相应工程目录下面的“DEBUG”子目录下，文件名以驱动DLL文件加上日期的方式命名，如kxric2003-7-10.log。

步骤3：在"科日新IO板卡向导"中选择创建设备的方式——包括“单个板卡创建”和“多个板卡创建”。其中：

单个板卡创建：指在一个设备中创建一块板卡；

多个板卡创建：指在一个设备中创建多个同型号子板卡，当然您也可以建立多个设备从而实现多块板卡的连接。

步骤4：在”科日新IO板卡 向导“中选择板卡安装，主要包括板卡号、板卡类型、基地址、AD输入方式、AD最大范围(或AD输入极性)、AD滤波次数、量程选择等选项。 其中：

板卡号：如果为多个板卡创建，则须填写板卡号，以便于开物2000对板卡设备的识别；如果为单个板卡创建则没有这个选项。

板卡类型：指用户使用的板卡型号，通过下拉菜单选择；

基址(16进制)：指16进制板卡基地址；

AD输入方式：指AD信号是单端还是差动；

AD最大范围(或AD输入极性)：选择AD信号的输入极性为单极性还是双极性(或者AD的输入极性为单极性或双极性)；

AD滤波次数：为滤除干扰而设计，算法为：若设定为10，则将采集到的10个数据按照大小顺序排列，取中间1/3数据的平均值，这个过程在驱动中完成，您可以根据板卡使用情况调节AD滤波次数。

标签的创建

使用“科日新IO板卡向导”完成板卡设备的创建后，可以进行标签设计。

1、在开发环境的“标签”击鼠标右键，选择“添加标签“，显示见下图，选择主设备为上面的‘Kxric，选择并填写‘主设备地址’，修改标签名。

开物的板卡驱动程序可以实现以下功能：模拟量输入、模拟量输出、数字量输入、数字量输出、定时/记数等功能。各部分功能在开物中对应的标签为：

AD：模拟量输入功能；

DA：模拟量输出功能；

DI：数字量输入功能；

DO：数字量输出功能；

INI_Count：为定时/记数器设定的初始值；

Count：为定时/记数器的当前值。

在板卡类设备中，标签的配置规则为：若为单个板卡创建，格式为： 标签+通道号，如AD0、DA3、DI5、DO6、Count2、INI_Count2等；若为多个设备创建，则格式为： 标签+板卡号+“:”+通道号，如AD0:0、DA0:3、DI1:5、DO0:6、Count0:2、INI_Count0:2；

2、根据您的特定使用需求，修改测量值和工程值的最大值、最小值、扫描周期等属性。单击‘添加’或‘完成’按钮。其中：

测量值最大值：设定为板卡当前量程的上限值；

测量值最小值：设定为板卡当前量程的下限值；

工程值最大值：设定为实际物理参数的上限值；

工程值最小值：设定为实际物理参数的下限值；

如：板卡的量程选择为：0 ～ 10V，对应现场的力信号为0 ～ 1000N，则测量值最大值设为 10；最小值设为 0；工程值最大值设为 1000；最小值设为 0。

请注意：假如只测量外界的电压信号则不需要更改测量值和工程值的最大值、 最小值，保持默认值就可以。

标签地址配置规则

标签地址可以按照下面的规则配置填写：

标签类型[ID:]Ch

说明：

项目符号

ID指板卡号，用于识别 同一设备中的不同子板卡， 板卡号设定范围为0 ～ 31，十进制表示。

项目符号

Ch指通道号，范围根据板卡类型不同，十进制表示。

项目符号 | 红色字表示格式中 的可变部分，变化范围参见各种板卡的帮助文件。
项目符号 | 蓝色括号不出现在标签地址中，蓝色括号内的内容在“单个板卡创建”时可省略。
项目符号 | 标签地址配置成不存在类型或板卡地址错误或通道号超出有效范围时，标签将不被承认， 不能读/写数据。

标签地址

含义

数据类型

读写类型

标签值范围

AD ID:Ch

模拟量输入

模拟量

只读

取决于板卡类型，请参阅相关帮助文件。

DA ID:Ch

模拟量输出

模拟量

只写

DI ID:Ch

数字量输入

开关量

只读

DO ID:Ch

数字量输出

开关量

只写

Count ID:Ch

计数器

模拟量

只读

INI_Count ID:Ch

计数器初值 模拟量 只写

标签举例：(以多个板卡创建为例，标签中包括板卡号 ，若选择单个板卡创建则不用配置板卡号，只须配置通道号，如AD0。)

标签 ：AD0:0
数据值类型：模拟量
描述 ：表示0号板卡的第0通道模拟量输入值

标签 ：DA0:0
数据值类型：模拟量
描述 ：表示0号板卡的第0通道模拟量输出值

标签 ：DI0:0
数据值类型：开关量
描述 ：表示0号板卡的第0通道开关输入值

标签 ：DO0:0
数据值类型：开关量
描述 ：表示0号板卡的第0通道开关输出值

标签 ：Count0:0
数据值类型：模拟量
描述 ：表示0号板卡的第0个记数器通道当前值

标签 ：INI_Count0:0
数据值类型：模拟量
描述 ：表示0号板卡的第0个记数器通道初值


K810

科日新控K810

硬件功能与特性 地址设置 标签地址及范围 标签举例 在线升级驱动

K810 的功能与特性

项目符号 | 32路单端/16路双端差动12位模拟量输入
项目符号 | 输入电压范围可选：0-5V；±5V；0-10V；±10V；mV级信号
项目符号 | AD启动方式：程序启动

 K810的地址设置

在您使 用K810板卡时，请确认已经为板卡设定了唯一的地址，具体设置为：

基地址选择范围为100H~3FFH。K810板卡占用2个连续IO地址。当开关置ON位时，该位无效；开关置OFF位时，该位有效。
基地址计算公式如下：基地址 = 所有有效位之和。
例：如上图所示：基地址 = 200H + 100H = 300H

K810支持的标签地址及范围

各种标签的详细解释请参见科日新控K系列板卡综述：

说明：

项目符号

ID指板卡号，用于识别设备中的不同板卡， 板卡号设定范围为0 ～ 31，十进制表示。

项目符号

Ch指通道号，范围根据板卡类型不同，十进制表示。

项目符号 | 红色字表示格式中可变部分，变化范围参见各种 板卡的帮助文件。
项目符号 | 蓝色括号不出现在标签地址中，蓝色括号内的内容在设备中只包含一块板卡时可省略。
项目符号 | 标签地址配置成不存在类型或板卡地址错误或通道号超出有效范围时，标签将不被承认， 不能读/写数据。

标签地址

含义

数据类型

读写类型

标签值范围

AD ID:Ch

输入电压值

模拟量

只读

单端：0～31； 双端：0～15

标签举例：(以多个板卡创建为例，标签中包括板卡号 ，若选择单个板卡创建则不用配置板卡号，只须配置通道号，如AD0。)

标签 ：AD0:0
数据值类型：模拟量
描述 ：表示0号板卡的第0通道模拟量输入值


K810A

科日新控K810A

K810A 的功能与特性

项目符号 | 32路单端/16路双端差动12位模拟量输入
项目符号 | 输入电压范围可选：0-5V；±5V；0-10V；±10V；mV级信号
项目符号 | AD启动方式：程序启动

 K810A的地址设置

在您使 用K810A板卡时，请确认已经为板卡设定了唯一的地址，具体设置为：

基地址选择范围为100H~3FFH。K810A板卡占用2个连续IO地址。当开关置ON位时，该位无效；开关置OFF位时，该位有效。
基地址计算公式如下：基地址 = 所有有效位之和。
例：如上图所示：基地址 = 200H + 100H = 300H

K810A支持的标签地址及范围

各种标签的详细解释请参见科日新控K系列板卡综述：

说明：

项目符号

ID指板卡号，用于识别设备中的不同板卡， 板卡号设定范围为0 ～ 31，十进制表示。

项目符号

Ch指通道号，范围根据板卡类型不同，十进制表示。

项目符号 | 红色字表示格式中可变部分，变化范围参见各种 板卡的帮助文件。
项目符号 | 蓝色括号不出现在标签地址中，蓝色括号内的内容在设备中只包含一块板卡时可省略。
项目符号 | 标签地址配置成不存在类型或板卡地址错误或通道号超出有效范围时，标签将不被承认， 不能读/写数据。

标签地址

含义

数据类型

读写类型

标签值范围

AD ID:Ch

输入电压值

模拟量

只读

单端：0～31； 双端：0～15

标签举例：(以多个板卡创建为例，标签中包括板卡号 ，若选择单个板卡创建则不用配置板卡号，只须配置通道号，如AD0。)

标签 ：AD0:0
数据值类型：模拟量
描述 ：表示0号板卡的第0通道模拟量输入值


K811

科日新控K811

K811 的功能与特性

项目符号 | 16路单端12位模拟量输入
项目符号 | 软件调节输入电压范围，可选范围：0-5V；±5V；0-10V
项目符号 | AD启动方式：程序启动和定时启动
项目符号 | 2路12位模拟量输出，可同时或分别输出
项目符号 | 输出信号范围：0~5V；0~10V；±5V；0~10mA；4~20mA
项目符号 | 24路TTL数字量输出/输入，输入/输出可以通过8255编程选择
项目符号 | 3路供用户使用的16位定时/计数器
项目符号 | 当采用定时启动AD方式时，只为用户提供1路或2路16位定时/计数器

 K811的地址设置

在您使 用K811板卡时，请确认已经为板卡设定了唯一的地址，具体设置为：

基地址选择范围为100H~1FFH，210H~2FFH及300H~36FH。K811板卡占用16个连续IO地址。当开关置ON位时，该位无效；开关置OFF位时，该位有效。 基地址计算公式如下：基地址 = 所有有效位之和。
例：如上图所示：基地址 = 200H + 100H = 300H

K811支持的标签地址及范围

各种标签的详细解释请参见科日新控K系列板卡综述：

说明：

项目符号

ID指板卡号，用于识别设备中的不同板卡， 板卡号设定范围为0 ～ 31，十进制表示。

项目符号

Ch指通道号，范围根据板卡类型不同，十进制表示。

项目符号 | 红色字表示格式中可变部分，变化范围参见各种 板卡的帮助文件。
项目符号 | 蓝色括号不出现在标签地址中，蓝色括号内的内容在设备中只包含一块板卡时可省略。
项目符号 | 标签地址配置成不存在类型或板卡地址错误或通道号超出有效范围时，标签将不被承认， 不能读/写数据。

标签地址

含义

数据类型

读写类型

标签值范围

AD ID:Ch

输入电压值

模拟量

只读

0～15

DA ID:Ch

输出电压值

模拟量

只写

0～1

DI ID:Ch

数字量输入

开关量

只读

根据设定最大0～23

DO ID:Ch

数字量输出

开关量

只写

根据设定最大0～23
Count ID:Ch

计数器

模拟量

只读

0～2
INI_Count ID:Ch

计数器初值

模拟量

只写 0～2

标签举例：(以多个板卡创建为例，标签中包括板卡号 ，若选择单个板卡创建则不用配置板卡号，只须配置通道号，如AD0。)

标签 ：AD0:0
数据值类型：模拟量
描述 ：表示0号板卡的第0通道模拟量输入值

标签 ：DA0:0
数据值类型：模拟量
描述 ：表示0号板卡的第0通道模拟量输出值

标签 ：DI0:0
数据值类型：开关量
描述 ：表示0号板卡的第0通道开关输入值

标签 ：DO0:0
数据值类型：开关量
描述 ：表示0号板卡的第0通道开关输出值

标签 ：Count0:0
数据值类型：模拟量
描述 ：表示0号板卡的第0个记数器通道当前值

标签 ：INI_Count0:0
数据值类型：模拟量
描述 ：表示0号板卡的第0个记数器通道初值


K811A

科日新控K811A

K811A 的功能与特性

项目符号 | 16路单端12位模拟量输入
项目符号 | 软件调节输入电压范围，可选范围：0-5V；±5V；0-10V
项目符号 | AD启动方式：程序启动和定时启动
项目符号 | 2路12位模拟量输出，可同时或分别输出
项目符号 | 输出信号范围：0~5V；0~10V；±5V；0~10mA；4~20mA
项目符号 | 24路TTL数字量输出/输入，输入/输出可以通过8255编程选择
项目符号 | 3路供用户使用的16位定时/计数器
项目符号 | 当采用定时启动AD方式时，只为用户提供1路或2路16位定时/计数器

 K811A的地址设置

在您使 用K811A板卡时，请确认已经为板卡设定了唯一的地址，具体设置为：

基地址选择范围为100H~1FFH，210H~2FFH及300H~36FH。K811A板卡占用16个连续IO地址。当开关置ON位时，该位无效；开关置OFF位时，该位有效。 基地址计算公式如下：基地址 = 所有有效位之和。
例：如上图所示：基地址 = 200H + 100H = 300H

K811A支持的标签地址及范围

各种标签的详细解释请参见科日新控K系列板卡综述：

说明：

项目符号

ID指板卡号，用于识别设备中的不同板卡， 板卡号设定范围为0 ～ 31，十进制表示。

项目符号

Ch指通道号，范围根据板卡类型不同，十进制表示。

项目符号 | 红色字表示格式中可变部分，变化范围参见各种 板卡的帮助文件。
项目符号 | 蓝色括号不出现在标签地址中，蓝色括号内的内容在设备中只包含一块板卡时可省略。
项目符号 | 标签地址配置成不存在类型或板卡地址错误或通道号超出有效范围时，标签将不被承认， 不能读/写数据。

标签地址

含义

数据类型

读写类型

标签值范围

AD ID:Ch

输入电压值

模拟量

只读

0～15

DA ID:Ch

输出电压值

模拟量

只写

0～1

DI ID:Ch

数字量输入

开关量

只读

根据设定最大0～23

DO ID:Ch

数字量输出

开关量

只写

根据设定最大0～23
Count ID:Ch

计数器

模拟量

只读

0～2
INI_Count ID:Ch

计数器初值

模拟量

只写 0～2

标签举例：(以多个板卡创建为例，标签中包括板卡号 ，若选择单个板卡创建则不用配置板卡号，只须配置通道号，如AD0。)

标签 ：AD0:0
数据值类型：模拟量
描述 ：表示0号板卡的第0通道模拟量输入值

标签 ：DA0:0
数据值类型：模拟量
描述 ：表示0号板卡的第0通道模拟量输出值

标签 ：DI0:0
数据值类型：开关量
描述 ：表示0号板卡的第0通道开关输入值

标签 ：DO0:0
数据值类型：开关量
描述 ：表示0号板卡的第0通道开关输出值

标签 ：Count0:0
数据值类型：模拟量
描述 ：表示0号板卡的第0个记数器通道当前值

标签 ：INI_Count0:0
数据值类型：模拟量
描述 ：表示0号板卡的第0个记数器通道初值


K816

科日新控K816

K816 的功能与特性

项目符号 | 32路单端/16路双端12位模拟量输入
项目符号 | 输入电压范围可选：0-5V；0-10V；±5V；±10V；mV级信号
项目符号 | AD启动方式：程序启动
项目符号 | 8路TTL数字量输入
项目符号 | 16路继电器数字量输出
项目符号 | 3路供用户使用的16位定时/计数器

 K816的地址设置

在您使 用K816板卡时，请确认已经为板卡设定了唯一的地址，具体设置为：

基地址选择范围为100H~3FFH。K816板卡占用8个连续IO地址。当开关置ON位时，该位无效；开关置OFF位时，该位有效。
基地址计算公式如下：基地址 = 所有有效位之和。
例：如上图所示：基地址 = 200H + 100H = 300H

K816支持的标签地址及范围

各种标签的详细解释请参见科日新控K系列板卡综述：

说明：

项目符号

ID指板卡号，用于识别设备中的不同板卡， 板卡号设定范围为0 ～ 31，十进制表示。

项目符号

Ch指通道号，范围根据板卡类型不同，十进制表示。

项目符号 | 红色字表示格式中可变部分，变化范围参见各种 板卡的帮助文件。
项目符号 | 蓝色括号不出现在标签地址中，蓝色括号内的内容在设备中只包含一块板卡时可省略。
项目符号 | 标签地址配置成不存在类型或板卡地址错误或通道号超出有效范围时，标签将不被承认， 不能读/写数据。

标签地址

含义

数据类型

读写类型

标签值范围

AD ID:Ch

输入电压值

模拟量

只读

单端：0～31；双端：0～15

DI ID:Ch

数字量输入

开关量

只读

0～7

DO ID:Ch

数字量输出

开关量

只写

0～15
Count ID:Ch

计数器

模拟量

只读

0～2
INI_Count ID:Ch

计数器初值

模拟量

只写 0～2

标签举例：(以多个板卡创建为例，标签中包括板卡号 ，若选择单个板卡创建则不用配置板卡号，只须配置通道号，如AD0。)

标签 ：AD0:0
数据值类型：模拟量
描述 ：表示0号板卡的第0通道模拟量输入值

标签 ：DI0:0
数据值类型：开关量
描述 ：表示0号板卡的第0通道开关输入值

标签 ：DO0:0
数据值类型：开关量
描述 ：表示0号板卡的第0通道开关输出值

标签 ：Count0:0
数据值类型：模拟量
描述 ：表示0号板卡的第0个记数器通道当前值

标签 ：INI_Count0:0
数据值类型：模拟量
描述 ：表示0号板卡的第0个记数器通道初值


K821

科日新控K821

K821 的功能与特性

项目符号 | 6路8位模拟量输出（互相独立，可同时或分别输出）
项目符号 | 输出信号范围：0~5V；1~5V；0~10V；±2.5V；±5V；±10V；0~10mA；4~20mA

 K821的地址设置

在您使 用K821板卡时，请确认已经为板卡设定了唯一的地址，具体设置为：

基地址选择范围为100H~1FFH，210H~2FFH及300H~36FH。K821板卡占用6个连续IO地址。当开关置ON位时，该位无效；开关置OFF位时，该位有效。 基地址计算公式如下：基地址 = 所有有效位之和。
例：如上图所示：基地址 = 200H + 100H = 300H

K821支持的标签地址及范围

各种标签的详细解释请参见科日新控K系列板卡综述：

说明：

项目符号

ID指板卡号，用于识别设备中的不同板卡， 板卡号设定范围为0 ～ 31，十进制表示。

项目符号

Ch指通道号，范围根据板卡类型不同，十进制表示。

项目符号 | 红色字表示格式中可变部分，变化范围参见各种 板卡的帮助文件。
项目符号 | 蓝色括号不出现在标签地址中，蓝色括号内的内容在设备中只包含一块板卡时可省略。
项目符号 | 标签地址配置成不存在类型或板卡地址错误或通道号超出有效范围时，标签将不被承认， 不能读/写数据。

标签地址

含义

数据类型

读写类型

标签值范围

DA ID:Ch

输出电压值

模拟量

只写

0～5

标签举例：(以多个板卡创建为例，标签中包括板卡号 ，若选择单个板卡创建则不用配置板卡号，只须配置通道号，如AD0。)

标签 ：DA0:0
数据值类型：模拟量
描述 ：表示0号板卡的第0通道模拟量输出值


K824

科日新控K824

K824 的功能与特性

项目符号 | 8路12位模拟量输出（前4路与后4路可同时或分别输出）
项目符号 | 输出信号范围：0~5V；0~10V；±5V；±10V；4~20mA

 K824的地址设置

在您使 用K824板卡时，请确认已经为板卡设定了唯一的地址，具体设置为：

基地址选择范围为100H~1FFH，210H~2FFH及300H~36FH。K824板卡占用8个连续IO地址。当开关置ON位时，该位无效；开关置OFF位时，该位有效。 基地址计算公式如下：基地址 = 所有有效位之和。
例：如上图所示：基地址 = 200H + 100H = 300H 。

K824支持的标签地址及范围

各种标签的详细解释请参见科日新控K系列板卡综述：

说明：

项目符号

ID指板卡号，用于识别设备中的不同板卡， 板卡号设定范围为0 ～ 31，十进制表示。

项目符号

Ch指通道号，范围根据板卡类型不同，十进制表示。

项目符号 | 红色字表示格式中可变部分，变化范围参见各种 板卡的帮助文件。
项目符号 | 蓝色括号不出现在标签地址中，蓝色括号内的内容在设备中只包含一块板卡时可省略。
项目符号 | 标签地址配置成不存在类型或板卡地址错误或通道号超出有效范围时，标签将不被承认， 不能读/写数据。

标签地址

含义

数据类型

读写类型

标签值范围

DA ID:Ch

输出电压值

模拟量

只写

0～7

标签举例：(以多个板卡创建为例，标签中包括板卡号 ，若选择单个板卡创建则不用配置板卡号，只须配置通道号，如AD0。)

标签 ：DA0:0
数据值类型：模拟量
描述 ：表示0号板卡的第0通道模拟量输出值


K830

科日新控K830

K830 的功能与特性

项目符号 | 8路供用户使用的16位定时/计数器（3片8253）
项目符号 | 第9通道连接内部2M晶振，用于分频

 K830的地址设置

在您使 用K830板卡时，请确认已经为板卡设定了唯一的地址，具体设置为：

基地址选择范围为100H~3FFH。K830板卡占用16个连续IO地址。当开关置ON位时，该位无效；开关置OFF位时，该位有效。
基地址计算公式如下：基地址 = 所有有效位之和。
例：如上图所示：基地址 = 200H + 100H = 300H 。

K830支持的标签地址及范围

各种标签的详细解释请参见科日新控K系列板卡综述：

说明：

项目符号

ID指板卡号，用于识别设备中的不同板卡， 板卡号设定范围为0 ～ 31，十进制表示。

项目符号

Ch指通道号，范围根据板卡类型不同，十进制表示。

项目符号 | 红色字表示格式中可变部分，变化范围参见各种 板卡的帮助文件。
项目符号 | 蓝色括号不出现在标签地址中，蓝色括号内的内容在设备中只包含一块板卡时可省略。
项目符号 | 标签地址配置成不存在类型或板卡地址错误或通道号超出有效范围时，标签将不被承认， 不能读/写数据。

标签地址

含义

数据类型

读写类型

标签值范围

Count ID:Ch

计数器

模拟量

只读

0～7
INI_Count ID:Ch

计数器初值

模拟量

只写 0～7

标签举例：(以多个板卡创建为例，标签中包括板卡号 ，若选择单个板卡创建则不用配置板卡号，只须配置通道号，如AD0。)

标签 ：Count0:0
数据值类型：模拟量
描述 ：表示0号板卡的第0个记数器通道当前值

标签 ：INI_Count0:0
数据值类型：模拟量
描述 ：表示0号板卡的第0个记数器通道初值


K831

科日新控K831

K831 的功能与特性

项目符号 | 8路TTL数字量输入
项目符号 | 8路TTL数字量输出
项目符号 | 15路16位定时/计数器（5片8253）

 K831的地址设置

在您使 用K831板卡时，请确认已经为板卡设定了唯一的地址，具体设置为：

基地址选择范围为200H~3FFH。K831板卡占用28个连续IO地址。当开关置ON位时，该位无效；开关置OFF位时，该位有效。
基地址计算公式如下：基地址 = 200H + 所有有效位之和。
例：如上图所示：基地址 = 200H + 100H = 300H 。

K831支持的标签地址及范围

各种标签的详细解释请参见科日新控K系列板卡综述：

说明：

项目符号

ID指板卡号，用于识别设备中的不同板卡， 板卡号设定范围为0 ～ 31，十进制表示。

项目符号

Ch指通道号，范围根据板卡类型不同，十进制表示。

项目符号 | 红色字表示格式中可变部分，变化范围参见各种 板卡的帮助文件。
项目符号 | 蓝色括号不出现在标签地址中，蓝色括号内的内容在设备中只包含一块板卡时可省略。
项目符号 | 标签地址配置成不存在类型或板卡地址错误或通道号超出有效范围时，标签将不被承认， 不能读/写数据。

标签地址

含义

数据类型

读写类型

标签值范围

DI ID:Ch

数字量输入

开关量

只读

0～7

DO ID:Ch

数字量输出

开关量

只写

0～7
Count ID:Ch

计数器

模拟量

只读

0～14
INI_Count ID:Ch

计数器初值

模拟量

只写 0～14

标签举例：(以多个板卡创建为例，标签中包括板卡号 ，若选择单个板卡创建则不用配置板卡号，只须配置通道号，如AD0。)

标签 ：DI0:0
数据值类型：开关量
描述 ：表示0号板卡的第0通道开关输入值

标签 ：DO0:0
数据值类型：开关量
描述 ：表示0号板卡的第0通道开关输出值

标签 ：Count0:0
数据值类型：模拟量
描述 ：表示0号板卡的第0个记数器通道当前值

标签 ：INI_Count0:0
数据值类型：模拟量
描述 ：表示0号板卡的第0个记数器通道初值


K833

科日新控K833

K833 的功能与特性

项目符号 | 8路供用户使用的16位定时/计数器（3片8253）
项目符号 | 第9通道连接内部2M晶振，用于分频

 K833的地址设置

在您使 用K833板卡时，请确认已经为板卡设定了唯一的地址，具体设置为：

基地址选择范围为100H~3FFH。K833板卡占用16个连续IO地址。当开关置ON位时，该位无效；开关置OFF位时，该位有效。
基地址计算公式如下：基地址 = 所有有效位之和。
例：如上图所示：基地址 = 200H + 100H = 300H 。

K833支持的标签地址及范围

各种标签的详细解释请参见科日新控K系列板卡综述：

说明：

项目符号

ID指板卡号，用于识别设备中的不同板卡， 板卡号设定范围为0 ～ 31，十进制表示。

项目符号

Ch指通道号，范围根据板卡类型不同，十进制表示。

项目符号 | 红色字表示格式中可变部分，变化范围参见各种 板卡的帮助文件。
项目符号 | 蓝色括号不出现在标签地址中，蓝色括号内的内容在设备中只包含一块板卡时可省略。
项目符号 | 标签地址配置成不存在类型或板卡地址错误或通道号超出有效范围时，标签将不被承认， 不能读/写数据。

标签地址

含义

数据类型

读写类型

标签值范围

Count ID:Ch

计数器

模拟量

只读

0～7
INI_Count ID:Ch

计数器初值

模拟量

只写 0～7

标签举例：(以多个板卡创建为例，标签中包括板卡号 ，若选择单个板卡创建则不用配置板卡号，只须配置通道号，如AD0。)

标签 ：Count0:0
数据值类型：模拟量
描述 ：表示0号板卡的第0个记数器通道当前值

标签 ：INI_Count0:0
数据值类型：模拟量
描述 ：表示0号板卡的第0个记数器通道初值


K840

科日新控K840

K840 的功能与特性

项目符号 | 16路TTL数字量输入
项目符号 | 16路继电器数字量输出

 K840的地址设置

在您使 用K840板卡时，请确认已经为板卡设定了唯一的地址，具体设置为：

K840板卡占用3个连续IO地址。当开关置ON位时，该位无效；开关置OFF位时，该位有效。 基地址计算公式如下：基地址 = 所有有效位之和。
例：如上图所示：基地址 = 200H + 100H = 300H 。

K840支持的标签地址及范围

各种标签的详细解释请参见科日新控K系列板卡综述：

说明：

项目符号

ID指板卡号，用于识别设备中的不同板卡， 板卡号设定范围为0 ～ 31，十进制表示。

项目符号

Ch指通道号，范围根据板卡类型不同，十进制表示。

项目符号 | 红色字表示格式中可变部分，变化范围参见各种 板卡的帮助文件。
项目符号 | 蓝色括号不出现在标签地址中，蓝色括号内的内容在设备中只包含一块板卡时可省略。
项目符号 | 标签地址配置成不存在类型或板卡地址错误或通道号超出有效范围时，标签将不被承认， 不能读/写数据。

标签地址

含义

数据类型

读写类型

标签值范围

DI ID:Ch

数字量输入

开关量

只读

0～15

DO ID:Ch

数字量输出

开关量

只写

0～15

标签举例：(以多个板卡创建为例，标签中包括板卡号 ，若选择单个板卡创建则不用配置板卡号，只须配置通道号，如AD0。)

标签 ：DI0:0
数据值类型：开关量
描述 ：表示0号板卡的第0通道开关输入值

标签 ：DO0:0
数据值类型：开关量
描述 ：表示0号板卡的第0通道开关输出值


K841

科日新控K841

K841 的功能与特性

项目符号 | 48路TTL数字量输出/输入（2个8255），输入/输出可以通过8255编程选择
项目符号 | 6路16位定时/计数器（2个8253）

 K841的地址设置

在您使 用K841板卡时，请确认已经为板卡设定了唯一的地址，具体设置为：

基地址选择范围为100H~3FFH。K841板卡占用16个连续IO地址。当开关置ON位时，该位无效；开关置OFF位时，该位有效。
基地址计算公式如下：基地址 = 所有有效位之和。
例：如上图所示：基地址 = 200H + 100H = 300H

K841支持的标签地址及范围

各种标签的详细解释请参见科日新控K系列板卡综述：

说明：

项目符号

ID指板卡号，用于识别设备中的不同板卡， 板卡号设定范围为0 ～ 31，十进制表示。

项目符号

Ch指通道号，范围根据板卡类型不同，十进制表示。

项目符号 | 红色字表示格式中可变部分，变化范围参见各种 板卡的帮助文件。
项目符号 | 蓝色括号不出现在标签地址中，蓝色括号内的内容在设备中只包含一块板卡时可省略。
项目符号 | 标签地址配置成不存在类型或板卡地址错误或通道号超出有效范围时，标签将不被承认， 不能读/写数据。

标签地址

含义

数据类型

读写类型

标签值范围

DI ID:Ch

数字量输入

开关量

只读

根据设定最大0～47

DO ID:Ch

数字量输出

开关量

只写

根据设定最大0～47
Count ID:Ch

计数器

模拟量

只读

0～5
INI_Count ID:Ch

计数器初值

模拟量

只写 0～5

标签举例：(以多个板卡创建为例，标签中包括板卡号 ，若选择单个板卡创建则不用配置板卡号，只须配置通道号，如AD0。)

标签 ：DI0:0
数据值类型：开关量
描述 ：表示0号板卡的第0通道开关输入值

标签 ：DO0:0
数据值类型：开关量
描述 ：表示0号板卡的第0通道开关输出值

标签 ：Count0:0
数据值类型：模拟量
描述 ：表示0号板卡的第0个记数器通道当前值

标签 ：INI_Count0:0
数据值类型：模拟量
描述 ：表示0号板卡的第0个记数器通道初值


K842

科日新控K842

K842 的功能与特性

项目符号

32路TTL数字量输入

K842的地址设置

在您使 用K842板卡时，请确认已经为板卡设定了唯一的地址，具体设置为：

K842板卡占用4个连续IO地址。当开关置ON位时，该位无效；开关置OFF位时，该位有效。基地址计算公式如下：基地址 = 所有有效位之和。
例：如上图所示：基地址 = 200H + 100H = 300H 。

K842支持的标签地址及范围

各种标签的详细解释请参见科日新控K系列板卡综述：

说明：

项目符号

ID指板卡号，用于识别设备中的不同板卡， 板卡号设定范围为0 ～ 31，十进制表示。

项目符号

Ch指通道号，范围根据板卡类型不同，十进制表示。

项目符号 | 红色字表示格式中可变部分，变化范围参见各种 板卡的帮助文件。
项目符号 | 蓝色括号不出现在标签地址中，蓝色括号内的内容在设备中只包含一块板卡时可省略。
项目符号 | 标签地址配置成不存在类型或板卡地址错误或通道号超出有效范围时，标签将不被承认， 不能读/写数据。

标签地址

含义

数据类型

读写类型

标签值范围

DI ID:Ch

数字量输入

开关量

只读

0～31

标签举例：(以多个板卡创建为例，标签中包括板卡号 ，若选择单个板卡创建则不用配置板卡号，只须配置通道号，如AD0。)

标签 ：DI0:0
数据值类型：开关量
描述 ：表示0号板卡的第0通道开关输入值


K843

科日新控K843

K843 的功能与特性

项目符号

32路继电器数字量输出

K843的地址设置

在您使 用K843板卡时，请确认已经为板卡设定了唯一的地址，具体设置为：

K843板卡占用4个连续IO地址。当开关置ON位时，该位无效；开关置OFF位时，该位有效。 基地址计算公式如下：基地址 = 所有有效位之和。
例：如上图所示：基地址 = 200H + 100H = 300H

K843支持的标签地址及范围

各种标签的详细解释请参见科日新控K系列板卡综述：

说明：

项目符号

ID指板卡号，用于识别设备中的不同板卡， 板卡号设定范围为0 ～ 31，十进制表示。

项目符号

Ch指通道号，范围根据板卡类型不同，十进制表示。

项目符号 | 红色字表示格式中可变部分，变化范围参见各种 板卡的帮助文件。
项目符号 | 蓝色括号不出现在标签地址中，蓝色括号内的内容在设备中只包含一块板卡时可省略。
项目符号 | 标签地址配置成不存在类型或板卡地址错误或通道号超出有效范围时，标签将不被承认， 不能读/写数据。

标签地址

含义

数据类型

读写类型

标签值范围

DO ID:Ch

数字量输出

开关量

只写

0～31

标签举例：(以多个板卡创建为例，标签中包括板卡号 ，若选择单个板卡创建则不用配置板卡号，只须配置通道号，如AD0。)

标签 ：DO0:0
数据值类型：开关量
描述 ：表示0号板卡的第0通道开关输出值


K846

科日新控K846

K846 的功能与特性

项目符号

64路继电器数字量输出

K846的地址设置

在您使 用K846板卡时，请确认已经为板卡设定了唯一的地址，具体设置为：

K846板卡占用8个连续IO地址。当开关置ON位时，该位无效；开关置OFF位时，该位有效。 基地址计算公式如下：基地址 = 所有有效位之和。
例：如上图所示：基地址 = 200H + 100H = 300H

K846支持的标签地址及范围

各种标签的详细解释请参见科日新控K系列板卡综述：

说明：

项目符号

ID指板卡号，用于识别设备中的不同板卡， 板卡号设定范围为0 ～ 31，十进制表示。

项目符号

Ch指通道号，范围根据板卡类型不同，十进制表示。

项目符号 | 红色字表示格式中可变部分，变化范围参见各种 板卡的帮助文件。
项目符号 | 蓝色括号不出现在标签地址中，蓝色括号内的内容在设备中只包含一块板卡时可省略。
项目符号 | 标签地址配置成不存在类型或板卡地址错误或通道号超出有效范围时，标签将不被承认， 不能读/写数据。

标签地址

含义

数据类型

读写类型

标签值范围

DO ID:Ch

数字量输出

开关量

只写

0～63

标签举例：(以多个板卡创建为例，标签中包括板卡号 ，若选择单个板卡创建则不用配置板卡号，只须配置通道号，如AD0。)

标签 ：DO0:0
数据值类型：开关量
描述 ：表示0号板卡的第0通道开关输出值


K847

科日新控K847

K847 的功能与特性

项目符号 | 8路TTL数字量输入
项目符号 | 8路继电器数字量输出，LED继电器状态指示灯

 K847的地址设置

在您使 用K847板卡时，请确认已经为板卡设定了唯一的地址，具体设置为：

K847板卡占用3个连续IO地址。当开关置ON位时，该位无效；开关置OFF位时，该位有效。
基地址计算公式如下：基地址 = 200H + 所有有效位之和。
例：如上图所示：基地址 = 200H + 100H = 300H 。

K847支持的标签地址及范围

各种标签的详细解释请参见科日新控K系列板卡综述：

说明：

项目符号

ID指板卡号，用于识别设备中的不同板卡， 板卡号设定范围为0 ～ 31，十进制表示。

项目符号

Ch指通道号，范围根据板卡类型不同，十进制表示。

项目符号 | 红色字表示格式中可变部分，变化范围参见各种 板卡的帮助文件。
项目符号 | 蓝色括号不出现在标签地址中，蓝色括号内的内容在设备中只包含一块板卡时可省略。
项目符号 | 标签地址配置成不存在类型或板卡地址错误或通道号超出有效范围时，标签将不被承认， 不能读/写数据。

标签地址

含义

数据类型

读写类型

标签值范围

DI ID:Ch

数字量输入

开关量

只读

0～7

DO ID:Ch

数字量输出

开关量

只写

0～7

标签举例：(以多个板卡创建为例，标签中包括板卡号 ，若选择单个板卡创建则不用配置板卡号，只须配置通道号，如AD0。)

标签 ：DI0:0
数据值类型：开关量
描述 ：表示0号板卡的第0通道开关输入值

标签 ：DO0:0
数据值类型：开关量
描述 ：表示0号板卡的第0通道开关输出值


K848

科日新控K84 8

K848的功能与特性

项目符号 | 24路TTL数字量输出/输入
项目符号 | 40路继电器数字量输出

 K848的地址设置

在您使用PCL818H板卡时，请确认已经为板卡设定了唯一的地址，具体设置为：

基地址选择范围000H～3FFH。当开关置ON位时，该位无效；开关置OFF位时，该位有效。
基地址计算公式如下：基地址 = 所有有效位之和
例：如上图所示：基地址 = 200H + 100H = 300H

K848 支持的标签地址及范围

各种标签的详细解释请参见科日新K系列板卡综述：

说明：
项目符号

ID指板卡号，用于识别设备中的不同板卡， 板卡号设定范围为0 ～ 31，十进制表示。

项目符号

Ch指通道号，范围根据板卡类型不同，十进制表示。

项目符号 | 红色字表示格式中可变部分，变化范围参见各种 板卡的帮助文件。
项目符号 | 蓝色括号不出现在标签地址中，蓝色括号内的内容在设备中只包含一块板卡时可省略。
项目符号 | 标签地址配置成不存在类型或板卡地址错误或通道号超出有效范围时，标签将不被承认， 不能读/写数据。

标签地址

含义

数据类型

读写类型

标签值范围

DI ID:Ch

数字量输入

开关量

只读

0 ～ 23

DO ID:Ch

数字量输出

开关量

只写

0 ～ 39

标签举例：(以多个板卡创建为例，标签中包括板卡号 ，若选择单个板卡创建则不用配置板卡号，只须配置通道号，如AD0。)

标签 ：DI0:0
数据值类型：开关量
描述 ：表示0号板卡的第0通道开关输入值

标签 ：DO0:0
数据值类型：开关量
描述 ：表示0号板卡的第0通道开关输出值


K849

科日新控K849

K849 的功能与特性

项目符号

64路TTL数字量输入

K849的地址设置

在您使 用K849板卡时，请确认已经为板卡设定了唯一的地址，具体设置为：

K849板卡占用8个连续IO地址。当开关置ON位时，该位无效；开关置OFF位时，该位有效。
基地址计算公式如下：基地址 = 200H + 所有有效位之和。
例：如上图所示：基地址 = 200H + 100H = 300H 。

K849支持的标签地址及范围

各种标签的详细解释请参见科日新控K系列板卡综述：

说明：

项目符号

ID指板卡号，用于识别设备中的不同板卡， 板卡号设定范围为0 ～ 31，十进制表示。

项目符号

Ch指通道号，范围根据板卡类型不同，十进制表示。

项目符号 | 红色字表示格式中可变部分，变化范围参见各种 板卡的帮助文件。
项目符号 | 蓝色括号不出现在标签地址中，蓝色括号内的内容在设备中只包含一块板卡时可省略。
项目符号 | 标签地址配置成不存在类型或板卡地址错误或通道号超出有效范围时，标签将不被承认， 不能读/写数据。

标签地址

含义

数据类型

读写类型

标签值范围

DI ID:Ch

数字量输入

开关量

只读

0～63

标签举例：(以多个板卡创建为例，标签中包括板卡号 ，若选择单个板卡创建则不用配置板卡号，只须配置通道号，如AD0。)

标签 ：DI0:0
数据值类型：开关量
描述 ：表示0号板卡的第0通道开关输入值


K812A

科日新控K812A

K812A 的功能与特性

项目符号 | 32路单端12位模拟量输入
项目符号 | 输入电压范围可选：±5V；0-10V
项目符号 | AD启动方式：程序启动

 K812A的地址设置

在您使 用K812A板卡时，请确认已经为板卡设定了唯一的地址，具体设置为：

基地址选择范围为100H~1FFH；210H~2FFH以及300H~3FFH。K812A板卡占用2个连续IO地址。当开关置ON位时，该位无效；开关置OFF位时，该位有效。 基地址计算公式如下：基地址 = 所有有效位之和。
例：如上图所示：基地址 = 200H + 100H = 300H

K812A支持的标签地址及范围

各种标签的详细解释请参见科日新控K系列板卡综述：

说明：

项目符号

ID指板卡号，用于识别设备中的不同板卡， 板卡号设定范围为0 ～ 31，十进制表示。

项目符号

Ch指通道号，范围根据板卡类型不同，十进制表示。

项目符号 | 红色字表示格式中可变部分，变化范围参见各种 板卡的帮助文件。
项目符号 | 蓝色括号不出现在标签地址中，蓝色括号内的内容在设备中只包含一块板卡时可省略。
项目符号 | 标签地址配置成不存在类型或板卡地址错误或通道号超出有效范围时，标签将不被承认， 不能读/写数据。

标签地址

含义

数据类型

读写类型

标签值范围

AD ID:Ch

输入电压值

模拟量

只读

0～31

标签举例：(以多个板卡创建为例，标签中包括板卡号 ，若选择单个板卡创建则不用配置板卡号，只须配置通道号，如AD0。)

标签 ：AD0:0
数据值类型：模拟量
描述 ：表示0号板卡的第0通道模拟量输入值