研华PCL839步进电机控制卡

PCL839概述 功能与特性 硬件设置 地址设置 在开物2000开发环境中创建设备 标签的创建 标签的地址配置规则 标签举例 在线升级驱动

研华PCL839步进电机控制卡概述

研华PCL839步进电机控制卡是一种高速三轴步进电机控制卡，可以方便的实现各种步进电机的控制。

PCL839的功能与特性

项目符号 | 设置步进电机各个轴的工作模式；
项目符号 | 设置步进电机的低速度值，高速度值和加/减速时间；
项目符号 | 各种停止方式的支持；
项目符号 | 各种控制功能包括回到原点、连续直线运行、定步长直线运行、从原点运行到设定的平面点或立体点、走圆弧。
项目符号 | 提供 16路DI/DO 功能。

PCL839的地址设置

研华PCL839步进电机控制卡采用ISA总线形式，占用计算机的ISA 插槽。在使用研华PCL839 步进电机控制卡之前必须先选择板卡的基址。PCL839 步进电机控制卡要求使用16位 连续的I/O地址，用DIP开关S1来设置基址，出厂默认值为16进制300。

在开物2000开发环境中创建设备

在开发环境的“硬件系统”中按照“新节点和设备向导”的指示配置所连接的 板卡。以便于开物2000识别和使用。

步骤1：选择”板卡“设备类型。单击“PCL839步进电机控制卡”， 这里可以查看“驱动版本号”，更改设备名称， 如“Advantech_PCL” ，然后单击“选择”按钮。

步骤2：在”研华PCL839步进电机控制卡向导“中选择执行的操作方式——“新建设备”。选中“新建设备”后单击”下一步”按钮(或双击“新建设备”)，您也可以选择“修改设

备”，对的

配置进行修改或者选择“察看设备”浏览已经设置好的板卡配置情况。

其中下面的按钮的含义分别为：

下载最新驱动：可以帮助您进入开物技术支持网站的下载专区中；

帮助信息：可以查看驱动的版本等信息；

调试设置：通常情况下“调试开关”打开，这时可以记录开物的基本信息，主要包括启动和退出的时间，标签情况，通讯情况等信息；如果把“输出错误信息”和“输出跟

踪信息”也选中的话，这时将记录开物运行过程中的全部通讯信息，对于记录通讯过程中的错误信息很有帮助，如果您在使用开物过程中，硬件连接有问题时，请打

开所有调试开关，将通讯信息记录下来，待整个通讯工程正常后，请您把“输出错误信息”和“输出跟踪信息”关闭。

注意：整个信息将存成LOG文件，在相应工程目录下面的“DEBUG”子目录下，文件名以驱动DLL文件加上日期的方式命名，如Advantech_PCL2004-5-26.log。

步骤3： 如果用连接多个板块，那么在界面中要选择“多个板块创建”。

步骤4：按照向导提示顺序执行，重点注意下面界面中对基址的选择，配置完点击“完成”。

PCL 839步进电机控制卡标签的创建

1、在开发环境的‘标签’中添加标签，显示下图，选择主设备为上面的‘Advantech_PCL’，选择并填写‘主设备地址’，修改标签名。

2、根据标签所控制的参数物理意义，测量值量程、工程值量程、扫描周期、转换方式、记录属性等。单击‘添加’或‘完成’按钮。

标签的地址配置规则

说明：

ID指站号，Ch指寄存器地址号。所有地址均采用2段：站号+地址号。

项目符号

ID指站号也是板卡号，用于识别设备中的不同板卡， 板卡号设定范围为0 ～ 31，十进制表示。

项目符号

Ch指寄存器号也是通道号，范围根据板卡 标签不同而不同，十进制表示。

项目符号 | 标签地址配置成不存在类型或板卡地址错误或通道号超出有效范围时，标签将不被承认， 不能读/写数据。
项目符号 | 红色字表示格式中可变部分，变化范围参见各种 板卡的帮助文件。

标签地址

含义

数据类型

读写类型

通道范围

标签值范围

备注（标签的相关参数）

Control_Channel ID:Ch 非运动操作的通道，包括SetMode、SetSpeed、MStop、SlowDown和SlDnStop 模拟量 只写 0 1～123。

其中1：1轴；2：2轴；3：三轴；4/12：1、2轴；5/13：1、3轴；6/23：2、3轴；7/123：1、2、3轴

Mode ID:Ch | 运行模式 | 模拟量 | 只写 | 0 | 0/1
SetMode ID:Ch | 为特定通道进行模式设置 | 开关量 | 只写 | 0 | 0/1 | Control_Channel和 Mode
SetSpeed_High ID:Ch | 设定特定通道的高速度值 | 模拟量 | 只写 | 0 | 1～16382
SetSpeed_Low ID:Ch | 设定特定通道的低速度值 | 模拟量 | 只写 | 0 | 1～16382
SetSpeed_Accelerate ID:Ch | 设定特定通道的加/减速度值 | 模拟量 | 只写 | 0 | 2～1023
SetSpeed ID:Ch | 设置各种速度值 | 开关量 | 只写 | 0 | 0/1 | Control_Channel、SetSpeed_High、SetSpeed_Low和SetSpeed_Accelerate
MStop ID:Ch | 停止特定通道的运动 | 开关量 | 只写 | 0 | 0/1 | Control_Channel
SlowDown ID:Ch | 对特定的通道进行斜坡减速 | 开关量 | 只写 | 0 | 0/1 | Control_Channel
SlDnStop ID:Ch | 对特定通道进行斜坡减速至低速度值然后停止 | 开关量 | 只写 | 0 | 0/1 | Control_Channel
Move_Channel ID:Ch 运动类型中的通道，包括（Org、PMove、CMove、Line、Line3D、Arc） 模拟量 只写 0 1～123。

其中1：1轴；2：2轴；3：三轴；4/12：1、2轴；5/13：1、3轴；6/23：2、3轴；7/123：1、2、3轴

Move_Dir ID:Ch | 运动方向 | 模拟量 | 只写 | 0～2 | 0/1
Move_Speed ID:Ch | 运动速度 | 模拟量 | 只写 | 0～2 | 0/1
Move_Step ID:Ch | 运动的步数 | 模拟量 | 只写 | 0～2 | 具体坐标值
Move_PX1 ID:Ch | X坐标 | 模拟量 | 只写 | 0 | 具体坐标值
Move_PX2 ID:Ch | 圆弧运动时第二点X坐标 | 模拟量 | 只写 | 0 | 具体坐标值
Move_PY1 ID:Ch | Y坐标 | 模拟量 | 只写 | 0 | 具体坐标值
Move_PY2 ID:Ch | 圆弧运动时第二点Y坐标 | 模拟量 | 只写 | 0 | 具体坐标值
Move_PZ1 ID:Ch | Z坐标 | 模拟量 | 只写 | 0 | 具体坐标值
Org ID:Ch | 对特定的通道进行回到原点的运动 | 开关量 | 只写 | 0 | 0/1 | Move_Channel、Move_Dir、Move_Speed
PMove ID:Ch | 对特定通道进行运行特定步长 | 开关量 | 只写 | 0 | 0/1 | Move_Channel、Move_Dir、Move_Speed、Move_Step
CMove ID:Ch | 对特定的通道进行连续运动 | 开关量 | 只写 | 0 | 0/1 | Move_Channel、Move_Dir、Move_Speed
Line ID:Ch | 对特定通道从当前位置（0,0）运行到指定位置（x,y） | 开关量 | 只写 | 0 | 0/1 | Move_Channel、Move_PX1、Move_PY1
Line3D ID:Ch | 对特定通道从当前位置（0,0,0）运行到指定位置（x,y,z） | 开关量 | 只写 | 0 | 0/1 | Move_Channel、Move_PX1、Move_PY1、Move_PZ1
Arc ID:Ch | 过当前点和设定的两个点进行圆弧运动 | 开关量 | 只写 | 0 | 0/1 | Move_Channel l、Move_Dir、Move_PX1、Move_PY1、Move_PX2、Move_PY 2
DI ID:Ch | 数字量输入 | 数字量 | 只读 | 0～15 | 0/1
DO IID:Ch | 数字量输出 | 数字量 | 只写 | 0～15 | 0/1
Current_StepID:Ch | 读取进行步进运动时剩余的步数 | 模拟量 | 只读 | 0～2 | 进行步进运动时剩余的步数 | 0～2分别代表X、Y和Z轴

标签举例：(以多个板卡创建为例，标签中包括板卡号 ，若选择单个板卡创建则不用配置板卡号，只须配置通道号，如Mode0。)

标签 ：Control_Channel0:0
数据值类型：模拟量
描述 ：表示0号板卡进行非运动操作对应的通道

标签 ：Mode0:0
数据值类型：模拟量
描述 ：表示0号板卡的运动模式

标签 ：SetMode0:0
数据值类型：开关量
描述 ：表示为0号板卡进行模式设置

标签 ：SetSpeed_High0:0
数据值类型：模拟量
描述 ：表示0号板卡的高速度值

标签 ：SetSpeed_Low0:0
数据值类型：模拟量
描述 ：表示0号板卡的低速度值

标签 ：SetSpeed_Accelerate0:0
数据值类型：模拟量
描述 ：表示0号板卡的加速度值

标签 ：SetSpeed0:0
数据值类型：开关量
描述 ：表示对0号板卡的速度值 进行设定

标签 ：MStop0:0
数据值类型：开关量
描述 ：表示停止0号板卡特定通道的运动

标签 ：SlowDown0:0
数据值类型：开关量
描述 ：表示0号板卡的特定通道进行斜坡减速

标签 ：SlDnStop0:0
数据值类型：开关量
描述 ：表示0号板卡的特定通道进行斜坡减速至低速度值然后停止

标签 ：Move_Channel0:0
数据值类型：模拟量
描述 ：表示运动在特定运动类型的通道 ，包括Org、PMove、CMove、Line、Line3D、Arc

标签 ：Move_Dir0:0
数据值类型：模拟量
描述 ： 指电机X轴的运动方向

标签 ：Move_Dir0:1
数据值类型：模拟量
描述 ： 指电机Y轴的运动方向

标签 ：Move_Dir0:2
数据值类型：模拟量
描述 ： 指电机Z轴的运动方向

标签 ：Move_Speed0:0
数据值类型：模拟量
描述 ： 电机X轴的运动速度，高速度还是低速度

标签 ：Move_Speed0:1
数据值类型：模拟量
描述 ： 电机Y轴的运动速度，高速度还是低速度

标签 ：Move_Speed0:2
数据值类型：模拟量
描述 ： 电机Z轴的运动速度，高速度还是低速度

标签 ：Move_Step0:0
数据值类型：模拟量
描述 ：电机X轴的运动步数

标签 ：Move_Step0:1
数据值类型：模拟量
描述 ：电机Y轴的运动步数

标签 ：Move_Step0:2
数据值类型：模拟量
描述 ：电机Z轴的运动步数

标签 ：Move_PX10:0
数据值类型：模拟量
描述 ：电机运动的X点坐标

标签 ：Move_PX20:0
数据值类型：模拟量
描述 ： 电机做圆弧运动时的第二点X坐标

标签 ：Move_PY10:0
数据值类型：模拟量
描述 ：电机运动的Y点坐标

标签 ：Move_PY20:0
数据值类型：模拟量
描述 ： 电机做圆弧运动时的第二点Y坐标

标签 ：Move_PZ10:0
数据值类型：模拟量
描述 ：电机做空间运动时的Z点坐标

标签 ：Org0:0
数据值类型：开关量
描述 ：表示对0号板卡的特定通道进行回到原点的运动

标签 ：PMove0:0
数据值类型：开关量
描述 ：表示对0号板卡的特定通道进行运动特定步长

标签 ：CMove0:0
数据值类型：开关量
描述 ：表示0号板卡的特定通道进行连续运动

标签 ：Line0:0
数据值类型：开关量
描述 ：表示0号板卡的特定通道从当前位置( 0 , 0 )运动到指定位置( x , y )

标签 ：Line3D0:0
数据值类型：开关量
描述 ：表示0号板卡的特定通道从当前位置( 0 , 0 , 0 )运动到指定位置(x , y , z)

标签 ：Arc0:0
数据值类型：开关量
描述 ：过当前点和设定的两个点进行圆弧运动 ，其中包括方向参数

标签 ：DI0:0
数据值类型：数字量
描述 ：表示0号板卡的第0路数字量输入

标签 ：DO0:0
数据值类型：数字量
描述 ：表示0号板卡的第0路数字量输出

标签 ：Current_Step 0:0
数据值类型：数字量
描述 ：表示0号板卡的X轴进行步进运动剩余的步熟。


研华PCL839卡使用说明

研华PCL839步进电机控制卡使用之前需设定的参数

项目符号 | 设定Control_Channel，如果是做普通运动选1个通道即可，如果是做直线运动或圆弧运动需选两个通道，如果做空间运动要选三个通道。
项目符号 | 设定 Mode值 0或1。
项目符号 | 把 Set Mode置成True进行模式设置。
项目符号 | 设置 SetSpeed_High的值。
项目符号 | 设置 SetSpeed_Low的值。
项目符号 | 设置 SetSpeed_Accelerate的值。
项目符号 | 把 SetSpeed 置成True进行速度设置。

研华PCL839步进电机控制卡运动时需设定的参数

项目符号 | 设定 Move_Channel 的值，如果是做普通运动选1个通道即可，如果是做直线运动或圆弧运动需选两个通道，如果做空间运动要选三个通道。
项目符号 | 如果要做步进运动要设定 Move_Step 的值。
项目符号 | 设置 Move_Dir 的值。
项目符号 | 设置 Move_Speed 的值 ，0为低速；1为高速。

设定完如下图：

研华PCL839步进电机控制卡运动时需设定的参数

项目符号 | 如果要进行连续运动把Cmove置为True。
项目符号 | 如果要进行步进运动把Pmove置为True。
项目符号 | 如果要停止目前的运动把Mstop置为True。
项目符号 | 如果要从高速做斜坡减速运动然后维持低速运动把 SlowDown置为True。
项目符号 | 如果要对通道进行斜坡减速至低速度值然后停止置SlDnStop为True。

设定完如下图：

研华PCL839步进电机控制卡做直线运动时需设定的参数

项目符号 | 设定 Move_Channel 的值，需选两个通道 。
项目符号 | 设定通道要运动到指定点的坐标( X1 , Y1)的值。
项目符号 | 将Line设为True。

设定完如下图：

研华PCL839步进电机控制卡做圆弧运动时需设定的参数

项目符号 | 设定 Move_Channel 的值，需选两个通道 。
项目符号 | 设定通道圆弧运动第一点的坐标( X1 , Y1),和圆弧运动第二点的坐标( X2 , Y2 )。
项目符号 | 将Arc设为True。

设定完如下图：

研华PCL839步进电机控制卡做空间运动时需设定的参数

项目符号 | 设定 Move_Channel 的值，空间运动要选三个通道。
项目符号 | 设定通道运动到指定位置的坐标( X1 , Y1 , Z1 )。
项目符号 | 将Line3D设为True。

设定完如下图：