研华PCI系列板卡综述

概述 硬件 设置 创建设备 创建标签 标签的地址规则 标签举例 在线升级驱动

研华PCI系列板卡概述

研华科技作为自动化国际领导厂商，产品覆盖工业自动化、网络和嵌入式系统等领域。研华板卡稳定性好，功能强大，在工业自动化领域有着广泛的应用。

开物2000系统支持下面类型的研华PCI板卡系列：

项目符号

PCI1713 ：32路单端/16路差动12位模拟量输入

项目符号

PCI1720 ：4路隔离12位模拟量输出

项目符号

PCI1723 ：8路16位模拟量输出 ；16路可编程数字量输入/输出

项目符号

PCI1711 ：16路单端12位模拟量输入；2路隔离12位模拟量输出；16路数字量输入；16路数字量输出

项目符号

PCI1710 ：8路 单端/16路差动12位模拟量输入 ；2路12位模拟量输出；16路可编程数字量输入/输出

项目符号

PCI1710HG ：8路 单端/16路差动12位模拟量输入 ；2路12位模拟量输出；16路可编程数字量输入/输出

项目符号

PCI1753 ：96路可编程数字量输入/输出

项目符号

PCI1780 ：8路数字量输入输出；8路定时计数 ；8路PWM输出

项目符号

PCI1762 ：16路数字量输入；16路继电器输出

关于PCI系列板卡的更详细信息请访问 研华公司网站。

开物2000还支持其它多种设备，详情请与 华富惠通公司联系。

研华PCI系列板卡的硬件设置

本版本的驱动程序使用研华的动态链接库ADSAPI.DLL，在使用板卡前，请 安装相应的驱动程序：1. 安装随板卡所带的板卡驱动程序 。安装方法为：将驱动光盘放入光驱中，光盘自动启动，点击“CONTINUE”，选择“INSTALLATION，安装INDIVIDUAL DRIVERS，然后选择相应的型号，方便起见也可以选择“FULL INSTALLATION”，根据提示即可完成驱动程序的安装。

2.安装研华板卡驱动光盘中提供的DEVICE MANAGER软件。安装方法为：将驱动光盘放入光驱中，光盘自动启动，点击“CONTINUE”，选择“INSTALLATION，安装DEVICE MANAGER，根据提示即可完成驱动程序的安装。

3.在开物中使用板卡前须使用研华的DEVICE MANAGER软件测试程序测试板卡是否正常，只有测试正常的板卡才可以在开物2000中使用。

研华PCI系列板卡采用 PCI 总线形式，占用计算机的 PCI 插槽。在您使用 研华 PCI 系列板卡时，请确认已经准确设定了一些板卡基本信息，主要包括板卡AD量程选择、DA参考电压选择、时钟选择、触发方式选择、中断选择，电压方式选择等。其中型号不同，板卡的硬件设置可能会不同，详细设置情况清参阅板卡说明书。

在开物2000开发环境中创建设备

在开发环境的“硬件系统”中按照“新节点和设备向导”的指示配置所连接的 板卡。以便于开物2000识别和使用。

步骤1：选择”板卡“设备类型。双击“研华PCI板卡”，或单击选中“研华PCI板卡”，这里可以查看“驱动版本号”，更改设备名称， 如“Advantech_PCI” ，然后单击“选择”按钮。

步骤2：在”研华PCI板卡向导“中选择执行的操作方式——“新建设备”。选中“新建设备”后单击”下一步”按钮(或双击“新建设备”)，您也可以选择“修改设备”，对板卡的配置进行修改或者选择“察看设备”浏览已经设置好的板卡配置情况。

其中下面的按钮的含义分别为：

下载最新驱动：可以帮助您进入开物技术支持网站的下载专区中；

帮助信息：可以查看驱动的版本等信息；

调试设置：通常情况下“调试开关”打开，这时可以记录开物的基本信息，主要包括启动和退出的时间，标签情况，通讯情况等信息；如果把“输出错误信息”和“输出跟踪信息”也选中的话，这时将记录开物运行过程中的全部通讯信息，对于记录通讯过程中的错误信息很有帮助，如果您在使用开物过程中，硬件连接有问题时，请打开所有调试开关，将通讯信息记录下来，待整个通讯工程正常后，请您把“输出错误信息”和“输出跟踪信息”关闭。

注意：整个信息将存成LOG文件，在相应工程目录下面的“DEBUG”子目录下，文件名以驱动DLL文件加上日期的方式命名，如Advantech_PCI2003-7-10.log。

步骤3：在“研华PCI板卡向导“中选择板卡安装，主要包括板卡号、板卡类型、基地址、AD输入方式、AD最大范围(或AD输入极性)、AD滤波次数、量程选择等选项。 其中：

板卡号：

板卡号的是由计算机系统自动配置的，各个板卡对应的板卡号可以从研华公司提供的DEVICE MANAGER软件中得到。具体情况可见下图，请在配置板卡号时注意。

从图中可以看到PCI1713板卡号为0，PCI1723板卡号为1，在开物中根据DEVICE MANAGER中提供的板卡号配置就可以。

板卡类型：指用户使用的板卡型号，通过下拉菜单选择；

AD输入方式：指AD信号是单端还是差动 ，研华PCI1713板卡可以支持单端或差动信号输入，在使用这项功能时，需要通过研华公司的DEVICE MANAGER来设定信号的输入方式，注意在设置时需要对每一个通道都进行设置，具体设置情况见下图（在DEVICE MANAGER中选择“SETUP选项”）：

AD最大范围(或AD输入极性)：选择AD信号的输入极性为单极性还是双极性(或者AD的输入极性为单极性或双极性)；

AD滤波次数：为滤除干扰而设计，算法为：若设定为10，则将采集到的10个数据按照大小顺序排列，取中间1/3数据的平均值，这个过程在驱动中完成，您可以根据板卡使用情况调节AD滤波次数。

PCI1723和PCI1753板卡提供可编程IO的功能，即数字量是输入还是输出可以通过软件设定，在建立设备过程中可以在可编程标签页中设定数字量的输入或输出方式。

其中芯片号对应板卡设备的8255或其兼容芯片号，一片8255或其兼容芯片提供24路数字量通道，分位端口A、端口B和端口C，可以任意配置位输入或输出功能；端口A对应前8路；端口B对应中间8路；端口C对应后8路。

对于第0片8255或其兼容芯片通道号范围从0～23；第1片通道号范围从24～47；第3片通道号范围从48～71；第4片通道号范围从72～95，其它依此类推；

例如：对于PCI1723：

其中芯片号0的端口A对应数字量通道0～7，端口B对应通道8～15。

如果端口A设定为输出，则在配置标签时应为DO0、DO1、DO2、DO3、DO4、DO5、DO6、DO7。

如果端口A设定为输入，则在配置标签时应为DI0、DI1、DI2、DI3、DI4、DI5、DI6、DI7；

如果端口B设定为输出，则在配置标签时应为DO8、DO9、DO10、DO11、DO12、DO13、DO14、DO15。

如果端口B设定为输入，则在配置标签时应为DI8、DI9、DI10、DI11、DI12、DI13、DI14、DI15。

对于PCI1753：

其中芯片号0端口A对应数字量通道0～7，端口B对应通道8～15。

如果端口A设定为输出，则在配置标签时应为DO0、DO1、DO2、DO3、DO4、DO5、DO6、DO7。

如果端口A设定为输入，则在配置标签时应为DI0、DI1、DI2、DI3、DI4、DI5、DI6、DI7；

如果端口B设定为输出，则在配置标签时应为DO8、DO9、DO10、DO11、DO12、DO13、DO14、DO15。

如果端口B设定为输入，则在配置标签时应为DI8、DI9、DI10、DI11、DI12、DI13、DI14、DI15。

其中芯片号3端口A对应数字量通道72～79，端口B对应通道80～87，端口C对应通道88～95。

如果端口A设定为输出，则在配置标签时应为DO72、DO73、DO74、DO75、DO76、DO77、DO78、DO79。

如果端口A设定为输入，则在配置标签时应为DI72、DI73、DI74、DI75、DI76、DI77、DI78、DI79；

如果端口B设定为输出，则在配置标签时应为DO80、DO81、DO82、DO83、DO84、DO85、DO86、DO87。

如果端口B设定为输入，则在配置标签时应为DI80、D81、DI82、DI83、DI84、DI85、DI86、DI87；

如果端口C设定为输出，则在配置标签时应为DO88、DO89、DO90、DO91、DO92、DO93、DO94、DO95。

如果端口C设定为输入，则在配置标签时应为DI88、DI89、DI90、DI91、DI92、DI93、DI94、DI95。

使用过程中请注意数字量标签的配置方法。

标签的创建

使用“研华PCI板卡向导”完成板卡设备的创建后，可以进行标签设计。

1、在开发环境的“标签”击鼠标右键，选择“添加标签“，显示见下图，选择主设备为上面的“Advantech_PCI” ，选择并填写"主设备地址"，修改标签名。

开物的板卡驱动程序可以实现以下功能：模拟量输入、模拟量输出、数字量输入、数字量输出、定时/记数等功能。各部分功能在开物中对应的标签为：

AD：模拟量输入功能；

DA：模拟量输出功能；

DI：数字量输入功能；

DO：数字量输出功能；

INI_Count：为定时/记数器设定的初始值；

Count：为定时/记数器的当前值。

在板卡类设备中，标签的配置规则为：若为单个板卡创建，格式为： 标签+通道号，如AD0、DA3、DI5、DO6、Count2、INI_Count2等；若为多个设备创建，则格式为： 标签+板卡号+“:”+通道号，如AD0:0、DA0:3、DI1:5、DO0:6、Count0:2、INI_Count0:2；

2、根据您的特定使用需求，修改测量值和工程值的最大值、最小值、扫描周期等属性。单击‘添加’或‘完成’按钮。其中：

测量值最大值：设定为板卡当前量程的上限值；

测量值最小值：设定为板卡当前量程的下限值；

工程值最大值：设定为实际物理参数的上限值；

工程值最小值：设定为实际物理参数的下限值；

如：板卡的量程选择为：0 ～ 10V，对应现场的力信号为0 ～ 1000N，则测量值最大值设为 10；最小值设为 0；工程值最大值设为 1000；最小值设为 0。

请注意：假如只测量外界的电压信号则不需要更改测量值和工程值的最大值、 最小值，保持默认值就可以。

标签地址配置规则

标签地址可以按照下面的规则配置填写：

标签类型[ID:]Ch

说明：

项目符号

ID指板卡号，用于识别 同一设备中的不同子板卡， 板卡号设定范围为0 ～ 31，十进制表示。

项目符号

Ch指通道号，范围根据板卡类型不同，十进制表示。

项目符号 | 红色字表示格式中 的可变部分，变化范围参见各种板卡的帮助文件。
项目符号 | 蓝色括号不出现在标签地址中，蓝色括号内的内容在“单个板卡创建”时可省略。
项目符号 | 标签地址配置成不存在类型或板卡地址错误或通道号超出有效范围时，标签将不被承认， 不能读/写数据。

标签地址

含义

数据类型

读写类型

标签值范围

AD ID:Ch

模拟量输入

模拟量

只读

取决于板卡类型，请参阅相关帮助文件。

DA ID:Ch

模拟量输出

模拟量

只写

DI ID:Ch

数字量输入

开关量

只读

DO ID:Ch

数字量输出

开关量

只写

Count ID:Ch

计数器

模拟量

只读

INI_Count ID:Ch

计数器初值 模拟量 只写

标签举例：(以多个板卡创建为例，标签中包括板卡号 ，若选择单个板卡创建则不用配置板卡号，只须配置通道号，如AD0。)

标签 ：AD0:0
数据值类型：模拟量
描述 ：表示0号板卡的第0通道模拟量输入值

标签 ：DA0:0
数据值类型：模拟量
描述 ：表示0号板卡的第0通道模拟量输出值

标签 ：DI0:0
数据值类型：开关量
描述 ：表示0号板卡的第0通道开关输入值

标签 ：DO0:0
数据值类型：开关量
描述 ：表示0号板卡的第0通道开关输出值

标签 ：Count0:0
数据值类型：模拟量
描述 ：表示0号板卡的第0个记数器通道当前值

标签 ：INI_Count0:0
数据值类型：模拟量
描述 ：表示0号板卡的第0个记数器通道初值


PCI1710

研华PCI 1710

硬件功能与特性 地址设置 标签地址及范围 标签举例 在线升级驱动

PCI1710的功能与特性

项目符号 | 16路单端12位模拟量输入
项目符号 | 软件调节输入电压范围：双极性：±10V；±5V；±2.5V；±1.25V；±0.625V；单极性：0～10V；0～5V；0～2.5V；0～1.25V
项目符号 | 支持多种AD触发方式
项目符号 | 2路12位模拟量输出
项目符号 | 16通道数字量输入
项目符号 | 16通道数字量输出
项目符号 | 模拟量输出量程为 0～5V；0～10V

PCI1710的地址设置

研华PCI1710板卡地址为浮动地址，由PCI总线协议分配，用户在使用PCI1710板卡时不必关心具体的板卡地址。

PCI1710 支持的标签地址及范围

各种标签的详细解释请参见研华PCI系列板卡综述：

说明：

项目符号

ID指板卡号，用于识别设备中的不同板卡， 板卡号设定范围为0 ～ 31，十进制表示。

项目符号

Ch指通道号，范围根据板卡类型不同，十进制表示。

项目符号 | 红色字表示格式中可变部分，变化范围参见各种 板卡的帮助文件。
项目符号 | 蓝色括号不出现在标签地址中，蓝色括号内的内容在设备中只包含一块板卡时可省略。
项目符号 | 标签地址配置成不存在类型或板卡地址错误或通道号超出有效范围时，标签将不被承认， 不能读/写数据。

需要注意的是，PCI1710提供单端和差动两种AD输入方式，其输入方式需要通过研华公司提供的软件进行设定。

标签地址

含义

数据类型

读写类型

标签值范围

AD ID:Ch

输入电压值

模拟量

只读

单端：0～15 差动：0～7

DA ID:Ch

输出电压值

模拟量

只写

0 ～ 1

DI ID:Ch

数字量输入

开关量

只读

0 ～ 15

DO ID:Ch

数字量输出

开关量

只写

0 ～ 15

标签举例：(以多个板卡创建为例，标签中包括板卡号 ，若选择单个板卡创建则不用配置板卡号，只须配置通道号，如AD0。)

标签 ：AD0:0
数据值类型：模拟量
描述 ：表示0号板卡的第0通道模拟量输入值

标签 ：DA0:0
数据值类型：模拟量
描述 ：表示0号板卡的第0通道模拟量输出值

标签 ：DI0:0
数据值类型：开关量
描述 ：表示0号板卡的第0通道开关输入值

标签 ：DO0:0
数据值类型：开关量
描述 ：表示0号板卡的第0通道开关输出值


PCI1710HG

研华PCI 1710HG

PCI1710HG的功能与特性

项目符号 | 16路单端12位模拟量输入
项目符号 | 软件调节输入电压范围：双极性：±10V；±5V；±1V；±0.5V；±0.1V；±0.05V；±0.01V；±0.005V；单极性：0～10V；0～1V；0～0.1V；0～0.01V；
项目符号 | 支持多种AD触发方式
项目符号 | 2路12位模拟量输出
项目符号 | 16通道数字量输入
项目符号 | 16通道数字量输出
项目符号 | 模拟量输出量程为 0～5V；0～10V

PCI1710HG的地址设置

研华PCI1710HG板卡地址为浮动地址，由PCI总线协议分配，用户在使用PCI1710HG板卡时不必关心具体的板卡地址。

PCI1710HG 支持的标签地址及范围

各种标签的详细解释请参见研华PCI系列板卡综述：

说明：

项目符号

ID指板卡号，用于识别设备中的不同板卡， 板卡号设定范围为0 ～ 31，十进制表示。

项目符号

Ch指通道号，范围根据板卡类型不同，十进制表示。

项目符号 | 红色字表示格式中可变部分，变化范围参见各种 板卡的帮助文件。
项目符号 | 蓝色括号不出现在标签地址中，蓝色括号内的内容在设备中只包含一块板卡时可省略。
项目符号 | 标签地址配置成不存在类型或板卡地址错误或通道号超出有效范围时，标签将不被承认， 不能读/写数据。

需要注意的是，PCI1710HG提供单端和差动两种AD输入方式，其输入方式需要通过研华公司提供的软件进行设定。

标签地址

含义

数据类型

读写类型

标签值范围

AD ID:Ch

输入电压值

模拟量

只读

单端：0～15差动：0～7

DA ID:Ch

输出电压值

模拟量

只写

0 ～ 1

DI ID:Ch

数字量输入

开关量

只读

0 ～ 15

DO ID:Ch

数字量输出

开关量

只写

0 ～ 15

标签举例：(以多个板卡创建为例，标签中包括板卡号 ，若选择单个板卡创建则不用配置板卡号，只须配置通道号，如AD0。)

标签 ：AD0:0
数据值类型：模拟量
描述 ：表示0号板卡的第0通道模拟量输入值

标签 ：DA0:0
数据值类型：模拟量
描述 ：表示0号板卡的第0通道模拟量输出值

标签 ：DI0:0
数据值类型：开关量
描述 ：表示0号板卡的第0通道开关输入值

标签 ：DO0:0
数据值类型：开关量
描述 ：表示0号板卡的第0通道开关输出值


PCI1711

研华PCI 1711

PCI1711的功能与特性

项目符号 | 16路单端12位模拟量输入
项目符号 | 软件调节输入电压范围，可选范围：±10V；±5V；±2.5V；±1.25V；±0.625V
项目符号 | 支持多种AD触发方式
项目符号 | 1路12位模拟量输出
项目符号 | 16通道数字量输入
项目符号 | 16通道数字量输出
项目符号 | 模拟量输出量程为 0～5V；0～10V

PCI1711的地址设置

研华PCI1711板卡地址为浮动地址，由PCI总线协议分配，用户在使用PCI1711板卡时不必关心具体的板卡地址。

PCI1711 支持的标签地址及范围

各种标签的详细解释请参见研华PCI系列板卡综述：

说明：

项目符号

ID指板卡号，用于识别设备中的不同板卡， 板卡号设定范围为0 ～ 31，十进制表示。

项目符号

Ch指通道号，范围根据板卡类型不同，十进制表示。

项目符号 | 红色字表示格式中可变部分，变化范围参见各种 板卡的帮助文件。
项目符号 | 蓝色括号不出现在标签地址中，蓝色括号内的内容在设备中只包含一块板卡时可省略。
项目符号 | 标签地址配置成不存在类型或板卡地址错误或通道号超出有效范围时，标签将不被承认， 不能读/写数据。

需要注意的是，PCI1711提供单端和差动两种AD输入方式，其输入方式需要通过研华公司提供的软件进行设定。

标签地址

含义

数据类型

读写类型

标签值范围

AD ID:Ch

输入电压值

模拟量

只读

0 ～ 15

DA ID:Ch

输出电压值

模拟量

只写

0 ～ 1

DI ID:Ch

数字量输入

开关量

只读

0 ～ 15

DO ID:Ch

数字量输出

开关量

只写

0 ～ 15

标签举例：(以多个板卡创建为例，标签中包括板卡号 ，若选择单个板卡创建则不用配置板卡号，只须配置通道号，如AD0。)

标签 ：AD0:0
数据值类型：模拟量
描述 ：表示0号板卡的第0通道模拟量输入值

标签 ：DA0:0
数据值类型：模拟量
描述 ：表示0号板卡的第0通道模拟量输出值

标签 ：DI0:0
数据值类型：开关量
描述 ：表示0号板卡的第0通道开关输入值

标签 ：DO0:0
数据值类型：开关量
描述 ：表示0号板卡的第0通道开关输出值


PCI1713

研华PCI 1713

PCI1713的功能与特性

项目符号 | 32路单端/16路差动12位模拟量输入
项目符号 | 软件调节输入电压范围，可选范围：±10V；±5V；±2.5V；±1.25V；±0.625V；0～10V；0～5V；0～2.5V；0～1.25V
项目符号 | 支持多种AD触发方式

PCI1713的地址设置

研华PCI1713板卡地址为浮动地址，由PCI总线协议分配，用户在使用PCI1713板卡时不必关心具体的板卡地址。

PCI1713 支持的标签地址及范围

各种标签的详细解释请参见研华PCI系列板卡综述：

说明：

项目符号

ID指板卡号，用于识别设备中的不同板卡， 板卡号设定范围为0 ～ 31，十进制表示。

项目符号

Ch指通道号，范围根据板卡类型不同，十进制表示。

项目符号 | 红色字表示格式中可变部分，变化范围参见各种 板卡的帮助文件。
项目符号 | 蓝色括号不出现在标签地址中，蓝色括号内的内容在设备中只包含一块板卡时可省略。
项目符号 | 标签地址配置成不存在类型或板卡地址错误或通道号超出有效范围时，标签将不被承认， 不能读/写数据。

需要注意的是，PCI1713提供单端和差动两种AD输入方式，其输入方式需要通过研华公司提供的软件进行设定。

标签地址

含义

数据类型

读写类型

标签值范围

AD ID:Ch

输入电压值

模拟量

只读

单端：0～31 差动：0～15

标签举例：(以多个板卡创建为例，标签中包括板卡号 ，若选择单个板卡创建则不用配置板卡号，只须配置通道号，如AD0。)

标签 ：AD0:0
数据值类型：模拟量
描述 ：表示0号板卡的第0通道模拟量输入值


PCI1720

研华PCI 1720

PCI1720的功能与特性

项目符号 | 4路隔离12位模拟量输出
项目符号 | 软件调节输出电压范围，可选电压范围：±10V；±5V；0～10V；0～5V；可选电流范围：0～20mA；4～20mA
项目符号 | 支持多种AD触发方式

PCI1720的地址设置

研华PCI1720板卡地址为浮动地址，由PCI总线协议分配，用户在使用PCI1720板卡时不必关心具体的板 卡地址。

PCI1720 支持的标签地址及范围

各种标签的详细解释请参见研华PCI系列板卡综述：

说明：

项目符号

ID指板卡号，用于识别设备中的不同板卡， 板卡号设定范围为0 ～ 31，十进制表示。

项目符号

Ch指通道号，范围根据板卡类型不同，十进制表示。

项目符号 | 红色字表示格式中可变部分，变化范围参见各种 板卡的帮助文件。
项目符号 | 蓝色括号不出现在标签地址中，蓝色括号内的内容在设备中只包含一块板卡时可省略。
项目符号 | 标签地址配置成不存在类型或板卡地址错误或通道号超出有效范围时，标签将不被承认， 不能读/写数据。

标签地址

含义

数据类型

读写类型

标签值范围

DA ID:Ch

模拟量输出

模拟量

只写

0～3

标签举例：(以多个板卡创建为例，标签中包括板卡号 ，若选择单个板卡创建则不用配置板卡号，只须配置通道号，如AD0。)

标签 ：DA0:0
数据值类型：模拟量
描述 ：表示0号板卡的第0通道模拟量输出值


PCI1723

研华PCI 1723

PCI1723的功能与特性

项目符号 | 8路16位模拟量输出
项目符号 | 模拟量输出电压范围为：±10V；电流输出为0～20mA；4～20mA
项目符号 | 16路可编程数字量输入/输出

PCI1723的地址设置

研华PCI1723板卡地址为浮动地址，由PCI总线协议分配，用户在使用PCI1723板卡时不必关心具体的板卡地址。

PCI1723 支持的标签地址及范围

各种标签的详细解释请参见研华PCI系列板卡综述：

说明：

项目符号

ID指板卡号，用于识别设备中的不同板卡， 板卡号设定范围为0 ～ 31，十进制表示。

项目符号

Ch指通道号，范围根据板卡类型不同，十进制表示。

项目符号 | 红色字表示格式中可变部分，变化范围参见各种 板卡的帮助文件。
项目符号 | 蓝色括号不出现在标签地址中，蓝色括号内的内容在设备中只包含一块板卡时可省略。
项目符号 | 标签地址配置成不存在类型或板卡地址错误或通道号超出有效范围时，标签将不被承认， 不能读/写数据。

标签地址

含义

数据类型

读写类型

标签值范围

DA ID:Ch

模拟量输出

模拟量

只写

0～7
DI ID:Ch

数字量输入

开关量

只读

根据设定最大：0～15
DO ID:Ch

数字量输出

开关量

只写

根据设定最大：0～15

标签举例：(以多个板卡创建为例，标签中包括板卡号 ，若选择单个板卡创建则不用配置板卡号，只须配置通道号，如AD0。)

标签 ：AD0:0
数据值类型：模拟量
描述 ：表示0号板卡的第0通道模拟量输入值

标签 ：DI0:0
数据值类型：开关量
描述 ：表示0号板卡的第0通道开关输入值

标签 ：DO0:0
数据值类型：开关量
描述 ：表示0号板卡的第0通道开关输出值


PCI1753

研华PCI 1753

PCI1753的功能与特性

项目符号

96路可编程数字量输入/输出

PCI1753的地址设置

研华PCI1753板卡地址为浮动地址，由PCI总线协议分配，用户在使用PCI1753板卡时不必关心具体的板卡地址。

PCI1753 支持的标签地址及范围

各种标签的详细解释请参见研华PCI系列板卡综述：

说明：

项目符号

ID指板卡号，用于识别设备中的不同板卡， 板卡号设定范围为0 ～ 31，十进制表示。

项目符号

Ch指通道号，范围根据板卡类型不同，十进制表示。

项目符号 | 红色字表示格式中可变部分，变化范围参见各种 板卡的帮助文件。
项目符号 | 蓝色括号不出现在标签地址中，蓝色括号内的内容在设备中只包含一块板卡时可省略。
项目符号 | 标签地址配置成不存在类型或板卡地址错误或通道号超出有效范围时，标签将不被承认， 不能读/写数据。

标签地址

含义

数据类型

读写类型

标签值范围

DI ID:Ch

数字量输入

开关量

只读

根据设定最大：0～95
DO ID:Ch

数字量输出

开关量

只写

根据设定最大：0～95

标签举例：(以多个板卡创建为例，标签中包括板卡号 ，若选择单个板卡创建则不用配置板卡号，只须配置通道号，如AD0。)

标签 ：DI0:0
数据值类型：开关量
描述 ：表示0号板卡的第0通道开关输入值

标签 ：DO0:0
数据值类型：开关量
描述 ：表示0号板卡的第0通道开关输出值


PCI1723

研华PCI 1762

PCI1762的功能与特性

项目符号

16路数字量输入；16路继电器输出

PCI1762的地址设置

研华PCI1762板卡地址为浮动地址，由PCI总线协议分配，用户在使用PCI1762板卡时不必关心具体的板卡地址。

PCI1762 支持的标签地址及范围

各种标签的详细解释请参见研华PCI系列板卡综述：

说明：

项目符号

ID指板卡号，用于识别设备中的不同板卡， 板卡号设定范围为0 ～ 31，十进制表示。

项目符号

Ch指通道号，范围根据板卡类型不同，十进制表示。

项目符号 | 红色字表示格式中可变部分，变化范围参见各种 板卡的帮助文件。
项目符号 | 蓝色括号不出现在标签地址中，蓝色括号内的内容在设备中只包含一块板卡时可省略。
项目符号 | 标签地址配置成不存在类型或板卡地址错误或通道号超出有效范围时，标签将不被承认， 不能读/写数据。

标签地址

含义

数据类型

读写类型

标签值范围

DI ID:Ch

数字量输入

开关量

只读

0～15
DO ID:Ch

数字量 （继电器）输出

开关量

只写

0～15

标签举例：(以多个板卡创建为例，标签中包括板卡号 ，若选择单个板卡创建则不用配置板卡号，只须配置通道号，如DI0等。)

标签 ：DI0:0
数据值类型：开关量
描述 ：表示0号板卡的第0通道开关输入值

标签 ：DO0:0
数据值类型：开关量
描述 ：表示0号板卡的第0通道开关输出值


PCI1780

研华PCI 1780

PCI1780 的功能与特性

项目符号 | 8路数字量输入输出；
项目符号 | 8路定时计数；
项目符号 | 8路可调解PWM输出；

PCI1780 的地址设置

研华 PCI1780 板卡地址为浮动地址，由PCI总线协议分配，用户在使用PCI1780板卡时不必关心具体的板卡地址。

PCI1780 支持的标签地址及范围

各种标签的详细解释请参见研华PCI系列板卡综述：

说明：
项目符号

ID指板卡号，用于识别设备中的不同板卡， 板卡号设定范围为0 ～ 31，十进制表示。

项目符号

Ch指通道号，范围根据板卡类型不同，十进制表示。

项目符号 | 红色字表示格式中可变部分，变化范围参见各种 板卡的帮助文件。
项目符号 | 标签地址配置成不存在类型或板卡地址错误或通道号超出有效范围时，标签将不被承认， 不能读/写数据。

需要注意的是，目前只提供了定时计数的六个计数模式（Ａ，Ｃ，Ｄ，Ｆ，Ｇ，Ｉ），一种时钟源CLK_N。

标签地址

含义

数据类型

读写类型

标签值范围

DI ID:Ch

数字量输入

开关量

只读

0～7
DO ID:Ch

数字量输出

开关量

只写

0～7
Count ID:Ch

计数器

模拟量

只读

0～7
INI_CountID:Ch

计数器初值

模拟量

只写

0～7
PWM_PeriodID:Ch

脉宽输出方波周期

模拟量

只写

0～7
PWM_HiPeriodID:Ch

脉宽输出方波高脉冲周期

模拟量

只写

0～7
PWM_OUTID:Ch

脉宽调制输出使能

开关量

只写

0～7

备注：标签PWM_PeriodID:Ch用来调解输出方波的周期，范围是0.0005~60ms；标签PWM_HiPeriodID:Ch用来调解输出方波中高脉冲的周期，范围是0.0005~60ms；标签PWM_OUTID:Ch用来控制脉宽输出的使能，控制脉宽输出功能的起停。这三个标签关联同一个PWM输出通道。

例如：首先设置PWM_PeriodID:Ch的值为10，PWM_HiPeriodID:Ch的值为5，然后使PWM_OUTID:Ch标签的值为true，则输出周期为10的方波，如果设置PWM_HiPeriodID:Ch标签的值为6，则输出周期为10，高脉冲周期为6的矩形波；在PWM_OUTID:Ch标签的值为true时，即可通过修改PWM_PeriodID:Ch和PWM_HiPeriodID:Ch的值来实时的调解脉宽。如果需要停止脉宽输出，则使PWM_OUTID:Ch标签的值为false。

注意：PWM_PeriodID:Ch的值需要大于PWM_HiPeriodID:Ch的值。

由于硬件本身对脉宽输出功能具有记忆功能，在退出前需要停止脉宽输出，否则在再次启动的时候，硬件仍然按照上次输出的脉宽波形输出。

标签举例：(以多个板卡创建为例，标签中包括板卡号 ，若选择单个板卡创建则不用配置板卡号，只须配置通道号，如AD0。)

标签 ：DI0:0
数据值类型：开关量
描述 ：表示0号板卡的第0通道开关输入值

标签 ：DO0:0
数据值类型：开关量
描述 ：表示0号板卡的第0通道开关输出值

标签 ：Count0:0
数据值类型：模拟量
描述 ：表示0号板卡的第0个记数器通道当前值

标签 ：INI_Count0:0
数据值类型：模拟量
描述 ：表示0号板卡的第0个记数器通道初值

标签 ：PWM_Period0:0
数据值类型：模拟量
描述 ：表示0号板卡的第0个脉宽输出通道当前值 的Period值

标签 ：PWM_HiPeriod0:0
数据值类型：模拟量
描述 ：表示0号板卡的第0个脉宽输出通道当前值 的HiPeriod值

标签 ：PWM_OUT0:0
数据值类型：开关量
描述 ：表示0号板卡的第0个脉宽输出通道输出使能