研华PCL系列板卡综述

概述 硬件 设置 创建设备 创建标签 标签的地址规则 标签举例 在线升级驱动

研华PCL系列板卡概述

研华科技作为自动化国际领导厂商，产品覆盖工业自动化、网络和嵌入式系统等领域。研华板卡稳定性好，功能强大，在工业自动化领域有着广泛的应用。

开物2000系统支持下面类型的研华PCL板卡系列：

项目符号

PCL711B ：8路12位单端模拟量输入；1路12位模拟量输出；16通道TTL数字量输出；16通道TTL数字量输入

项目符号

PCL720 ：32路TTL/DTL数字量输入，32路TTL/DTL数字量输出，3路16位定时/计数器

项目符号

PCL722 ：144路TTL数字量输入/输出

项目符号

PCL724 ：24路TTL数字量输入/输出

项目符号

PCL725 ：8路继电器输出，LED继电器状态指示灯；8路光电隔离输入

项目符号

PCL726 ：6路12位模拟量输出；16通道TTL数字量输出；16通道TTL数字量输入

项目符号

PCL728 ：2路12位模拟量输出

项目符号

PCL730 ：16路TTL数字量输入；16路隔离数字量；16路TTL数字量输出；16路隔离数字量输出

项目符号

PCL73 3 ：32路隔离数字量输入

项目符号

PCL734 ：32路隔离数字量输出

项目符号

PCL735 ：12路继电器数字量输出，LED继电器状态指示灯

项目符号

PCL813B ：32路12位单端模拟量输入

项目符号

PCL812PG：16路12位单端模拟量输入；2路12位模拟量输出；1路16位定时/记数器；16通道TTL/DTL数字量输出；16通道TTL/DTL数字量输入

项目符号

PCL818H ：16路单端/8路差动12位模拟量输入；1路12位模拟量输出；1路16位定时/记数器；16通道TTL/DTL数字量输出；16通道TTL/DTL数字量输入

项目符号

PCL81 8L ：16路单端/8路差动12位模拟量输入；1路12位模拟量输出；16通道TTL/DTL数字量输出；16通道TTL/DTL数字量输入

项目符号

PCL818LS ：16路单端/8路差动12位模拟量输入；16通道TTL/DTL数字量输出；16通道TTL/DTL数字量输入

项目符号

PCL818HD ：16路单端/8路差动12位模拟量输入；1路12位模拟量输出；16通道TTL/DTL数字量输出；16通道TTL/DTL数字量输入；1路16位定时/计数器

项目符号

PCL818HG：16路单端/8路差动12位模拟量输入；1路12位模拟量输出；16通道TTL/DTL数字量输出；16通道TTL/DTL数字量输入；1路16位定时/计数器

项目符号

PCL836 ：6路定时/记数器；16通道TTL数字量输出；16通道TTL数字量输入

关于PCL系列板卡的更详细信息请访问 研华公司网站。

开物2000还支持其它多种设备，详情请与 华富惠通公司联系。

研华PCL系列板卡的硬件设置

研华PCL系列板卡采用ISA总线形式，占用计算机的ISA插槽。在您使用研华系列板卡时，请确认已经准确设定了一些板卡基本信息，主要包括板卡基地址、DA参考电压选择、内部电压选择、时钟选择、FIFO使能、触发方式选择、中断选择，电压方式选择等。其中型号 不同，板卡的硬件设置可能会不同，详细设置情况清参阅板卡说明书。

在开物2000开发环境中创建设备

在开发环境的‘硬件系统’中按照‘新节点和设备向导’的指示配置所连接的模块。以便于开物2000识别和使用。

步骤1：选择‘板卡’设备类型。双击‘研华IO板卡’，或单击选中‘研华IO板卡’，更改设备名称， 然后单击‘选择’按钮。

步骤2：选择操作方式-新建设备(一个设备中可以包含多个模块)。选中‘新建设备’后单击‘下一步’按钮(或双击‘新建设备’)。

步骤3：显示‘研华IO板卡’配置向导界面。在向导配置界面设定板卡的类型、板卡号、基地址、输入方式、极性、AD滤波次数、量程等选项。 其中板卡类型为用户使用的板卡型号；板卡号为板卡基地址；输入方式为单端还是差动；极性为单极性还是双极性；AD滤波次数为滤除干扰而设计，算法为：若取10则将采集到的10个数据按照大小顺序排列，取中间1/3数据的平均值。单击‘完成’按钮，结束设备配置向导。

标签的创建

使用‘设备向导’创建完成板卡后，可以进行标签设计。

1、在开发环境的‘标签’中添加标签，显示下图，选择主设备为上面的‘Advantech’，选择并填写‘主设备地址’，修改标签名。

2、根据板卡的工作模式和标签所监控的参数物理意义，修改测量值零点、测量值量程、工程值零点、工程值量程、扫描周期、转换方式、记录属性等。单击‘添加’或‘完成’按钮。

标签的地址配置规则

标签的主地址可以按照下面的规则配置填写：

标签类型[ID:]Ch

说明：

  • ID指板卡号，用于识别设备中的不同板卡， 板卡号设定范围为0 ～ 31，十进制表示。

  • Ch指通道号，范围根据板卡类型不同，十进制表示。

  • 红色字表示格式中可变部分，变化范围参见各种 板卡的帮助文件。
  • 蓝色括号不出现在标签地址中，蓝色括号内的内容在设备中只包含一块板卡时可省略。
  • 标签地址配置成不存在类型或板卡地址错误或通道号超出有效范围时，标签将不被承认， 不能读/写数据。

标签地址

含义

数据类型

读写类型

标签值范围

AD ID:Ch

输入电压值

模拟量

只读

取决于板卡类型，请参阅相关帮助文件。

DA ID:Ch

输出电压值

模拟量

只写

DI ID:Ch

数字量输入

开关量

只读

DO ID:Ch

数字量输出

开关量

只写

Count ID:Ch

计数器

模拟量

只读

INI_Count ID:Ch

计数器初值 模拟量 只写

标签举例：

标签 ：AD0:0
数据值类型：模拟量
描述 ：表示0号板卡的第0通道模拟量输入值

标签 ：DA0:0
数据值类型：模拟量
描述 ：表示0号板卡的第0通道模拟量输出值

标签 ：DI0:0
数据值类型：开关量
描述 ：表示0号板卡的第0通道开关输入值

标签 ：DO0:0
数据值类型：开关量
描述 ：表示0号板卡的第0通道开关输出值

标签 ：Count0:0
数据值类型：模拟量
描述 ：表示0号板卡的第0个记数器通道当前值

标签 ：INI_Count0:0
数据值类型：模拟量
描述 ：表示0号板卡的第0个记数器通道初值


PCL711B

研华PCL 711B

硬件功能与特性 地址设置 标签地址及范围 标签举例 在线升级驱动

PCL711B的功能与特性

项目符号 | 8路12位单端模拟量输入
项目符号 | 软件调节输入电压范围，可选范围：±5V；±2.5V；±1.25V；±0.625V；±0.3125V
项目符号 | 支持多中AD触发方式
项目符号 | 1路12位模拟量输出
项目符号 | 输出电压范围为0～5V；0～10V
项目符号 | 16通道TTL数字量输出
项目符号 | 16通道TTL数字量输入

PCL711B的地址设置

在您使用PCL711B板卡时，请确认已经为板卡设定了唯一的地址，具体设置为：

默认地址：220H

地 址 线

A9

A8

A7

A6

A5

200

100

80

40

20

16 进制数

A4

10

ON

OFF

1

2

3

4

5

6

基地址选择范围000H～3F0H。当开关置ON位时，该位无效；开关置OFF位时，该位有效。
基地址计算公式如下：基地址 = 所有有效位之和
例：如上图所示：基地址 = 200H + 20H = 220H

PCL711B 支持的标签地址及范围

各种标签的详细解释请参见研华PCL系列板卡综述：

说明：

项目符号

ID指板卡号，用于识别设备中的不同板卡， 板卡号设定范围为0 ～ 31，十进制表示。

项目符号

Ch指通道号，范围根据板卡类型不同，十进制表示。

项目符号 | 红色字表示格式中可变部分，变化范围参见各种 板卡的帮助文件。
项目符号 | 蓝色括号不出现在标签地址中，蓝色括号内的内容在设备中只包含一块板卡时可省略。
项目符号 | 标签地址配置成不存在类型或板卡地址错误或通道号超出有效范围时，标签将不被承认， 不能读/写数据。

标签地址

含义

数据类型

读写类型

标签值范围

AD ID:Ch

输入电压值

模拟量

只读

0～7

DA ID:Ch

输出电压值

模拟量

只写

0

DI ID:Ch

数字量输入

开关量

只读

0～15

DO ID:Ch

数字量输出

开关量

只写

0～15

标签举例：

标签 ：AD0:0
数据值类型：模拟量
描述 ：表示0号板卡的第0通道模拟量输入值

标签 ：DA0:0
数据值类型：模拟量
描述 ：表示0号板卡的第0通道模拟量输出值

标签 ：DI0:0
数据值类型：开关量
描述 ：表示0号板卡的第0通道开关输入值

标签 ：DO0:0
数据值类型：开关量
描述 ：表示0号板卡的第0通道开关输出值


PCL720

研华PCL 720

PCL720的功能与特性

项目符号 | 32路TTL/DTL数字量输入
项目符号 | 32路TTL/DTL数字量输出
项目符号 | 3路16位定时/计数器
项目符号 | 输出驱动能力强
项目符号 | 低输入负载
项目符号 | 板载晶振提供时钟源

 PCL720的地址设置

在您使用PCL720板卡时，请确认已经为板卡设定了唯一的地址，具体设置为：

ON

OFF

1

2

3

4

5

6

默认地址：2A0H

地 址 线

A8

A7

A6

A5

A4

A3

100

80

40

20

10

8

16 进制数

基地址选择范围200H～3F8H。当开关置ON位时，该位无效；开关置OFF位时，该位有效。
基地址计算公式如下：基地址 = 200 + 所有有效位之和
例：如上图所示：基地址 = 200H + 80H + 20H = 2A0H

PCL720 支持的标签地址及范围

各种标签的详细解释请参见研华PCL系列板卡综述：

说明：

项目符号

ID指板卡号，用于识别设备中的不同板卡， 板卡号设定范围为0 ～ 31，十进制表示。

项目符号

Ch指通道号，范围根据板卡类型不同，十进制表示。

项目符号 | 红色字表示格式中可变部分，变化范围参见各种 板卡的帮助文件。
项目符号 | 蓝色括号不出现在标签地址中，蓝色括号内的内容在设备中只包含一块板卡时可省略。
项目符号 | 标签地址配置成不存在类型或板卡地址错误或通道号超出有效范围时，标签将不被承认， 不能读/写数据。

标签地址

含义

数据类型

读写类型

标签值范围

DI ID:Ch

数字量输入

开关量

只读

0～15

DO ID:Ch

数字量输出

开关量

只写

0～15

Count ID:Ch

计数器

模拟量

只读

0～2

INI_Count ID:Ch

计数器初值 模拟量 只写 0～2

标签举例：

标签 ：DI0:0
数据值类型：开关量
描述 ：表示0号板卡的第0通道开关输入值

标签 ：DO0:0
数据值类型：开关量
描述 ：表示0号板卡的第0通道开关输出值

标签 ：Count0:0
数据值类型：模拟量
描述 ：表示0号板卡的第0个记数器通道当前值

标签 ：INI_Count0:0
数据值类型：模拟量
描述 ：表示0号板卡的第0个记数器通道初值


PCL722

研华PCL 722

PCL722的功能与特性

项目符号 | 144路TTL数字量输出/输入
项目符号 | 输入/输出可以通过8255编程选择

 PCL722的地址设置

在您使用PCL722板卡时，请确认已经为板卡设定了唯一的地址，具体设置为：

ON

OFF

1

2

3

4

5

6

默认地址：2C0H

地 址 线

A9

A8

A7

A6

A5

A4

2 00

10 0

8 0

4 0

2 0

10

16 进制数

基地址选择范围200H～3FFH。当开关置ON位时，该位无效；开关置OFF位时，该位有效。
基地址计算公式如下：基地址 = 所有有效位之和
例：如上图所示：基地址 = 200H + 80H+ 40H = 2C0H

PCL722 支持的标签地址及范围

各种标签的详细解释请参见研华PCL系列板卡综述：

说明：

项目符号

ID指板卡号，用于识别设备中的不同板卡， 板卡号设定范围为0 ～ 31，十进制表示。

项目符号

Ch指通道号，范围根据板卡类型不同，十进制表示。

项目符号 | 红色字表示格式中可变部分，变化范围参见各种 板卡的帮助文件。
项目符号 | 蓝色括号不出现在标签地址中，蓝色括号内的内容在设备中只包含一块板卡时可省略。
项目符号 | 标签地址配置成不存在类型或板卡地址错误或通道号超出有效范围时，标签将不被承认， 不能读/写数据。

标签地址

含义

数据类型

读写类型

标签值范围

DI ID:Ch

数字量输入

开关量

只读

根据设定最大0～143

DO ID:Ch

数字量输出

开关量

只写

根据设定最大0～143

标签举例：

标签 ：DI0:0
数据值类型：开关量
描述 ：表示0号板卡的第0通道开关输入值

标签 ：DO0:0
数据值类型：开关量
描述 ：表示0号板卡的第0通道开关输出值


PCL724

研华PCL 724

PCL724的功能与特性

项目符号 | 24路TTL数字量输出/输入
项目符号 | 输入/输出可以通过8255编程选择

 PCL724的地址设置

在您使用PCL724板卡时，请确认已经为板卡设定了唯一的地址，具体设置为：

ON

OFF

1

2

3

4

5

6

默认地址：2C0

地 址 线

A8

A7

A6

A5

A4

A3

100

80

40

20

10

8

16 进制数

7

8

A2

4

基地址选择范围200H～3FFH。当开关置ON位时，该位无效；开关置OFF位时，该位有效。
基地址计算公式如下：基地址 =200H + 所有有效位之和
例：如上图所示：基地址 = 200H + 80H+ 40H = 2C0H

PCL724 支持的标签地址及范围

各种标签的详细解释请参见研华PCL系列板卡综述：

说明：

项目符号

ID指板卡号，用于识别设备中的不同板卡， 板卡号设定范围为0 ～ 31，十进制表示。

项目符号

Ch指通道号，范围根据板卡类型不同，十进制表示。

项目符号 | 红色字表示格式中可变部分，变化范围参见各种 板卡的帮助文件。
项目符号 | 蓝色括号不出现在标签地址中，蓝色括号内的内容在设备中只包含一块板卡时可省略。
项目符号 | 标签地址配置成不存在类型或板卡地址错误或通道号超出有效范围时，标签将不被承认， 不能读/写数据。

标签地址

含义

数据类型

读写类型

标签值范围

DI ID:Ch

数字量输入

开关量

只读

根据设定最大0～23

DO ID:Ch

数字量输出

开关量

只写

根据设定最大0～23

标签举例：

标签 ：DI0:0
数据值类型：开关量
描述 ：表示0号板卡的第0通道开关输入值

标签 ：DO0:0
数据值类型：开关量
描述 ：表示0号板卡的第0通道开关输出值


PCL725

研华PCL 725

PCL725的功能与特性

项目符号 | 8路继电器数字量输出
项目符号 | LED继电器状态指示灯
项目符号 | 8路光电隔离数字量输入
项目符号 | 跳线选择光电隔离/非光电隔离信号

 PCL725的地址设置

在您使用PCL725板卡时，请确认已经为板卡设定了唯一的地址，具体设置为：

ON

OFF

1

2

3

4

5

6

默认地址：2A8

地 址 线

A8

A7

A6

A5

A4

A3

100

80

40

20

10

8

16 进制数

7

8

A2

4

A1

2

基地址选择范围200H～3FEH。当开关置ON位时，该位无效；开关置OFF位时，该位有效。
基地址计算公式如下：基地址 = 200H + 所有有效位之和
例：如上图所示：基地址 = 200H + 80H+ 20H +8H = 2A8H

PCL725 支持的标签地址及范围

各种标签的详细解释请参见研华PCL系列板卡综述：

说明：

项目符号

ID指板卡号，用于识别设备中的不同板卡， 板卡号设定范围为0 ～ 31，十进制表示。

项目符号

Ch指通道号，范围根据板卡类型不同，十进制表示。

项目符号 | 红色字表示格式中可变部分，变化范围参见各种 板卡的帮助文件。
项目符号 | 蓝色括号不出现在标签地址中，蓝色括号内的内容在设备中只包含一块板卡时可省略。
项目符号 | 标签地址配置成不存在类型或板卡地址错误或通道号超出有效范围时，标签将不被承认， 不能读/写数据。

标签地址

含义

数据类型

读写类型

标签值范围

DI ID:Ch

数字量输入

开关量

只读

0～7

DO ID:Ch

数字量输出

开关量

只写

0～7

标签举例：

标签 ：DI0:0
数据值类型：开关量
描述 ：表示0号板卡的第0通道开关输入值

标签 ：DO0:0
数据值类型：开关量
描述 ：表示0号板卡的第0通道开关输出值


PCL726

研华PCL 726

PCL726的功能与特性

项目符号 | 6路12位独立模拟量输出通道
项目符号 | 多种电压量程可以选择：±10V；±5V；0～5V；0～10V；4～20mA
项目符号 | 16通道TTL数字量输出
项目符号 | 16通道TTL数字量输入

 PCL726的地址设置

在您使用PCL726板卡时，请确认已经为板卡设定了唯一的地址，具体设置为：

ON

OFF

1

2

3

4

5

默认地址：2C0

地 址 线

A8

A7

A6

A5

A4

100

80

40

20

10

16 进制数

基地址选择范围200H～3F0H。当开关置ON位时，该位无效；开关置OFF位时，该位有效。
基地址计算公式如下：基地址 =200H + 所有有效位之和
例：如上图所示：基地址 = 200H + 80H+ 40H = 2C0H

PCL726 支持的标签地址及范围

各种标签的详细解释请参见研华PCL系列板卡综述：

说明：

项目符号

ID指板卡号，用于识别设备中的不同板卡， 板卡号设定范围为0 ～ 31，十进制表示。

项目符号

Ch指通道号，范围根据板卡类型不同，十进制表示。

项目符号 | 红色字表示格式中可变部分，变化范围参见各种 板卡的帮助文件。
项目符号 | 蓝色括号不出现在标签地址中，蓝色括号内的内容在设备中只包含一块板卡时可省略。
项目符号 | 标签地址配置成不存在类型或板卡地址错误或通道号超出有效范围时，标签将不被承认， 不能读/写数据。

标签地址

含义

数据类型

读写类型

标签值范围

DA ID:Ch

输出电压值

模拟量

只写

0～5

DI ID:Ch

数字量输入

开关量

只读

0～15

DO ID:Ch

数字量输出

开关量

只写

0～15

标签举例：

标签 ：DA0:0
数据值类型：模拟量
描述 ：表示0号板卡的第0通道模拟量输出值

标签 ：DI0:0
数据值类型：开关量
描述 ：表示0号板卡的第0通道开关输入值

标签 ：DO0:0
数据值类型：开关量
描述 ：表示0号板卡的第0通道开关输出值


PCL728

研华PCL 728

PCL728的功能与特性

项目符号 | 2路12位模拟量输出
项目符号 | 电压输出范围为：双极性：±10V；±5V；单极性：0～10 V；0～5 V； 电流：0～20mA；4～20mA

 PCL728的地址设置

在您使用PCL728板卡时，请确认已经为板卡设定了唯一的地址，具体设置为：

默认地址：2C0

ON

OFF

1

2

3

4

5

地址线

A9

A8

A7

A6

A5

200

100

80

40

20

16 进制数

6

7

8

A4

A3

10

8

基地址选择范围200H～3F0H。当开关置ON位时，该位无效；开关置OFF位时，该位有效。
基地址计算公式如下：基地址 = 所有有效位之和
例：如上图所示：基地址 = 200H + 80H + 40H = 2C0H

PCL728 支持的标签地址及范围

各种标签的详细解释请参见研华PCL系列板卡综述：

说明：

项目符号

ID指板卡号，用于识别设备中的不同板卡， 板卡号设定范围为0 ～ 31，十进制表示。

项目符号

Ch指通道号，范围根据板卡类型不同，十进制表示。

项目符号 | 红色字表示格式中可变部分，变化范围参见各种 板卡的帮助文件。
项目符号 | 蓝色括号不出现在标签地址中，蓝色括号内的内容在设备中只包含一块板卡时可省略。
项目符号 | 标签地址配置成不存在类型或板卡地址错误或通道号超出有效范围时，标签将不被承认， 不能读/写数据。

标签地址

含义

数据类型

读写类型

标签值范围

DA ID:Ch

输出电压值

模拟量

只写

0 ～ 1

标签举例：

标签 ：DA0:0
数据值类型：模拟量
描述 ：表示0号板卡的第0通道模拟量输出值


PCL730

研华PCL 730

PCL730的功能与特性

项目符号 | 16路TTL数字量输入
项目符号 | 16路隔离数字量输入
项目符号 | 16路TTL数字量输出
项目符号 | 16路隔离数字量输出
项目符号 | 输出驱动能力强

 PCL730的地址设置

在您使用PCL730板卡时，请确认已经为板卡设定了唯一的地址，具体设置为：

默认地址：300H

ON

OFF

1

2

3

4

5

地 址 线

A9

A8

A7

A6

A5

200

100

80

40

20

16 进制数

6

7

8

A4

A3

10

8

4

A2

基地址选择范围200H～3F0H。当开关置ON位时，该位无效；开关置OFF位时，该位有效。
基地址计算公式如下：基地址 = 所有有效位之和
例：如上图所示：基地址 = 200H + 100H = 300H

PCL730 支持的标签地址及范围

各种标签的详细解释请参见研华PCL系列板卡综述：

说明：

项目符号

ID指板卡号，用于识别设备中的不同板卡， 板卡号设定范围为0 ～ 31，十进制表示。

项目符号

Ch指通道号，范围根据板卡类型不同，十进制表示。

项目符号 | 红色字表示格式中可变部分，变化范围参见各种 板卡的帮助文件。
项目符号 | 蓝色括号不出现在标签地址中，蓝色括号内的内容在设备中只包含一块板卡时可省略。
项目符号 | 标签地址配置成不存在类型或板卡地址错误或通道号超出有效范围时，标签将不被承认， 不能读/写数据。

标签地址

含义

数据类型

读写类型

标签值范围

DI ID:Ch

数字量输入

开关量

只读

0 ～ 31

DO ID:Ch

数字量输出

开关量

只写

0 ～ 31

标签举例：

标签 ：DI0:0
数据值类型：开关量
描述 ：表示0号板卡的第0通道开关输入值

标签 ：DO0:0
数据值类型：开关量
描述 ：表示0号板卡的第0通道开关输出值


PCL733

研华PCL 733

PCL733的功能与特性

项目符号

16路隔离数字量输入

PCL733的地址设置

在您使用PCL733板卡时，请确认已经为板卡设定了唯一的地址，具体设置为：

默认地址：300H

ON

OFF

1

2

3

4

5

地 址 线

A9

A8

A7

A6

A5

200

100

80

40

20

16 进制数

6

7

8

A4

A3

10

8

4

A2

基地址选择范围200H～3F0H。当开关置ON位时，该位无效；开关置OFF位时，该位有效。
基地址计算公式如下：基地址 = 所有有效位之和
例：如上图所示：基地址 = 200H + 100H = 300H

PCL733 支持的标签地址及范围

各种标签的详细解释请参见研华PCL系列板卡综述：

说明：

项目符号

ID指板卡号，用于识别设备中的不同板卡， 板卡号设定范围为0 ～ 31，十进制表示。

项目符号

Ch指通道号，范围根据板卡类型不同，十进制表示。

项目符号 | 红色字表示格式中可变部分，变化范围参见各种 板卡的帮助文件。
项目符号 | 蓝色括号不出现在标签地址中，蓝色括号内的内容在设备中只包含一块板卡时可省略。
项目符号 | 标签地址配置成不存在类型或板卡地址错误或通道号超出有效范围时，标签将不被承认， 不能读/写数据。

标签地址

含义

数据类型

读写类型

标签值范围

DI ID:Ch

数字量输入

开关量

只读

0 ～ 31

标签举例：

标签 ：DI0:0
数据值类型：开关量
描述 ：表示0号板卡的第0通道开关输入值


PCL734

研华PCL 734

PCL734的功能与特性

项目符号 | 32路隔离数字量输出
项目符号 | 驱动能力强

 PCL734的地址设置

在您使用PCL734板卡时，请确认已经为板卡设定了唯一的地址，具体设置为：

基地址选择范围200H～3FFH。当开关置ON位时，该位无效；开关置OFF位时，该位有效。
基地址计算公式如下：基地址 = 所有有效位之和
例：如上图所示：基地址 = 200H + 100H = 300H

PCL734 支持的标签地址及范围

各种标签的详细解释请参见研华PCL系列板卡综述：

说明：

  • ID指板卡号，用于识别设备中的不同板卡， 板卡号设定范围为0 ～ 31，十进制表示。

  • Ch指通道号，范围根据板卡类型不同，十进制表示。

  • 红色字表示格式中可变部分，变化范围参见各种 板卡的帮助文件。
  • 蓝色括号不出现在标签地址中，蓝色括号内的内容在设备中只包含一块板卡时可省略。
  • 标签地址配置成不存在类型或板卡地址错误或通道号超出有效范围时，标签将不被承认， 不能读/写数据。

标签地址

含义

数据类型

读写类型

标签值范围

DO ID:Ch

数字量输出

开关量

只写

0 ～ 31

标签举例：

标签 ：DO0:0
数据值类型：开关量
描述 ：表示0号板卡的第0通道开关输出值


PCL735

研华PCL 735

PCL735的功能与特性

项目符号 | 12路继电器数字量输出
项目符号 | LED继电器状态指示灯

 PCL735的地址设置

在您使用PCL735板卡时，请确认已经为板卡设定了唯一的地址，具体设置为：

默认地址：300H

ON

OFF

1

2

3

4

5

地 址 线

A9

A8

A7

A6

A5

200

100

80

40

20

16 进制数

6

7

8

A4

A3

10

8

4

A2

基地址选择范围200H～3FFH。当开关置ON位时，该位无效；开关置OFF位时，该位有效。
基地址计算公式如下：基地址 = 所有有效位之和
例：如上图所示：基地址 = 200H + 100H = 2C0H

PCL735 支持的标签地址及范围

各种标签的详细解释请参见研华PCL系列板卡综述：

说明：

项目符号

ID指板卡号，用于识别设备中的不同板卡， 板卡号设定范围为0 ～ 31，十进制表示。

项目符号

Ch指通道号，范围根据板卡类型不同，十进制表示。

项目符号 | 红色字表示格式中可变部分，变化范围参见各种 板卡的帮助文件。
项目符号 | 蓝色括号不出现在标签地址中，蓝色括号内的内容在设备中只包含一块板卡时可省略。
项目符号 | 标签地址配置成不存在类型或板卡地址错误或通道号超出有效范围时，标签将不被承认， 不能读/写数据。

标签地址

含义

数据类型

读写类型

标签值范围

DO ID:Ch

数字量输出

开关量

只写

0 ～ 11

标签举例：

标签 ：DO0:0
数据值类型：开关量
描述 ：表示0号板卡的第0通道开关输出值


PCL812PG

研华PCL 812PG

PCL812PG的功能与特性

项目符号 | 16路12位单端模拟量输入
项目符号 | 软件调节模拟量输入量程(双级性)：±5V；±2.5V；±1.25V；±0.625V；±0.3125V
项目符号 | 多种AD触发模式
项目符号 | 1路定时/记数器
项目符号 | 2路12位模拟量输出
项目符号 | 板卡提供-5V和-10V参考电压，模拟量输出量程为 0～5V；0～10V；通过外部电压量程可以改变
项目符号 | 16通道TTL数字量输出
项目符号 | 16通道TTL数字量输入

 PCL812PG的地址设置

在您使用PCL812PG板卡时，请确认已经为板卡设定了唯一的地址，具体设置为：

基地址选择范围200H～3F0H。当开关置ON位时，该位无效；开关置OFF位时，该位有效。
基地址计算公式如下：基地址 = 所有有效位之和
例：如上图所示：基地址 = 200H + 100H = 300H

PCL812PG 支持的标签地址及范围

各种标签的详细解释请参见研华PCL系列板卡综述：

说明：

  • ID指板卡号，用于识别设备中的不同板卡， 板卡号设定范围为0 ～ 31，十进制表示。

  • Ch指通道号，范围根据板卡类型不同，十进制表示。

  • 红色字表示格式中可变部分，变化范围参见各种 板卡的帮助文件。
  • 蓝色括号不出现在标签地址中，蓝色括号内的内容在设备中只包含一块板卡时可省略。
  • 标签地址配置成不存在类型或板卡地址错误或通道号超出有效范围时，标签将不被承认， 不能读/写数据。

标签地址

含义

数据类型

读写类型

标签值范围

AD ID:Ch

输入电压值

模拟量

只读

0 ～ 15

DA ID:Ch

输出电压值

模拟量

只写

0 ～ 1

DI ID:Ch

数字量输入

开关量

只读

0 ～ 15

DO ID:Ch

数字量输出

开关量

只写

0 ～ 15

Count ID:Ch

计数器

模拟量

只读

0

INI_Count ID:Ch

计数器初值 模拟量 只写 0

标签举例：

标签 ：AD0:0
数据值类型：模拟量
描述 ：表示0号板卡的第0通道模拟量输入值

标签 ：DA0:0
数据值类型：模拟量
描述 ：表示0号板卡的第0通道模拟量输出值

标签 ：DI0:0
数据值类型：开关量
描述 ：表示0号板卡的第0通道开关输入值

标签 ：DO0:0
数据值类型：开关量
描述 ：表示0号板卡的第0通道开关输出值

标签 ：Count0:0
数据值类型：模拟量
描述 ：表示0号板卡的第0个记数器通道当前值

标签 ：INI_Count0:0
数据值类型：模拟量
描述 ：表示0号板卡的第0个记数器通道初值


PCL813B

研华PCL 813B

PCL813B的功能与特性

项目符号 | 32路12位单端模拟量输入
项目符号 | 模拟量输入电压范围：单极性：±5V；±2.5V；±1.25V；±0.625V； 双极性：0～10V；0～5V；0～2.5V；0～1.25V

 PCL813B的地址设置

在您使用PCL813B板卡时，请确认已经为板卡设定了唯一的地址，具体设置为：

基地址选择范围000H～3F0H。当开关置ON位时，该位无效；开关置OFF位时，该位有效。
基地址计算公式如下：基地址 = 所有有效位之和
例：如上图所示：基地址 = 200H + 10H = 210H

PCL813B 支持的标签地址及范围

各种标签的详细解释请参见研华PCL系列板卡综述：

说明：

  • ID指板卡号，用于识别设备中的不同板卡， 板卡号设定范围为0 ～ 31，十进制表示。

  • Ch指通道号，范围根据板卡类型不同，十进制表示。

  • 红色字表示格式中可变部分，变化范围参见各种 板卡的帮助文件。
  • 蓝色括号不出现在标签地址中，蓝色括号内的内容在设备中只包含一块板卡时可省略。
  • 标签地址配置成不存在类型或板卡地址错误或通道号超出有效范围时，标签将不被承认， 不能读/写数据。

标签地址

含义

数据类型

读写类型

标签值范围

AD ID:Ch

输入电压值

模拟量

只读

0 ～ 31

标签举例：

标签 ：AD0:0
数据值类型：模拟量
描述 ：表示0号板卡的第0通道模拟量输入值


PCL818H

研华PCL 818H

PCL818H的功能与特性

项目符号 | 16路单端/8路差动12位模拟量输入
项目符号 | 1路12位模拟量输出
项目符号 | 1路16位定时/记数器
项目符号 | 16通道TTL/DTL数字量输出
项目符号 | 16通道TTL/DTL数字量输入
项目符号 | 模拟量输入电压范围：±5V；±2.5V；±1.25V；±0.625V；0～10V；0～5V；0～2.5V；0～1.25V
项目符号 | 多种AD触发模式
项目符号 | 板卡提供-5V和-10V参考电压，模拟量输出量程为 0～5V；0～10V；通过外部电压量程可以改变

 PCL818H的地址设置

在您使用PCL818H板卡时，请确认已经为板卡设定了唯一的地址，具体设置为：

默认地址：300H

ON

OFF

1

2

3

4

5

地 址 线

A9

A8

A7

A6

A5

200

100

80

40

20

16 进制数

6

A4

10

基地址选择范围000H～3FFH。当开关置ON位时，该位无效；开关置OFF位时，该位有效。
基地址计算公式如下：基地址 = 所有有效位之和
例：如上图所示：基地址 = 200H + 100H = 300H

PCL818H 支持的标签地址及范围

各种标签的详细解释请参见研华PCL系列板卡综述：

说明：

项目符号

ID指板卡号，用于识别设备中的不同板卡， 板卡号设定范围为0 ～ 31，十进制表示。

项目符号

Ch指通道号，范围根据板卡类型不同，十进制表示。

项目符号 | 红色字表示格式中可变部分，变化范围参见各种 板卡的帮助文件。
项目符号 | 蓝色括号不出现在标签地址中，蓝色括号内的内容在设备中只包含一块板卡时可省略。
项目符号 | 标签地址配置成不存在类型或板卡地址错误或通道号超出有效范围时，标签将不被承认， 不能读/写数据。

标签地址

含义

数据类型

读写类型

标签值范围

AD ID:Ch

输入电压值

模拟量

只读

单端0 ～ 15；差动0 ～ 7

DA ID:Ch

输出电压值

模拟量

只写

0

DI ID:Ch

数字量输入

开关量

只读

0 ～ 15

DO ID:Ch

数字量输出

开关量

只写

0 ～ 15

Count ID:Ch

计数器

模拟量

只读

0

INI_Count ID:Ch

计数器初值 模拟量 只写 0

标签举例：

标签 ：AD0:0
数据值类型：模拟量
描述 ：表示0号板卡的第0通道模拟量输入值

标签 ：DA0:0
数据值类型：模拟量
描述 ：表示0号板卡的第0通道模拟量输出值

标签 ：DI0:0
数据值类型：开关量
描述 ：表示0号板卡的第0通道开关输入值

标签 ：DO0:0
数据值类型：开关量
描述 ：表示0号板卡的第0通道开关输出值

标签 ：Count0:0
数据值类型：模拟量
描述 ：表示0号板卡的第0个记数器通道当前值

标签 ：INI_Count0:0
数据值类型：模拟量
描述 ：表示0号板卡的第0个记数器通道初值


PCL818HD

研华PCL 818HD

PCL818HD的功能与特性

项目符号 | 16路单端/8路差动12位模拟量输入
项目符号 | 1路12位模拟量输出
项目符号 | 16通道TTL/DTL数字量输出
项目符号 | 16通道TTL/DTL数字量输入
项目符号 | 1路16位定时/计数器
项目符号 | 模拟量输入电压范围：双级性：±5V；±2.5V；±1.25V；±0.625V；单级性：0～10V；0～5V；0～2.5V；0～1.25V
项目符号 | 板卡提供-5V和-10V参考电压，模拟量输出量程为 0～5V；0～10V；通过外部电压量程可以改变

 PCL818HD的地址设置

在您使用PCL818HD板卡时，请确认已经为板卡设定了唯一的地址，具体设置为：

基地址选择范围000H～3F0H。当开关置ON位时，该位无效；开关置OFF位时，该位有效。
基地址计算公式如下：基地址 = 所有有效位之和
例：如上图所示：基地址 = 200H + 100H = 300H

PCL818HD 支持的标签地址及范围

各种标签的详细解释请参见研华PCL系列板卡综述：

说明：

  • ID指板卡号，用于识别设备中的不同板卡， 板卡号设定范围为0 ～ 31，十进制表示。

  • Ch指通道号，范围根据板卡类型不同，十进制表示。

  • 红色字表示格式中可变部分，变化范围参见各种 板卡的帮助文件。
  • 蓝色括号不出现在标签地址中，蓝色括号内的内容在设备中只包含一块板卡时可省略。
  • 标签地址配置成不存在类型或板卡地址错误或通道号超出有效范围时，标签将不被承认， 不能读/写数据。

标签地址

含义

数据类型

读写类型

标签值范围

AD ID:Ch

输入电压值

模拟量

只读

单端0 ～ 15；差动0 ～ 7

DA ID:Ch

输出电压值

模拟量

只写

0

DI ID:Ch

数字量输入

开关量

只读

0 ～ 15

DO ID:Ch

数字量输出

开关量

只写

0 ～ 15

Count ID:Ch

计数器

模拟量

只读

0

INI_Count ID:Ch

计数器初值 模拟量 只写 0

标签举例：

标签 ：AD0:0
数据值类型：模拟量
描述 ：表示0号板卡的第0通道模拟量输入值

标签 ：DA0:0
数据值类型：模拟量
描述 ：表示0号板卡的第0通道模拟量输出值

标签 ：DI0:0
数据值类型：开关量
描述 ：表示0号板卡的第0通道开关输入值

标签 ：DO0:0
数据值类型：开关量
描述 ：表示0号板卡的第0通道开关输出值

标签 ：Count0:0
数据值类型：模拟量
描述 ：表示0号板卡的第0个记数器通道当前值

标签 ：INI_Count0:0
数据值类型：模拟量
描述 ：表示0号板卡的第0个记数器通道初值


PCL818HG

研华PCL 818HG

PCL818HG的功能与特性

项目符号 | 16路单端/8路差动12位模拟量输入
项目符号 | 1路12位模拟量输出
项目符号 | 16通道TTL/DTL数字量输出
项目符号 | 16通道TTL/DTL数字量输入
项目符号 | 1路16位定时/计数器
项目符号 | 模拟量输入电压范围：双级性：±10V；±5V；±1V；±0.5V；±0.1V；±0.05V；±0.01V；±0.005V；单级性：0～10V；0～1V；0～0.1V；0～0.01V
项目符号 | 板卡提供-5V和-10V参考电压，模拟量输出量程为 0～5V；0～10V；通过外部电压量程可以改变

 PCL818HG的地址设置

在您使用PCL818HG板卡时，请确认已经为板卡设定了唯一的地址，具体设置为：

基地址选择范围000H～3FFH。当开关置ON位时，该位无效；开关置OFF位时，该位有效。
基地址计算公式如下：基地址 = 所有有效位之和
例：如上图所示：基地址 = 200H + 100H = 300H

PCL818HG 支持的标签地址及范围

各种标签的详细解释请参见研华PCL系列板卡综述：

说明：

  • ID指板卡号，用于识别设备中的不同板卡， 板卡号设定范围为0 ～ 31，十进制表示。

  • Ch指通道号，范围根据板卡类型不同，十进制表示。

  • 红色字表示格式中可变部分，变化范围参见各种 板卡的帮助文件。
  • 蓝色括号不出现在标签地址中，蓝色括号内的内容在设备中只包含一块板卡时可省略。
  • 标签地址配置成不存在类型或板卡地址错误或通道号超出有效范围时，标签将不被承认， 不能读/写数据。

标签地址

含义

数据类型

读写类型

标签值范围

AD ID:Ch

输入电压值

模拟量

只读

单端0 ～ 15；差动0 ～ 7

DA ID:Ch

输出电压值

模拟量

只写

0

DI ID:Ch

数字量输入

开关量

只读

0 ～ 15

DO ID:Ch

数字量输出

开关量

只写

0 ～ 15

Count ID:Ch

计数器

模拟量

只读

0

INI_Count ID:Ch

计数器初值 模拟量 只写 0

标签举例：

标签 ：AD0:0
数据值类型：模拟量
描述 ：表示0号板卡的第0通道模拟量输入值

标签 ：DA0:0
数据值类型：模拟量
描述 ：表示0号板卡的第0通道模拟量输出值

标签 ：DI0:0
数据值类型：开关量
描述 ：表示0号板卡的第0通道开关输入值

标签 ：DO0:0
数据值类型：开关量
描述 ：表示0号板卡的第0通道开关输出值

标签 ：Count0:0
数据值类型：模拟量
描述 ：表示0号板卡的第0个记数器通道当前值

标签 ：INI_Count0:0
数据值类型：模拟量
描述 ：表示0号板卡的第0个记数器通道初值


PCL818L

研华PCL 818L

PCL818L的功能与特性

项目符号 | 16路单端/8路差动12位模拟量输入
项目符号 | 1路12位模拟量输出
项目符号 | 16通道TTL/DTL数字量输出(若支持模拟量扩展板，则仅可以使用8～16路数字量输出，其中0～7通道用语选择扩展板使用)
项目符号 | 16通道TTL/DTL数字量输入
项目符号 | 模拟量输入电压范围(双级性)：±10V；±5V；±2.5V；±1.25V和±5V；±2.5V；±1.25V；±0.625V
项目符号 | 板卡提供-5V和-10V参考电压，模拟量输出量程为 0～5V；0～10V；通过外部电压量程可以改变

注意：

1.若需要连接扩展板，则需要将AD输入方式设定在“差动”方式下，开物2000中也需要选择输入方式。

2. 若使用PCL789D扩展板，具体的通道配置如下，在PCL789D中可以通过跳线选择这一块扩展板连接在PCL818L的哪一个通道上，设选择在通道n上，则这一块扩展板的通道号为(n*16+0)～(n*16+15)，即如果选择通道2，则通道号为32～47；

3.如果使用扩展板，则16通道TTL/DTL数字量输出中仅可以使用8～16路数字量输出，其中0～7通道用于选择扩展板使用。

 PCL818L的地址设置

在您使用PCL818L板卡时，请确认已经为板卡设定了唯一的地址，具体设置为：

基地址选择范围000H～3FFH。当开关置ON位时，该位无效；开关置OFF位时，该位有效。
基地址计算公式如下：基地址 = 所有有效位之和
例：如上图所示：基地址 = 200H + 100H = 300H

PCL818L 支持的标签地址及范围

各种标签的详细解释请参见研华PCL系列板卡综述：

说明：

  • ID指板卡号，用于识别设备中的不同板卡， 板卡号设定范围为0 ～ 31，十进制表示。

  • Ch指通道号，范围根据板卡类型不同，十进制表示。

  • 红色字表示格式中可变部分，变化范围参见各种 板卡的帮助文件。
  • 蓝色括号不出现在标签地址中，蓝色括号内的内容在设备中只包含一块板卡时可省略。
  • 标签地址配置成不存在类型或板卡地址错误或通道号超出有效范围时，标签将不被承认， 不能读/写数据。

标签地址

含义

数据类型

读写类型

标签值范围

AD ID:Ch

输入电压值

模拟量

只读

单端0 ～ 15；差动0 ～ 7

DA ID:Ch

输出电压值

模拟量

只写

0

DI ID:Ch

数字量输入

开关量

只读

0 ～ 15

DO ID:Ch

数字量输出

开关量

只写

0 ～ 15

若支持模拟量扩展板，则仅可以使用8～16路数字量输出

标签举例：

标签 ：AD0:0
数据值类型：模拟量
描述 ：表示0号板卡的第0通道模拟量输入值

标签 ：DA0:0
数据值类型：模拟量
描述 ：表示0号板卡的第0通道模拟量输出值

标签 ：DI0:0
数据值类型：开关量
描述 ：表示0号板卡的第0通道开关输入值

标签 ：DO0:0
数据值类型：开关量
描述 ：表示0号板卡的第0通道开关输出值


PCL818LS

研华PCL 818LS

PCL818LS的功能与特性

项目符号 | 16路单端/8路差动12位模拟量输入
项目符号 | 1路12位模拟量输出
项目符号 | 16通道TTL/DTL数字量输出
项目符号 | 16通道TTL/DTL数字量输入
项目符号 | 模拟量输入电压范围(双级性)：±10V；±5V；±2.5V；±1.25V和±5V；±2.5V；±1.25V；±0.625V
项目符号 | 板卡提供-5V和-10V参考电压，模拟量输出量程为 0～5V；0～10V；通过外部电压量程可以改变

 PCL818LS的地址设置

在您使用PCL818LS板卡时，请确认已经为板卡设定了唯一的地址，具体设置为：

默认地址：300H

ON

OFF

1

2

3

4

5

地 址 线

A9

A8

A7

A6

A5

200

100

80

40

20

16 进制数

6

A4

10

基地址选择范围000H～3FFH。当开关置ON位时，该位无效；开关置OFF位时，该位有效。
基地址计算公式如下：基地址 = 所有有效位之和
例：如上图所示：基地址 = 200H + 100H = 300H

PCL818LS 支持的标签地址及范围

各种标签的详细解释请参见研华PCL系列板卡综述：

说明：

项目符号

ID指板卡号，用于识别设备中的不同板卡， 板卡号设定范围为0 ～ 31，十进制表示。

项目符号

Ch指通道号，范围根据板卡类型不同，十进制表示。

项目符号 | 红色字表示格式中可变部分，变化范围参见各种 板卡的帮助文件。
项目符号 | 蓝色括号不出现在标签地址中，蓝色括号内的内容在设备中只包含一块板卡时可省略。
项目符号 | 标签地址配置成不存在类型或板卡地址错误或通道号超出有效范围时，标签将不被承认， 不能读/写数据。

标签地址

含义

数据类型

读写类型

标签值范围

AD ID:Ch

输入电压值

模拟量

只读

单端0 ～ 15；差动0 ～ 7

DA ID:Ch

输出电压值

模拟量

只写

0

DI ID:Ch

数字量输入

开关量

只读

0 ～ 15

DO ID:Ch

数字量输出

开关量

只写

0 ～ 15

标签举例：

标签 ：AD0:0
数据值类型：模拟量
描述 ：表示0号板卡的第0通道模拟量输入值

标签 ：DA0:0
数据值类型：模拟量
描述 ：表示0号板卡的第0通道模拟量输出值

标签 ：DI0:0
数据值类型：开关量
描述 ：表示0号板卡的第0通道开关输入值

标签 ：DO0:0
数据值类型：开关量
描述 ：表示0号板卡的第0通道开关输出值


PCL836

研华PCL 836

PCL836的功能与特性

项目符号 | 6路16位定时/计数器
项目符号 | 16通道TTL/DTL数字量输出
项目符号 | 16通道TTL/DTL数字量输入
项目符号 | 输入频率最大为10M
项目符号 | 板卡提供10M时钟基准

 PCL836的地址设置

在您使用PCL836板卡时，请确认已经为板卡设定了唯一的地址，具体设置为：

默认地址：240H

ON

OFF

1

2

3

4

5

地 址 线

A9

A8

A7

A6

A5

200

100

80

40

20

16 进制数

基地址选择范围200H～3E0H。当开关置ON位时，该位无效；开关置OFF位时，该位有效。
基地址计算公式如下：基地址 = 所有有效位之和
例：如上图所示：基地址 = 200H + 40H = 240H

PCL836 支持的标签地址及范围

各种标签的详细解释请参见研华PCL系列板卡综述：

说明：

项目符号

ID指板卡号，用于识别设备中的不同板卡， 板卡号设定范围为0 ～ 31，十进制表示。

项目符号

Ch指通道号，范围根据板卡类型不同，十进制表示。

项目符号 | 红色字表示格式中可变部分，变化范围参见各种 板卡的帮助文件。
项目符号 | 蓝色括号不出现在标签地址中，蓝色括号内的内容在设备中只包含一块板卡时可省略。
项目符号 | 标签地址配置成不存在类型或板卡地址错误或通道号超出有效范围时，标签将不被承认， 不能读/写数据。

标签地址

含义

数据类型

读写类型

标签值范围

DI ID:Ch

数字量输入

开关量

只读

0 ～ 15

DO ID:Ch

数字量输出

开关量

只写

0 ～ 15

Count ID:Ch

计数器

模拟量

只读

0 ～ 5

INI_Count ID:Ch

计数器初值 模拟量 只写 0 ～ 5

标签举例：

标签 ：DI0:0
数据值类型：开关量
描述 ：表示0号板卡的第0通道开关输入值

标签 ：DO0:0
数据值类型：开关量
描述 ：表示0号板卡的第0通道开关输出值

标签 ：Count0:0
数据值类型：模拟量
描述 ：表示0号板卡的第0个记数器通道当前值

标签 ：INI_Count0:0
数据值类型：模拟量
描述 ：表示0号板卡的第0个记数器通道初值