泓格IO板卡

概述 硬件 设置 创建设备 创建标签 标签的地址规则 标签举例 在线升级驱动

泓格A系列板卡概述

泓格科技作为自动化国际领导厂商，产品覆盖工业自动化、网络和嵌入式系统等领域。泓格板卡稳定性好，功能强大，在工业自动化领域有着广泛的应用。

开物2000系统支持下面类型的泓格A板卡系列：

项目符号

A 726 ：6路12位模拟量输出；16通道TTL数字量输出；16通道TTL数字量输入

项目符号

A728 ：2路12位模拟量输出

项目符号

A812PG：16路12位单端模拟量输入；2路12位模拟量输出；1路16位定时/记数器；16通道TTL/DTL数字量输出；16通道TTL/DTL数字量输入

关于A系列板卡的更详细信息请访问 泓格公司网站。

开物2000还支持其它多种设备，详情请与 华富惠通公司联系。

泓格A系列板卡的硬件设置

泓格A系列板卡采用ISA总线形式，占用计算机的ISA插槽。在您使用 泓格系列板卡时，请确认已经准确设定了一些板卡基本信息，主要包括板卡基地址、DA参考电压选择、内部电压选择、时钟选择、FIFO使能、触发方式选择、中断选择，电压方式选择等。其中型号 不同，板卡的硬件设置可能会不同，详细设置情况清参阅板卡说明书。

在开物2000开发环境中创建设备

在开发环境的‘硬件系统’中按照‘新节点和设备向导’的指示配置所连接的模块。以便于开物2000识别和使用。

步骤1：选择‘板卡’设备类型。双击‘泓格IO板卡’，或单击选中‘泓格IO板卡’，更改设备名称， 然后单击‘选择’按钮。

步骤2：选择操作方式-新建设备(一个设备中可以包含多个模块)。选中‘新建设备’后单击‘下一步’按钮(或双击‘新建设备’)。

步骤3：显示‘泓格IO板卡’配置向导界面。在向导配置界面设定板卡的类型、板卡号、基地址、输入方式、极性、AD滤波次数、量程等选项。 其中板卡类型为用户使用的板卡型号；板卡号为板卡基地址；输入方式为单端还是差动；极性为单极性还是双极性；AD滤波次数为滤除干扰而设计，算法为：若取10则将采集到的10个数据按照大小顺序排列，取中间1/3数据的平均值。单击‘完成’按钮，结束设备配置向导。

标签的创建

使用‘设备向导’创建完成板卡后，可以进行标签设计。

1、在开发环境的‘标签’中添加标签，显示下图，选择主设备为上面的‘Advantech’，选择并填写‘主设备地址’，修改标签名。

2、根据板卡的工作模式和标签所监控的参数物理意义，修改测量值零点、测量值量程、工程值零点、工程值量程、扫描周期、转换方式、记录属性等。单击‘添加’或‘完成’按钮。

标签的地址配置规则

标签的主地址可以按照下面的规则配置填写：

标签类型[ID:]Ch

说明：

  • ID指板卡号，用于识别设备中的不同板卡， 板卡号设定范围为0 ～ 31，十进制表示。

  • Ch指通道号，范围根据板卡类型不同，十进制表示。

  • 红色字表示格式中可变部分，变化范围参见各种 板卡的帮助文件。
  • 蓝色括号不出现在标签地址中，蓝色括号内的内容在设备中只包含一块板卡时可省略。
  • 标签地址配置成不存在类型或板卡地址错误或通道号超出有效范围时，标签将不被承认， 不能读/写数据。

标签地址

含义

数据类型

读写类型

标签值范围

AD ID:Ch

输入电压值

模拟量

只读

取决于板卡类型，请参阅相关帮助文件。

DA ID:Ch

输出电压值

模拟量

只写

DI ID:Ch

数字量输入

开关量

只读

DO ID:Ch

数字量输出

开关量

只写

Count ID:Ch

计数器

模拟量

只读

INI_Count ID:Ch

计数器初值 模拟量 只写

标签举例：

标签 ：AD0:0
数据值类型：模拟量
描述 ：表示0号板卡的第0通道模拟量输入值

标签 ：DA0:0
数据值类型：模拟量
描述 ：表示0号板卡的第0通道模拟量输出值

标签 ：DI0:0
数据值类型：开关量
描述 ：表示0号板卡的第0通道开关输入值

标签 ：DO0:0
数据值类型：开关量
描述 ：表示0号板卡的第0通道开关输出值

标签 ：Count0:0
数据值类型：模拟量
描述 ：表示0号板卡的第0个记数器通道当前值

标签 ：INI_Count0:0
数据值类型：模拟量
描述 ：表示0号板卡的第0个记数器通道初值


A726

泓格A72 6

硬件功能与特性 地址设置 标签地址及范围 标签举例 在线升级驱动

A726的功能与特性

项目符号 | 6路12位独立模拟量输出通道
项目符号 | 多种电压量程可以选择：±10V；±5V；0～5V；0～10V；4～20mA
项目符号 | 16通道TTL数字量输出
项目符号 | 16通道TTL数字量输入

 A726的地址设置

在您使用A726板卡时，请确认已经为板卡设定了唯一的地址，具体设置为：

ON

OFF

1

2

3

4

5

默认地址：2C0

地 址 线

A8

A7

A6

A5

A4

100

80

40

20

10

16 进制数

基地址选择范围200H～3F0H。当开关置ON位时，该位无效；开关置OFF位时，该位有效。
基地址计算公式如下：基地址 =200H + 所有有效位之和
例：如上图所示：基地址 = 200H + 80H+ 40H = 2C0H

A726 支持的标签地址及范围

各种标签的详细解释请参见泓格IO板卡：

说明：

项目符号

ID指板卡号，用于识别设备中的不同板卡， 板卡号设定范围为0 ～ 31，十进制表示。

项目符号

Ch指通道号，范围根据板卡类型不同，十进制表示。

项目符号 | 红色字表示格式中可变部分，变化范围参见各种 板卡的帮助文件。
项目符号 | 蓝色括号不出现在标签地址中，蓝色括号内的内容在设备中只包含一块板卡时可省略。
项目符号 | 标签地址配置成不存在类型或板卡地址错误或通道号超出有效范围时，标签将不被承认， 不能读/写数据。

标签地址

含义

数据类型

读写类型

标签值范围

DA ID:Ch

输出电压值

模拟量

只写

0～5

DI ID:Ch

数字量输入

开关量

只读

0～15

DO ID:Ch

数字量输出

开关量

只写

0～15

标签举例：

标签 ：DA0:0
数据值类型：模拟量
描述 ：表示0号板卡的第0通道模拟量输出值

标签 ：DI0:0
数据值类型：开关量
描述 ：表示0号板卡的第0通道开关输入值

标签 ：DO0:0
数据值类型：开关量
描述 ：表示0号板卡的第0通道开关输出值


A728

泓格A72 8

硬件功能与特性 地址设置 标签地址及范围 标签举例 在线升级驱动

A728的功能与特性

项目符号 | 8路12位独立模拟量输出通道
项目符号 | 多种电压量程可以选择：±10V；±5V；0～5V；0～10V；4～20mA
项目符号 | 16通道TTL数字量输出
项目符号 | 16通道TTL数字量输入

 A728的地址设置

在您使用A728板卡时，请确认已经为板卡设定了唯一的地址，具体设置为：

ON

OFF

1

2

3

4

5

默认地址：2C0

地 址 线

A8

A7

A6

A5

A4

100

80

40

20

10

16 进制数

基地址选择范围200H～3F0H。当开关置ON位时，该位无效；开关置OFF位时，该位有效。
基地址计算公式如下：基地址 =200H + 所有有效位之和
例：如上图所示：基地址 = 200H + 80H+ 40H = 2C0H

A728 支持的标签地址及范围

各种标签的详细解释请参见泓格IO板卡：

说明：

项目符号

ID指板卡号，用于识别设备中的不同板卡， 板卡号设定范围为0 ～ 31，十进制表示。

项目符号

Ch指通道号，范围根据板卡类型不同，十进制表示。

项目符号 | 红色字表示格式中可变部分，变化范围参见各种 板卡的帮助文件。
项目符号 | 蓝色括号不出现在标签地址中，蓝色括号内的内容在设备中只包含一块板卡时可省略。
项目符号 | 标签地址配置成不存在类型或板卡地址错误或通道号超出有效范围时，标签将不被承认， 不能读/写数据。

标签地址

含义

数据类型

读写类型

标签值范围

DA ID:Ch

输出电压值

模拟量

只写

0～7

DI ID:Ch

数字量输入

开关量

只读

0～15

DO ID:Ch

数字量输出

开关量

只写

0～15

标签举例：

标签 ：DA0:0
数据值类型：模拟量
描述 ：表示0号板卡的第0通道模拟量输出值

标签 ：DI0:0
数据值类型：开关量
描述 ：表示0号板卡的第0通道开关输入值

标签 ：DO0:0
数据值类型：开关量
描述 ：表示0号板卡的第0通道开关输出值


A812PG

泓格A81 2PG

硬件功能与特性 地址设置 标签地址及范围 标签举例 在线升级驱动

A812PG的功能与特性

项目符号 | 16路12位单端/8路差动模拟量输入
项目符号 | 软件调节模拟量输入量程(双级性)：±10V；±5V；±2.5V；±1.25V；±0.625V；±0.3125V
项目符号 | 多种AD触发模式
项目符号 | 1路定时/记数器
项目符号 | 2路12位模拟量输出
项目符号 | 板卡提供-5V和-10V参考电压，模拟量输出量程为 0～5V；0～10V；通过外部电压量程可以改变
项目符号 | 16通道TTL数字量输出
项目符号 | 16通道TTL数字量输入

 A812PG的地址设置

在您使用A812PG板卡时，请确认已经为板卡设定了唯一的地址，具体设置为：

文本框: 地 址 线

基地址选择范围200H～3F0H。当开关置ON位时，该位无效；开关置OFF位时，该位有效。
基地址计算公式如下：基地址 = 所有有效位之和
例：如上图所示：基地址 = 200H + 20H = 220H

A812PG 支持的标签地址及范围

各种标签的详细解释请参见泓格IO板卡：

说明：

  • ID指板卡号，用于识别设备中的不同板卡， 板卡号设定范围为0 ～ 31，十进制表示。

  • Ch指通道号，范围根据板卡类型不同，十进制表示。

  • 红色字表示格式中可变部分，变化范围参见各种 板卡的帮助文件。
  • 蓝色括号不出现在标签地址中，蓝色括号内的内容在设备中只包含一块板卡时可省略。
  • 标签地址配置成不存在类型或板卡地址错误或通道号超出有效范围时，标签将不被承认， 不能读/写数据。

标签地址

含义

数据类型

读写类型

标签值范围

AD ID:Ch

输入电压值

模拟量

只读

0 ～ 15

DA ID:Ch

输出电压值

模拟量

只写

0 ～ 1

DI ID:Ch

数字量输入

开关量

只读

0 ～ 15

DO ID:Ch

数字量输出

开关量

只写

0 ～ 15

Count ID:Ch

计数器

模拟量

只读

0

INI_Count ID:Ch

计数器初值 模拟量 只写 0

标签举例：

标签 ：AD0:0
数据值类型：模拟量
描述 ：表示0号板卡的第0通道模拟量输入值

标签 ：DA0:0
数据值类型：模拟量
描述 ：表示0号板卡的第0通道模拟量输出值

标签 ：DI0:0
数据值类型：开关量
描述 ：表示0号板卡的第0通道开关输入值

标签 ：DO0:0
数据值类型：开关量
描述 ：表示0号板卡的第0通道开关输出值

标签 ：Count0:0
数据值类型：模拟量
描述 ：表示0号板卡的第0个记数器通道当前值

标签 ：INI_Count0:0
数据值类型：模拟量
描述 ：表示0号板卡的第0个记数器通道初值