宏拓PCI系列板卡综述

概述 硬件 设置 创建设备 创建标签 标签的地址规则 标签举例 在线升级驱动

宏拓PCI系列板卡概述

北京宏拓控制技术有限责任公司是一家专门从事工业过程控制产品和工程的开发、生产、销售及服务的专业测控技术公司。

开物2000系统支持下面类型的宏拓PCI板卡系列：

项目符号

PCI7505：16路光电隔离 型开关量输入；16路光电隔离型开关量输出

关于PCI系列板卡的更详细信息请访问 宏拓公司网站。

开物2000还支持其它多种设备，详情请与 华富惠通公司联系。

宏拓PCI系列板卡的硬件设置

宏拓PCI系列板卡采用PCI总线形式，占用计算机的PCI插槽。在您使用研华系列板卡时，请确认已经准确设定了一些板卡基本信息，主要包括DA参考电压选择、内部电压选择、时钟选择、FIFO使能、触发方式选择、中断选择，电压方式选择等。其中型号不同，板卡的硬件设置可能会不同，详细设置情况清参阅板卡说明书。

在开物2000开发环境中创建设备

在开发环境的‘硬件系统’中按照‘新节点和设备向导’的指示配置所连接的模块。以便于开物2000识别和使用。

步骤1：选择‘板卡’设备类型。双击‘宏拓PCI系列板卡’，或单击选中‘宏拓PCI系列板卡’，更改设备名称， 然后单击‘选择’按钮。

步骤2：选择操作方式-新建设备(一个设备中可以包含多个模块)。选中‘新建设备’后单击‘下一步’按钮(或双击‘新建设备’)。

步骤3：显示‘宏拓PCI系列板卡’配置向导界面。在向导配置界面设定板卡的类型、板卡号、基地址、输入方式、极性、AD滤波次数、量程等选项。 其中板卡类型为用户使用的板卡型号；板卡号为板卡基地址；输入方式为单端还是差动；极性为单极性还是双极性；AD滤波次数为滤除干扰而设计，算法为：若取10则将采集到的10个数据按照大小顺序排列，取中间1/3数据的平均值。单击‘完成’按钮，结束设备配置向导。

标签的创建

使用‘设备向导’创建完成板卡后，可以进行标签设计。

1、在开发环境的‘标签’中添加标签，显示下图，选择主设备为上面的‘Hotec_PCI’，选择并填写‘主设备地址’，修改标签名。

2、根据板卡的工作模式和标签所监控的参数物理意义，修改测量值零点、测量值量程、工程值零点、工程值量程、扫描周期、转换方式、记录属性等。单击‘添加’或‘完成’按钮。

标签的地址配置规则

标签的主地址可以按照下面的规则配置填写：

标签类型[ID:]Ch

说明：

项目符号

ID指板卡号，用于识别设备中的不同板卡， 板卡号设定范围为0 ～ 31，十进制表示。

项目符号

Ch指通道号，范围根据板卡类型不同，十进制表示。

项目符号 | 红色字表示格式中可变部分，变化范围参见各种 板卡的帮助文件。
项目符号 | 蓝色括号不出现在标签地址中，蓝色括号内的内容在设备中只包含一块板卡时可省略。
项目符号 | 标签地址配置成不存在类型或板卡地址错误或通道号超出有效范围时，标签将不被承认， 不能读/写数据。

标签地址

含义

数据类型

读写类型

标签值范围

AD ID:Ch

输入电压值

模拟量

只读

取决于板卡类型，请参阅相关帮助文件。

DA ID:Ch

输出电压值

模拟量

只写

DI ID:Ch

数字量输入

开关量

只读

DO ID:Ch

数字量输出

开关量

只写

Count ID:Ch

计数器

模拟量

只读

INI_Count ID:Ch

计数器初值 模拟量 只写

标签举例：

标签 ：AD0:0
数据值类型：模拟量
描述 ：表示0号板卡的第0通道模拟量输入值

标签 ：DA0:0
数据值类型：模拟量
描述 ：表示0号板卡的第0通道模拟量输出值

标签 ：DI0:0
数据值类型：开关量
描述 ：表示0号板卡的第0通道开关输入值

标签 ：DO0:0
数据值类型：开关量
描述 ：表示0号板卡的第0通道开关输出值

标签 ：Count0:0
数据值类型：模拟量
描述 ：表示0号板卡的第0个记数器通道当前值

标签 ：INI_Count0:0
数据值类型：模拟量
描述 ：表示0号板卡的第0个记数器通道初值


PCI7505

宏拓 PCI7505

硬件功能与特性 地址设置 标签地址及范围 标签举例 在线升级驱动

PCI7505的功能与特性

项目符号 | 符合PCI总线标准
项目符号 | 独立光电隔离型16路开关量输入
项目符号 | 独立光电隔离型16路电平或功率输出板
项目符号 | 各输出信号具有锁存功能，最大驱动能力为＋24V/200mA
项目符号 | 工作电压：5V±0.25V
项目符号 | 工作温度：0℃～50℃
项目符号 | 湿度：5%～95%
项目符号 | 工作电流： <200mA
项目符号 | 外部工作电压：24V±1.0V或12V±0.5V

 PCI7505的地址设置

PCI7505总线地址为浮动地址，由PCI总线协议分配，用户在使用PCI7505板卡时不必关心具体的板口地址。

PCI7505 支持的标签地址及范围

各种标签的详细解释请参见宏拓PCI系列板卡综述：

说明：

项目符号

ID指板卡号，用于识别设备中的不同板卡， 板卡号设定范围为0 ～ 31，十进制表示。

项目符号

Ch指通道号，范围根据板卡类型不同，十进制表示。

项目符号 | 红色字表示格式中可变部分，变化范围参见各种 板卡的帮助文件。
项目符号 | 蓝色括号不出现在标签地址中，蓝色括号内的内容在设备中只包含一块板卡时可省略。
项目符号 | 标签地址配置成不存在类型或板卡地址错误或通道号超出有效范围时，标签将不被承认， 不能读/写数据。

标签地址

含义

数据类型

读写类型

标签值范围

DI ID:Ch

数字量输入

开关量

只读

0 ～ 15

DO ID:Ch

数字量输出

开关量

只写

0 ～ 15

标签举例：

标签 ：DI0:0
数据值类型：开关量
描述 ：表示0号板卡的第0通道开关输入值

标签 ：DO0:0
数据值类型：开关量
描述 ：表示0号板卡的第0通道开关输出值