华控HY6000系列板卡综述

华控HY6000/8000系列板卡综述

板卡概述 硬件 设置 创建设备 创建标签 标签的地址规则 标签举例 在线升级驱动

华控HY6000/8000系列板卡概述

北京华控技术有限责任公司是专业从事自动化控制技术的研究及自动化产品及项目的开发、制造与销售服务的企业。公司成立以来，一直坚持纵向一体化发展战略，对现场总线技术这一领域持续投入了大量的人力和财力，并取得了长足的进步。短短几年，公司产品已发展为多种现场总线，四大类别，十几个系列，几百个品种规格。形成了以现场总线技术为主的核心技术体系。

开物2000系统支持下面类型的华控HY6000/8000板卡系列：

项目符号

HY6020 ：32路12位单端模拟量输入；1路12位模拟量输出

项目符号

HY6021 ：32路12位单端模拟量输入

项目符号

HY6022 ：32路12位单端模拟量输入；1路12位模拟量输出

项目符号

HY6023 ：32路12位单端模拟量输入

项目符号

HY6080 ：8路8位模拟量输出；8路TTL数字量输出；8路TTL数字量输入

项目符号

HY8021A ：16路单端/16路伪双端/8路差动12位模拟量输入，2路12位模拟量输出 ，8路数字量输入通道，8路数字量输出通道

项目符号

HY8021B ：16路单端/16路伪双端/8路差动12位模拟量输入，2路12位模拟量输出 ，8路数字量输入通道，8路数字量输出通道

项目符号

HY8021C ：16路单端/16路伪双端/8路差动12位模拟量输入，2路12位模拟量输出

项目符号

HY8021D ：16路单端/16路伪双端/8路差动12位模拟量输入，2路12位模拟量输出

项目符号

HY8021E ：16路单端/16路伪双端/8路差动12位模拟量输入，2路12位模拟量输出

关于HY6000/8000系列板卡的更详细信息请访问 华控公司网站 。

开物2000还支持其它多种设备，详情请与 华富惠通公司 联系。

华控HY6020系列板卡的硬件设置

华控HY6000/8000系列板卡采用ISA总线形式，占用计算机的ISA插槽。在您使用 华控K系列板卡时，请确认已经准确设定了一些板卡基本信息，主要包括板卡基地址、 量程选择、DA参考电压选择、时钟选择、触发方式选择、中断选择，电压方式选择等。其中型号不同，板卡的硬件设置可能会不同，详细设置情况清参阅板卡说明书。

注意：

华控6020系列板卡可以工作在流水工作方式和HY1232兼容工作方式下，在使用过程中一定要注意保持跳线位于HY1232兼容工作方式下，具体跳线方式如下：

在开物2000开发环境中创建设备

在开发环境的“硬件系统”中按照“新节点和设备向导”的指示配置所连接的 板卡。以便于开物2000识别和使用。

步骤1：选择”板卡“设备类型。双击“华控IO板卡”，或单击选中“华控IO板卡”，这里可以查看“驱动版本号”，更改设备名称， 如“HY” ，然后单击“选择”按钮。

步骤2：在”华控IO板卡向导“中选择执行的操作方式——“新建设备”。选中“新建设备”后单击”下一步”按钮(或双击“新建设备”)，您也可以选择“修改设备”，对板卡的配置进行修改或者选择“察看设备”浏览已经设置好的板卡配置情况。

其中下面的按钮的含义分别为：

下载最新驱动：可以帮助您进入开物技术支持网站的下载专区中；

帮助信息：可以查看驱动的版本等信息；

调试设置：通常情况下“调试开关”打开，这时可以记录开物的基本信息，主要包括启动和退出的时间，标签情况，通讯情况等信息；如果把“输出错误信息”和“输出跟踪信息”也选中的话，这时将记录开物运行过程中的全部通讯信息，对于记录通讯过程中的错误信息很有帮助，如果您在使用开物过程中，硬件连接有问题时，请打开所有调试开关，将通讯信息记录下来，待整个通讯工程正常后，请您把“输出错误信息”和“输出跟踪信息”关闭。

注意：整个信息将存成LOG文件，在相应工程目录下面的“DEBUG”子目录下，文件名以驱动DLL文件加上日期的方式命名，如kxric2003-7-10.log。

步骤3：在"华控IO板卡向导"中选择创建设备的方式——包括“单个板卡创建”和“多个板卡创建”。其中：

单个板卡创建：指在一个设备中创建一块板卡；

多个板卡创建：指在一个设备中创建多个同型号子板卡，当然您也可以建立多个设备从而实现多块板卡的连接。

步骤4：在”华控IO板卡向导“中选择板卡安装，主要包括板卡号、板卡类型、基地址、AD输入方式、AD最大范围(或AD输入极性)、AD滤波次数、量程选择等选项。 其中：

板卡号：如果为多个板卡创建，则须填写板卡号，以便于开物2000对板卡设备的识别；如果为单个板卡创建则没有这个选项。

板卡类型：指用户使用的板卡型号，通过下拉菜单选择；

基址(16进制)：指16进制板卡基地址；

AD输入方式：指AD信号是单端还是差动；

AD最大范围(或AD输入极性)：选择AD信号的输入极性为单极性还是双极性(或者AD的输入极性为单极性或双极性)；

AD滤波次数：为滤除干扰而设计，算法为：若设定为10，则将采集到的10个数据按照大小顺序排列，取中间1/3数据的平均值，这个过程在驱动中完成，您可以根据板卡使用情况调节AD滤波次数。

标签的创建

使用“华控IO板卡向导”完成板卡设备的创建后，可以进行标签设计。

1、在开发环境的“标签”击鼠标右键，选择“添加标签“，显示见下图，选择主设备为上面的‘Kxric，选择并填写‘主设备地址’，修改标签名。

开物的板卡驱动程序可以实现以下功能：模拟量输入、模拟量输出、数字量输入、数字量输出、定时/记数等功能。各部分功能在开物中对应的标签为：

AD：模拟量输入功能；

DA：模拟量输出功能；

DI：数字量输入功能；

DO：数字量输出功能；

INI_Count：为定时/记数器设定的初始值；

Count：为定时/记数器的当前值。

在板卡类设备中，标签的配置规则为：若为单个板卡创建，格式为： 标签+通道号，如AD0、DA3、DI5、DO6、Count2、INI_Count2等；若为多个设备创建，则格式为： 标签+板卡号+“:”+通道号，如AD0:0、DA0:3、DI1:5、DO0:6、Count0:2、INI_Count0:2；

2、根据您的特定使用需求，修改测量值和工程值的最大值、最小值、扫描周期等属性。单击‘添加’或‘完成’按钮。其中：

测量值最大值：设定为板卡当前量程的上限值；

测量值最小值：设定为板卡当前量程的下限值；

工程值最大值：设定为实际物理参数的上限值；

工程值最小值：设定为实际物理参数的下限值；

如：板卡的量程选择为：0 ～ 10V，对应现场的力信号为0 ～ 1000N，则测量值最大值设为 10；最小值设为 0；工程值最大值设为 1000；最小值设为 0。

请注意：假如只测量外界的电压信号则不需要更改测量值和工程值的最大值、 最小值，保持默认值就可以。

标签地址配置规则

标签地址可以按照下面的规则配置填写：

标签类型[ID:]Ch

说明：

项目符号

ID指板卡号，用于识别 同一设备中的不同子板卡， 板卡号设定范围为0 ～ 31，十进制表示。

项目符号

Ch指通道号，范围根据板卡类型不同，十进制表示。

项目符号 | 红色字表示格式中 的可变部分，变化范围参见各种板卡的帮助文件。
项目符号 | 蓝色括号不出现在标签地址中，蓝色括号内的内容在“单个板卡创建”时可省略。
项目符号 | 标签地址配置成不存在类型或板卡地址错误或通道号超出有效范围时，标签将不被承认， 不能读/写数据。

标签地址

含义

数据类型

读写类型

标签值范围

AD ID:Ch

模拟量输入

模拟量

只读

取决于板卡类型，请参阅相关帮助文件。

DA ID:Ch

模拟量输出

模拟量

只写

DI ID:Ch

数字量输入

开关量

只读

DO ID:Ch

数字量输出

开关量

只写

标签举例：(以多个板卡创建为例，标签中包括板卡号 ，若选择单个板卡创建则不用配置板卡号，只须配置通道号，如AD0。)

标签 ：AD0:0
数据值类型：模拟量
描述 ：表示0号板卡的第0通道模拟量输入值

标签 ：DA0:0
数据值类型：模拟量
描述 ：表示0号板卡的第0通道模拟量输出值

标签 ：DI0:0
数据值类型：开关量
描述 ：表示0号板卡的第0通道开关输入值

标签 ：DO0:0
数据值类型：开关量
描述 ：表示0号板卡的第0通道开关输出值


HY6020

华控HY6 020

硬件功能与特性 地址设置 标签地址及范围 标签举例 在线升级驱动

HY6020的功能与特性

项目符号 | 32路12位单端模拟量输入
项目符号 | 硬件跳线选择输入电压范围，可选范围：±5V；0～5V
项目符号 | 1路12位模拟量输出
项目符号 | 输出电压范围为±5V；0～5V

 HY6020的地址设置

在您使用HY6020板卡时，请确认已经为板卡设定了唯一的地址，具体设置为：

默认地址：280H

地 址 线

A8

A7

A6

A5

A4

100

80

40

20

10

16 进制数

A3

8

ON

OFF

1

2

3

4

5

6

基地址选择范围200H～3F8H。当开关置OFF位时，该位无效；开关置ON位时，该位有效。
基地址计算公式如下：基地址 = 所有有效位之和
例：如上图所示：基地址 = 200H + 80H = 280H

HY6020 支持的标签地址及范围

各种标签的详细解释请参见 华控HY6000系列系列板卡综述：

说明：

项目符号

ID指板卡号，用于识别设备中的不同板卡， 板卡号设定范围为0 ～ 31，十进制表示。

项目符号

Ch指通道号，范围根据板卡类型不同，十进制表示。

项目符号 | 红色字表示格式中可变部分，变化范围参见各种 板卡的帮助文件。
项目符号 | 蓝色括号不出现在标签地址中，蓝色括号内的内容在设备中只包含一块板卡时可省略。
项目符号 | 标签地址配置成不存在类型或板卡地址错误或通道号超出有效范围时，标签将不被承认， 不能读/写数据。

标签地址

含义

数据类型

读写类型

标签值范围

AD ID:Ch

模拟量输入

模拟量

只读

0～31

DA ID:Ch

模拟量输出

模拟量

只写

0

标签举例：(以多个板卡创建为例，标签中包括板卡号 ，若选择单个板卡创建则不用配置板卡号，只须配置通道号，如AD0。)

标签 ：AD0:0
数据值类型：模拟量
描述 ：表示0号板卡的第0通道模拟量输入值

标签 ：DA0:0
数据值类型：模拟量
描述 ：表示0号板卡的第0通道模拟量输出值


HY6021

华控HY6 021

HY6021的功能与特性

项目符号 | 32路12位单端模拟量输入
项目符号 | 硬件跳线选择输入电压范围，可选范围：±5V；0～5V

 HY6021的地址设置

在您使用HY6021板卡时，请确认已经为板卡设定了唯一的地址，具体设置为：

默认地址：280H

地 址 线

A8

A7

A6

A5

A4

100

80

40

20

10

16 进制数

A3

8

ON

OFF

1

2

3

4

5

6

基地址选择范围200H～3F8H。当开关置OFF位时，该位无效；开关置ON位时，该位有效。
基地址计算公式如下：基地址 = 所有有效位之和
例：如上图所示：基地址 = 200H + 80H = 280H

HY6021 支持的标签地址及范围

各种标签的详细解释请参见华控HY6000系列系列板卡综述：

说明：

项目符号

ID指板卡号，用于识别设备中的不同板卡， 板卡号设定范围为0 ～ 31，十进制表示。

项目符号

Ch指通道号，范围根据板卡类型不同，十进制表示。

项目符号 | 红色字表示格式中可变部分，变化范围参见各种 板卡的帮助文件。
项目符号 | 蓝色括号不出现在标签地址中，蓝色括号内的内容在设备中只包含一块板卡时可省略。
项目符号 | 标签地址配置成不存在类型或板卡地址错误或通道号超出有效范围时，标签将不被承认， 不能读/写数据。

标签地址

含义

数据类型

读写类型

标签值范围

AD ID:Ch

模拟量输入

模拟量

只读

0～31

标签举例：(以多个板卡创建为例，标签中包括板卡号 ，若选择单个板卡创建则不用配置板卡号，只须配置通道号，如AD0。)

标签 ：AD0:0
数据值类型：模拟量
描述 ：表示0号板卡的第0通道模拟量输入值


HY6022

华控HY6 022

HY6022的功能与特性

项目符号 | 32路单端/16路差动12位模拟量输入
项目符号 | 硬件跳线选择输入电压范围，可选范围：±5V；0～5V
项目符号 | 1路12位模拟量输出
项目符号 | 输出电压范围为±5V；0～5V

 HY6022的地址设置

在您使用HY6022板卡时，请确认已经为板卡设定了唯一的地址，具体设置为：

默认地址：280H

地 址 线

A8

A7

A6

A5

A4

100

80

40

20

10

16 进制数

A3

8

ON

OFF

1

2

3

4

5

6

基地址选择范围200H～3F8H。当开关置OFF位时，该位无效；开关置ON位时，该位有效。
基地址计算公式如下：基地址 = 所有有效位之和
例：如上图所示：基地址 = 200H + 80H = 280H

HY6022 支持的标签地址及范围

各种标签的详细解释请参见华控HY6000系列系列板卡综述：

说明：

项目符号

ID指板卡号，用于识别设备中的不同板卡， 板卡号设定范围为0 ～ 31，十进制表示。

项目符号

Ch指通道号，范围根据板卡类型不同，十进制表示。

项目符号 | 红色字表示格式中可变部分，变化范围参见各种 板卡的帮助文件。
项目符号 | 蓝色括号不出现在标签地址中，蓝色括号内的内容在设备中只包含一块板卡时可省略。
项目符号 | 标签地址配置成不存在类型或板卡地址错误或通道号超出有效范围时，标签将不被承认， 不能读/写数据。

标签地址

含义

数据类型

读写类型

标签值范围

AD ID:Ch

模拟量输入

模拟量

只读

单端0～31 差动0～15

标签举例：(以多个板卡创建为例，标签中包括板卡号 ，若选择单个板卡创建则不用配置板卡号，只须配置通道号，如AD0。)

标签 ：AD0:0
数据值类型：模拟量
描述 ：表示0号板卡的第0通道模拟量输入值


HY6023

华控HY6 023

HY6023的功能与特性

项目符号 | 32路单端/16路差动12位模拟量输入
项目符号 | 硬件跳线选择输入电压范围，可选范围：±5V；0～5V
项目符号 | 1路12位模拟量输出
项目符号 | 输出电压范围为±5V；0～5V

 HY6023的地址设置

在您使用HY6023板卡时，请确认已经为板卡设定了唯一的地址，具体设置为：

默认地址：280H

地 址 线

A8

A7

A6

A5

A4

100

80

40

20

10

16 进制数

A3

8

ON

OFF

1

2

3

4

5

6

基地址选择范围200H～3F8H。当开关置OFF位时，该位无效；开关置ON位时，该位有效。
基地址计算公式如下：基地址 = 所有有效位之和
例：如上图所示：基地址 = 200H + 80H = 280H

HY6023 支持的标签地址及范围

各种标签的详细解释请参见华控HY6000系列系列板卡综述：

说明：

项目符号

ID指板卡号，用于识别设备中的不同板卡， 板卡号设定范围为0 ～ 31，十进制表示。

项目符号

Ch指通道号，范围根据板卡类型不同，十进制表示。

项目符号 | 红色字表示格式中可变部分，变化范围参见各种 板卡的帮助文件。
项目符号 | 蓝色括号不出现在标签地址中，蓝色括号内的内容在设备中只包含一块板卡时可省略。
项目符号 | 标签地址配置成不存在类型或板卡地址错误或通道号超出有效范围时，标签将不被承认， 不能读/写数据。

标签地址

含义

数据类型

读写类型

标签值范围

AD ID:Ch

模拟量输入

模拟量

只读

单端0～31 差动0～15

DA ID:Ch

模拟量输出

模拟量

只写

0

标签举例：(以多个板卡创建为例，标签中包括板卡号 ，若选择单个板卡创建则不用配置板卡号，只须配置通道号，如AD0。)

标签 ：AD0:0
数据值类型：模拟量
描述 ：表示0号板卡的第0通道模拟量输入值

标签 ：DA0:0
数据值类型：模拟量
描述 ：表示0号板卡的第0通道模拟量输出值


HY6080

华控HY6 080

HY6080的功能与特性

项目符号 | 8路8位模拟量输出
项目符号 | 硬件跳线选择输出电压/电流范围，可选范围：±10V；±5V；0～5V；0～10V；1～5V；4～20mA；0～10mA
项目符号 | 8路TTL数字量输出
项目符号 | 8路TTL数字量输入

 HY6080的地址设置

在您使用HY6080板卡时，请确认已经为板卡设定了唯一的地址，具体设置为：

默认地址：280H

地 址 线

A8

A7

A6

A5

A4

100

80

40

20

10

16 进制数

A3

8

ON

OFF

1

2

3

4

5

6

基地址选择范围200H～3F8H。当开关置OFF位时，该位无效；开关置ON位时，该位有效。
基地址计算公式如下：基地址 = 所有有效位之和
例：如上图所示：基地址 = 200H + 80H = 280H

HY6080 支持的标签地址及范围

各种标签的详细解释请参见 华控HY6000系列系列板卡综述：

说明：

项目符号

ID指板卡号，用于识别设备中的不同板卡， 板卡号设定范围为0 ～ 31，十进制表示。

项目符号

Ch指通道号，范围根据板卡类型不同，十进制表示。

项目符号 | 红色字表示格式中可变部分，变化范围参见各种 板卡的帮助文件。
项目符号 | 蓝色括号不出现在标签地址中，蓝色括号内的内容在设备中只包含一块板卡时可省略。
项目符号 | 标签地址配置成不存在类型或板卡地址错误或通道号超出有效范围时，标签将不被承认， 不能读/写数据。

标签地址

含义

数据类型

读写类型

标签值范围

DI ID:Ch

数字量输入

开关量

只读

0 ～ 7

DO ID:Ch

数字量输出

开关量

只写

0 ～ 7

DA ID:Ch

模拟量输出

模拟量

只写

0 ～ 7

标签举例：(以多个板卡创建为例，标签中包括板卡号 ，若选择单个板卡创建则不用配置板卡号，只须配置通道号，如AD0。)

标签 ：DA0:0
数据值类型：模拟量
描述 ：表示0号板卡的第0通道模拟量输出值

标签 ：DI0:0
数据值类型：开关量
描述 ：表示0号板卡的第0通道开关输入值

标签 ：DO0:0
数据值类型：开关量
描述 ：表示0号板卡的第0通道开关输出值


华控HY8021A

HY8021A的功能与特性

项目符号 | 16路单端/16路伪双端/8路差动12位模拟量输入
项目符号 | 硬件跳线选择输入电压范围，可选范围：±5V；±10v; 0～10V
项目符号 | 程控增益: 1,10,100,1000
项目符号 | 2路12位模拟量输出
项目符号 | 输出电压范围为±5V；0～5V; ±10V; 0~10V;
项目符号 | 8路数字量输入通道
项目符号 | 8路数字量输出通道

 HY8021A的地址设置

在您使用HY8021B板卡时，请确认已经为板卡设定了唯一的地址，具体设置为：

默认地址：280H

地 址 线

文本框: 地 址 线

A8

A7

A6

A5

A4

100

80

40

20

10

16 进制数

A3

8

ON

OFF

1

2

3

4

5

6

基地址选择范围200H～3F8H。当开关置OFF位时，该位 有效；开关置ON位时，该位无效。
基地址计算公式如下：基地址 = 所有有效位之和
例：如上图所示：基地址 = 200H + 80H = 280H

HY8021A 支持的标签地址及范围

各种标签的详细解释请参见华控HY8000系列系列板卡综述：

说明：

项目符号

ID指板卡号，用于识别设备中的不同板卡， 板卡号设定范围为0 ～ 31，十进制表示。

项目符号

Ch指通道号，范围根据板卡类型不同，十进制表示。

项目符号 | 红色字表示格式中可变部分，变化范围参见各种 板卡的帮助文件。
项目符号 | 蓝色括号不出现在标签地址中，蓝色括号内的内容在设备中只包含一块板卡时可省略。
项目符号 | 标签地址配置成不存在类型或板卡地址错误或通道号超出有效范围时，标签将不被承认， 不能读/写数据。

标签地址

含义

数据类型

读写类型

标签值范围

通道值范围

ADID:Ch

模拟量输入通道

模拟量

只读

0~65536 单端0~15差动0~7
DAID:Ch

模拟量输出通道

模拟量 只写 0~65536 0~1
DIID:Ch

数字量输入通道

数字量 只读 0/1 0~7
DOID:Ch

数字量输出通道

数字量 只写 0/1 0~7

标签举例：(以多个板卡创建为例，标签中包括板卡号 ，若选择单个板卡创建则不用配置板卡号，只须配置通道号，如AD0。)

标签 ：AD0:0
数据值类型：模拟量
描述 ：表示0号板卡的第0通道模拟量输入值

标签 ：DA0:0
数据值类型：模拟量
描述 ：表示0号板卡的第0通道模拟量输出值

标签 ：DI0:0
数据值类型：模拟量
描述 ：表示0号板卡的第0通道数字量输入值

标签 ：DO0:0
数据值类型：模拟量
描述 ：表示0号板卡的第0通道数字量输出值


华控HY8021B

HY8021B的功能与特性

项目符号 | 16路单端/16路伪双端/8路差动12位模拟量输入
项目符号 | 硬件跳线选择输入电压范围，可选范围：±5V；±10v; 0～10V
项目符号 | 程控增益: 1,2,4,8
项目符号 | 2路12位模拟量输出
项目符号 | 输出电压范围为±5V；0～5V; ±10V; 0~10V;
项目符号 | 8路数字量输入通道
项目符号 | 8路数字量输出通道

 HY8021B的地址设置

在您使用HY8021B板卡时，请确认已经为板卡设定了唯一的地址，具体设置为：

默认地址：280H

地 址 线

文本框: 地 址 线

A8

A7

A6

A5

A4

100

80

40

20

10

16 进制数

A3

8

ON

OFF

1

2

3

4

5

6

基地址选择范围200H～3F8H。当开关置OFF位时，该位 有效；开关置ON位时，该位无效。
基地址计算公式如下：基地址 = 所有有效位之和
例：如上图所示：基地址 = 200H + 80H = 280H

HY8021B 支持的标签地址及范围

各种标签的详细解释请参见华控HY8000系列系列板卡综述：

说明：

项目符号

ID指板卡号，用于识别设备中的不同板卡， 板卡号设定范围为0 ～ 31，十进制表示。

项目符号

Ch指通道号，范围根据板卡类型不同，十进制表示。

项目符号 | 红色字表示格式中可变部分，变化范围参见各种 板卡的帮助文件。
项目符号 | 蓝色括号不出现在标签地址中，蓝色括号内的内容在设备中只包含一块板卡时可省略。
项目符号 | 标签地址配置成不存在类型或板卡地址错误或通道号超出有效范围时，标签将不被承认， 不能读/写数据。

标签地址

含义

数据类型

读写类型

标签值范围

通道值范围

ADID:Ch

模拟量输入通道

模拟量

只读

0~65536 单端0~15差动0~7
DAID:Ch

模拟量输出通道

模拟量 只写 0~65536 0~1
DIID:Ch

数字量输入通道

数字量 只读 0/1 0~7
DOID:Ch

数字量输出通道

数字量 只写 0/1 0~7

标签举例：(以多个板卡创建为例，标签中包括板卡号 ，若选择单个板卡创建则不用配置板卡号，只须配置通道号，如AD0。)

标签 ：AD0:0
数据值类型：模拟量
描述 ：表示0号板卡的第0通道模拟量输入值

标签 ：DA0:0
数据值类型：模拟量
描述 ：表示0号板卡的第0通道模拟量输出值

标签 ：DI0:0
数据值类型：模拟量
描述 ：表示0号板卡的第0通道数字量输入值

标签 ：DO0:0
数据值类型：模拟量
描述 ：表示0号板卡的第0通道数字量输出值


华控HY8021C

HY8021C的功能与特性

项目符号 | 16路单端/16路伪双端/8路差动12位模拟量输入
项目符号 | 硬件跳线选择输入电压范围，可选范围：±5V；±10v; 0～10V
项目符号 | 程控增益: 1,10,100,1000
项目符号 | 输出电压范围为±5V；0～5V; ±10V; 0~10V;
项目符号 | 8路数字量输入通道
项目符号 | 8路数字量输出通道

 HY8021C的地址设置

在您使用HY8021C板卡时，请确认已经为板卡设定了唯一的地址，具体设置为：

默认地址：280H

地 址 线

文本框: 地 址 线

A8

A7

A6

A5

A4

100

80

40

20

10

16 进制数

A3

8

ON

OFF

1

2

3

4

5

6

基地址选择范围200H～3F8H。当开关置OFF位时，该位 有效；开关置ON位时，该位无效。
基地址计算公式如下：基地址 = 所有有效位之和
例：如上图所示：基地址 = 200H + 80H = 280H

HY8021C 支持的标签地址及范围

各种标签的详细解释请参见华控HY8000系列系列板卡综述：

说明：

项目符号

ID指板卡号，用于识别设备中的不同板卡， 板卡号设定范围为0 ～ 31，十进制表示。

项目符号

Ch指通道号，范围根据板卡类型不同，十进制表示。

项目符号 | 红色字表示格式中可变部分，变化范围参见各种 板卡的帮助文件。
项目符号 | 蓝色括号不出现在标签地址中，蓝色括号内的内容在设备中只包含一块板卡时可省略。
项目符号 | 标签地址配置成不存在类型或板卡地址错误或通道号超出有效范围时，标签将不被承认， 不能读/写数据。

标签地址

含义

数据类型

读写类型

标签值范围

通道值范围

ADID:Ch

模拟量输入通道

模拟量

只读

0~65536 单端0~15差动0~7
DIID:Ch

数字量输入通道

数字量 只读 0/1 0~7
DOID:Ch

数字量输出通道

数字量 只写 0/1 0~7

标签举例：(以多个板卡创建为例，标签中包括板卡号 ，若选择单个板卡创建则不用配置板卡号，只须配置通道号，如AD0。)

标签 ：AD0:0
数据值类型：模拟量
描述 ：表示0号板卡的第0通道模拟量输入值

标签 ：DI0:0
数据值类型：模拟量
描述 ：表示0号板卡的第0通道数字量输入值

标签 ：DO0:0
数据值类型：模拟量
描述 ：表示0号板卡的第0通道数字量输出值


华控HY8021D

HY8021D的功能与特性

项目符号 | 16路单端/16路伪双端/8路差动12位模拟量输入
项目符号 | 硬件跳线选择输入电压范围，可选范围：±5V；±10v; 0～10V
项目符号 | 程控增益: 1,2,4,8
项目符号 | 输出电压范围为±5V；0～5V; ±10V; 0~10V;
项目符号 | 8路数字量输入通道
项目符号 | 8路数字量输出通道
项目符号 |

HY8021D的地址设置

在您使用HY8021D板卡时，请确认已经为板卡设定了唯一的地址，具体设置为：

默认地址：280H

地 址 线

文本框: 地 址 线

A8

A7

A6

A5

A4

100

80

40

20

10

16 进制数

A3

8

ON

OFF

1

2

3

4

5

6

基地址选择范围200H～3F8H。当开关置OFF位时，该位 有效；开关置ON位时，该位无效。
基地址计算公式如下：基地址 = 所有有效位之和
例：如上图所示：基地址 = 200H + 80H = 280H

HY8021D 支持的标签地址及范围

各种标签的详细解释请参见华控HY8000系列系列板卡综述：

说明：

项目符号

ID指板卡号，用于识别设备中的不同板卡， 板卡号设定范围为0 ～ 31，十进制表示。

项目符号

Ch指通道号，范围根据板卡类型不同，十进制表示。

项目符号 | 红色字表示格式中可变部分，变化范围参见各种 板卡的帮助文件。
项目符号 | 蓝色括号不出现在标签地址中，蓝色括号内的内容在设备中只包含一块板卡时可省略。
项目符号 | 标签地址配置成不存在类型或板卡地址错误或通道号超出有效范围时，标签将不被承认， 不能读/写数据。

标签地址

含义

数据类型

读写类型

标签值范围

通道值范围

ADID:Ch

模拟量输入通道

模拟量

只读

0~65536 单端0~15差动0~7
DIID:Ch

数字量输入通道

数字量 只读 0/1 0~7
DOID:Ch

数字量输出通道

数字量 只写 0/1 0~7

标签举例：(以多个板卡创建为例，标签中包括板卡号 ，若选择单个板卡创建则不用配置板卡号，只须配置通道号，如AD0。)

标签 ：AD0:0
数据值类型：模拟量
描述 ：表示0号板卡的第0通道模拟量输入值

标签 ：DI0:0
数据值类型：模拟量
描述 ：表示0号板卡的第0通道数字量输入值

标签 ：DO0:0
数据值类型：模拟量
描述 ：表示0号板卡的第0通道数字量输出值


华控HY8021E

HY8021E的功能与特性

项目符号 | 16路单端/16路伪双端/8路差动12位模拟量输入
项目符号 | 硬件跳线选择输入电压范围，可选范围：±5V；±10v; 0～10V
项目符号 | 输出电压范围为±5V；0～5V; ±10V; 0~10V;
项目符号 | 8路数字量输入通道
项目符号 | 8路数字量输出通道

 HY8021E的地址设置

在您使用HY8021E板卡时，请确认已经为板卡设定了唯一的地址，具体设置为：

默认地址：280H

地 址 线

文本框: 地 址 线

A8

A7

A6

A5

A4

100

80

40

20

10

16 进制数

A3

8

ON

OFF

1

2

3

4

5

6

基地址选择范围200H～3F8H。当开关置OFF位时，该位 有效；开关置ON位时，该位无效。
基地址计算公式如下：基地址 = 所有有效位之和
例：如上图所示：基地址 = 200H + 80H = 280H

HY8021E 支持的标签地址及范围

各种标签的详细解释请参见华控HY8000系列系列板卡综述：

说明：

项目符号

ID指板卡号，用于识别设备中的不同板卡， 板卡号设定范围为0 ～ 31，十进制表示。

项目符号

Ch指通道号，范围根据板卡类型不同，十进制表示。

项目符号 | 红色字表示格式中可变部分，变化范围参见各种 板卡的帮助文件。
项目符号 | 蓝色括号不出现在标签地址中，蓝色括号内的内容在设备中只包含一块板卡时可省略。
项目符号 | 标签地址配置成不存在类型或板卡地址错误或通道号超出有效范围时，标签将不被承认， 不能读/写数据。

标签地址

含义

数据类型

读写类型

标签值范围

通道值范围

ADID:Ch

模拟量输入通道

模拟量

只读

0~65536 单端0~15差动0~7
DIID:Ch

数字量输入通道

数字量 只读 0/1 0~7
DOID:Ch

数字量输出通道

数字量 只写 0/1 0~7

标签举例：(以多个板卡创建为例，标签中包括板卡号 ，若选择单个板卡创建则不用配置板卡号，只须配置通道号，如AD0。)

标签 ：AD0:0
数据值类型：模拟量
描述 ：表示0号板卡的第0通道模拟量输入值

标签 ：DI0:0
数据值类型：模拟量
描述 ：表示0号板卡的第0通道数字量输入值

标签 ：DO0:0
数据值类型：模拟量
描述 ：表示0号板卡的第0通道数字量输出值