凌华PCI系列板卡综述

概述 硬件 设置 创建设备 创建标签 标签的地址规则 标签举例 在线升级驱动

凌华PCI系列板卡概述

凌华科技作为自动化国际领导厂商，产品覆盖工业自动化、网络和嵌入式系统等领域。凌华板卡稳定性好，功能强大，在工业自动化领域有着广泛的应用。

开物2000系统支持下面类型的凌华PCI板卡系列：

项目符号

PCI7248 ：48路可编程DI/DO

项目符号

PCI7296 ：96路可编程DI/DO

关于PCI系列板卡的更详细信息请访问 凌华公司网站。

开物2000还支持其它多种设备，详情请与 华富惠通公司联系。

凌华PCI系列板卡的硬件设置

凌华PCI系列板卡采用 PCI 总线形式，占用计算机的 PCI 插槽。在您使用凌华 PCI 系列板卡时，请确认已经准确设定了一些板卡基本信息。其中型号不同，板卡的硬件设置可能会不同，详细设置情况清参阅板卡说明书。

在开物2000开发环境中创建设备

本版本的驱动程序使用凌华 的动态链接库，在使用板卡前，请根据操作系统的不同，安装随板卡所带的驱动程序，另外须使用测试程序测试板卡是否正常，只有测试正常的板卡才可以在开物2000中使用。

在开发环境的“硬件系统”中按照“新节点和设备向导”的指示配置所连接的板卡。以便于开物2000识别和使用。

步骤1：选择”板卡“设备类型。双击“凌华PCI板卡”，或单击选中“凌华PCI板卡”，这里可以查看“驱动版本号”，更改设备名称， 如“Adlink_PCI” ，然后单击“选择”按钮。

步骤2：在”凌华PCI板卡向导“中选择执行的操作方式——“新建设备”。选中“新建设备”后单击”下一步”按钮(或双击“新建设备”)，您也可以选择“修改设备”，对板卡的配置进行修改或者选择“察看设备”浏览已经设置好的板卡配置情况。

其中下面的按钮的含义分别为：

下载最新驱动：可以帮助您进入开物技术支持网站的下载专区中；

帮助信息：可以查看驱动的版本等信息；

调试设置：通常情况下“调试开关”打开，这时可以记录开物的基本信息，主要包括启动和退出的时间，标签情况，通讯情况等信息；如果把“输出错误信息”和“输出跟踪信息”也选中的话，这时将记录开物运行过程中的全部通讯信息，对于记录通讯过程中的错误信息很有帮助，如果您在使用开物过程中，硬件连接有问题时，请打开所有调试开关，将通讯信息记录下来，待整个通讯工程正常后，请您把“输出错误信息”和“输出跟踪信息”关闭。

注意：整个信息将存成LOG文件，在相应工程目录下面的“DEBUG”子目录下，文件名以驱动DLL文件加上日期的方式命名，如Adlink_PCI2003-8-18.log。

步骤3：在“凌华PCI板卡向导“中选择板卡安装，主要包括板卡号、板卡类型、基地址、AD输入方式、AD最大范围(或AD输入极性)、AD滤波次数、量程选择等选项。 其中：

板卡号： 对于同型号的板卡来说，如果有3块板卡，其板卡号分别为0、1、2；如果还有其他型号板卡，则其板卡号也是从0开始。

对于板卡号在工控机上的对应关系，一般来说，距离CPU最近的为0，然后依次为1、2......；请在配置板卡号时注意。

对于不同型号板卡到以便于开物2000对板卡设备的识别；如果为单个板卡创建则没有这个选项。

板卡类型：指用户使用的板卡型号，通过下拉菜单选择；

AD输入方式：指AD信号是单端还是差动；

AD最大范围(或AD输入极性)：选择AD信号的输入极性为单极性还是双极性(或者AD的输入极性为单极性或双极性)；

AD滤波次数：为滤除干扰而设计，算法为：若设定为10，则将采集到的10个数据按照大小顺序排列，取中间1/3数据的平均值，这个过程在驱动中完成，您可以根据板卡使用情况调节AD滤波次数。

请在本步骤中配置板卡的 可编程IO功能，凌华PCI7248/7296板卡模拟8255芯片模式0的功能，其数字量可以通过编程设定，开物驱动程序对其进行了封装，在使用过程中 ，您需要在“可编程I/O”标签页选择PA/PB/PC_L/PC_H口是输入还是输出功能。

其中芯片号代表板卡上8255的编号，0为第一片8255，1为第二片8255，其他依次类推。在配置标签时，第一片8255的PA口对应0--7通道；PB口对应8--15通道；PC_L对应16--19通道；PC_H对应20-23通道；第二片8255的PA口对应24--31通道；PB口对应32--39通道；PC_L对应40--43通道；PC_H对应44--47通道；其他依次类推。

如果第一片8255PA口设定为输出，则在配置标签时应为DO0、DO1、DO2、DO3、DO4、DO5、DO6、DO7。

如果第一片8255PB口设定为输出，则在配置标签时应为DI0、DI1、DI2、DI3、DI4、DI5、DI6、DI7，其他依次类推。

标签的创建

使用“凌华PCI板卡向导”完成板卡设备的创建后，可以进行标签设计。

1、在开发环境的“标签”击鼠标右键，选择“添加标签“，显示见下图，选择主设备为上面的“Adlink_PCI” ，选择并填写"主设备地址"，修改标签名。

开物的板卡驱动程序可以实现以下功能：模拟量输入、模拟量输出、数字量输入、数字量输出、定时/记数等功能。各部分功能在开物中对应的标签为：

AD：模拟量输入功能；

DA：模拟量输出功能；

DI：数字量输入功能；

DO：数字量输出功能；

INI_Count：为定时/记数器设定的初始值；

Count：为定时/记数器的当前值。

在板卡类设备中，标签的配置规则为：若为单个板卡创建，格式为： 标签+通道号，如AD0、DA3、DI5、DO6、Count2、INI_Count2等；若为多个设备创建，则格式为： 标签+板卡号+“:”+通道号，如AD0:0、DA0:3、DI1:5、DO0:6、Count0:2、INI_Count0:2；

2、根据您的特定使用需求，修改测量值和工程值的最大值、最小值、扫描周期等属性。单击‘添加’或‘完成’按钮。其中：

测量值最大值：设定为板卡当前量程的上限值；

测量值最小值：设定为板卡当前量程的下限值；

工程值最大值：设定为实际物理参数的上限值；

工程值最小值：设定为实际物理参数的下限值；

如：板卡的量程选择为：0 ～ 10V，对应现场的力信号为0 ～ 1000N，则测量值最大值设为 10；最小值设为 0；工程值最大值设为 1000；最小值设为 0。

请注意：假如只测量外界的电压信号则不需要更改测量值和工程值的最大值、 最小值，保持默认值就可以。

标签地址配置规则

标签地址可以按照下面的规则配置填写：

标签类型[ID:]Ch

说明：

项目符号

ID指板卡号，用于识别 同一设备中的不同子板卡， 板卡号设定范围为0 ～ 31，十进制表示。

项目符号

Ch指通道号，范围根据板卡类型不同，十进制表示。

项目符号 | 红色字表示格式中 的可变部分，变化范围参见各种板卡的帮助文件。
项目符号 | 蓝色括号不出现在标签地址中，蓝色括号内的内容在“单个板卡创建”时可省略。
项目符号 | 标签地址配置成不存在类型或板卡地址错误或通道号超出有效范围时，标签将不被承认， 不能读/写数据。

标签地址

含义

数据类型

读写类型

标签值范围

AD ID:Ch

模拟量输入

模拟量

只读

取决于板卡类型，请参阅相关帮助文件。

DA ID:Ch

模拟量输出

模拟量

只写

DI ID:Ch

数字量输入

开关量

只读

DO ID:Ch

数字量输出

开关量

只写

Count ID:Ch

计数器

模拟量

只读

INI_Count ID:Ch

计数器初值 模拟量 只写

标签举例：(以多个板卡创建为例，标签中包括板卡号 ，若选择单个板卡创建则不用配置板卡号，只须配置通道号，如AD0。)

标签 ：AD0:0
数据值类型：模拟量
描述 ：表示0号板卡的第0通道模拟量输入值

标签 ：DA0:0
数据值类型：模拟量
描述 ：表示0号板卡的第0通道模拟量输出值

标签 ：DI0:0
数据值类型：开关量
描述 ：表示0号板卡的第0通道开关输入值

标签 ：DO0:0
数据值类型：开关量
描述 ：表示0号板卡的第0通道开关输出值

标签 ：Count0:0
数据值类型：模拟量
描述 ：表示0号板卡的第0个记数器通道当前值

标签 ：INI_Count0:0
数据值类型：模拟量
描述 ：表示0号板卡的第0个记数器通道初值


PCI7248

凌华PCI 7248

硬件功能与特性 地址设置 标签地址及范围 标签举例 在线升级驱动

PCI7248的功能与特性

项目符号

48路可编程DI/DO

PCI7248的地址设置

凌华PCI7248板卡地址为浮动地址，由PCI总线协议分配，用户在使用PCI7248板卡时不必关心具体的板卡地址。

PCI7248 支持的标签地址及范围

各种标签的详细解释请参见凌华PCI系列板卡综述：

说明：

项目符号

ID指板卡号，用于识别设备中的不同板卡， 板卡号设定范围为0 ～ 31，十进制表示。

项目符号

Ch指通道号，范围根据板卡类型不同，十进制表示。

项目符号 | 红色字表示格式中可变部分，变化范围参见各种 板卡的帮助文件。
项目符号 | 蓝色括号不出现在标签地址中，蓝色括号内的内容在设备中只包含一块板卡时可省略。
项目符号 | 标签地址配置成不存在类型或板卡地址错误或通道号超出有效范围时，标签将不被承认， 不能读/写数据。

标签地址

含义

数据类型

读写类型

标签值范围

DI ID:Ch

数字量输入

开关量

只读

根据设定最大：0～47
DO ID:Ch

数字量输出

开关量

只写

根据设定最大：0～47

标签举例：(以多个板卡创建为例，标签中包括板卡号 ，若选择单个板卡创建则不用配置板卡号，只须配置通道号，如DI0。)

标签 ：DI0:0
数据值类型：开关量
描述 ：表示0号板卡的第0通道开关输入值

标签 ：DO0:0
数据值类型：开关量
描述 ：表示0号板卡的第0通道开关输出值


PCI7296

凌华PCI 7296

硬件功能与特性 地址设置 标签地址及范围 标签举例 在线升级驱动

PCI7296的功能与特性

项目符号

96路可编程DI/DO

PCI7296的地址设置

凌华PCI7296板卡地址为浮动地址，由PCI总线协议分配，用户在使用PCI7296板卡时不必关心具体的板卡地址。

PCI7296 支持的标签地址及范围

各种标签的详细解释请参见凌华PCI系列板卡综述：

说明：

项目符号

ID指板卡号，用于识别设备中的不同板卡， 板卡号设定范围为0 ～ 31，十进制表示。

项目符号

Ch指通道号，范围根据板卡类型不同，十进制表示。

项目符号 | 红色字表示格式中可变部分，变化范围参见各种 板卡的帮助文件。
项目符号 | 蓝色括号不出现在标签地址中，蓝色括号内的内容在设备中只包含一块板卡时可省略。
项目符号 | 标签地址配置成不存在类型或板卡地址错误或通道号超出有效范围时，标签将不被承认， 不能读/写数据。

标签地址

含义

数据类型

读写类型

标签值范围

DI ID:Ch

数字量输入

开关量

只读

根据设定最大：0～95
DO ID:Ch

数字量输出

开关量

只写

根据设定最大：0～95

标签举例：(以多个板卡创建为例，标签中包括板卡号 ，若选择单个板卡创建则不用配置板卡号，只须配置通道号，如DI0。)

标签 ：DI0:0
数据值类型：开关量
描述 ：表示0号板卡的第0通道开关输入值

标签 ：DO0:0
数据值类型：开关量
描述 ：表示0号板卡的第0通道开关输出值