EASY_IO模块

概述 硬件连接 创建设备 创建标签 标签的地址规则 标签举例 在线升级驱动

概述

巨腾ESAY_IO系列智能模块采用ModBus通讯协议,其支持eIO_UI_08,eIO_AO_02,eIO_DI_16,eIO_DIO_16,eIO_DO_PR_08,eIO_CI_02,EM_RS485_IsolatedV1,

EM_RS485_UnisolatedV1,EM_AO_IsolatedV1,EM_AO_UnisolatedV1,EM_UI_IsolatedV1,EM_UI_UnisolatedV1系列产品之间的通讯。本协议采用串行通讯（RS-485通讯协议）,

使用您计算机中的串行口。

硬件连接

ESAY_IO系列模块与开物2000的连接说明:

ESAY_IO 系列模块采用RS-485接口时（能接多台仪表）：

配置设备工作参数.

设置ESAY_IO系列 模块

ESAY_IO 系列模块的所有标签（见标签类型中所列），

重要设置如下：

设 置 项 | 设 置 方 式
通讯通道地址的选择 | 地址唯一：1-63
通讯数据格式（固定） | 8个数据位，1个停止位(无校验)
通讯波特率范围 | 4800-38400Bit/S范围内任意设置，缺省设置为9600Bit/S

注：通讯通道地址及波特率的设置方法:打开模块面板可以进行跳线设置.

创建设备

在开发环境的‘硬件系统’中按照‘新节点和设备向导’的指示配置所连接的模块。以便于开物2000识别和使用。

步骤1：选择设备类型。双击‘’，或单击选中‘’，更改设备名称，最后单击‘选择’按钮。

步骤2：选择操作方式-新建设备(一个设备中可以包含多个)。选中‘新建设备’后单击‘下一步’按钮(或双击‘新建设备’)。

步骤3：选择创建方式-单个或多个创建(一个设备中可以包含多个)。选中 创建方式后单击‘下一步’按钮(或双击‘标准创建’)。

步骤4：设置设备类型及参数选项，单击‘下一步’按钮。

步骤5：设备串口通讯参数，单击‘下一步’。

步骤6：显示设备及参数汇总窗口，单击‘完成’按钮，结束设备配置向导。

创建标签

使用设备向导创建完成值能模块的配置后，可以进行标签设计。

1、在开发环境的‘标签’中添加标签，显示下图，选择主设备为上面的‘’，选择并填写‘主设备地址’，修改标签名。

2、根据智能模块的工作模式和标签所监控的参数物理意义，修改测量值零点、测量值量程、工程值零点、工程值量程、扫描周期、转换方式、记录属性等。单击‘添加’或‘完成’按钮。

标签的地址规则

标签的主地址可以按照下面的规则配置填写：

标签类型[ID:]Ch

说明：

  • ID指智能模块的地址，用于识别设备中的智能模块， 智能模块的站号地址以十进制表示，地址设定范围为1～ 63。标签地址中省略ID时，开物2000系统默认为是所连接设备的最小的站号地址。

  • Ch指的是线圈或者寄存器地址。十进制表示。

  • 标签地址配置成不存在类型或模块地址错误或通道号超出有效范围时，标签将不被承认，读不上数据。

    标签含义

    标签名

    标签格式

    标签类型

    取值范围
    数字量的输出 | DO | DOID:CHANNAL | 数字量（只写） | TRUE--FALSE
    数字量的输入 | DI | DIID:CHANNAL | 数字量（只读） | TRUE--FALSE
    模拟量的输出 | AO | AOID:CHANNAL | 模拟量（只读） | 0--4095
    模拟量的输入 | AI | AIID:CHANNAL | 模拟量（只写） | 0--4095

    注：CHANNAL 的取值范围为0-32，具体范围及所代表的含义视模块型号不同而有所差异，详情请参照EASY_IO系列智能 模块使用手册。

    注:如果用户想连接多个设备的话,不能直接在组态中的计算机节点下创建多个该模块节点,这样会引起com口的争用,从而导致只是一块 模块能采上数。

标签举例

标签 ：DI1:5
数据值类型：开关量
描述 ：表示设备配置示例中站号地址为1的智能模块的通道地址为5的输 入点的状态值

标签 ：DO2:3
数据值类型：开关量
描述 ：表示设备配置示例中站号地址为2的智能模块的通道地址为1的输出点的状态

标签 ：AI4:5
数据值类型：模拟量
描述 ：表示设备配置示例中站号地址为4的智能模块的通道地址为5的保持寄存器的值（十进制表示）

标签 ：AO5:4
数据值类型：模拟量
描述 ：表示设备配置示例中站号地址为5的智能模块的通道地址为4的保持寄存器的值（十进制表示）