长英LTM8000系列模块

长英LTM8000_USB系列模块

概述 硬件连接 创建设备 创建标签 标签地址规则 标签举例 在线升级驱动

概述

该驱动为USB转485设备专用，使用这个驱动首先需要安装这个设备的驱动程序。

硬件连接

把USB转485设备连接在计算机的USB口，把长英模块连接在USB转485设备的两个485口上。

创建设备

步骤1：选择设备类型。双击‘长英LTM8000模块(USB)’，或单击选中‘长英LTM8000模块(USB)’，更改设备名称，最后单击‘选择’按钮。

步骤2：选择操作方式-新建设备(一个设备中可以包含多个模块)。选中‘新建设备’后单击‘下一步’按钮(或双击‘新建设备’)。

步骤3：在自动搜索窗口的右边有目前计算机上可用的USB转485设备的编号（USB ID），一个USB转485设备有两个485端口，一个USB ID和端口号对应一个485总线。选择一个USB ID和端口号，再选择搜索等待时间（一般情况默认即可，如果模块通道上的传感器少可以把等待时间改小，增加搜索的速度；如果模块通道上的传感器很多，需要把这个时间改大，否则可能有些传感器搜索不到）。 搜索完后点【暂停搜索】按钮，再下拉框中选择另一个端口，点击【继续搜索】按钮。

步骤4：修改超时时间和通讯间隔时间：一般情况默认即可，如果模块上的传感器多，需要把通讯间隔时间加大。

步骤5：显示设备及参数汇总窗口，单击‘完成’按钮，结束设备配置向导。

创建标签

使用设备向导创建完成模块的配置后，可以进行标签设计。

1、在开发环境的‘标签’中添加标签，显示下图，选择主设备为上面的‘LTM8660’，选择并填写‘主设备地址’，修改标签名。

2、根据模块的工作模式和标签所监控的参数物理意义，修改测量值零点、测量值量程、工程值零点、工程值量程、扫描周期、转换方式、记录属性等。单击‘添加’或‘完成’按钮。

标签地址规则

标签的主地址可以按照下面的规则配置填写：

标签类型[ID:]Ch.SensorNum.BitNum.PortID

说明：

  • ID指模块的模块地址，用于识别设备中的模块， 模块地址以十六进制表示，地址设定范围为00 ～ FF 。标签地址中省略ID时，开物2000系统默认为是所连接的最小模块地址。

  • Ch指通道号。范围通常为 0～7。十进制表示。

  • SensorNum指传感器的序号。范围通常为 0～63。十进制表示。

  • ITUNum指ITU的序号。十进制表示。

  • BitNum指开关量标签在ITU中的位序号。范围通常为 0～7。十进制表示。

  • PortID指 485总线所连接的USB端口号，0或者1。

  • 红色字表示格式中可变部分，变化范围参见各种模块的帮助文件。
  • 蓝色括号不出现在标签地址中，蓝色括号内的内容在设备中只包含一个模块时可省略。
  • 标签地址配置成不存在类型或模块地址错误或通道号超出有效范围时，标签将不被承认，读不上数据。

标签地址

含义

数据类型

读写类型

标签值范围

HumidID:Ch.SensorNum.PortID

湿度值

模拟量

只读

0～100

TempID:Ch.SensorNum.PortID

温度值

模拟量

只读

-55～125

AIID:Ch.SensorNum.PortID

模拟量输入

模拟量

只读

0～20

VID:Ch.SensorNum.PortID

电压输入

模拟量

只读

0～5

AID:Ch.SensorNum.PortID

电流输入

模拟量

只读

4～20
TCID:Ch.SensorNum.PortID | 高温热电偶值 | 模拟量 | 只读 | 0～760

DIID:Ch.ITUNum.BitNum.PortID

开关量输入

开关量

只读

true=开关闭合

false=开关断开

DO ID:Ch.ITUNum.BitNum.PortID

开关量输出

开关量

读写

true=继电器动作
false=继电器不动作
SFID:Ch.SensorNum.PortID | 水分值 | 模拟量 | 只读 | 0-30

标签举例

标签 ：Humid1:7.1.0
数据值类型：模拟量
描述 ：表示设备配置示例中1号模块LTM8300的7通道1号传感器的湿度值 ，USB端口号为0。

标签 ：Temp3:7.0.1
数据值类型：模拟量
描述 ：表示设备配置示例中3号模块LTM8002的7通道0号传感器的温度值 ，USB端口号为1。

标签 ：TC0C:2.0.1
数据值类型：模拟量
描述 ：表示0CH号模块LTM8660的2通道LTM8902第0路热电偶温度值 ，USB端口号为1。

标签 ：DI1F:0.0.0.0
数据值类型：开关量
描述 ：表示1FH号模块LTM8600的第0路开关量输入值，USB端口号为0。

标签 ：DO1F:1.0.0.0
数据值类型：开关量
描述 ：表示1FH号模块LTM8600的第0路开关量输出值，USB端口号为0。