艾雷斯DAC8000系列模块

概述 设置 网络接线图 超时时间和通讯间隔时间 在线升级驱动

概述

艾雷斯系列是一套内置微处理器的智能的传感器接口模块。可以通过一套简单的命令语言（ASCII格式）对他们进行远程控制并在485网上通讯。它们提供信号调节、隔离、搜索、A/D、D/A、DI、DO、数据比较和数据通讯。一些模块提供数字I/O线路用来控制继电器和TTL电平装置。

开物2000支持的艾雷斯8000系列模块有：

项目符号 | DAC8013E
项目符号 | DAC8017
项目符号 | DAC8018
项目符号 | DAC8021
项目符号 | DAC8050
项目符号 | DAC8052
项目符号 | DAC8053
项目符号 | DAC8060
项目符号 | DAC8080

设置

通过从主机上用模块厂家所提供的应用软件发出的一套命令，可以设置参数包括I/O地址、波特率、和有无校验等。

艾雷斯模块上电后INIT*端子和GND端子短接时模块的状态叫做INIT*状态。

INIT*状态的缺省值为：

波特率：9600

地址：00H

校验和：无

设置方法如下：

（1）给其他所有的部件（该艾雷斯模块除外）上电。

（2）给该模块的INIT*和GND短接后上电。（如下图示：）

（3）等待7秒钟使其自检且检索生效。

（4）设定该模块地址、校验和和/或波特率（具体的命令输入参看艾雷斯模块说明书）。

（5）关掉该模块的电源。

（6）使INIT*和GND之间断开再给该模块上电。

（7）等7秒钟使其自检且检索生效。

（8）检查所设定的值是否正确。

注意事项：

*必须使所有的模块和主机的波特率、校验和的值相一致。

*只能在INIT*状态下设置地址、波特率、校验和。

*所做的改动只有在再启动后才生效。

艾雷斯模块组成的网络接线图

注：该网络最多可接256个艾雷斯模块，* 如多于256个模块需加DACRS--485中继器。

通讯超时时间

通讯超时时间：

由于通讯的距离不同，计算机发送一条查询命令后，需要等待一段时间才能收到模块的应答信息，如果在通讯超时时间内没有收到完整而正确的应答信息，计算机将认为由于线路干扰等原因这次通讯失败。在开物2000中通讯超时时间的取值范围是10-60000(毫秒)。

通讯超时时间可以在设备向导的退出确认页中设定，如下图：


DAC8013E

概述 通讯连线示意图 地址设置 数据类型 在线升级驱动

概述

DAC 8013E是模拟量输入模块，一路模拟量输入。

通讯连线示意图：（DAC8520系列）

地址设置

所有的设置参数包括I/O地址、速率、奇偶性、校准参数都可以通过模块厂家提供的软件或命令进行远程设置。

数据类型

寄存器名称

寄存器

读写类型

数据类型

模拟量输入

AI0

只读

模拟量

量程校准

SPANCAL

只写

开关量

零校准

ZEROCAL

只写

开关量

举例：

寄存器： AI2:0
数据类型： 模拟量
注释： 模拟量输入值,模块地址为2


DAC8017

概述

DAC 8017是16位8通道模拟量输入模块，前6路为双端差动式，后2路为单端模拟量输入。

通讯连线示意图：（DAC8520系列）

地址设置

所有的设置参数包括I/O地址、速度、奇偶性、校准参数都可以通过模块厂家提供的软件或命令进行远程设置。
注:DAC8017的地址设置数字为16进制,即:当地址设置为10以上数时,地址设置是16进制的A,B,C,D.....。

数据类型

寄存器名称

寄存器

读写类型

变量类型

模拟量输入

AI0~7

读/写

模拟量

量程校准

SPANCAL

只写

开关量

零校准

ZEROCAL

只写

开关量

多通道状态

MP

读写

开关量

举例：

寄存器： AI2:0
数据类型： 模拟量
注释： 模拟量输入值,模块地址为2，通道号为0

寄存器： AI2:1
数据类型： 模拟量
注释： 模拟量输入值,模块地址为2，通道号为1

寄存器： AI2:2
数据类型： 模拟量
注释： 模拟量输入值,模块地址为2，通道号为2

寄存器： AI2:3
数据类型： 模拟量
注释： 模拟量输入值,模块地址为2，通道号为3

寄存器： AI2:4
数据类型： 模拟量
注释： 模拟量输入值,模块地址为2，通道号为4

寄存器： AI2:5
数据类型： 模拟量
注释： 模拟量输入值,模块地址为2，通道号为5

寄存器： AI2:6
数据类型： 模拟量
注释： 模拟量输入值，模块地址为2，通道号为6

寄存器： AI2:7
数据类型： 模拟量
注释： 模拟量输入值,模块地址为2，通道号为7


DAC8018

概述

DAC 8018是16位8通道模拟输入数据记录模块，前6路为双端差动模拟量输入，后2路为单端模拟量输入。

通讯连线示意图：（DAC8520系列）

地址设置

所有的设置参数包括I/O地址、速率、奇偶性、高限和低限报警、校准参数都可以通过模块厂家提供的软件或命令进行远程设置。

数据类型

寄存器名称

寄存器

读写类型

变量类型

模拟量输入

AI0~7

读/写

         模拟量

量程校准

SPANCAL

只写

         开关量

零校准

ZEROCAL

只写

         开关量

多通道状态

MP

读写

         开关量

冷端补偿值

CJCVAL

只读

         模拟量

冷端补偿偏移量值

CJCOFF

只写

         模拟量

举例：

寄存器： AI2:0
数据类型： 模拟量
注释： 模拟量输入值,模块地址为2

寄存器： AI2:1
数据类型： 模拟量
注释： 模拟量输入值,模块地址为2

寄存器： AI2:2
数据类型： 模拟量
注释： 模拟量输入值,模块地址为2

寄存器： AI2:3
数据类型： 模拟量
注释： 模拟量输入值,模块地址为2

寄存器： AI2:4
数据类型： 模拟量
注释： 模拟量输入值,模块地址为2

寄存器： AI2:5
数据类型： 模拟量
注释： 模拟量输入值,模块地址为2

寄存器： AI2:6
数据类型： 模拟量
注释： 模拟量输入值,模块地址为2

寄存器： AI2:7
数据类型： 模拟量
注释： 模拟量输入值,模块地址为2


DAC8021

概述

DAC 8021是模拟量输出模块，一路模拟量输出。

通讯连线示意图：（DAC8520系列）

地址设置

所有的设置参数包括I/O地址、速度、奇偶性、高限和低限报警、校准参数都可以通过模块厂家提供的软件或命令进行远程设置。

数据类型

寄存器名称

寄存器

读写类型

数据类型

模拟量输出

AO0

读/写

模拟量

4mA校准

CURCALF

只写

开关量

20mA校准

CURCALT

只写

开关量

整理校准

TRIMCAL

只写

模拟量

举例：

（1）寄存器： AO2:0
数据类型： 模拟量
注释： 模拟量输出值,模块地址为2

（2）若校准20mA,先建立标签一开关量类型的标签主地址为CURCALT并在运行是把它置为True，再建立标签一模拟量类型的标签主地址为TRIMCAL并在运行是把它置为偏差值（单位为µA）,偏差值最大不能超过±95µA。


DAC8050

概述

DAC 8050是数字I/O模块，7通道数字量输入，8通道数字量输出。

通讯连接示意图：（DAC8520系列）

地址设置

所有的设置参数包括I/O地址、速度、奇偶性都可以通过模块厂家提供的软件或命令进行远程设置。

数据类型

寄存器名称

寄存器

读写类型

数据类型

数字量输入

DI0~6

只读

开关量

数字量输出

DO0~7

读/写

开关量

举例：

寄存器： DI2:0
数据类型： 开关量
注释： 第0通道数字量输入,模块地址为2

寄存器： DO2:0
数据类型： 开关量
注释： 第0通道数字量输出,模块地址为2


DAC8052

概述

DAC 8052是8路带隔离数字量输入模块，6路双端数字量输入，2路单端数字量输入。

通讯连接示意图：（DAC8520系列）

地址设置

所有的设置参数包括I/O地址、速度、奇偶性都可以通过模块厂家提供的软件或命令进行远程设置。

数据类型

寄存器名称

寄存器

读写类型

数据类型

数字量输入

DI0~7

只读

开关量

举例：

寄存器： DI2:0
数据类型： 开关量
注释： 第0通道数字量输入,模块地址为2


DAC8053

概述

DAC 8053是16路数字量输入模块

数字输入
（1）干触点

逻辑0：接地
逻辑1：开路

（2）湿触点

逻辑0：最大为+2V
逻辑1：+4V~30V
电源：24V

通讯连接示意图：（DAC8520系列）

地址设置

所有的设置参数包括I/O地址、速度、奇偶性、高限和低限报警、校准参数都可以通过模块厂家提供的软件或命令进行远程设置。

数据类型

寄存器名称

寄存器

读写类型

数据类型

数字量输入

DI0~15

只读

开关量

举例：

寄存器： DI2:0
数据类型： 开关量
注释：第0通道数字量输入,模块地址为2


DAC8060

概述

DAC 8060是继电器输出模块

继电器输出
（1）格式A：2通道
（2）格式B：2通道
电源：24V

通讯连接示意图：（DAC8520系列）

地址设置

所有的设置参数包括I/O地址、速度、奇偶性都可以通过模块厂家提供的软件或命令进行远程设置。

数据类型

寄存器名称

寄存器

读写类型

数据类型

数字量输出

DO0~1

读/写

开关量

举例：

寄存器： DO2:0
数据类型： 开关量
注释： 第0通道数字量输出,模块地址为2


DAC8080

概述

DAC 8080是计数/频率输出模块

·2通道独立的32位计数（counter0和counter1）
·输入频率：最大为50Hz
·输入模式：隔离或不隔离

1.隔离输入电平：

逻辑0：最大为+1V
逻辑1：+3.5V~+30V
接线如图示：

2.不隔离输入电平：

逻辑0：0~ +5V（缺省值为0.8V）
逻辑1：0~ +5V（缺省值为2.4V）
接线如图示：

·数字输出DO：2通道
·电源：24V

通讯连接示意图：（DAC8520系列）

地址设置

所有的设置参数包括I/O地址、速度、奇偶性、高限和低限报警、校准参数都可以通过模块厂家提供的软件或命令进行远程设置。

数据类型

寄存器名称

寄存器

读写类型

数据类型

输入信号模式

ISM

读/写

开关量

计数器值

PCV

只读

模拟量

门模式

GM

读/写

开关量

最大计数器值

MCV

读/写

模拟量

计数器启动/停止状态

CS

读/写

开关量

清计数器

CLSC

只写

开关量

初始化计数器值

ICV

读/写

模拟量

报警使能

ALA

读/写

开关量

报警低限值

ALV

读/写

模拟量

数字量输出

DO

读/写

开关量

举例：

寄存器： DO2:0
数据类型： 开关量
注释： 第0通道数字量输出,模块地址为2

寄存器： PCV2:0
数据类型：模拟量
注释： 第0通道计数器值,模块地址为2

寄存器： PCV2:1
数据类型：模拟量
注释： 第1通道计数器值,模块地址为2