研华ADAM5000系列模块

研华ADAM5510系列模块

概述 系统连接示意图 设备创建 标签创建 标签的地址配置规则 在线驱动升级

概述

研华ADAM5510 系列是一套内置微处理器的智能的传感器接口模块。可以通过自定义协议实现对他们进行远程控制并在 485 网上通讯。

它们提供 AI、AO、DI、DO 等功能，其包含四 I/O 槽位，最大网络连接设备为32。

开物2000现支持ADAM5013,ADAM5017,ADAM5018,ADAM5024,ADAM5050,ADAM5051,ADAM5052,

ADAM5056,ADAM5060,ADAM5068,ADAM5080模块。

系统连接示意图：

设备创建向导及参数设置

1． 用户以RS232/RS485 与开物 2000连接：

  • 创建一个或多个子设备

  • 默认通讯参数：波特率9600(RS232)/38400(RS485)、8位数据位、1位停止位、无校验

  • 设备可选地址范围：0-31

2． 运行创建向导创建设备

步骤1：选择设备类型，双击选择‘研华 ADAM5510系列模块’。

步骤2：选择操作方式-新建设备，单击下一步。

步骤 3 ，选择创建设备方式，单击下一步。

步骤4：选择设备及配置设备地址，进入下一步。

步骤5：配置串口参数，进入下一步。

步骤6：显示所有配置参数，结束设备创建。

标签创建

使用设备创建向导创建完设备模块后就可以进行标签创建。

在开发环境中选‘标签’添加标签，见下图。选择主设备为创建的相应模块，选择并填写‘主设备地址’，修改标签名。

注意：

1:如果是ADAM5018/ADAM5017模块标签，请设置其标签扫描周期为1秒。

2:对ADAM5018模块，需要根据其量程在开物标签设置其相应的工程值范围：

+/-15mv，+/-20mA:工程值最大最小值减小1000倍

+/-50mv， +/-100mv:工程值最大最小值减小100倍

+/-500mv:工程值最大最小值减小10倍

+/-1v， +/-2.5v:工程值最大最小值减小10000倍

3:对ADAM5017模块，需要根据其量程在开物标签设置其相应的工程值范围：

+/-10v，+/-5v,+/-20mA:工程值最大最小值减小1000倍

+/-150mv:工程值最大最小值减小100倍

+/-500mv:工程值最大最小值减小10倍

+/-1v:工程值最大最小值减小10000倍

标签类型及地址配置规则

标签类型：AI,AO,DI,DO

标签主地址可以安下面规则创建：

标签类型[ID]:SLOT.CHN

说明：

1． 标签类型主要指监测和控制的数据类型。如模拟量输入输出，数字量输入输出等。

2． 标示ID是指设备的地址号；

3． 标示SLOT是指槽号，ADAM5510范围为0-3；

4． 标示CHN是指某一某块的通道号。不同类型设备的范围不同，其最大范围为0-15；

5． 标签地址配置成不存在标签类型或错误地址、槽号通道号超出范围，标签将被不承认，数据都将无法读数。

标签举例

标签：AI0:0.2

数据类型：模拟量

描 述：表示 0 站号 I/O 模块 0 槽号 2 通道的数据输入值。

标签：A00:0.2

数据类型：模拟量

描 述：表示 0 站号 I/O 模块 0 槽号 2 通道的数据输入值。

标签：DO0:3.5

数据类型：开关量

描 述：表示 0 站号 I/O 模块 3 槽号 5 通道的开关量输出值。