研华ADAM5000系列模块

概述 系统连接示意图 设备创建 标签创建 标签的地址配置规则 在线驱动升级

概述

研华ADAM5000 系列是一套内置微处理器的智能的传感器接口模块。可以通过一套简单的命令语言（ASCII 格式）对他们进行远程控制并在 485 网上通讯。它们提供 AI、AO、DI、DO 等功能。其包含四 I/O 槽位的 ADAM5000/485 和八 I/O 槽位的 ADAM5000E两种设备类型。

开物2000 支持的 ADAM5000 系列 I/O模块有：

  • ADAM5017：八通道 AI输入模块

  • ADAM5018：七热电耦输入模块

  • ADAM5024 ：四通道 AO输出模块

  • ADAM5051 ：十六通道 DI输入模块

  • ADAM5060 ：六通道继电器输出模块

关于ADAM5000系列的更详细信息请访问

系统连接示意图：

设备创建向导及参数设置

1． 用户以RS232/RS485 与开物 2000连接：

  • 创建一个或多个子设备

  • 默认通讯参数：波特率9600、8位数据位、1位起始位、1位停止位、无校验

  • 允许连接设备类型：ADAM5017、ADAM5018、ADAM5024、ADAM5051、ADAM5060

  • 设备可选地址范围：0-255

2． 运行创建向导创建设备

步骤1：选择设备类型，双击选择‘研华 ADAM5000系列模块’。

步骤2：选择操作方式-新建设备，单击下一步。

步骤 3：显示自动搜索的配置界面，单击下一步。

步骤4：显示设备及参数汇总窗口，单击‘完成’按钮，结束设备配置向导。

标签创建

使用设备创建向导创建完设备模块后就可以进行标签创建。

在开发环境中选‘标签’添加标签，见下图。选择主设备为创建的相应模块，选择并填写‘主设备地址’，修改标签名。

标签的地址配置规则

标签主地址可以安下面规则创建：

标签类型[ID]：SLOT.CHN

说明：

1． 标签类型主要指监测和控制的数据类型。如模拟量输入输出，数字量输入输出等。可以取为：AI/AO/DI/DO；

2． 标示ID是指设备的地址号；

3． 标示SLOT是指槽号，ADAM5000/485范围为0-3、ADAM5000E范围为0-7；

4． 标示CHN是指某一某块的通道号。不同类型设备的范围不同，其范围为0-15；

5． 标签地址配置成不存在标签类型或错误地址、槽号通道号超出范围，标签将被不承认，数据都将无法读数。

设备支持的标签列表

ADAM5017支持的标签

标签类型

功能说明

读写特性

槽号范围

通道号范围

AI

模拟量输入

读

0-7

0-7

ADAM5018支持的标签

标签类型

功能说明

读写特性

槽号范围

通道号范围

AI

模拟量输入

读

0-7

0-6

ADAM5024支持的标签

标签类型

功能说明

读写特性

槽号范围

通道号范围

AO

模拟量输出

写

0-3

0-3

ADAM5051支持的标签

标签类型

功能说明

读写特性

槽号范围

通道号范围

值范围

DI

数字量输入

读

0-7

0-15

0-1

ADAM5060支持的标签

标签类型

功能说明

读写特性

槽号范围

通道号范围

值范围

DI

数字量输入

读

0-7

0-5

0-1

DO

数字量输出

写

0-7

0-5

0-1

标签举例

标签：AI0:0.2

数据类型：模拟量

描 述：表示 0 站号 I/O 模块 0 槽号 2 通道的数据输入值。

标签：AO0:2.2

数据类型：模拟量

描 述：表示 0 站号 I/O 模块 2 槽号 2 通道的数据输出值。

标签：DI0:3.9

数据类型：开关量

描 述：表示 0 站号 I/O 模块 3 槽号 9 通道的开关输入值。

标签：DO0:3.5

数据类型：开关量

描 述：表示 0 站号 I/O 模块 3 槽号 5 通道的开关输入/输出值。