峰光数显卡尺通讯模块

峰光数显卡尺通讯模块综述

模块概述 硬件 设置 创建设备 创建标签 标签的地址规则 标签举例 在线升级驱动

峰光数显卡尺通讯模块概述

峰光数显卡尺通讯模块可以使数显量具通过RS232串口和计算机传输数据。

开物2000还支持其它多种设备，详情请与 华富惠通公司联系。

峰光数显卡尺通讯模块的硬件设置

在使用峰光数显卡尺通讯模块前请先按照使用说明书设定好通讯方式。

波特率为 9600baud；

数据位8位，停止位1位，无校验。

在开物2000开发环境中创建设备

在开发环境的“硬件系统”中按照“新节点和设备向导”的指示配置所连接的 模块。以便于开物2000识别和使用。

步骤1：选择”智能模块“设备类型。双击“峰光数显卡尺通讯模块”，或单击选中“峰光数显卡尺通讯模块”，这里可以查看“驱动版本号”，更改设备名称， 如“RS04L” ，然后单击“选择”按钮。

步骤2：在”峰光数显卡尺通讯模块向导“中选择执行的操作方式——“新建设备”。选中“新建设备”后单击”下一步”按钮(或双击“新建设备”)，您也可以选择“修改设备”，对 模块的配置进行修改或者选择“察看设备”浏览已经设置好的模块配置情况。

其中下面的按钮的含义分别为：

下载最新驱动：可以帮助您进入开物技术支持网站的下载专区中；

帮助信息：可以查看驱动的版本等信息；

调试设置：通常情况下“调试开关”打开，这时可以记录开物的基本信息，主要包括启动和退出的时间，标签情况，通讯情况等信息；如果把“输出错误信息”和“输出跟踪信息”也选中的话，这时将记录开物运行过程中的全部通讯信息，对于记录通讯过程中的错误信息很有帮助，如果您在使用开物过程中，硬件连接有问题时，请打开所有调试开关，将通讯信息记录下来，待正常后，请您把“输出错误信息”和“输出跟踪信息”关闭。

注意：整个信息将存成LOG文件，在相应工程目录下面的“DEBUG”子目录下，文件名以驱动DLL文件加上日期时间的方式命名，如RS04L2004-05-31-13-33-54.LOG。

步骤3：在"峰光数显卡尺通讯模块向导"中选择创建设备的方式——包括“单个 模块创建”和“多个模块创建”。其中：

单个LED创建：指在一个设备中创建一块模块；

多个LED创建：指在一个设备中创建多个子模块，当然您也可以建立多个设备从而实现多块 模块的连接。

步骤4：在”峰光数显卡尺通讯模块向导“中选择 模块类型， 设置模块设备号，若连接多块模块可以选择“添加智能模块”，若需要修改模块的参数，可以先选中“设备配置图”中的设备，然后更改 模块类型和设备号，最后点击“修改智能模块”；若需要删除多余的或错误的智能模块，可以选择“删除智能模块”。 其中：

模块号：在RS485网络中模块的站号，不允许重复， 本驱动不用关心。

模块类型：指用户使用的模块型号，通过下拉菜单选择；

步骤5：设置计算机的串口参数，主要包括串口号、波特率、数据位、停止位、校验方式等。其中波特率、数据位、停止位、校验方式等，其中除串口号外其它参数一定与下位机完全相同。

步骤6：察看您建立的设备，没有问题，请点击“完成”按钮，如果有问题，可以点击“上一步”进行必要的修改。至此，整个设备建立完成。

标签的创建

使用“峰光数显卡尺通讯模块向导”完成模块的创建后，可以进行标签设计。

1、在开发环境的“标签”击鼠标右键，选择“添加标签“，显示见下图，选择主设备为上面的‘RS04L'，选择并填写‘主设备地址’，修改标签名。

实现的主要功能包括实时采集数显卡尺的测量数据；

在模块类设备中，标签的配置规则为：标签+通道号，如DISTANCE0；

2、根据您的特定使用需求，修改测量值和工程值的最大值、最小值、扫描周期等属性。单击‘添加’或‘完成’按钮。其中：

测量值最大值：设定为模块当前量程的上限值；

测量值最小值：设定为模块当前量程的下限值；

工程值最大值：设定为实际物理参数的上限值；

工程值最小值：设定为实际物理参数的下限值；

如：模块的量程为：0 ～ 99999，对应现场的重量信号为0 ～ 999.99，则测量值最大值设为 99999；最小值设为 0；工程值最大值设为 999.99；最小值设为 0。

请注意：假如只测量外界的现场信号则不需要更改测量值和工程值的最大值、 最小值，保持默认值就可以。

标签地址配置规则

标签地址可以按照下面的规则配置填写：

标签类型[ID:]Ch ，其中CH范围 见下表。

说明：

项目符号

ID指模块号，用于识别同一设备中的不同子模块， 模块号设定范围为0 ～ 255，十进制表示。

项目符号

Ch指通道号，范围根据 模块类型不同，十进制表示。

项目符号 | 红色字表示格式中的可变部分 。
项目符号 | 蓝色括号不出现在标签地址中，蓝色括号内的内容在“单个 模块创建”时可省略。
项目符号 | 标签地址配置成不存在类型或模块地址错误或通道号超出有效范围时，标签将不被承认， 不能读/写数据。

标签地址

标签含义

数据类型

读写类型

通道地址范围

通道代表含义

DISTANCE CH

数显卡尺实时测量值

模拟量

只读

0

无

标签举例：

标签 ：DISTANCE0
数据值类型：模拟量
描述 ：表示数显卡尺的实时测量值。