威达ICPCON8000模块

概述 设备创建向导及参数设置 标签的创建 标签的地址配置规则 设备支持的标签列表 在线升级驱动

概述

威达ICPCON8000系列模块是一种基于类DOS操作系统的PC-Based控制器。

硬件的控制软件需要用户采用C语言设计特定的DOS程序，并下载到控制器中执行。硬件的通讯部分软件也需要用户实现。

硬件出厂时，厂家在硬件系统中预装一个标准程序《8K485.exe》。此485通讯程序所采用的通讯协议《I-8810 command protocol》就是本驱动程序所遵循的规范。

ICPCON8000家族还包括扩展Unit(I/O Expansion Unit)，其通讯端口采用RS485标准，采用的协议遵循《I-7000 command protocol》，在扩展Unit上每个模块是独立的，在通讯协议报文中以模块的ID为地址进行访问，Unit本身不存在ID编号。主控制Unit上模块的访问涉及到两个地址主控制Unit的NetID和模块在主控制Unit上的槽号。

本驱动程序对主控制Unit(Main Control Unit)上的模块的通讯遵循《I-8810 command protocol》，对扩展Unit上的模块的访问遵循《I-7000 command protocol》。

用户在购买了ICPCON8000系列模块后，如果不开发定制软件，可通过RS232或RS485方式与开物2000系统直接通讯（INIT* pin OPEN）。如果需要在主控制器上定制特殊功能，或扩展Unit连接到主控制Unit的COM3，然后通过主控制Unit与开物2000通讯，此时，需要开发特殊的DOS程序，此DOS对PC端的通讯需要实现《I-8810 command protocol》和《I-7000 command protocol》两个协议，对COM3的通讯实现《I-7000 command protocol》协议。

下面是系统示意图：

设备创建向导及参数设置

1、用户在使用开物2000的配置向导前，需要做如下工作：

运行7000Util软件包，设定主控制Unit上每个模块的工作模式、通讯参数，设定扩展Unit上每个模块的ID和工作模式、通讯参数。

2、用户以RS232方式连接与开物2000，允许与主控制Unit直接连接：

  • 标准创建方式或自动创建方式，只创建一个子设备。
  • 默认通讯参数：波特率9600、8位数据位、1位起始位、1位停止位、无校验
  • 允许连接的设备类型：i8410/i8810
  • 设备可选地址范围：0-255

用户以RS485方式连接与开物2000，允许与主控制Unit直接连接：

  • 多设备创建方式或自动创建方式，可创建多个子设备。
  • 默认通讯参数：波特率115200、8位数据位、1位起始位、1位停止位、无校验
  • 允许连接的设备类型：i8410/i8810/i87017/i87024/i87054
  • 设备可选地址范围：0-255

3、运行创建向导创建设备

在开发环境的‘硬件系统’中按照‘新节点和设备向导’的指示配置所连接的模块。以便于开物2000识别和使用。

选择设备类型。双击‘威达ICPCON8000模块’，或单击选中‘威达ICPCON8000模块’，更改设备名称，最后单击‘选择’按钮。

选择操作方式-新建设备(一个设备中可以连接多个模块)。双击‘新建设备’。

选择创建设备的方式：双击‘多设备创建’。（如果模块已经连接到本机，双击‘自动创建’）

显示多设备创建界面，选择好设备类型，输入模块号后，点击‘添加设备’按钮。添加完所有的设备后，单击‘下一步’按钮。

下图示范的是通过RS485与一个主控制Unit（控制模块类型i8811）和一个扩展Unit连接。扩展Unit上安装了两个i87017模块、两个i87054模块和一个i87024模块，模块安装的槽位位置任意，但是模块的ID通过7000Util软件包设定。

显示计算机串行口通讯参数窗口，修改完串行口、波特率等参数后，单击‘下一步’按钮。

标签的创建

使用设备向导创建完成模块的配置后，可以进行标签设计。

1、在开发环境的‘标签’中添加标签，显示下图，选择主设备为上面的‘威达ICPCON8000模块’，选择并填写‘主设备地址’，修改标签名。

2、 根据模块的工作模式和标签所监控的参数物理意义，修改测量值零点、测量值量程、工程值零点、工程值量程、扫描周期、转换方式等。单击‘添加’或‘完成’按钮。

标签的地址配置规则

标签的主地址可以按照下面的规则配置填写：

标签类型NetID:[Slot.]Chn

说明：
1. 主控制Unit上的变量必须配置Slot. ，扩展Unit上的变量必须省略Slot或配置成0。

2.标签类型主要指监测和控制的数据类型，如模拟量输入输出，数字量输入输出等。可以取为：AI_M/AO_M/DI_M/DO_M/AI_E/AO_E/DI_E/DO_E。
带后缀M的标签用于配置主控制Unit上模块的变量，带后缀E的标签用于配置扩展Unit上模块的变量。

3.NetID指设备的标识ID。
设备可取类型包括：i8410/i8810/i87017/i87024/i87054等，其中i8410、i8810是主控制设备类型，i87017/i87024/i87054是扩展设备类型。
NetID就是指i8410、i8810的NetID。对扩展Unit来说，指在该Unit上安装在某一Slot中的模块（i87017/i87024/i87054）的ID，取值范围：0-255。

4.Slot指主控制Unit上的某一Slot(槽号)，只对i8410/i8810有效。i8410取值范围：0-3，i8810取值范围：0-7。

5.Chn指模块上的变量通道号，不同类型设备的取值范围稍有差别，最大取值范围：0-15，

设备支持的标签列表

表1 i8810支持的标签

标签类型

功能描述

缺省数据类型

读写特性

 槽号范围

通道号范围

值范围

AI_M

模拟量输入(模块在主控制Unit上)

模拟量

只读

0-7

0-7

-9999至9999

AO_M

模拟量输出(模块在主控制Unit上)

模拟量

读写

0-7

0-3

-9999至9999

DI_M

数字量输入(模块在主控制Unit上)

开关量

只读

0-7

0-7

true或false

DO_M

数字量输出(模块在主控制Unit上)

开关量

读写

0-7

0-7

true或false

表2 i8410支持的标签

标签类型

功能描述

缺省数据类型

读写特性

 槽号范围

通道号范围

值范围

AI_M

模拟量输入(模块在主控制Unit上)

模拟量

只读

0-7

0-7

-9999至9999

AO_M

模拟量输出(模块在主控制Unit上)

模拟量

读写

0-7

0-3

-9999至9999

DI_M

数字量输入(模块在主控制Unit上)

开关量

只读

0-7

0-7

true或false

DO_M

数字量输出(模块在主控制Unit上)

开关量

读写

0-7

0-7

true或false

表3 i87017支持的标签

标签类型

功能描述

缺省数据类型

读写特性

通道号范围

值范围

AI_E

模拟量输入(模块在扩展Unit上)

模拟量

只读

0-7

-9999至9999

表4 i87024支持的标签

标签类型

功能描述

缺省数据类型

读写特性

通道号范围

值范围

AO_E

模拟量输出(模块在扩展Unit上)

模拟量

读写

0-3

-9999至9999

表5 i87054支持的标签

标签类型

功能描述

缺省数据类型

读写特性

通道号范围

值范围

DI_E

数字量输入(模块在扩展Unit上)

开关量

只读

0-7

true或false

DO_E

数字量输出(模块在扩展Unit上)

开关量

读写

0-7

true或false