天辰智能模块

概述 硬件连接 创建设备 创建标签 标签地址及范围 标签举例 在线升级驱动

概述

北京昆仑天辰仪表科技有限公司以工业自动化测量显示及控制用仪器仪表和模块为主导产品。
开物2000支持以下系列的模块：

MXSE：包括模拟量采集、报警、变送输出等多种功能。

MXST：包括模拟量采集、报警、变送输出等多种功能。

开物2000还支持其它多种设备，详情请与 华富惠通公司联系。

硬件连接

通讯端口硬件的推荐设置：

天辰智能模块采用RS485连接，多块仪表时清按下图连接终端电阻。

波特率可选范围：2400bps、4800bps、9600bps、19200bps。

波特率 | 9600bps
起始位 | 1
数据位 | 8
停止位 | 1
校验位 | 无校验

创建设备

在开发环境的‘硬件系统’中按照‘新节点和设备向导’的指示配置所连接的模块。以便于开物2000识别和使用。

步骤1：选择设备类型，更改设备名称，最后单击‘选择’按钮。

步骤2：选择操作方式-新建设备(一个设备中可以包含多个)。选中‘新建设备’后单击‘下一步’按钮(或双击‘新建设备’)。

步骤3：选择创建方式(一个设备中可以包含多个)。选中 创建方式后单击‘下一步’按钮(或双击‘标准创建’)。

步骤4：设置模块类型和设备号，单击‘下一步’按钮。

步骤5：设备串口通讯参数， 如下图所设，单击‘下一步’。

步骤6：显示设备及参数配置图，点击‘完成’按钮，完成设备配置向导.

创建标签

使用“天辰智能模块向导“完成设备的创建后，可以进行标签设计。

1、在开发环境的‘标签’中添加标签，显示下图，选择上述主设备‘TianChenModule'，选择并填写‘主地址’，修改标签名。

2、根据仪表的工作模式和标签所监控的参数物理意义，修改工程值零点、工程值量程、扫描周期、转换方式、记录属性等。
单击‘添加’或‘完成’按钮。

标签地址及范围

标签的主地址可以按照下面的规则配置填写：

标签类型[ID:][CH]

说明：模块地址使用10进制，对于参数地址PARM使用16进制。

项目符号 | 标签地址中省略ID时，开物2000系统默认为是所连接设备的最小的站号地址,天辰智能模块的站号为0～99。
项目符号 | Ch指通道号，范围因标签类型而异，十进制表示。
项目符号 | 标签地址配置成不存在类型或仪表地址错误或通道号超出有效范围时，标签将不被承认，读不上数据。
标签地址 | 含义 | 数据类型 | 读写类型 | 通道地址范围 | 标签值范围
PV ID:CH | 巡检仪测量值 | 模拟量 | 只读 | 1～16 | -99999～99999
PV_ALARM ID:CH | 模块报警状态 | 开关量 | 只读 | 1～4 | 0/1
PARM ID:CH | 读取/设置模块参数 | 模拟量 | 读/写 | 16～79 | 见参数地址表
AO ID:CH | 设置/回读变送输出 | 模拟量 | 读/写 | 1 | -99999～99999
SetPassWord ID:CH | 是否允许设置仪表参数 | 开关量 | 只写 | 0 | 0/1,为真则可以修改
CommLink | 通信线路状态(-系统标签-) | 模拟量/字符串量 | 只读 | ---- | 0=通讯始终不成功
 |  |  |  |  | 1=通讯正常
 |  |  |  |  | 2=通讯出现干扰
 |  |  |  |  | 3=通讯出现故障
 |  |  |  |  | 4=通讯线路断路
 |  |  |  |  | 5=暂停通讯
DeviceLink ID: | 设备通讯连接状态(-系统标签-) | 模拟量/字符串量 | 只读 | ---- | 0=通讯始终不成功
 |  |  |  |  | 1=通讯正常
 |  |  |  |  | 2=通讯出现干扰
 |  |  |  |  | 3=通讯出现故障
 |  |  |  |  | 4=通讯线路断路
 |  |  |  |  | 5=暂停通讯

下面是标签PARM对应的参数地址：

名称 | 内容 | 地址 | 取值范围
oA | 密码 | 10H | 0~9999
c-b | 折线功能选择 | 11H | 0对应OFF，1对应ON
c1 | 第1折线点测量值 | 12H | -19999~45000
b1 | 第1折线点标准值 | 13H | -19999~45000
c2 | 第2折线点测量值 | 14H | -19999~45000
b2 | 第2折线点标准值 | 15H | -19999~45000
c3 | 第3折线点测量值 | 16H | -19999~45000
b3 | 第3折线点标准值 | 17H | -19999~45000
c4 | 第4折线点测量值 | 18H | -19999~45000
b4 | 第4折线点标准值 | 19H | -19999~45000
c5 | 第5折线点测量值 | 1AH | -19999~45000
b5 | 第5折线点标准值 | 1BH | -19999~45000
c6 | 第6折线点测量值 | 1CH | -19999~45000
b6 | 第6折线点标准值 | 1DH | -19999~45000
c7 | 第7折线点测量值 | 1EH | -19999~45000
b7 | 第7折线点标准值 | 1FH | -19999~45000
c8 | 第8折线点测量值 | 20H | -19999~45000
b8 | 第8折线点标准值 | 21H | -19999~45000
c9 | 第9折线点测量值 | 22H | -19999~45000
b9 | 第9折线点标准值 | 23H | -19999~45000
c10 | 第10折线点测量值 | 24H | -19999~45000
b10 | 第10折线点标准值 | 25H | -19999~45000
c11 | 第11折线点测量值 | 26H | -19999~45000
b11 | 第11折线点标准值 | 27H | -19999~45000
c12 | 第12折线点测量值 | 28H | -19999~45000
b12 | 第12折线点标准值 | 29H | -19999~45000
c13 | 第13折线点测量值 | 2AH | -19999~45000
b13 | 第13折线点标准值 | 2BH | -19999~45000
c14 | 第14折线点测量值 | 2CH | -19999~45000
b14 | 第14折线点标准值 | 2DH | -19999~45000
c15 | 第15折线点测量值 | 2EH | -19999~45000
b15 | 第15折线点标准值 | 2FH | -19999~45000
incH | 输入信号选择 | 30H | 0 ~ 19
in-d | 显示小数点位置选择 | 31H | 0 ~ 4 顺序对应 0.0000；00.000；000.00；0000.0；00000
u-r | 量程下限 | 32H | -19999~45000
F-r | 量程上限 | 33H | -19999~45000
in-A | 零点修正值 | 34H | -19999~45000
Fi | 满度修正值 | 35H | 0.5000~1.5000
FLtr | 数字滤波时间常数 | 36H | 1 ~ 20
PF | 开平方运算选择 | 38H | 注2
cHo | 小信号切除门限 | 39H | 0 ~ 25
bout | 故障代用值 | 3CH | -19999~45000
Add | 模块通讯地址 | 40H | 0 ~ 99
bAud | 通讯速率选择 | 41H | 0 ~ 3 顺序对应2400，4800，9600，19200
ctA | 变送输出控制权选择 | 45H | 0对应OFF，1对应ON
Li | 冷端补偿修正值 | 47H | 0.0000~2.0000
oP | 输出信号选择 | 4DH | 0对应OFF，1对应ON
bA-L | 变送输出下限 | 4EH | -19999~45000
bA-H | 变送输出上限 | 4FH | -19999~45000

注意事项：由于天辰智能模块数据格式的原因，在理解标签读/写数据数值的时候，要注意小数点的位置，例如小数点的位置为2时，假如需要写的数据为20，那么在开物2000中需要写的数据为20*100=2000。在使用过程中可以建立标签PV_ALARM0:3 1用于了解当前小数点的位置。

标签举例

标签 ：PV 0:1
数据值类型：模拟量
描述 ：表示设备号地址为0的模块第1通道测量值

标签 ：PV_ALARM0:1
数据值类型：开关量
描述 ：表示设备号地址为0的模块的第一报警状态

标签 ：PARM 0:33
数据值类型：开关量
描述 ：表示设备号地址为0的 模块的量程上限。

标签 ：SetPassWord 1:0
数据值类型：开关量
描述 ：表示设备号地址为1的模块的 参数值是否允许修改，为真则可以修改。

标签 ：AO0:1
数据值类型：开关量
描述 ：表示设置/回读设备号地址为0的 模块的变送输出值。

标签 ：DeviceLink0:
数据值类型：模拟量
描述 ：表示设备配置示例中0号设备的最新通讯状态