三兴达CAN总线

三兴达CAN总线（基于PCI非智能卡）

概述 硬件连接 创建设备 创建标签 标签地址及范围 标签举例 在线升级驱动

概述

北京三兴达科技有限责任公司座落于我国高新技术产业基地—中关村，公司成立伊始即致力于工业自动化控制的开发、研制、技术咨询和售后服务。公司技术力量雄厚，拥有一批专业经验丰富、富于创新、充满信心的专业技术人员。在三兴达人共同努力下，本公司推出的CAN 总线产品集强大的功能和使用方便于一体，受到各界用户的一致关注和好评，在电力、石化、铝电解、环保、智能楼宇、铁路等领域发挥着越来越重要的作用。三兴达公司成立于1996 年，是国内最早进行CANBUS 开发研究的几家公司之一，为国内CANBUS 的推广应用作了大量的工作。公司开发的具有自主知识产权的CANBUS系列产品，质量可靠、工作稳定，已被广泛应用于国民经济的各行业。

开物2000支持以下型号的CAN卡模块（基于PCI非智能卡方式）：

项目符号 | ICM1000_0108 ：8路12位模拟量输入入(输入信号: 0-10Ma，0-20Ma，4-20mA 电流；0-5V，1-5V，0-10V，0-20V 电压)
项目符号 | ICM1000_0202 ：2路模拟量输出(输出信号：0-10mA，4-20mA 电流；0-5V，1-5V，0-10V电压)
项目符号 | ICM1000_0204 ：4路模拟量输出(输出信号：0-10mA，4-20mA 电流；0-5V，1-5V，0-10V电压)
项目符号 | ICM1000_0308 ：8路光电隔离数字量输入
项目符号 | ICM1000_0404J ：4路继电器输出
项目符号 | ICM1000_0416J ：16路继电器输出
项目符号 | ICM1000_0108R ：8路12位模拟量输入入(输入信号：J、K、S、T、R、E 各种型号热电偶，mv 信号，带冷端补偿)
项目符号 | ICM1000_0106P ：6路12位模拟量输入(输入信号：Pt100,Cu 各种型号热电阻，二、三线输入)
项目符号 | ICM1000_0408 ：8路光电隔离TTL数字量输出
项目符号 | ICM1000_3416 ：16路数字量输出/输入

开物2000还支持其它多种设备，详情请与 华富惠通公司联系。

硬件连接

本版本的驱动程序使用研华的动态链接库Pcicandrv.DLL，在使用CAN卡前，请安装相应的驱动程序。

在使用三兴达CAN卡时要注意设置好CAN卡的波特率和地址号，不同型号的设置可能回。

通讯端口硬件的推荐设置：

三兴达CAN卡采用CAN总线连接，多块仪表时 请选择连接终端电阻。

波特率可选范围：5K、10K、20K、40K、50K、100K、125K、160K、250K、320K、500K、800K和1000Kbps。

默认拨特率为5K。

创建设备

在开发环境的‘硬件系统’中按照‘新节点和设备向导’的指示配置所连接的仪表。以便于开物2000识别和使用。

步骤1：选择设备类型，更改设备名称，最后单击‘选择’按钮。

步骤2：选择操作方式-新建设备(一个设备中可以包含多个)。选中‘新建设备’后单击‘下一步’按钮(或双击‘新建设备’)。

步骤3：选择创建方式(一个设备中可以包含多个)。选中 创建方式后单击‘下一步’按钮(或双击‘标准创建’)。

步骤4：设置仪表类型和设备号，单击‘下一步’按钮。

步骤5：设备CAN卡通讯参数， 如下图所设，单击‘下一步’不同，其中CAN卡卡号指插在计算机插槽上的CAN卡卡号。

步骤6：显示设备及参数配置图，点击‘完成’按钮，完成设备配置向导.

创建标签

使用“三兴达CAN卡向导“完成设备的创建后，可以进行标签设计。

1、在开发环境的‘标签’中添加标签，显示下图，选择上述主设备‘CAN’，选择并填写‘主地址’，修改标签名。

2、根据仪表的工作模式和标签所监控的参数物理意义，修改工程值零点、工程值量程、扫描周期、转换方式、记录属性等。
单击‘添加’或‘完成’按钮。

标签地址及范围

标签的主地址可以按照下面的规则配置填写：

标签类型[ID:][CH]

说明：

项目符号 | 标签地址中省略ID时，开物2000系统默认为是所连接设备的最小的站号地址,三兴达CAN卡的站号为0～31。
项目符号 | Ch指通道号，范围因标签类型而异，十进制表示。
项目符号 | 标签地址配置成不存在类型或仪表地址错误或通道号超出有效范围时，标签将不被承认，读不上数据。
标签地址 | 含义 | 数据类型 | 读写类型 | 标签值范围
AD ID:Ch | 模拟量输入 | 模拟量 | 只读 | 见使用说明书
DA ID:Ch | 模拟量输出 | 模拟量 | 只写
DI ID:Ch | 数字量输入 | 开关量 | 只读
DO ID:Ch | 数字量输出 | 开关量 | 只写

下面是各种型号的通道范围：

CAN 模块型号 | 标签类型 | 通道范围
ICM1000_0108 | 模拟量输入 | 1～ 8
ICM1000_0202 | 模拟量输出 | 1～2
ICM1000_0204, | 模拟量输出 | 1～ 4
ICM1000_0308 | 数字量输入 | 1～ 8
ICM1000_0404J, | 数字量输出 | 1～ 4
ICM1000_0416J | 数字量输出 | 1～ 16
ICM1000_0108R | 模拟量输入 | 1～ 8
ICM1000_0106P, | 模拟量输入 | 1～6
ICM1000_0408 | 数字量输出 | 1～ 8
ICM1000_3416 | 数字量输入/输出 | DI：1～ 16 DO：1～ 16

标签举例

标签 ：AD1:1
数据值类型：模拟量
描述 ：表示1号板卡的第1通道模拟量输入值

标签 ：DA1:1
数据值类型：模拟量
描述 ：表示1号板卡的第1通道模拟量输出值

标签 ：DI1:1
数据值类型：开关量
描述 ：表示1号板卡的第1通道开关输入值

标签 ：DO1:1
数据值类型：开关量
描述 ：表示1号板卡的第1通道开关输出值