Guardian CMC-12智能仪表

概述 硬件连接 创建设备 创建标签 标签的地址规则 标签举例 附件（寄存器地址） 在线升级驱动

概述

CMC-12SCH是一种冷冻压缩机控制器。本驱动采用MODBUS通讯协议，因此在使用之前请将CMC-12SCH控制器的通讯方式设定为MODBUS模式 。

硬件连接

创建设备

在开发环境的‘硬件系统’中按照‘新节点和设备向导’的指示配置所连接的模块。以便于开物2000识别和使用。

步骤1：选择设备类型。双击‘ Guardian CMC-12SCH’，或单击选中‘Guardian CMC-12SCH ’，更改设备名称，最后单击‘选择’按钮。

步骤2：选择操作方式-新建设备(一个设备中可以包含多个)。选中‘新建设备’后单击‘下一步’按钮(或双击‘新建设备’)。

步骤3：显示设备创建方式配置界面。在向导选择多 设备创建，单击‘下一步’按钮。

步骤4：显示设备 配置向导，在此向导中添加相应的设备，并确定其单元号，单击“下一步”按钮。

步骤5：显示串口参数配置向导，在向导中配置好各参数，单击‘下一步’按钮。

步骤6：显示设备及参数汇总窗口，单击‘完成’按钮，结束设备配置向导。

创建标签

使用设备向导创建完成模块的配置后，可以进行标签设计。

1、在开发环境的‘标签’中添加标签，显示下图，选择主设备为上面的‘ ’，选择并填写‘主设备地址’，修改标签名。

2、根据模块的工作模式和标签所监控的参数物理意义，修改测量值零点、测量值量程、工程值零点、工程值量程、扫描周期、转换方式、记录属性等。单击‘添加’或‘完成’按钮。

标签的地址规则

标签的主地址可以按照下面的规则配置填写：

标签类型[ID:]Ch

说明：

  • 标签类型指的是ModBus RTU兼容设备所识别的参数类型（注：不是设备中的实际参数类型），一般包括00、10、30、40、DW、Float六种类型.

  • ID指设备地址，用于识别 开物工程设备中的某个PLC。ID是十六进制表示形式 ，位数不限。从0开始编址。标签地址中省略ID时，开物2000系统默认为是所连接的设备地址是开物工程设备中的最小的设备地址。

  • Ch指参数地址号。是十进制表示。从1开始编址。

  • 红色字表示格式中可变部分，变化范围参见各种PLC的技术手册。
  • 蓝色括号不出现在标签地址中，蓝色括号内的内容在 工程设备中只包含一个子设备时可省略。
  • 标签地址配置成不存在类型或设备地址错误或 参数地址超出有效范围时，标签将不被承认，读不上数据。

标签地址

含义

数据类型

读写类型

标签值范围

00 ID:Ch

输出线圈

开关量

只读

true= 线圈闭合

false=线圈断开

10 ID:Ch

输入节点

开关量

读写

true=节点闭合
false=节点断开

30 ID:Ch

输入寄存器

模拟量

只读

0～65535

40 ID:Ch

保持寄存器(字格式)

模拟量

读写

0～65535
40_Int2ID:Ch | 保持寄存器( 二字节有符号整数) | 模拟量 | 读写 | -32768～+32767
40_Int4ID:Ch | 保持寄存器(四字节有符号整数) | 模拟量 | 读写 | -2147483647～+2147483647

DW ID:Ch

保持寄存器(双字格式)(低位在前)

模拟量

读写

0～4294967295

DW_HLID:Ch

保持寄存器(双字格式)（高位在前）

模拟量

读写

0～4294967295
FLOAT ID:Ch 保持寄存器(4字节浮点数格式) 模拟量

读写

-9999999999～9999999999
DEVICELINKID 各子设备线路通讯状态 字符串/模拟量/开关量 只读

模拟量，字符串量各有7种状态并相互对应如下：

0——通讯始终不成功！ ；

1——通讯正常!；

2——通讯出现干扰!；

3——通讯出现故障!；

4——通讯线路断路!；

5——设备掉电或设备故障!；

6——通讯暂停!

开关量：

True ——通讯正常

False——通讯不正常

COMMLINK 总线线路通讯状态 字符串/模拟量/开关量 只读

模拟量，字符串量各有7种状态并相互对应如下：

0——通讯始终不成功！ ；

1——通讯正常!；

2——通讯出现干扰!；

3——通讯出现故障!；

4——通讯线路断路!；

5——设备掉电或设备故障!；

6——通讯暂停!

开关量：

True ——通讯正常

False——通讯不正常

标签举例

标签 ：002:118
数据值类型：开关量
描述 ：表示读取设备配置示例中2号CMC-12SCH设备118寄存器的数值。

标签 ：102:134
数据值类型：开关量
描述 ：表示读取设备配置示例中2号CMC-12SCH设备134寄存器的数值。

标签 ：302:04
数据值类型：模拟量
描述 ：表示读取1设备配置示例中2号CMC-12SCH设备04寄存器的数值。

标签 ：40 2:10
数据值类型：模拟量
描述 ：表示读取设备配置示例中2号CMC-12SCH设备10寄存器的数值。

标签 ：CommLink
数据值类型：模拟量
描述 ：表示读取设备配置示例中 当前总线线路的通讯状态。

标签 ：DEVICELINK1
数据值类型 ：模拟量
描述 ：表示读取设备配置示例中 总线上1号CMC-12SCH设备 的通讯线路状态。

附件(寄存器地址)


用户常见问题

设备向导首页的“调试设置”按钮有什么用处 设备向导首页的“版本信息”按钮有什么用处
RS485网络应用提示

3.10.0.0版及更高版本中，设备向导首页的“调试设置”按钮有什么用处?

请注意“调试设置”按钮功能只有在开发和调试阶段才能使用，在现场运行时一定要关闭所有调试选项，否则可能会产生不可预见的错误。

点击“调试设置”按钮，打开调试窗口。根据需要打开调试选项，退出保存工程后运行一段时间。开物会记录这段时间发生的一些重要信息。通过这些信息可以达到下面目的：

项目符号

检查标签设计是否有错误
项目符号

查看设备通讯效率，提供设计优化参考
项目符号

检查线路连接情况，是否有强干扰源
项目符号

检查运行计算机的硬件配置，操作系统，运行的开物版本，运行的驱动程序版本。
项目符号

检查系统资源，尤其是内存是否够用。
项目符号

将工程文件夹压缩成一个文件Email给开物2000的技术人员，为技术人员远程离线诊断错误提供原始资料。
项目符号

查找诊断其他与通讯相关的未明错误的原因。

3.10.0.0版及更高版本中，设备向导首页的“版本信息”按钮有什么用处?

通过点击“版本信息”按钮，可以达到下面目的：

项目符号

提示当前所用驱动程序的版本号，方便开物2000的技术服务人员提供更细致的服务。
项目符号

提示驱动程序提供的功能，支持的硬件型号等重要信息。
项目符号

显示最新的驱动程序帮助文件。

RS485 网络应用提示

项目符号 | 在RS485 网络中， 当通讯距离增长（<1200m），或波特率提高时，应在网络的 两端最后一个节点处的 com+，com-间并接一只 120 Ω左右的线路匹配电阻，以保障网络的可靠运行。
项目符号 | 当 RS485 网络节点数量增加，（>32）或通讯距离超过 1200m 时，应在网络中适当地加入 RS485 中继器。（最好是隔离型的），以保证网络的通讯顺畅。
项目符号 | RS485网络结构应尽量保证为一条干线，各节点引入的支线段应越短越好，以免引起杂波干扰，影响通讯。
项目符号 | RS485 网络的通讯线最好使用屏蔽双绞线。com+与 com-为一个线对，并且屏蔽层应在网络的源端单点接地，可有效地防止外界干扰。
项目符号 | RS485网络干线在布线时， 应避免与动力线系统电源线靠近或平行布置，尽量与其距离远一些。