天津陆海ZLX-2000调节仪

概述 仪表与系统的连接及设置 各功能标签变量的设定 在线升级驱动

概述

ZLX-2000是天津陆海石油设备系统工程公司生产的集显示、记录、控制功能一体的，具有12路模拟量输入、8路模拟量输出、8路开关量输入、8路开关量输出的多功能、多回路调节仪,主要用于化工精镏塔、聚合釜、缩合釜及锅炉等装置的优化控制。

本驱动程序支持天津陆海石油设备系统工程公司ZLX-2000仪表。

本驱动适用的机型：ZLX-2000多功能智能控制调节仪

本驱动程序支持的功能

（1） 实时数据读入

15路AI

8路AO（MV调节输出）

8路DI

8路DO

（2） 时间、日期

读入CPU1、CPU2时间

时间、日期校准

（3） 手自动切换

主要是切换8路MV(调节输出)，同时进行MV输出

（4） 开关量输出

a. 开始进料

b. 开始升温

c. 开始回收

d. 开始低压回收

（5） 参数整定

按照仪表设计的特点，仪表的整定分成13页，每页有多个参数成批设置

仪表与系统的连接及设置

从机连接台数31台(Max1200m)

ZLX-2000仪表485通信接口接线(其余端子接线方法见说明书)

通信接口

2线式RS-485通信

端子58

RS-485 +

端子59

RS_485 -

最大通信速度

9600bps

RS-485通信接口参数设置

项目 | 规格
规格 | ELA RS485标准
最大连接台数 | 31台
通信方式 | 2线式半双工
同步方式 | 起止同步式
通信顺序 | 无顺序
最大通信距离 | 1200m
通信速度 | 9600
起始位 | 1位
数据位 | 8位
奇偶校验 | 无
停止位 | 1或2位

通讯端口硬件的推荐设置：

波特率 9600 bps

数据位 8

停止位 1

校验位无校验

各功能标签变量的设定

开物2000按照标签名称来读取仪表相应的数据。开物2000定义的标签地址与仪表的各类数据相对应，定义非法地址的标签将不被承认。如定义的标签地址在所用的仪表具体型号中不存在，将读不上数据。

标签地址编码格式：标签类型[站号:]地址号

或标签类型[站号:]参数页号.参数号

标签地址类型和地址范围

标签类型 | 数据类型 | 标签说明 | 地址最小值 | 地址最大值 | 读写属性 | 备注
ＡＩ | 模拟量 | 模拟量输入 | １ | １５ | R
ＭＶ | 模拟量 | 模拟量输出 | １ | ８ | R/W | 调节输出
ＤＩ | 开关量 | 开关量输入 | １ | ８ | R/W | 为和仪表使用者的习惯适应,此类标签从仪表的角度是开入，从上位机的角度实际是开出。
ＤＯ | 开关量 | 开关量输出 | 1 | 8 | R | 为和仪表使用者的习惯适应,此类标签从仪表的角度是开出，从上位机的角度实际是开入。

标签类型 | 数据类型 | 标签说明 | 页号 | 最小值 | 地址最大值 | 读写属性 | 备注

PARA

模拟量

参数设置

1 1 26

R/W

格式：PARA[站号：]页号.参数号
模拟量 | 2 | 1 | 16
模拟量 | 3 | 1 | 11
开关量 | 4 | 1 | 16
开关量 | 5 | 1 | 8
模拟量 | 6 | 1 | 5
模拟量 | 7 | 1 | 16
模拟量 | 8 | 1 | 16
模拟量 | 9 | 1 | 16
模拟量 | 10 | 1 | 10
模拟量 | 11 | 1 | 5
模拟量 | 12 | 1 | 8
模拟量 | 13 | 1 | 5

标签类型 | 数据类型 | 标签说明 | 地址最小值 | 地址最大值 | 读写属性 | 备注
DATETIME 字符串 日期时间 1 2 R/W

CPU1时间

CPU2时间

AUTO | 开关量 | 自动/手动 | 1 | 8 | W | 切换
DATETIME | 字符串 | 日期时间 | 1 | 31 | R | 表示仪表当前的通讯状态

说明：

1. 参数读入的方法

（1） 新建一个标签，标签名称任意,这里设为ParaRead4。主地址设为：PARA4:

其中 4：表示读入4#仪表的参数 ，注意，此地址不要设置页号和参数号。

（2） 在图页中新建一个按钮，在‘按钮抬起’脚本中加入以下脚本。

（3） araRead4.Vaue := n; //n表示第n页参数，该页的数据读入到该页相应的标签中

如果读入第三页参数 ，可以写以下脚本

ParaRead4.Value := 3;

如果读入第十三页参数

ParaRead4.Value := 13;

2． 日期时间型标签的说明

（1） 日期时间型为字符串型变量

格式是： 年-月-日 时：分：秒

例： 03-04-28 10:30:30

(2) 如果给日期时间型变量按上述格式赋值，则是校正仪表的时间日期。

如果给日期时间型变量赋值为‘READ’,表示从仪表读入时间日期参数。

例：

datetime1_2.Value := DateTimeToStr(now);//表示把1#仪表的CPU2时间更新为当前上位机的时间

datetime1_2.Value := ‘03-04-28 10:30:30’; //表示把1#仪表的CPU2时间更新为03-04-28 10:30:30

datetime1_2.Value := ‘READ’;//表示读入1#仪表CPU2的当前时间。