PY-500智能压力表

概述 硬件连接 创建设备 创建标签 标签的地址规则 标签举例 在线升级驱动

概述

硬件连接

默认通讯参数如下：

波特率 | 9600bps
数据位 | 8
停止位 | 1
校验方式 | 无校验

创建设备

在开发环境的‘硬件系统’中按照‘新节点和设备向导’的指示配置所连接的模块。以便于开物2000识别和使用。

步骤1：选择设备类型。双击‘’，或单击选中‘’，更改设备名称，最后单击‘选择’按钮。

步骤2：选择操作方式-新建设备(一个设备中可以包含多个)。选中‘新建设备’后单击‘下一步’按钮(或双击‘新建设备’)。

步骤3： 显示单个、多个仪表或者自动创建，单击‘下一步’按钮。

步骤4：单击“下一步”。

步骤5：显示串口的设定参数，单击“完成”。

步骤6：显示设备的设定参数，单击“完成”。

创建标签

使用设备向导创建完成模块的配置后，可以进行标签设计。

1、在开发环境的‘标签’中添加标签，显示下图，选择主设备为上面的‘’，选择并填写‘主设备地址’，修改标签名。

2、根据仪表的工作模式和标签所监控的参数物理意义，修改测量值零点、测量值量程、工程值零点、工程值量程、扫描周期、转换方式、记录属性等。单击‘添加’或‘完成’按钮。

标签的地址规则

标签的主地址可以按照下面的规则配置填写：

标签类型[ID:]Ch

说明：

项目符号

ID指仪表的仪表地址，用于识别设备中的仪表， 仪表地址以十进制表示，地址设定范围为00 ～ 31 。标签地址中省略ID时，开物2000系统默认为是所连接的最小仪表地址。

项目符号

Ch指通道号。范围根据标签类型所决定。

项目符号 标签地址配置成不存在类型或模块地址错误或通道号超出有效范围时，标签将不被承认，读不上数据。

标签地址

含义

数据类型

读写类型

标签值范围

EDID:

满量程

模拟量

可读可写

0～9999

ALID:

主继电器报警值

模拟量

可读可写

0～9999

PV ID:

当前压力值

模拟量

只读

0～9999

标签举例

标签 ：PV 1:
数据值类型：模拟量
描述 ：表示设备配置示例中1号设备的当前压力值

标签 ：AL1:
数据值类型：模拟量
描述 ：表示设备配置示例中1号设备的 主继电器的报警值

标签 ：ED1:
数据值类型：模拟量
描述 ：表示设备配置示例中1 号设备的满量程