CB920配料控制器

概述 硬件连接 创建设备 创建标签 标签地址及范围 标签举例 在线升级驱动

CB920中配方标签的使用规则：

1、配方的下传方法

首先设定好各仓的目标量M_FINAL、粗计量M_COARSE、过冲量 M_FINE，配方的各设值必须满足以下条件( 目标量 > 粗计量 > 过冲量 )，

否则配方将下传不成功。设定好配方后，通过LOAD_SETM标签将配方下传。

2、配方的读取

建好配方的各标签后，可通过READ_SETM标签来读取保存在配料控制器中的配方数据。

概述

CB920配料控制器是世界上最小的配料控制器。使用21世纪最新之Delta－Sigma芯片以达至高精度及快速转换效果。使用RS485标准接口进行多点或远距离通讯，适合不同的配料或包装系统使用。

硬件连接

通讯端口硬件的推荐设置：

波特率 | 9600bps
数据位 | 7
停止位 | 1
校验位 | 偶校验

创建设备

在开发环境的‘硬件系统’中按照‘新节点和设备向导’的指示配置所连接的仪表。以便于开物2000识别和使用。

步骤1：选择设备类型，更改设备名称，最后单击‘选择’按钮。

步骤2：选择操作方式-新建设备(一个设备中可以包含多个)。选中‘新建设备’后单击‘下一步’按钮(或双击‘新建设备’)。

步骤3：选择创建方式(一个设备中可以包含多个)。选中 创建方式后单击‘下一步’按钮(或双击‘标准创建’)。

步骤4：设置仪表类型和设备号，单击‘下一步’按钮。

步骤5：设备串口通讯参数， 如下图所设，单击‘下一步’。

步骤6：显示设备及参数配置图，点击‘完成’按钮，完成设备配置向导.

创建标签

使用“CB920配料控制器向导“完成设备的创建后，可以进行标签设计。

1、在开发环境的‘标签’中添加标签，显示下图，选择上述主设备‘CB920’，选择并填写‘主地址’，修改标签名。

2、根据仪表的工作模式和标签所监控的参数物理意义，修改工程值零点、工程值量程、扫描周期、转换方式、记录属性等。
单击‘添加’或‘完成’按钮。

标签地址及范围

标签的主地址可以按照下面的规则配置填写：

标签类型[ID:][CH]

说明：

项目符号 | ID指仪表的设备号地址， 该版本驱动只适用于RS232，所以ID值只能为0。 标签地址中省略ID时，开物2000系统默认为是所连接设备的最小的站号地址。
项目符号 | Ch指通道号，范围因标签类型 而异，十进制表示。
项目符号 | 标签地址配置成不存在类型或仪表地址错误或通道号超出有效范围时，标签将不被承认，读不上数据。

标签地址 | 说明 | 变量类型 | 读写类型 | 地址范围 | 标签值范围
CAL_ZERO ID:CH | 零位调校 | 开关量 | 只写 | 1 | true 或false
CAL_SPANID:CH | 称量间距调校 | 模拟量 | 只写 | 1 | -65535～65535
ENQ ID:CH | 读取最终实际配料值 | 模拟量 | 只读 | 1～4 | -65535～65535
FUNC_1LID:CH | 零位跟踪时间 | 模拟量 | 只写 | 1 | 0,5,10,15 或20
 | 零位跟踪范围 | 模拟量 | 只写 | 2 | 5,10,15,20,25,30,35,40,45 或50
 | 重量变动检测时间 | 模拟量 | 只写 | 3 | 0, 1 或2
 | 重量变动检测范围 | 模拟量 | 只写 | 4 | 1, 2, 5 或10
 | 小数点 | 模拟量 | 只写 | 5 | 0, 1, 2, 3 或4
 | 数(只有在选择无小数点时方可选择) | 模拟量 | 只写 | 6 | 1 或10
 | 分度间距 | 模拟量 | 只写 | 7 | 1, 2 或5
 | 最大量程 | 模拟量 | 只写 | 8 | 500,1000,1200,1500,2000,2500,3000,4000,5000,6000,8000,10000,12000,15000,20000, 25000,30000,40000,50000,60000,80000,100000
 | RS232/RS485 波特率 | 模拟量 | 只写 | 9 | 2400, 4800, 9600 或19200
 | 零位范围 | 模拟量 | 只写 | 10 | 1--100(整数值)
 | 单位 | 模拟量 | 只写 | 11 | 暂不支持
FUNC_2LID:CH | 归零范围 | 模拟量 | 只写 | 1 | 1--10(整数值)
 | 允差范围 | 模拟量 | 只写 | 2 | 1--99
 | 延迟卸料控制时间 | 模拟量 | 只写 | 3 | 1--99
 | 延迟检测超差时间 | 模拟量 | 只写 | 4 | 1--99
 | 禁止比较时间(对于粗计量) | 模拟量 | 只写 | 5 | 1--99
 | 禁止比较时间(对于精计量) | 模拟量 | 只写 | 6 | 1--99
 | 数字滤波 | 模拟量 | 只写 | 7 | 0,2,4,8,16,32,64,128,256
 | 第二阶段数字滤波 | 模拟量 | 只写 | 8 | 0,1
 | 第二阶段滤波范围 | 模拟量 | 只写 | 9 | 0--99
 | 启动延迟时间 | 模拟量 | 只写 | 10 | 0--99
 | 自动补偿 | 模拟量 | 只写 | 11 | 0 --99
 | 检查超差 | 模拟量 | 只写 | 12 | 0 --99
 | BCD 输出次数 | 模拟量 | 只写 | 13 | 15, 50,100 或200
 | 生产自动去皮 | 模拟量 | 只写 | 14 | 0 --99
FUNC_3LID:CH | 上电自动归零 | 模拟量 | 只写 | 1 | 0 或1
 | 首次去皮生产 | 模拟量 | 只写 | 2 | 0 或1
 | 启动生产条件 | 模拟量 | 只写 | 3 | 0, 1, 2 或3
 | 自动去皮条件 | 模拟量 | 只写 | 4 | 0 或1
 | 去皮延迟时间 | 模拟量 | 只写 | 5 | 0 --99
 | 去皮检测次数 | 模拟量 | 只写 | 6 | 1--99
 | 精计量延迟控制 | 模拟量 | 只写 | 7 | 0 --100
 | 精计量延迟时间 | 模拟量 | 只写 | 8 | 0 --99
 | 点动配料控制(精计量控制启动时间) | 模拟量 | 只写 | 9 | 0 --99
 | 点动配料控制(精计量控制关闭时间) | 模拟量 | 只写 | 10 | 0 --99
 | 比较检测次数 | 模拟量 | 只写 | 11 | 1 --99
 | 过冲量补偿范围 | 模拟量 | 只写 | 12 | 0 --999
 | 重量显示保持时间 | 模拟量 | 只写 | 13 | 0 --9
 | 允许添量配料 | 模拟量 | 只写 | 14 | 0 --1
 | ID 代码(只在硬件选择RS485 后才有显示) | 模拟量 | 只写 | 15 | 00 --99
GET_TAREID:CH | 获取皮重 | 模拟量 | 只读 | 1 | -19999-------99999
GET_ZEROID:CH | 获取零位漂移 | 模拟量 | 只读 | 1 | -19999-------99999
LOAD_SETM ID:CH | 将配方下传 | 开关量 | 只写 | 1 | true 或false
M_COARSEID:CH | 粗计量设定 | 模拟量 | 读/写 | 1～4 | -65535～65535
M_FINALID:CH | 目标重量设定 | 模拟量 | 读/写 | 1～4 | -65535～65535
M_FINEID:CH | 过冲量设定 | 模拟量 | 读/写 | 1～4 | -65535～65535
READID:CH | 读取实时计量值 | 模拟量 | 只读 | 1 | -65535～65535
READ_SETM ID:CH | 读取仪表中的配方 | 开关量 | 只写 | 1 | true 或false
RLYID:CH | 物料1输出口 | 开关量 | 只写 | 1 | true 或false
 | 物料2输出口 | 开关量 | 只写 | 2 | true 或false
 | 物料3输出口 | 开关量 | 只写 | 3 | true 或false
 | 物料4输出口（中速配料输出口） | 开关量 | 只写 | 4 | true 或false
 | 快速配料输出口 | 开关量 | 只写 | 5 | true 或false
 | 慢速配料输出口 | 开关量 | 只写 | 6 | true 或false
 | 卸料输出口 | 开关量 | 只写 | 7 | true 或false
 | 误差输出口 | 开关量 | 只写 | 8 | true 或false
SET_TAREID:CH | 设定皮重 | 开关量 | 只写 | 1 | false：取消设定皮重 true：设定皮重
SET_ZERO ID:CH | 设定零位漂移 | 开关量 | 只写 | 1 | false：重新设定零位漂移 true：设置零位漂移
START_UP ID:CH | 启动或停止生产 | 开关量 | 只写 | 1 | false（停止），true（启动）

标签举例

标签 ：ENQ 0:1
数据值类型：模拟量
描述 ：表示设备号地址为0的仪表的M1的最终实际配料值

标签 ：LOAD_SETM0:1
数据值类型：开关量
描述 ：表示控制设备号地址为0的仪表的配方下

标签 ：READ_SETM 0:1
数据值类型：开关量
描述 ：表示控制设备号地址为0的仪表的配方读取

标签 ：READ0:1
数据值类型：模拟量
描述 ：表示设备号地址为0的仪表的实时计量值

标签 ：M_FINAL0:1
数据值类型：模拟量
描述 ：表示设备号地址为0的仪表的M1的目标重量设定值

标签 ：M_COARSE0:1
数据值类型：模拟量
描述 ：表示设备号地址为0的仪表的M1的粗计量设定值

标签 ：M_FINE0:1
数据值类型：模拟量
描述 ：表示设备号地址为0的仪表的M1的过冲量设定值

标签 ：START_UP 0:1
数据值类型：开关量
描述 ：表示设备号地址为0的仪表的启动或停止生产