西门子 SIPART 系列仪表

概述 标签说明 标签举例 在线升级驱动

概述

西门子 SIPART 系列仪表用于过程控制，功能强大，使用方便，性能稳定。

仪表通讯参数

通讯格式：默认为：1 位启始位，7 位数据位，1 位停止位， 偶校验。

波特率：默认为 9600bps。

地址：可选范围为 0～31，十进制。

注意：关于通讯参数的设定请参照通讯说明书进行，其中 S98 设定设备号，其它参数请保留默认设置即可。假如需要上位机修改过程类参数设定值，需要将 S93 参数设为 3。

标签说明

项目符号 | 下表中 ID 指仪表的设备表号(开物 2000 设备向导中的表号)。
项目符号 | 红色字表示格式中设备号，十进制数表示 ，蓝色部分表示地址号，十进制表示。
项目符号 | 注:此处仪表中的通信地址 ID 号以 10 进制表示，CH 通道号以 16 进制表示。 关于参数设置中的数据格式，请参照通讯说明书中的参数类型说明，即‘TYPE’项。

标签地址 | 含义 | 类型 | 读写 类型 | 通道地址 CH1范围[16 进制] | 通道地址 CH2范围[16 进制] | 标签值范围
PV ID:CH1 | 读取 PV 值 | 模拟量 | 只读 | 0 | 无 | -999999--999999
SPI ID:CH1 | 读取|设置 SP1 | 模拟量 | 读写 | 0 | 无 | -999999--999999
SPII ID:CH1 | 读取|设置 SP2 | 模拟量 | 读写 | 0 | 无 | -999999--999999
FLAG ID:CH1 | 修改参数标志 | 模拟量 | 读写 | 0 | 无 | 0--255
PARM_FIX ID:CH1.CH2 | 读取|设置参数[FIX 格式] | 模拟量 | 读写 | 对应参数中 | 对应参数中 的低地址 | -999999--999999
PARM_LIN ID:CH1.CH2 | 读取|设置参数[LIN 格式] | 模拟量 | 读写 | 对应参数中 的高地址 | 对应参数中 的低地址 | -999999--999999
PARM_BIN ID:CH1.CH2 | 读取|设置参数[BIN 格式] | 模拟量 | 读写 | 对应参数中 的高地址 | 对应参数中 的低地址 | -999999--999999

标签举例：(以多个仪表创建为例，标签中包括仪表号)

标签 ：PV1:0
数据值类型：模拟量
描述 ：表示 1 号仪表的 PV 值。

标签 ：SPI2:0
数据值类型：模拟量
描述 ：读取|设置 2 号仪表的 SP1 值。

标签 ：FLAG3:0
数据值类型：模拟量
描述 ：读取|设置 3 号仪表的参数修改标志。
注意
这个参数设置为 128 时表示修改 STRUCTURE 类参数高地址为 45H 如 STRS 参数开始，这时仪表面板 ‘STRS’闪烁，可以修改低地址为 01-64 范围的参数数据，修改完毕后，需要将数值设定为64，表示修改完毕。
这个参数设置为32时表示修改 PARAMETERS 类参数高地址为 46H，如 ONPA 中的低地址 00-37H；OFPA 中的 9A-D3H；CLPA 中的 40-99H，CAE1 中的 D4-EFH 这时仪表面板 ‘ONPA’闪烁，修改完毕后，需要将数值设定为16，表示修改完毕。

标签 ：PARM_BIN3:46.46
数据值类型：模拟量
描述 ：读取|设置 3 号仪表的第一段时间，数据格式为 BIN。
注意：关于时间设定格式为 12.05 表示 12 小时 05 分钟，12. 5[12.50]表示 12 小时 50 分钟；