聚龙无纸记录仪

鞍山-聚龙无纸记录仪

概述 硬件连接及设置 硬件接线图 地址设置 标签类型 在线升级驱动

鞍山-聚龙无纸记录仪协议概述

聚龙网络化仪表通信协议支持与聚龙无纸记录仪产品之间的通讯。本协议采用串行通讯

（RS-232C或RS-485通讯协议），使用您计算机中的串行口。

开物2000还支持其它多种仪表，详情请与 华富惠通公司联系。

鞍山-聚龙无纸记录仪与系统的连接及设置

上下位机硬件连接与设置

聚龙无纸记录仪与开物2000的连接说明:

聚龙无纸记录仪采用RS-232C接口时（只能接一台仪表）：

采用RS-485接口时：

设置聚龙无纸记录仪

聚龙无纸记录仪的所有标签（见标签类型中所列）都可通过仪表面板上的按键进行设置，

重要设置如下：

设 置 项

设 置 方 式

通讯通道地址的选择

地址唯一：0-239

通讯数据格式（固定）

8个数据位，1个停止位(无校验)

通讯波特率范围

4800-38400Bit/S范围内任意设置，出厂缺省设置为9600Bit/S

鞍山-聚龙无纸记录仪与系统的接线图

当聚龙无纸记录仪采用RS-485通讯方式时，应用上位计算机RS-232C串口通讯时必须采用RS-232C/RS-485转换装置。

应用上位计算机9针RS-232C串口时的硬件连线图如下：

而应用上位计算机25针RS-232C串口时的硬件连线图如下：

当聚龙无纸记录仪采用RS-232C通讯方式时,只能接一台记录仪表：

以25针RS-232C接口为例：

鞍山-聚龙无纸记录仪的I/O设备地址设置

当采用RS-485通讯方式时，最多能带240台AI系列仪表，其地址号范围是0-239。

鞍山-聚龙无纸记录仪标签类型

标签类型详细说明

标签含义

标签名

标签类型

取值范围
浮点数据 | PARAMdd(dd:1-49) | 模拟量 | 1.5*10^-45--3.4*10^38
状态标志 | FLAGdd(dd:1-5,1-9) | 模拟量 | 0--255

举例

标签：PARAMdd

标签类型：模拟量

注释：四字节浮点数据，仪表实时采集。

PARAM1，记录仪采集的第一通道浮点数据；

PARAM2，记录仪采集的第二通道浮点数据；

PARAM49，记录仪采集的第四十九通道浮点数据；

标签：FLAGdd

标签类型：模拟量

注释：单字节状态标志数据，仪表实时采集，对该类标签的访问缺省为按字节方式，也可按位方式。

FLAG1，记录仪采集的第一字节状态标志数据；

FLAG1.0，记录仪采集的第一字节中第一位的状态标志；

FLAG1.7，记录仪采集的第一字节中第八位的状态标志；

注：因聚龙无纸记录仪支持多种通讯协议，所以状态标志标签的地址范围有两种，分别为FLAG1-FLAG5及

FLAG1-FLAG9。