科利XK系列称重显示控制器

XK3138型称重显示控制器

概述 硬件连接 创建设备 创建标签 标签的地址规则 标签举例 在线升级驱动

概述

XK3138型称重显示控制器由杭州科利电子工程有限公司设计和生产。该控制器是以电阻应变式传感器为信号源，采用多重积分A/D转换技术及MCS51系列单片微机等大规模集成电路组成的高精度、高可靠、多功能称重仪表，能进行多路输入、输出自动控制信号的处理。抗干扰能力强，结构合理，维修方便，适合在各种自动化配料系统中用作显示控制仪表。本控制器具有以下主要功能:

项目符号

零点自动跟踪

项目符号

量程、分度值、小数点位置等均以面板数字式设定

项目符号

能选择开机自动清零或记忆方式开机

项目符号

称量数据断电保护

项目符号

实时日历时钟

项目符号

具有8路开关量输出接口，定值可任意设定为正值、负值或零

项目符号

具有6路开关量输入接口，可远控进行清零、累计、打印操作

项目符号

具有BCD码信息输出接口

项目符号

具有RS232C、RS485及电流环三种串行通讯接口

项目符号

具有标准打印接口

项目符号

自带传感器供桥电源

项目符号

有0～5V或4～20mA电流输出接口(选配)

主要技术参数

项目符号

准确度等级: 3级 (GB7724)

项目符号

内分辩率: 1/500000

项目符号

最大秤量显示值Max,分度值d,由面板数字设定

项目符号

分度数n: n=Max/d

项目符号

有效净重显示范围: £105 % Max

项目符号

传感器供桥电源: 10VDC,传感器并联输入,不多于8只,单只阻抗不低于350W

项目符号

开关量输入为6路（无电势触点）

项目符号

开关量输出为8路（无电势触点）,触点容量为DC 28V/2A;AC 220V/1A

项目符号

模拟电压输出0～5V或电流输出4～20mA (RL £ 750W)

项目符号

累计值最大为9999999(7位)

项目符号

始重设定范围: £ 20 %Max

项目符号

工作环境温度: – 10 ~ 40 ℃

项目符号

相对湿度: £ 90%

项目符号

额定电源电压: AC 220V (-15%～+10%)

项目符号

外型尺寸: 416mm×265mm×120mm

项目符号

重量: 8kg

项目符号

功耗: < 30W

硬件连接

若采用RS485接口与PC机通讯，则需在PC机的任一ISA总线槽内插入科利公司生产的485_PC接口板，将PC机的串行接口由RS232转换成RS485。此时XK3138后面板上RS232的DB–15P插座和PC机内485_PC板上的DB–9P及DB–25P插座间的电缆接线方式如下:

a. 和PC机DB–9P插座接线:

XK3138的DB–15P脚号

PC机的DB–9P脚号

9

-------------------------

9

10

-------------------------

6

12

-------------------------

1

13

-------------------------

4

b. 和PC机DB–25P插座接线:

XK3138的DB–15P脚号

PC机的DB–25P脚号

9

-------------------------

18

10

-------------------------

11

12

-------------------------

9

13

-------------------------

25

创建设备

在开发环境的‘硬件系统’中按照‘新节点和设备向导’的指示配置所连接的称重显示控制器。以便于开物2000识别和使用。

步骤1：从‘智能仪表’类中选择设备类型。双击‘科利XK系列称重显示控制器’，或单击选中‘科利XK系列称重显示控制器’，更改设备名称，最后单击‘选择’按钮。

步骤2：选择操作方式-新建设备(一个设备中可以包含多个)。选中‘新建设备’后单击‘下一步’按钮(或双击‘新建设备’)。

步骤3： 选择创建设备的方式：（假设称重显示控制器已经连接到本机）选中‘自动创建’后，单击‘下一步’按钮，或直接双击‘自动创建’选项。

步骤4：显示自动搜索设备配置界面。在向导自动搜索到所有硬件设备后，单击‘下一步’按钮。

步骤5：显示设备及参数汇总窗口，单击‘完成’按钮，结束设备配置向导。

创建标签

使用设备向导创建完成称重显示控制器的配置后，可以进行标签设计。

1、在开发环境的‘标签’中添加标签，显示下图，选择主设备为上面的‘科利3138’，选择并填写‘主设备地址’，修改标签名。

2、根据称重显示控制器的工作模式和标签所监控的参数物理意义，修改测量值零点、测量值量程、工程值零点、工程值量程、扫描周期、转换方式、记录属性等。单击‘添加’或‘完成’按钮。

标签的地址规则

标签的主地址可以按照下面的规则配置填写：

标签类型[ID:]

说明：

项目符号

ID指称重显示控制器的称重显示控制器地址，用于识别设备中的称重显示控制器，称重显示控制器地址以十进制表示，地址设定范围为1 ～8 。标签地址中省略ID时，开物2000系统默认为是所连接的最小称重显示控制器地址。
项目符号

蓝色括号不出现在标签地址中，蓝色括号内的内容在设备中只包含一个称重显示控制器时可省略。
项目符号

称重显示控制器地址错误时，标签将不被承认，读不上数据。

标签地址

含义

数据类型

读写类型

标签值范围

GID:

当前秤量值

模拟量

只读

-99999～99999

GUnitID:

秤量单位

模拟量/字符串量

只读

0=吨

1=千克

GStatusID

称重显示控制器工作状态

模拟量/字符串量

只读

0=秤量稳定

1=秤量未稳定
2=秤量太小
3=始重太重
4=称重值过载

CommLink

通信线路状态(-系统标签-)

模拟量/字符串量

只读

0=通讯始终不成功

1=通讯正常
2=通讯出现干扰
3=通讯出现故障
4=通讯线路断路
5=暂停通讯

DeviceLinkID:

设备通讯连接状态(-系统标签-)

模拟量/字符串量

只读

0=通讯始终不成功

1=通讯正常
2=通讯出现干扰
3=通讯出现故障
4=通讯线路断路
5=暂停通讯

标签举例

标签 ：G2:
数据值类型：模拟量
描述 ：表示设备配置示例中2号称重显示控制器XK3138的当前秤量值

标签 ：GStatus2:
数据值类型：字符串量
描述 ：表示2号称重显示控制器XK3138的当前工作状态

标签 ：DeviceLink2:
数据值类型：模拟量
描述 ：表示设备配置示例中2号称重显示控制器XK3138的最新通讯状态


用户常见问题

设备向导首页的“调试设置”按钮有什么用处

设备向导首页的“版本信息”按钮有什么用处

RS485网络应用提示

3.10.0.0版及更高版本中，设备向导首页的“调试设置”按钮有什么用处?

请注意“调试设置”按钮功能只有在开发和调试阶段才能使用，在现场运行时一定要关闭所有调试选项，否则可能会产生不可预见的错误。

点击“调试设置”按钮，打开调试窗口。根据需要打开调试选项，退出保存工程后运行一段时间。开物会记录这段时间发生的一些重要信息。通过这些信息可以达到下面目的：

项目符号

检查标签设计是否有错误
项目符号

查看设备通讯效率，提供设计优化参考
项目符号

检查线路连接情况，是否有强干扰源
项目符号

检查运行计算机的硬件配置，操作系统，运行的开物版本，运行的驱动程序版本。
项目符号

检查系统资源，尤其是内存是否够用。
项目符号

将工程文件夹压缩成一个文件Email给开物2000的技术人员，为技术人员远程离线诊断错误提供原始资料。
项目符号

查找诊断其他与通讯相关的未明错误的原因。

3.10.0.0版及更高版本中，设备向导首页的“版本信息”按钮有什么用处?

通过点击“版本信息”按钮，可以达到下面目的：

项目符号

提示当前所用驱动程序的版本号，方便开物2000的技术服务人员提供更细致的服务。
项目符号

提示驱动程序提供的功能，支持的硬件型号等重要信息。
项目符号

显示最新的驱动程序帮助文件。

RS485 网络应用提示

项目符号 | 在RS485 网络中， 当通讯距离增长（<1200m），或波特率提高时，应在网络的 两端最后一个节点处的 com+，com-间并接一只 120 Ω左右的线路匹配电阻，以保障网络的可靠运行。
项目符号 | 当 RS485 网络节点数量增加，（>32）或通讯距离超过 1200m 时，应在网络中适当地加入 RS485 中继器。（最好是隔离型的），以保证网络的通讯顺畅。
项目符号 | RS485网络结构应尽量保证为一条干线，各节点引入的支线段应越短越好，以免引起杂波干扰，影响通讯。
项目符号 | RS485 网络的通讯线最好使用屏蔽双绞线。com+与 com-为一个线对，并且屏蔽层应在网络的源端单点接地，可有效地防止外界干扰。
项目符号 | RS485网络干线在布线时， 应避免与动力线系统电源线靠近或平行布置，尽量与其距离远一些。